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You can use the Snap application to create control programs to control equipment, from single pieces of 

equipment to complex functions. 

You build control programs using individual blocks of programming code called microblocks. You determine the 

properties for each microblock and connect the microblocks with graphical wires to create a sequence of 

operation. 

A control program is assigned to a piece of equipment in the i-Vu®/Field Assistant application, then downloaded 

into the controller that will directly control and monitor the equipment. You can change editable properties and 

view non-editable properties of control programs in the i-Vu®/Field Assistant interface. 

 

 

  

Use the following steps to create a control program: 

1 Develop the logic (page 4). 

2 Format Properties pages (page 13). 

3 Simulate the control program (page 25). 

 

  

 

 
 

What is Snap? 
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Getting to know Snap 
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 TIPS 

• If the Property Editor is not visible, double-click an object in the workspace, unless it is a restricted 

microblock..  

• A restricted microblock has been added by the factory and has a red outline and line through it. Your ability to 

interact with these microblocks is limited. You cannot add inputs or outputs, though you can re-wire them. If 

you remove or delete a restricted microblock, you cannot add it back once you exit Snap. 

  

• You can use the Property Editor as a free-standing window, or you can select Options > Dock Property Editor 

to dock it in the Snap window. 

• Keyboard shortcuts are shown beside their corresponding commands in the menus.  

• Press Ctrl + an arrow key to nudge selected objects. Press Shift+Ctrl while using the arrow keys to increase 

the size of the nudge. 

• Click  to undo 1 action, or click the drop-down arrow next to it to undo multiple actions at one time. Click 

 or its drop-down arrow to redo actions. The number of actions you can undo or redo depends on the size 

of your computer's memory. 

• The workspace size has no limit.  

• Press Home to position the upper left corner of the workspace in the upper left corner of the window.  

• Press End to jump to the bottom of the control program. 

• Use the arrow keys or your mouse's scroll wheel to scroll through the workspace. 

• From the Options menu you can: 

○ Hide or show the workspace grid 

○ Enable Snap Figures and Text to Grid to constrain movement to 8 pixels for quick alignment; disable this 

feature for 1-pixel movement 

○ Zoom the view to 50, 100, or 200% 
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Use the following procedures to develop your control program. 

NOTES 

• Make sure a control program broadcasts a single color by using one of the following: 

○ 1 Setpoint microblock 

○ 1 Set Color microblock 

○ 1 or more Set Color If True microblocks 

• Each Time Clock microblock in a control program must have a unique schedule category. 

• To use one or more ZS or Wireless Sensors, the control program must have one Sensor Binder microblock and 

one of the following microblocks for each value type that will be read from the sensor network: 

• BACnet Analog Sensed Value Input microblock – For values such as temperature or humidity 

• BACnet Binary Sensed Value Input microblock – For values such as occupied/unoccupied 

• To use an SPT sensor, the control program must have an RS Zone Sensor microblock. 

 

 
 

To begin a control program 

The Snap application creates a .equipment file that is the control program that you download into a controller.  

1 In the application, select one of the following in the Control Program menu:  

○ CCN for downloading into an i-Vu® CCN Router or i-Vu® Link.  

○ i-Vu® Integrator for downloading into an i-Vu® Integrator 

○ Open (non-PIC) for downloading into: 

▪ AppController (OPN-APP) 

▪ Carrier® ChillerVu™ (OPN-PSM-MPCXPE and OPN-PSM-SIM) 

▪ i-Vu® Open Link (OPN-OL) 

▪ MPC Open XP (OPN-MPCXP) 

▪ UC Open (OPN-UC) 

▪ UC Open XP (OPN-UCXP) 

▪ UPC Open (OPN-UPC) 

○    PSM for downloading into a Carrier® ChillerVu™ controller 

 

2 Select File > Save As. 

○ i-Vu® Express - browse to a convenient location. 

○ i-Vu® Pro - browse to the <system_name>\programs folder. 

 

Developing the logic 
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3 Name the .equipment file. The name must:  

• Begin with a letter. 

• Not contain spaces or periods. 

• Be unique throughout a i-Vu®/Field Assistant system. 

4 Click Save.  

  

NOTES  

• A Carrier® ChillerVu™ (PSM) control program from EquipmentBuilder may contain custom microblocks that 

are locked and cannot be edited. These blue microblocks are outlined in red with a line drawn through them. 

• Select File > Info to view the file's name, location, and dates.  

• To use °C for setpoint microblocks, select Control Program > Metric before making the control program. If you 

change the Metric option for an existing control program, you must delete and reinsert all setpoint 

microblocks. 

To enable Metric for all future control programs, select Options > Preferences, then select Create new control 

programs as metric.  

 

 
 

To place microblocks 

1 Right-click the microblock palette. 

 

 
2 Click the icon of the microblock you want to use. 

3 Move the cursor into the workspace. 

NOTE  Press and hold Shift if you want to place 2 or more of the selected microblocks. 

4 Click to place the microblock. 

5 Edit the microblock's properties in the Property Editor.  
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NOTES   

○ If the Property Editor is not open, double-click the microblock. 

○ Red text in a field indicates an invalid value. 

○ You can right-click some properties and select Make Editable or Make Read-Only to determine that 

property's functionality in the i-Vu®/Field Assistant interface. 

  

 TIPS  

• Place all input microblocks on the left side of the workspace and all output microblocks on the right. 

• Arrange microblocks so that logic flows from left to right and the sequence of operation can be easily followed. 

• Hold Ctrl as you move a microblock to detach it from its wire. 

• Use the Microblock Common Properties Editor (page 29) to view, compare, and edit common properties of I/O 

microblocks. 

• You determine the appearance of items on the i-Vu®/Field Assistant Property Page > Equipment tab by how 

you order the microblocks in your control program in Snap. To change the order, see To reorder items on the 

Properties page (page 14). 

 

 
 

To draw wires and labels 

Wires are special lines in a control program that transmit values from one microblock to another. Solid wires 

transmit analog data; dashed wires transmit binary data. Wires connect microblock inputs and outputs. They can 

also connect to other wires.  

Output and input labels connect items just as wires do. Use labels when a value is needed in several places within 

a control program or when wires would clutter or complicate the control program. 

  

 
  

To draw wires 

1 Hold your cursor over a microblock nib until the cursor changes to crosshairs, then click and drag in the 

direction you want the wire to go. 

NOTE  A wire automatically makes a 90° turn if you drag away from a straight line. To create additional 90° 

turns, right-click while continuing to hold down the left mouse button. 
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2 Release the left mouse button to end the wire.  

NOTES   

○ The red error indicator at the microblock's nib disappears if the wire connected properly. 

○ When drawing wires between closely placed microblocks, you can temporarily disable the snap-to feature 

by pressing Ctrl while drawing a wire. 

  

To change an existing wire 

NOTE  If you move a microblock, connected wires move with it. 

1 Right-click the wire, then select Edit Shape. 

2 Do one of the following: 

○ Click and drag any wire segment in the direction of the move icon. 

○ Right-click where you want to add a joint on a wire, then select Add Joint. 

○ Right-click a green wire joint, then select Remove Joint. 

○ Click a wire, then select a different wire from the Type drop-down list.  

   

To add labels 

1 Select the Label tool.  

 

2 Move the cursor to the nib of a microblock or to the end of a wire, then click the workspace. 

 TIP  To quickly change the label's direction, press I (for Input label) or O (for Output label) while moving the 

label. 

3 Type a name in the Label Text field of the Property Editor. 

NOTE  If the Property Editor is not open, double-click the label. 

4 Optional:  Change the Direction of the label in the Property Editor. 

  

To change a label's text 

1 Select the label. 

NOTE  To locate the label, see To find a microblock, label, or text (page 30). 

2 Edit the Label Text field. 

NOTE  If the Property Editor is not open, double-click the label. 

3 Optional:  Click Rename all labels named '__' to change all labels that have the same label text. 
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To view errors 

The Snap application checks for errors as you build your control program and indicates errors with red dots, wires, 

and boxes. 

1 Click  in the lower right corner or select Control Program > Errors on the menu bar to view the errors.  

2 Click an error in the list to highlight its location in the workspace. 

  

NOTE  You cannot download a program that has errors. 

 

 
 

To add text 

Use the Text tool to add descriptive text to the control program. 

1 Select the Text tool. 

 

2 Click in the workspace where you want the text to begin. 

3 Edit the text and its properties in the Property Editor. See table below. 

NOTE  If the Property Editor is not open, double-click the text. 

  

Field Notes 

Text Type the comment you want to add to the control program. 

Font Select a font. Be sure that all system computers have the font installed. 

Size Choose a point size from the drop-down list. 

Style Check Bold, Italics, or both. 

Foreground Click the color swatch to select the color of the text. 

Transparent Background Check to remove the background color and pattern.   

Background Click the color swatch to select the color of the box behind the text. 

  

NOTE  To change the default settings for all text that you will add to the control program, select Options > Palette. 

Change the settings on the Font tab. 
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To arrange text blocks 

1 Select 1 or more text blocks. 

2 Right-click one of the text blocks, then select 1 of the following: 

• Bring Forward 

• Bring to Front 

• Send Backward 

• Send to Back 

 

 
 

To add lines and shapes 

Use lines and shapes to organize and clarify the control program. 

 
  

To draw a line or polygon 

1 Select the line or polygon tool. 

NOTE  To draw multiple similar figures, press and hold Shift as you draw them. 

2 To begin drawing the figure in the workspace, click and hold the left mouse button as you move the mouse. 

3 While holding down the left mouse button, right-click to add angles. 

4 Release the left mouse button to complete the line or polygon. 

  

NOTE  To change the shape of an existing figure, right-click the figure, then select Edit Shape. Click and drag a 

green point to move it. 
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To draw a rectangle or ellipse 

1 Select the rectangle or circle tool. 

NOTE  To draw multiple similar figures, press and hold Shift as you draw them. 

2 Click and drag in the workspace to begin drawing the figure. 

3 Release the mouse to complete the rectangle or ellipse. 

  

NOTE  Hold Ctrl while you drag to draw a square or a circle. 

  

To change the color or pattern of figures 

To change: 

• The color or pattern of a selected figure, click the appropriate rectangle in the Property Editor, and then make 

your selection.  If the Property Editor is not open, double-click the figure. 

NOTE  Select the red cross-hatch pattern for no fill. 

• The color or pattern of multiple selected figures, select Options > Palette. 

NOTE  Select the red cross-hatch pattern for no fill. 

• The default color or pattern for all figures that you will draw, select Options > Palette.  

   

To arrange figures 

1 Select 1 or more figures. 

2 Right-click 1 of the figures, then select 1 of the following: 

• Bring Forward 

• Bring to Front 

• Send Backward 

• Send to Back 

 

 
 

To add an image 

Select Edit > Insert Image to add a .gif, .png, .jpg, or .bmp image to your control program. 

NOTE  Your image must be created with a standard 256 color palette. Anything greater will be reduced to 256 

colors and may not display correctly in i-Vu®/Field Assistant. 
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To create a custom microblock 

If you want simple, easy-to-troubleshoot Logic pages, put complicated calculations in a custom microblock. 

NOTES   

• You cannot view or change a custom microblock's logic in the i-Vu®/Field Assistant interface. 

• You can put custom microblocks inside other custom microblocks.  

  

 

  

To create a custom microblock 

1 In the menu on the top bar, select Custom Microblocks > Add New Custom Microblock. 

2 Right-click the custom microblock, then select Step Inside Custom Microblock. 

3 In the custom microblock window, place custom I/O microblocks to create nibs on the custom microblock. 

NOTE  The order of the microblocks in the custom microblock window determines the location of the nibs on 

the custom microblock. 

4 Place other microblocks, wires, and labels to create the custom microblock's logic. 

5 To return to the main workspace, click Control Program at the top of the custom microblock window. 
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To select properties for ViewBuilder graphics 

The Snap application lets you select the microblock property values that you want to appear on a i-Vu®/Field 

Assistant graphic. This allows the graphics creator to see the property values and quickly obtain their paths in 

ViewBuilder. These microblock property selections are saved when you save the control program. 

  

1 Right-click a microblock in the workspace, then choose Select Properties For Graphics. 

2 Check any property whose value you want to display on a graphic.  

NOTE  To see all properties, clear the checkbox Show properties typically shown on graphics.  

3 Optional:  To add a comment for a property such as "Do not include units", select the property and then 

click , or you can double-click the property. 

  

NOTE  Select Control Program > Properties For Graphics to see all the properties that you selected in the control 

program. In the Comments box, you can type a comment that is not for a specific property. To delete a property, 

select it and then click . 

 

 
 



 

 

 
Snap v8.5 Carrier Proprietary and Confidential ©2023 Carrier. 

Help  All rights reserved. 

 13 

 

Making a control program automatically creates a i-Vu®/Field Assistant Properties page. The initial properties 

displayed on a Properties page are defined in the Snap Property Editor. 

i-Vu® Pro only - To preview Properties pages in the i-Vu® interface without connecting to the controllers, run i-Vu 

Pro Design Server instead of i-Vu Pro Server. 

 

 

 

In the control program, you can change the way text appears on the Properties page by using a Text microblock or 

by editing a microblock's Property Page Text field in the Property Editor. 

  

NOTE  If you change a control program after downloading it to the controller, you must:  

1 Save the .equipment file. 

2 Reload the control program. See "Working with control programs" in i-Vu®/Field Assistant Help. 

3 Download the control program. See "Downloading to controllers" in i-Vu®/Field Assistant Help. 

 

 

 

 

 
 

Formatting Properties pages 
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To reorder items on the Properties page 

1 Select Reorder > Edit Order. 

2 Select the microblock(s) you want to move. Ctrl+click or Shift+click to select and move multiple microblocks. 

3 Use the buttons at the right to move, cut, or paste microblocks.  

4 Click OK. 

  

NOTES   

• To find a single microblock in the Edit Order dialog box, do one of the following: 

• Right-click the microblock in the workspace, then select Show in Edit Order. 

• In the Edit Order dialog box, click  to search for the microblock. 

  

• To edit a microblock's Property Page Text from the Edit Order dialog box, do one of the following: 

• Double-click the microblock. 

• Select it and then click . 
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To use the Text microblock to format text 

The Text microblock allows you to format text, add horizontal lines, and arrange items on the Properties page. Text 

microblocks placed in a control program in the Snap application are not visible on the Field Assistant Logic page. 

  

1 Place a Text microblock in the workspace to the right of the microblock logic. 

2 In the Property Editor, select a format option from the Type drop-down list. See table below.  

NOTE  If the Property Editor is not open, double-click the microblock. 

3 Type text in the Property Page Text field. 

  

Text Type Notes 

Plain For creating plain text. 

Separator To create a horizontal line on the Properties page, often used to offset or group 

information, choose Separator as the Text Type. If you would like text to appear on 

the separator line, type the text in the Property Page Text field. 

Bold For creating bold text. 

Expand Begin Closed 

Expand Begin Opened  

Expand End 

To format a section using expanded formatting, first insert a Text microblock with 

the Text Type set as Expand Begin Closed or Expand Begin Opened, depending on 

how you want the area to display when first viewed. If you would like text to appear 

on your expandable line, type the text in the Property Page Text field. 

 

You must also insert a Text microblock with the Text Type set as Expand End at the 

end of the section you wish to group together. 

Table Begin 

Table End 

To align data in a table, insert a Text microblock with the Text Type set as Table 

Begin. To complete the table, insert a Text microblock with the Text Type set as 

Table End after the last item you want to include in the table. 

 

NOTE  When working with a table within an expanded section, make sure the table 

begins after the Expand Begin and ends before the Expand End. 
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Text Type Notes 

Conditional Hide Begin 

Conditional Hide End 

You can hide part of the Properties page based on a value from a specific 

microblock. For example, you can specify that the Properties page text from an 

Analog Input microblock will only appear on the Properties page if the value is 

above 85. The expression is evaluated relative to the entire control program, not at 

that particular microblock. 

Place a Text microblock with the Text Type set as Conditional Hide Begin before the 

microblock to be evaluated and another set to Conditional Hide End after it. Type a 

conditional expression in the Properties Page Text field of the Text microblock. 

Microblock properties may be referenced between the dollar signs ($), and the 

expression must be Boolean. For example, to show the microblock Properties page 

text only when the present value of the point named Zone Temp is greater than 85, 

the expression would be "$Zone_Temp/present_value$ >85". 

See Operators (page 18) for more information. 

NOTES   

• When referring to the name of a point, use the RefName rather than the Display 

Name. 

• Technical Support does not provide assistance with writing and editing 

Javascript. See Javascript textbooks, available in most bookstores, for help with 

Javascript. 

 TIP  If you are adding the Conditional Hide formatting after the control program 

has been designed or would prefer to group all of the Text microblocks within the 

control program, use the Reorder menu to correctly place the Text microblocks. 

Important Begin 

Important End 

These options are currently not used. 
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To correctly order Begin/End Text microblocks 

When adding Text microblocks in the Snap application that have a Begin or End text type, you must define the 

correct order for the microblocks so that the text appears correctly on a Properties page. Each Begin microblock 

must be followed by an End microblock, and you can have a set of Begin/End microblocks inside of another set of 

Begin/End microblocks. The initial order of the Properties page text is the order in which you add microblocks to 

the workspace. Moving the microblocks will not correct the Properties page order. If the microblocks are outlined in 

yellow, your Begin/End microblocks are out of order. In the example below, the order of the first and fourth 

microblocks are reversed. 

  

  
  

To correct the order, you can either change the microblocks' Type selection in the Property Editor, or select Reorder 

> Edit Order. See To reorder items on the Properties page (page 14). 
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Operators 

An operator defines how each piece of an expression is to be handled. For example, an operator can compare or 

perform an action between the value of a microblock property, a literal value, or the result of an expression. The 

following table lists operators that can be used in expressions.  

  

Path Operators 

$path$ Get value Gets the value of the path 

??path?? Check for presence Checks for the existence of the path. If it exists, the expression is true. If it does 

not, the expression is false. 

Operators that return true/false 

< Less than Compares numeric data. Returns true if the value to the left of the operator is 

smaller than the value to the right. 

> Greater than Compares numeric data. Returns true if the value to the left of the operator is 

larger than the value to the right. 

<= Less than or equal to Compares numeric data. Returns true if the value to the left of the operator is 

smaller than or equal to the value to the right. 

>= Greater than or equal to Compares numeric data. Returns true if the value to the left of the operator is 

larger than or equal to the value to the right. 

! Not Evaluates the expression and returns the opposite.  Example: 

!$zone_temp/locked$  

If zone_temp/locked is true, the expression is false. If zone_temp/locked is false, 

the expression is true. 

== Equal to Compares data. Returns true if the value on both sides of the operator are equal. 

!= Not equal to Compares data. Returns true if the value to the left of the operator does not 

match the value to the right. 

&& And Combines expressions. Returns true if the expressions on both sides of && result 

in true. For example: 

$zone_temp/locked$==false 

&&$zone_temp/present_value$>75 

?'#FF0000':'#FFF660' 

|| Or Combines expressions. Returns true if the expression on either side or both sides 

of the operator results in true. 

Operators that return a numeric value 

+ Add Adds numeric data, expressions, or values. 

- Subtract Subtracts numeric data, expressions, or values. 

* Multiply Multiplies numeric data, expressions, or values. 

/ Divide Divides numeric data, expressions, or values. 

% Modulus Finds the remainder in the division of numeric data, expressions, or values. 

Other operators 

( ) Parentheses Use to nest expressions. Operations in parentheses are evaluated before those 

outside parentheses. 
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Editing Properties page text using special characters 

For many microblocks, you can edit or format Properties page text in the microblock's Property Page Text field 

using special characters described below.  

  

To...   In the Property Page Text field, 

type... 

  Example 

Display a microblock 

property 

  The microblock property between 2 

dollar signs 

See Microblock Reference Help for 

property reference names. 

See Formatting a microblock 

property (page 20). 

  The value is $Present_Value$  

Displays: 

The value is 69.   

 

Make a column-

aligned table 

  { to begin a table, then } to end 

the table 

  

[ to begin a row, then ]^$ to end 

a row.  

Exception: Type ] to end last row 

in table.  

  

| (a pipe) to align cells 

  

 

  {[|History Recorder: |Current cycle = 

|$Current/Latched_Value$| on 

|$Current/Latched_Time$|$Current/ 

Latched_Date$ 

|since|$Current/Reset_Time$|$Current/ 

Reset_Date$]^$ 

 
[||Previous cycle = 

|$Previous/Latched_Value$| on 

|$Previous/Latched_Time$|$Previous/ 

Latched_Date$ 

|since|$Previous/Reset_Time$|$Previous/Rese

t_Date$]} 

Displays: 

 

Hide default text 

 

  ^## if Property Page Text field is 

empty. 

If the Property Page Text field shows 

the default text, delete the text. 

   

Display two 

microblock 

properties on the 

same line 

  ^$ at the end of the text for the first 

microblock 

  MB#1:     Enable when Supply Temp is more than 

$Constant$ (F) ^$ 

MB#2:     Disable when $Hyst$ (F) below Zone 

Temp. 

Displays: 

 

Begin a new line of 

text 

  ^\ where you want a new line to 

begin 

  Time for daily trend report:^\ ___ hh:mm 24 

hr 

Displays: 

Time for daily trend report: 

02:00 hh:mm 24 hr 



 

 

 
Snap v8.5 Carrier Proprietary and Confidential ©2023 Carrier. 

Help  All rights reserved. 

 20 

 

To...   In the Property Page Text field, 

type... 

  Example 

Bold text   !{text!}   !{NOTE!}  Must be enabled for... 

Displays: 

NOTE  Must be enabled for... 

Make a line of text 

not wrap in the 

action pane 

  ^( at the beginning of the text and 

^) at the end 

   

 

Display one of the 

following characters: 

^ \ $ { } [ ] | ! 

  \x, where x is the character you 

want to display 

  Do not change \! 

Displays:    

Do not change! 

 

 

 
 

Formatting a microblock property 

To add a microblock property in a microblock's Properties Page Text field, type the property between 2 dollar signs. 

For example, $current_Value$. This is called an expression. 

Each microblock property has default formatting that determines how it looks on the Properties page. You can 

change the way it looks by adding a control and one or more parameters to the expression.  

EXAMPLES 

• To display the present value of Duty cycle in a time format that shows minutes and seconds, type  
$Present_Value:control=”minsec”$ 

• To display the Period microblock property in a time format that shows minutes and seconds and make it 

editable, type $Period:control="minsec" editable="true"$.   

  

Breakdown of an expression 

  

 

   

The entire expression is between 2 dollar signs.  

 A microblock property  Example:  Period 

 A colon 

 Type a colon after the microblock property to add a control. 
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 control=      

A control determines how a property is displayed on the Properties page. Include a control= statement in the 

expression only if you want to use a control other than the default. Type control=, followed by the control name 

.  

 A control    Example:  "minsec" 

Type the control between quotation marks. See table below. 

 A space 

Type a space after a control statement or a parameter statement.  

 A parameter    Example:  editable= 

You can add one or more parameters to the expression. To specify a control, type the name of the parameter (see 

table below), an equal sign, and then a value .  

 A parameter value    Example:  "true" 

See table below. 

  

Controls and parameters 

A microblock property data type determines the type of control that can be used. 

 

To display a... Data must be.. 
 Control  Parameter  Parameter value 

Checkbox 

 

 

Boolean 

Example:  A binary 

parameter's present 

value 

 

button 

 

type WidgetImageButton.TOGGLE 

editable true or false 

(Default value is true.) 

truewhendown 

Check mark appears when the 

value is false instead of true. 

  

true or false 

(Default value is true.) 

Radio button 

 

 

Boolean 

Example:  A binary 

parameter's present 

value 

or 

  

Integer 

button 

 

type WidgetImageButton.RADIO 

editable true or false 

(Default value is true.) 

truewhendown 

Button is selected when the 

value is false instead of true. 

true or false 

(Default value is true.) 
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To display a... Data must be.. 
 Control  Parameter  Parameter value 

Example:  An analog 

parameter's present 

value 

or 

  

Enumerated 

Example:  A binary, 

analog, or multi-

state parameter's 

present value 

 

index 

For integer or enumerated 

values, index is the number of 

the state the radio button is to 

represent. 

  

  

  

any integer 

(Default value is null.) 

Text 

 

Character string 

Example:  A point's 

display name 

  

charstring editable true or false 

(Default value is true.) 

Date 

 

 

Date 

Example:  A wire 

lock's begin 

date/end date 

 

date 

 

editable true or false 

(Default value is true.) 

hasdayofweek 

Displays the day of the week 

with the date. 

  

true or false 

(Default value is true.) 

Number 

 

 

Integer 

(no decimal) 

Example:  An analog 

parameter's present 

value 

or 

  

Real 

(has decimal) 

Example:  An analog 

parameter's present 

value 

or 

  

Unsigned 

Example:  Any 

point's expander 

number 

  

number 

 

editable true or false 

(Default value is true.) 

digits_right_of_decimal 

(real number only) 

number of digits 

(Default value is null.) 

digits_left_of_decimal number of digits 

(Default value is null.) 

showplussign true or false 

(Default value is false.) 

scalingfactor 

Multiplies the actual value by 

the scalingfactor value. 

Example, to convert watts to 

kilowatts, use .001 as the 

scaling factor value. 

any floating point number except 0 

(Default value is 1.) 

Droplist 

 

Enumerated 

Example:  A binary, 

analog, or multi-

state parameter's 

present value 

  

droplist editable true or false 

(Default value is true.) 
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To display a... Data must be.. 
 Control  Parameter  Parameter value 

Time 

 

 

Time 

Example:  A wire 

lock's begin 

time/end time 

 

time 

 

editable true or false 

(Default value is true.) 

displaywhat One of the following: 

ControlTimeInput.HMSD 

ControlTimeInput.HMS 

ControlTimeInput.MSD 

ControlTimeInput.HM 

ControlTimeInput.SD 

ControlTimeInput.MS 

ControlTimeInput.H 

ControlTimeInput.M 

ControlTimeInput.S 

ControlTimeInput.D 

where H=hour, M=minutes, 

S=seconds, D=milliseconds 

(Default value is ControlTimeInput. 

HMSD.) 

 

Timer 

 

 

Unsigned numbers 

used as a timer 

Example:  A duty 

cycle's time 

 

minsec 

 

editable true or false 

(Default value is true.) 

scalingfactor 

Multiplies the actual value by 

the scalingfactor value. 

Example:  To convert watts to 

kilowatts, use .001 as the 

scalingfactor value. 

any floating point number except 0 

(Default value is 1.) 

showhours true or false 

(Default value is false.) 

showseconds true or false 

(Default value is true.) 

 

 
 



 

 

 
Snap v8.5 Carrier Proprietary and Confidential ©2023 Carrier. 

Help  All rights reserved. 

 24 

 

A i-Vu®/Field Assistant system has pre-defined alarm and schedule categories. But, you can add custom 

categories in the Snap application, then add the same custom category in the i-Vu®/Field Assistant interface. See 

"Using schedule categories" and "Alarm categories" in i-Vu®/Field Assistant Help. 

  

To add a custom category in the Snap application 

1 Select Options > Preferences. 

2 On the Alarm/Schedule Categories tab, select the Alarm Category tab to create a custom alarm category, or 

select one of the following Sched. Category tabs. 

  

Select this tab... To create a schedule category for this microblock... 

Time Clock Sched. Category Carrier Schedule 

Carrier Schedule with TLO and Override Status 

BACnet Time Clock with TLO and Override Status 

Modeled Schedule Sched. Category BACnet Modeled Schedule 

NOTES   

•  The Multi-state Time Clock Sched. Category tab is not used. 

•  Ignore any of the existing categories on these tabs except Occupancy. 

  

3 Click . 

4 Type the category name.  

NOTES   

○ This name must be identical to the reference name that you give the category when you add it in the i-

Vu®/Field Assistant interface.  

○ Do not use occupancy as the custom category name. 

○ The name can contain lowercase letters, numbers, hyphens, and underscores (no spaces); it cannot 

begin with a number. 

5  Click OK twice. 

The new category will now appear in a microblock's Category droplist. 

  

NOTE  To copy all custom category information to another computer, click Export below the category tabs, then 

save the file. On the other computer, click Import, then select the exported file. 

 

 
 

To use custom alarm and schedule categories 
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In simulation mode, you can specify microblock properties and define an operating environment to see how a 

control program will operate. 

To simulate a control program: 

1 Select Control Program > Simulate. 

2 In the Simulator window, select Options > Setup. 

3 Define the simulation conditions. See table below. 

4 Do one of the following: 

• Click  to run the simulation continuously until you click  to stop it. Set the Time Increment fields (see 

table below) to define how fast the simulation will run. 

• Click  to run the simulation one step at a time. 

• Click  to run the simulation as fast as possible. 

5 Click a microblock, then select its Simulation tab to enter values that will help you check the programming. 

See NOTES below. 

6 Verify that the logic performs the desired sequence of operation. 

7 Close the simulation window to return to the workspace. 

 

Field Notes 

Calendar Enter the starting Time and Date for the simulation. 

Communications Check Communications Ok to simulate normal communication. Uncheck this field to 

simulate lost communication. 

Time Increment The Step Every value determines how often the simulation recalculates values in real 

time. 

The One Step = value determines how much simulation time passes between each 

step. 

For example, to see 30 minutes of simulation in 1 second of real time, use the following 

settings: 

○ Step Every 00:01 (mm:ss) 

○ One Step = 30:00 (mm:ss)   

 TIP  Set your One Step = shorter than the shortest delay in your control program to 

avoid stepping over the delay in the simulation. 

  

 

 

 

 

 

 

Simulating a control program 
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NOTES   

• For simulation only, decimal values smaller than hundredths are rounded to the nearest hundredth. For 

example .025 is rounded to .03. 

• The Simulator has the same options as the main Snap workspace for locating items in the control program. 

See: 

To find a microblock or label (page 30) 

To find identical labels (page 31) 

To show a logical path (page 31) 

To show a wire's source microblock (page 31) 

  

• Hold the cursor over a wire or label to see its value. 
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Use the following features to work efficiently. 

 

 
 

To create and use symbols 

You can reuse a sequence of programming by exporting it to a .logicsymbol file that you can import into other 

control programs. 

You can add frequently-used symbols to your Favorites list and organize them for ease of use. 

  

To export a symbol 

1 Select the items in a control program that you want in the symbol. 

2 Select Edit > Export Symbol. 

3 Type a File Name. The application will automatically add the .logicsymbol file extension. 

4 Check Selected Items Only. 

5 Click Save. 

  

To import a symbol 

1 Open the control program you want to paste a symbol into. 

2 Select Edit > Import Symbol. 

3 Browse to the symbol, then double-click it. 

4 Click in the workspace to place the symbol. 

  

NOTE  You can drag a .logicsymbol from Windows Explorer to the Snap workspace. Select multiple items to drag 

them simultaneously. Hold down Ctrl as you drag and drop the .logicsymbol into the workspace to have it open as a 

separate file. 

  

To add symbols to your Favorites list 

1 Select the items in a control program that you want in the symbol. 

2 Right-click one of the items, then select Add to Favorites. 

3 Type a Name and a Description. 

4 Click Ok. 

  

 

Snap productivity tools 
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To put a Favorites item in a control program 

1 Click Favorites. 

2 Select the name of the symbol. 

3 Click in the workspace to place the symbol. 

  

To organize favorites 

1 Select Favorites > Organize. 

2 Use the buttons on the right to: 

○ Add new favorite 

○ Remove favorite 

○ Edit favorite's name or description 

○ Move up 

○ Move down 

○ Open selected favorite in main view for editing 
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To view or edit microblock common properties 

The Microblock Common Properties Editor lets you view or edit common properties for the Carrier, I/O, Network, 

and BACnet microblocks in a control program.  

1 To see the common properties of: 

• All Carrier, I/O, Network, and BACnet microblocks in the control program, click  on the toolbar. 

• Selected microblocks, shift+click the microblocks, click , then click Selected Microblocks. 

2 Select the tab for the properties you want to see. 

  

 
  

NOTES 

• Select File > Export to write the data to a CSV (Comma Separated Values) text file so that you can edit the file 

in a spreadsheet program. Click File > Import to import the CSV file back into the Microblock Common 

Properties Editor.  

 CAUTION  Do not change any column header name or microblock reference name in the spreadsheet 

program. 

• To undo changes made in the Editor, close the Editor, then use the Undo feature . 

• See Microblock Reference Help for a description of each property. 
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To find a microblock, label, or text in the workspace 

NOTE  This feature will not search: 

• Date, time, or duration fields  

• Multi-State text fields 

  

1 Select Edit > Find/Replace. 

2 Enter the text you are looking for in the Find What field. Snap will search Property Editor text fields for this 

text. 

3 Check Case Sensitive if you want to find items that exactly match the uppercase or lowercase text you typed in 

step 2. 

4 Check the type of items you want to find in the Search box. 

5 Click Find. 

6 Select an item in the Found Items list. That item is highlighted in the workspace. 

7 Click Close. 

 

 
 

To find and replace text in a microblock, label, or text entry field 

Follow the steps below to find and replace text in Property Editor text fields. 

NOTE  This feature will not search: 

• Date, time, or duration fields 

• Multi-State text fields 

  

1 Select Edit > Find/Replace. 

2 Enter the text you are looking for in the Find What field. 

3 Check Case Sensitive if you want to find items that exactly match the uppercase or lowercase text you typed in 

step 2. 

4 Check the type of items you want to find in the Search box. 

5 Click Find. 

6 In the Found Items list, check the item(s) whose text you want to replace. You can use the Check All or 

Uncheck All buttons if needed. 

7 Type the new text in the Replace With field. 

8 Click Replace. 

9 Click Close. 
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To find identical labels 

1 Right-click a label. 

2 Select Find Label Usages. 

3 Click an item in the list. That label is highlighted in the workspace. 

4 Click Close. 

 

 
 

To show a logical path 

Right-click a wire, then select Highlight Connections.  

If you leave the Highlight Connection box open while you highlight additional wires, each wire is highlighted with a 

different color. Click Change Color to select a different color for the highlight. 

Click Clear Highlight to turn off the highlighting. 

 

 
 

To show a wire's source microblock 

1 Right-click a wire. 

2 Select Go To Source. 
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You can create control programs in Snap that work with various types of wireless or ZS sensors. For each 

microblock that uses a sensor's value, you: 

• Select an Rnet tag that defines what type of information the value is. If Snap does not have the Rnet tag you 

need, you can create custom Rnet tags (page 33).  

• Define how the value should be displayed if using a ZS sensor. Snap lets you set the order for information to 

be displayed on a ZS sensor (page 32). 

 

 
 

To set the order of information displayed on a ZS sensor 

If the control program contains multiple microblocks whose values will appear on a ZS sensor screen, you can 

define the order in which the values will appear.  

EXAMPLES 

• If you assigned 3 microblocks to the Home screen, you can set the order that they will cycle through when no 

user is interacting with the sensor.  

• If you assigned 3 microblocks to the Info screen, you can set the order that they will appear in when a user 

presses the sensor's  button. 

 

To set the order: 

1 Select Reorder > Sensor Display Order.  

2 Select the microblock(s) you want to move, then click  or .  

NOTES   

○ Use Ctrl+click, Shift+click, or both to select multiple items. 

○ The first microblock in the list must be the first microblock that will appear on the Home screen. 

○ To highlight just the microblocks assigned to a particular screen or defined as Maintenance or Alarm, 

select an option in the Highlight list.  

3 Optional:  If you assigned multiple microblocks to the Home screen, the sensor will display the first microblock 

for 10 seconds by default. To shorten the time, select 3 seconds at the bottom of the window. 

4 Click OK. 

 

 

 
 

Defining options for sensors 
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To create custom Rnet tags 

Rnet tags are descriptions and numbers that identify types of system values, and determine how a ZS sensor will 

display the value. For example: 

• If a BACnet Binary Value Status microblock has the Rnet tag Fan Status (100), the sensor will display a fan 

icon when the microblock is active.  

• If a BACnet Multi-State Value Status microblock has the Rnet tag Demand Level (502), the sensor will display 

the demand level along with the number 502 to identify the value. 

The Snap application has pre-defined Rnet tags like those described above, but you can add custom tags if 

needed.  

1 Select Options > Preferences. 

2 On the Rnet Tags tab, select the tab (Binary, Analog, or Multi-state) for the type of microblock for which you 

are adding the tag.  

3 Click . 

4 Type a descriptive Display Name for of the Rnet tag.  

5 Optional:  The Rnet Tag Number field is prefilled with the next available tag number for the type of tag you are 

adding. (Binary tags are in the 1100's, Analog tags are in the 1300's, and Multi-State tags are in the 1500's.) 

You can change this number if needed. 

6 Click OK twice. 

The new Rnet tag will appear in a microblock's Rnet Tag droplist. 

  

 CAUTION  If you create a control program with a custom Rnet tag and then open the program in another 

instance of the Snap application that has the same tag number defined for a different value, the Snap application 

will replace its tag name with the tag name from the control program. 

NOTES   

• To delete a custom Rnet tag, select it, and then click . 

• To copy all custom Rnet tags to another computer, click Export, then save the file. On the other computer, 

click Import, then select the exported file. 
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Menu command Notes 

Edit > Third Party BACnet 

Addresses 

You can convert a control program into an integration program by setting 

Network I/O microblock addresses using discovered BACnet information 

from i-Vu®/Field Assistant. 

Control Program > Bundled 

Resources 

i-Vu® Pro only: 

When making a control program for use in a non-English system, use this 

command to embed the translation files in the control program, omitting the 

need to maintain separate files. See “Setting up your system for non-English 

languages” in i-Vu® Pro Help. 

Control Program >  

Unlock Control Program 

To edit a control program created in EquipmentBuilder, open the control 

program in Snap, then select this menu command. 

Options > Preferences These apply to the Snap application, not just the current file. 

 On this tab... You can... 

 General • Set the metric option as the default for all future 

control programs. See To begin a control program 

(page 4). 

• Guarantee that all control program file names do 

not contain spaces. 

 Alarm/Schedule 

Categories 
• Add custom alarm or schedule categories. See To 

use custom alarm and schedule categories (page 

24). 

 Rnet Tags • Add custom Rnet tags. See To create custom Rnet 

tags (page 33). 

• Export custom tags from one computer and import 

them on another. 

 Droplist Options Customize the following droplists in certain 

microblocks: 

• BACnet Engineering Units (Airflow, AO, AI) 

• Output types (AO) 

• Actuator types (AO) 

• Input types (AI) 

• Sensor types (AI) 

   

   

   

   

   

Miscellaneous Snap menu commands and features 
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Menu command Notes 

Tools > Configure Tools 

 

Click Add, then select a file(s) to add the following to the Tools menu. 

Click this option... To... 

Export Control Program 

Image 

Export the control program page to a .png file. 

You can choose a black or white background. 

Remove all Property 

Page Text 

Uncheck the Show Property Page Text field for all 

microblocks in the current control program. 

Scripts Write scripts to manipulate or extract information 

from the control program. See Help in the plug-

in's Script Editor for instructions. 

Statistics 

 

See information about the current control 

program. For example, the number of 

microblocks. 

Window Select another currently open file to view or edit.  

Help > Tip of the Day Uncheck Show tips on startup if you don't want to see the tips when you start 

the application. 

Help > Apply Update Use this command to install i-Vu®/Field Assistant service packs or patches, 

or to update all drivers, graphic libraries, or Help. 

Help > About Technical support may ask you for this version, license, or Java VM 

information. 
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The following applies only to an i-Vu® Pro v6.5 system. 
 

Creating control programs and translation files for a non-English system 

To have the i-Vu®/Field Assistant interface display a control program’s user-defined text (such as microblock 

names and property text) in a non-English language, you must: 

1 Create the control program using key terms instead of the text.  

2 Create translation files of key terms and their language-specific equivalents. 

In  the i-Vu®/Field Assistant interface, the key term is replaced with its equivalent in the translation file for the 

current operator language. If a i-Vu®/Field Assistant Properties page or graphic shows ??key term??, the key term 

is missing from the translation file.  

 

NOTE  To edit existing control programs or translation files, see Editing translation files, control programs, or 

graphics (page 39). 

 

 
 

To enter a key term in the Snap application 

In the Snap Property Editor, type @ before each key term.  

  

  

NOTES 

• Type only the key term in the Snap application. Expressions such as $present_value$ are put in the 

translation file as part of the translated text. See EXAMPLES in "Translation files" below. 

• Key terms can contain only alphanumeric characters and underscores (no spaces) and cannot start with a 

number.  

 

 

 

 
 

Working with control programs for non-English systems 
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Translation files 

Translation files are used to translate key terms in control programs and graphics. A translation file contains key 

terms and their language-specific equivalents.  

For a non-English system, you must create an English translation file and a non-English translation file* for each of 

the following: 

• Each control program 

• Key terms used in multiple control programs 

• Key terms used in multiple graphics 

  

EXAMPLES  

Translation files Key term=Language-specific equivalent 

English This_value=This value is $present_value$ 

Zone_temp=Zone temperature 

Spanish     This_value=Este valor es $present_value$ 

Zone_temp=Temperatura de zona 

*If the i-Vu®/Field Assistant interface will display multiple non-English languages, create a translation file for each 

language. 

 

 
 

To create and implement a translation file 

Create your translation file in a text editor, such as Microsoft® Word, that supports the character encoding you 

need. 

1 Type one key term and language equivalent per line, left justified, starting in column 1. Do not put spaces on 

either side of the equal sign.   

2 Save the file using the appropriate file name and location in the table below. 

  

If key terms are used in... the file name is... File location 

A single control program <any_name>_xx.native* Any location 

Multiple control programs equipment_xx.native* <system_name>\resources 

A single  

graphic 

<graphic_name>_xx.native* 

 

<system_name>\graphics\lvl5 

Multiple  

graphics 

translations_xx.native* <system_name>\resources 

*  xx = the language extension code. See "Extension codes and encoding" below. 

  

If you are using: 

○ the English character set, save the file as Text only. 

○ a non-English character set, save the file as Encoded text . (See your application’s help for information on 

saving files as encoded text.) When prompted for the language and encoding, see “Extension codes and 

encoding” below. 
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3 Open the control program in the Snap application, then select Control Program > Bundled Resources.  

4 Click  , locate and select the translation file(s) for this control program, then click Open. 

NOTES   

○ Do not add equipment_xx.native files that you created for multiple control programs. 

○ You can use Ctrl+click or Shift+click to select multiple files. 

5 Save the control program. The translation files are embedded in the control program; the original files are no 

longer necessary. 

  

Extension codes and encoding 

Language  Extension Codes Encoding 

Brazillian Portuguese _pt_BR ISO-8859-1 

English _en ISO-8859-1 

Canadian French _fr ISO-8859-1 

French _fr_FR ISO-8859-1 

German _de ISO-8859-1 

Italian _it ISO-8859-1 

Japanese _ja EUC-JP 

Korean _ko EUC-KR 

Russian _ru KOI8_R 

Spanish _es ISO-8859-1 

Swedish _sv ISO-8859-1 

Simplified Chinese _zh GB2312 

Traditional Chinese _zh_TW Big5 

Thai _th TIS620 

Vietnamese _vi Cp1258 

* Encoding is used when you create the translation file. 
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Editing translation files, control programs, or graphics for a non-English 

system 

If you add or edit a key term in a control program or graphic, be sure to make the same change in the translation 

file. See Creating control programs and translation files (page 36). 

If you make changes after attaching a control program or graphic in SiteBuilder, do one of the following: 

• If you changed text only in a control program or its translation file, right-click the control program on the 

Geographic tree, then select Rebuild Equipment Pages. 

• If you changed logic in the control program, right-click the control program on the Geographic tree, then select 

Reload Control Program. 

• If you changed a translation file located in <system_name>\resources, right-click each applicable graphic on 

the Geographic tree, then select Rebuild Graphic Resources. 

 
 

To edit a bundled resource 

The Snap application bundles (embeds) the translation file(s) for a control program into the .equipment file. See 

steps 3 through 5 in To create and implement a translation file (page 37). To edit a bundled translation file:  

1 Open the control program in the Snap application.  

2 Select Control Program > Bundled Resources.  

3 Select the file, then click  to save it to your hard drive.  

4 Edit the translation file. 

5 In the Bundled Resources dialog box in the Snap application, click  and select the edited file. 

6 Click OK to overwrite the existing file. 

 
 

Editing a control program in the Snap application 

To edit a non-English control program: 

1 Open the .equipment file in the Snap application, then make your edits. 

2 Select Control Program > Bundled Resources. 

3 Verify that the list shows all translation files specifically for the control program. Use the plus or minus button 

to add or delete translation files. 

NOTE  This list shows the translation files in the <system_name>\programs folder. This list should not include 

translation files for multiple control programs or graphics. 

4 Click OK. 

5 Save the control program. The translation files are bundled with the control program; the original files are no 

longer necessary. 

  

NOTE  If you need to change a translation file after you save the control program, see To edit a bundled resource 

(page 39). 
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Copying translation files to another system 

To copy most translation files from one system to another, you copy the files in the source system and paste them 

into the same folders in the destination system. 

However, if your source system and destination system have translation files with the same name, copying and 

pasting would overwrite the file(s) in the destination system. In this case: 

1 Open the source system’s translation file in a text editor, then copy the key terms and translations. 

2 Open the destination system’s translation file in a text editor, then paste into it the key terms that you copied. 

Remove any duplicate key terms. 
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Snap allows you to create programs to control points that reside in a different control program in the same 

controllers or in a different controllers. Use network microblocks to write to or read from points/properties in the 

equipment's control programs.  

You can create a control program in Snap for the following i-Vu® Open controllers:  

• AppController (OPN-APP) 

• Carrier® ChillerVu™ (OPN-PSM-MPCXPE and OPN-PSM-SIM) 

• i-Vu® Open Link (OPN-OL) 

• MPC Open XP (OPN-MPCXP) 

• UC Open (OPN-UC) 

• UC Open XP (OPN-UCXP) 

• UPC Open (OPN-UPC) 

NOTE  See i-Vu®/Field Assistant Help for instructions on downloading control programs into the controllers.  

You must: 

• Know the BACnet address of the point/property 

• Ensure the point/property is Network Visible 

• Have Installer role to download control programs or view BACnet Points tab 

 
 

Create a control program 

Step 1:  Identify Network points and network visibility 

1 Start the i-Vu®/Field Assistant application. 

2 Select the controller/equipment from which points will be read from or written to.   

3 Select Report tab > Equipment > Point List.  

4 Click Option tab. Check the following boxes to get a report listing: 

○ Type 

○ Device ID 

○ BACnet points 

5 Click Run to generate a report listing of all available BACnet points in the controller. 

6 Identify the desired points and required information to connect to them. 

7 On the Properties page > BACnet Objects tab, locate the points that need to be configured as Network Visible. 

Select the Network Visible checkbox for all required points/properties. 

8 Click OK. 

NOTE Network Visible points are also accessible to third-party devices. 

Creating Snap programs to use in i-Vu® Open Controllers 
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Step 2:  Prepare the control program 

1 Start Snap. 

2 Place microblocks and connect wires.   

3 Enter desired Display Name and Reference Name in the Property Editor for each microblock. 

 

Step 3:  Simulate program 

In simulation mode, you specify microblock properties and define an operating environment to see how a control 

program will operate. 

To simulate a control program: 

1 Select Control Program > Simulate. 

2 In the Simulator window, select Options > Setup. 

3 Define the simulation conditions. 

4 Do one of the following: 

• Click  to run the simulation continuously until you click  to stop it. Set the Time Increment fields (see 

table below) to define how fast the simulation will run. 

• Click  to run the simulation one step at a time. 

• Click  to run the simulation as fast as possible. 

5 Click a microblock and then select Simulation to enter values to check in the program.  NOTE  See Simulating 

a control program (page 25) for more information. 

6 Verify that the logic performs the desired sequence of operation. 

7 Close the simulation window to return to the workspace. 

  

Step 4:  Save program 

Click  or File > Save to save your control program. 

 

Step 5: Add a new control program to a programmable controller 

1 Select the router in the navigation tree. 

2 Select Devices > Manage tab. 

3 Select the controller in the list on the page. 

4 Click . A dialog window appears. 

5 Enter a name for your control program in Display Name and select your controller in the Controller drop-down 

list. 

NOTE  If you already have the maximum number of control programs for a controller, it will not appear in the 

list.  
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6 If you have already added the desired control program to the i-Vu®/Field Assistant application, click the arrow 

next to Control Program and select your program. 

7 If you have not previously added the control program, click Add New under Control Programs. A second dialog 

window appears. 

8 Browse to the .equipment file that you created in Snap and click Continue.  

9 To upload a graphic, click Add New under Views and browse to your .view file. 

10 Click Continue. When message appears File added successfully, click Close. 

11 Click Close again. 

12 Right-click on the programmable controller in the controller list and select Check Status from the list. The 

status of the controller should say File Mismatch. 

13 Click the Download All Content button.  

 

Step 6:  Configure Network microblock address 

1 Select the programmable controller in the navigation tree. 

2 Select Properties page > Network Points tab and click the point/property to open the microblock popup. 

3 On the Details tab, select the point/property in the navigation tree. 

4 Click Apply. 
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Example: Limit heating stages 

Use the following steps to create a control program to write to the Number of Heating Stages, based on the 

Outdoor Air Temperature in an RTU Open controller and download it into a UC Open XP.  

  

Step 1:  Prepare the control program 

1 Open Snap. 

2 Use the following microblocks to create the program.  

 

 

Use... To... 

ANI Read the Outdoor Air Temperature from the RTU Open. 

ANI Read the Number of Heating Stages actual value on the RTU Open and display the status on the 

Properties page > Equipment tab of the UC Open XP. 

ANO2 Write the max number of stages to the RTU Open, using Enable to restrict heating if OAT is above 30 

degrees.  

  

 

 

 

 

 

 

 



 

 

 
Snap v8.5 Carrier Proprietary and Confidential ©2023 Carrier. 

Help  All rights reserved. 

 45 

 

Step 2:  Make points network visible and obtain addresses 

1 Start i-Vu®/Field Assistant. 

2 Select the RTU Open in the navigation tree. 

3 Select Properties page > Equipment tab. 

4 Locate and click on Outdoor Air Temperature. 

 

 

 

5 Select the Details tab on the microblock popup to ensure the point is Network Visible. 

6 Repeat step 2 for the Number of Heating Stages. 

  

Step 3:  Simulate program 

See Simulating a control program (page 25) for details. 

  

Step 4:  Save program 

Click  or File > Save to save your control program. 
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Step 5:  Download program in i-Vu®/Field Assistant 

1 You may use either of the following methods to open the Control Programs dialog window in i-Vu®/Field 

Assistant: 

 

Method 1: From the Devices page  

1. Select the router in the navigation tree and go to the Devices page. 

2. Select the UC Open XP in the list on the page. 

3. Click . A dialog window appears. 

4. Enter a name for your control program in Display Name and select your controller in the Controller drop-

down list. 

NOTE  If you already have the maximum number of control programs for a controller, it will not appear in the 

list.  

5. If you have already added the desired control program to the i-Vu®/Field Assistant application, click the 

arrow next to Control Program and select your program. 

6. If you have not previously added the control program, click Add New under Control Programs. A second 

dialog window appears. 

7. Browse to the .equipment file that you created in Snap and click Continue.  

8. When message appears File added successfully, click Close. 

9. Click Close again. 

10. Right-click on the programmable controller in the controller list and select Check Status from the list. The 

status of the controller should say File Mismatch. 

11. Click the Download All Content button. 

 

Method 2: From the navigation tree  

1. Right-click the UC Open XP in the navigation tree and select Configure in the drop-down menu. A dialog 

window appears. 

2. Click Add New under Control Programs. A new dialog window appears. 

3. Browse to your edited control program and click Continue. When message appears File added 

successfully, click Close. 

4. Click Close again. 

5. Select the router in the navigation tree and go to the Devices page. 

6. Right-click on the programmable controller in the controller list and select Check Status from the list. The 

status of the controller should say File Mismatch. 

7. Click the Download All Content button. 

Step 6: Configure Network microblock address 

1 Select the UC Open XP in the navigation tree. 

2 Select Properties page > Network Points tab and click the point/property to open the microblock popup. 

3 On the Details tab, select the point/property in the navigation tree. 

4 Click Apply. 

5 Repeat these steps for all network microblock addresses. 
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UPC Open control program 

When creating a Snap application for the UPC Open, you must identify and map the points from the CCN controller 

that you want to be accessible to i-Vu®/Field Assistant and/or a BAS system. Use the following guidelines to create 

a control program for the UPC Open. 

  

Step 1:  Identify data  

• Identify the data to be mapped by the UPC Open. 

• Identify the CCN table and point name for the desired data. 

• Determine data that you need to be accessible over the network. 

• Determine data that you need to trend. 

  

Step 2:  Standard communication logic 

• Open Snap. 

• Use the following microblocks to create the communication section of the control program.  

  

 

  

Use... To... 

CCN Controller Define the Element for the CCN equipment that the UPC Open interfaces with. 

BACnet Binary Value 

Status 

Display the status of communication between the BMS and CCN equipment.  

Not Invert the communication status signal from the CCN controller. 

Delay On Make Wait for a specified time before sending a signal to the alarm for lost  

communication.  

Digital Trend Record communication status for trend purposes. 

BACnet Alarm Display an alarm when communication is lost between the BMS and CCN 

equipment.  

NOTE  Go to the Driver page in i-Vu®/Field Assistant to finish configuring the control program once it is 

downloaded to the controller. See "Configuring the UPC Open's properties" in the UPC Open Installation and 

Startup Guide. 

  



 

 

 
Snap v8.5 Carrier Proprietary and Confidential ©2023 Carrier. 

Help  All rights reserved. 

 48 

 

Step 3:  Mapping the desired points 

• Use the following guidelines to determine the type of Carrier microblocks you require: 

  

Guidelines: Carrier Value microblocks vs Carrier Point microblocks 

 Carrier Analog/Binary 

Value 

Carrier Analog/Binary 

Point 

Allows for trending  X 

Allows for alarming  X 

Network Visible  X 

Contains a BACnet Object  X 

Can be used in a graphic to force a variable X X 

  

• Place the appropriate mircroblock on the workspace. 

 

NOTE  These microblocks do not require output connections, as i-Vu®/Field Assistant automatically links to 

the CCN path and displays the status on the Properties page.  

 

Setting the path 

Use the information below to format a valid path for the particular microblock you are using to read from or write 

to the CCN point. Select Editable to edit path in i-Vu®/Field Assistant.  

Path format: CCN://device specifier/table specifier/point name:instance# 

NOTE  Each item in the path is limited to 8 alpha-numeric characters. 

 

Device specifier 

LINK is always the Device 

Specifier 

CCN://LINK/… 
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Table specifer - Use one of the following: 

Definition table name:  Name of 

table containing the desired point 

CCN://LINK/MYTABLE:MYDATA1 

Data table name CCN://LINK/MYDATA1 

Point name:instance# 

Field name CCN://LINK/…/FLDNAME 

Optional 

Instance# is the instance number of the point name. Use this item in the path if more than one field in a table 

share the same point name. 

 

EXAMPLES 

Use the following syntax to read the the CCN Chiller Start/Stop point shown below: 

CCN://LINK/GENUNIT/CHIL_S_S 

 
Points with the same point name must specify the instance #. Use the following syntax: 

• Current Alarm 1 CCN://LINK/GENUNIT/alarm:1 

• Current Alarm 2 CCN://LINK/GENUNIT/alarm:2 
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• Current Alarm 3 CCN://LINK/GENUNIT/alarm:3 

 
 

Change editable addresses/paths in i-Vu®/Field Assistant on the:  

• The Details tab of a Point Properties dialog box. 

• The Address column on the Properties > Network Points page. 

  

Step 4: Occupancy 

• To support BACnet scheduling in the CCN controller, through the UPC Open, you must add a Carrier Schedule 

microblock from the Carrier library.  

  

occ 

 

 Carrier Schedule Microblock 

• Edit the Write to global schedule number and enter the number of the occupancy table (OCCPC##) of the CCN 

Controller that is to be written to.   

  

Step 5: Linkage 

If you require Airside Linkage, you must create a separate control program in EquipmentBuilder and download it to 

the UPC Open controller. No setup is required for the Linkage application in UPC Open using i-Vu®/Field Assistant. 

NOTE  This is only applicable if the UPC Open interfaces to an i-Vu®/Field Assistant system where the CCN 

controller is the air source for the i-Vu®/Field Assistant zoning system. 
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Important changes to this document are listed below. Minor changes such as typographical or formatting errors are not 

listed. 

  

Date Topic Change description Code* 

  No changes yet  

  

*  For internal use only 

 

 

Document revision history 





 

 

 

 

 

  
 

 
 

Carrier  ©2023 ·  Catalog No. 11-808-935-01 · 2/24/2023 

 


