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An i-Vu® system is a web-based building automation system that can be accessed from anywhere in the world 
through a web browser, without the need for special software on the workstation. Through the web browser, you 
can perform building management functions such as:  

• adjust setpoints and other control parameters 

• set and change schedules 

• graphically trend important building conditions  

• view and acknowledge alarms 

• run preconfigured and custom reports on energy usage, occupant overrides, and much more 

 

   i-Vu® Standard  i-Vu® Plus 

Part number CIV-OPN CIV-OPNPL 

Networks supported BACnet and CCN BACnet and CCN 

Routing devices • USB-CCN Adapter 

• USB-MS/TP Adapter 

• Open/CCN routers 

• Carrier® ChillerVu™ 

• i-Vu® XT Router (#XT-RB) 

• USB-CCN Adapter 

• USB-MS/TP Adapter 

• Open/CCN Routers 

• Open/CCN Links 

• Carrier® ChillerVu™ 

• i-Vu® XT and TruVu™ routers 

Maximum controllers supported 750 750 

Trend storage 7 days 62 days 

Alarms storage 500 500 

Audit Log storage 30 days 30 days 

Custom Equipment and Trend 
Reports   

Tenant Override Billing Reports   

Weather Add-on   

Web Services (XML/SOAP) Data 
Access   

BACnet/Modbus®/LonWorks® 
integration   
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i-Vu® Standard and Plus web server specifications 

  

 i-Vu® web server   

Operating temperature 32°F  to 122°F (0°C to 50°C). For indoor use only 

Storage temperature -4°F to 158°F (-20°C to 70°C) 

Storage humidity 5% to 90% RH 

Weight 2.4 lb (1.09 kg) 

Dimensions 4.52 in. (115 mm) deep x 4.37 in. (111 mm) wide x 1.9 in. (48.7 mm) high 

USB ports 4 USB 3.0 ports for i-Vu® network connection or for backing up/restoring 
system data 

LAN port Integrated Intel® 10/100/1000 Mbps port for Ethernet  

VESA mounting plate Attach the web server to the back of a flat monitor 

Mini DisplayPorts Connect to a monitor for troubleshooting 

Safety Compliance IEC, UL, EN, CAN/CSA 

Environmental Compliance RoHS 2011/65/EU, WEEE 2002/96/EC, China RoHS MII Order #39 

EMC Compliance FCC CFR Title 47, Chapter I, Part 15, Subparts A, B 

 

 

i-Vu® tools 

Develop and configure graphics and a system database for your i-Vu® system using the following i-Vu® tools. 

NOTE  The i-Vu® tools have a built-in license that expires 2 years after the software is released. Contact Carrier 
Control Systems Support for updates concerning your license. 

 

Use... To... 

ViewBuilder Create or edit graphics 

 

Tech tools for the Installer only: 
Use... To... 

EquipmentBuilder Build or edit control programs (.equipment files) for programmable 
controllers. Can also produce graphics, sequence of operation, and 
screen files  

Alarm Notification Receive a message on any networked computer that is running the i-
Vu® Alarm Notification Client application 

Virtual BACview® View and change property values and the controller's real time clock 



 What is the i-Vu® Standard/Plus application?
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Use... To... 

BBMD Configuration Tool Configure BACnet/IP Broadcast Management Devices (BBMDs) 

NOTE  If your system has multiple routers that reside on different IP 
subnets, you must set up one router on each IP subnet as a BACnet/IP 
Broadcast Management Device (BBMD).  

MSTP Capture Utility Capture BACnet traffic on MS/TP. It is intended for situations where 
Carrier Control Systems Support needs a network capture to 
troubleshoot communications.  

Test & Balance • Calibrate airflow in a VAV or VVT Zone controller  
• Calibrate the static pressure in a VVT Bypass controller  
• Commission air terminals 
• Override reheat and terminal fans 
NOTE  Use Test & Balance to manipulate the controllers associated with 
an air source, but not the air source itself, or heating and cooling 
equipment, such as chillers and boilers. 

Snap Build custom control programs using individual blocks of programming 
code called microblocks 

LonWorks Integration Tool Generate the microblock addresses automatically for third-party 
LonWorks points 

AppLoader Use to download .clipping files to restore factory defaults and check 
Module Status (Modstat) through the Rnet port 

Field Assistant Service or start up and commission a piece of equipment or a network of 
controllers. 
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What's new in the i-Vu® Standard/Plus application 

  

Feature Improvement 

New web server Model NUC7i3DNHE  - New look with same functionality 

Management Tool security 
enhancements 

• Management Tool automatically locks out the user for 30 minutes after 5 
unsuccessful login attempts. 

• Management Tool automatically locks out the user after 30 minutes of 
inactivity. 

• New option to Redirect HTTP requests to HTTPS. 

i-Vu® security enhancement Security in the Management Tool and the i-Vu® web server increased by the 
user installing browser self-signed certificates. 

v7.0 cumulative update #3  

New fields in System Options 
(page 29) 

The General tab now shows the System Language and lets you choose the 
number of levels to show in i-Vu® paths. 

v7.0  

Custom reports (page 100) i-Vu® Plus only - v7.0 custom reports are managed through the new Report 
Manager. 

You can export one or more custom reports to a file so that they can be 
imported into another system. 

A custom report can provide data for the following new items on a Graphics 
page: 
• Data table 
• Chart 
• Color map 
See What's new in the ViewBuilder application (page 5) for more information on 
the above items. 

NOTE  To support upgraded systems, you can still create and access legacy 
(v6.5 and earlier) custom reports (page 104). 

Scheduled Reports (page 103) i-Vu® Plus only - You can set up a report to run on a recurring basis. The report 
is saved as a file (PDF, CSV, or XLS), and you can choose to have it 
automatically emailed to someone. 

Email Server Configuration 
(page 29) 

The Email Server Configuration settings, used by scheduled reports and the 
Send Email alarm action, are now located on the System Options > General 
tab. 

Send Email alarm action (page 
78) 

This alarm action can use the default Email Server Configuration settings 
defined in System Options, or you can enter settings specific to the alarm 
action.  

New FDD alarm categories 
(page 83) 

i-Vu® now has two new alarm categories, FDD Comfort and FDD Energy. 

What's new in v7.0 
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Feature Improvement 

Add-ons (page 38) The i-Vu® Plus application now allows only signed add-ons that are supported 
by Carrier. The i-Vu® Standard application does not support add-ons. 

WAP device support This has been removed from the i-Vu® application. Smart phone support 
introduced in v6.5 replaced this functionality. 

 

 

What's new in the ViewBuilder application 

  

Feature Improvement 

Local Variables ViewBuilder now preserves local variables through cut/copy and paste, as well as 
when importing a .viewsymbol. 

Layers  • ViewBuilder now preserves layers when importing a .viewsymbol.  

• If cutting/copying a selection assigned to layers, you must hold Shift while 
pasting in a new file to preserve layer assignments. 

 

What's new in the Snap application 

 

Feature Improvement 

Support for the following new optional features has been added to Snap. When released, you can download 
them from https://accounts.ivusystems.com/tsaplctrackweb.nsf/download under Technician Tools Software 
and Updates > v7.0 installs and updates or 
http://hvacpartners.com/Pages/PS/Software/ControlsDownloads/aspx under i-Vu SAL Files and Updates. 

Improved Edit Order Provides more flexibility and reduces the time needed to create property pages 
for equipment.  

Translation Assistance Tool Simplifies the process of creating non-English control programs. 
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The i-Vu® system can be viewed on the following client devices and web browsers. 
  

Computers  
The client computer should have at least: 
•  Dual core processor  
•  1.5 GB RAM 
•  Communications link of 10 Mbps or higher 
  
The i-Vu® application will work with slower computers and slower links, but the results may not be satisfactory. 
  

A computer with this 
operating system... 

Supports these web browsers... 

Windows® GoogleTM ChromeTM v66.0 or later 1 

Internet Explorer® v11 Desktop 

Microsoft® Edge v40 or later 

Mozilla® Firefox® v60.0 or later 

Mac® OS X® 
(Apple® Mac only) 

Safari® v11 or later 2 

Google Chrome v66.0 or later 

Mozilla Firefox v60.0 or later 

 

Linux® Google Chrome v66.0 or later 

Mozilla Firefox v60.0 or later 

1 Best performance 

2 Best performance unless browser is running on a Mac® Mini or a MacBook: 

 WARNING If machine is running Mountain Lion 10.8x with an integrated Intel HD 400 graphics card, 
it will experience display issues. Use one of these workarounds for better performance: 
• If an additional NVIDIA graphics card is available, manually switch the graphic card setting in MAC® OS 

X® to use that card. 
• If not, use GoogleTM ChromeTM v66.0 or later. 

 

Mobile devices 
   

Device type Platform support 

Smart phone AndroidTM, iOS 

Tablet AndroidTM, iOS, SurfaceTM 

 
NOTE  Some functionality may be limited by the capability of the mobile device and operating system. 

Setting up i-Vu® client devices and web browsers 
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Setting up and using a computer with the i-Vu® system 

  

• Set the monitor's screen resolution to a minimum of 1920 x 1080 with 32-bit color quality 

• You may want to disable the computer's navigation sounds. 
  

Mac only 
NOTE  The instructions below are for a Mac OS X 10.8. Other versions may vary slightly. See your computer's Help 
if necessary. 
  

Computer settings To change setting... 

Enable right-clicking to see 
right-click menus: 

 

      On a Mac 1 Select System Preferences > Mouse. 

2 Click the drop-down list that points to the mouse's right-click button, 
then select Secondary Button. 

      On a MacBook 1 Select System Preferences > Trackpad. 

2 Enable Secondary click.  

 

The instructions in Help are for a Windows computer. For instructions that include the Ctrl key, replace Ctrl with 
Command. For example, replace Ctrl+click with Command+click.  

 

 

Setting up and using a web browser to access the i-Vu® interface 

After installing and connecting to the i-Vu® application and Management Tool, every computer that will be used to 
access the application and the Management Tool must install 2 self-signed certificates for your browser. See 
Install self-signed certificates for network security (page 12). 

NOTE  Thei-Vu® application installer must make sure certificates are installed on the users' computer(s).   

 

To set up and use Internet Explorer 
NOTES 

• The instructions below are for Internet Explorer® 11. Other versions may vary slightly. See your web browser's 
Help if necessary. 

• If the menu bar is not visible, right-click on the window's header, and then select Menu bar. 
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Web browser settings To set in Internet Explorer... 

Accept First-party and  
Third-party cookies 

Tools > Internet Options > Privacy > Advanced button 

Automatically check for newer 
versions of stored pages 

Tools > Internet Options > General > Browsing history > Settings button 

Load ActiveX Control Tools > Internet Options > Security > Custom Level button. Under 
ActiveX controls and plug-ins, set the following: 
• Download signed ActiveX controls > Prompt 
• Download unsigned ActiveX controls > Disable 
• Run ActiveX controls and plug-ins > Enable 
• Script ActiveX controls marked safe for scripting > Enable 

Select Play animations in web pages Tools > Internet Options > Advanced > under Multimedia  

Disable all the options on the Explorer 
Bar 

View > Explorer Bars 

Disable web browser's pop-up 
blockers 

Tools > Pop-up Blocker > Turn Off Pop-Up Blocker 

Disable external toolbar  
pop-up blockers 

Varies 

Hide the web browser's toolbars View > Toolbars 

  

To... Do the following... 

Maximize the web browser window Press F11 to turn full-screen mode on\off, or use the 
minimize/maximize button in the top right corner of the browser window. 

Have 2 different users logged in to 
the i-Vu® system on the same 
computer 

Start a new web browser session. Select File > New Session. 

Clear browser cache 1 Select Tools > Internet Options. 

2 Click Delete. 

3 If you had the i-Vu® system saved as a Favorite, uncheck Preserve 
Favorites website data. 

4 Click Delete again. 
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To set up and use Microsoft Edge 
The instructions below are for Microsoft® Edge. 
  

Web browser settings To set in Microsoft Edge... 

Do not block cookies More Actions > Settings > View Advanced Settings > Cookies 

Disable web browser's pop-up 
blockers * 

More Actions > Settings > View Advanced Settings > Block pop-ups  

  

To... Do the following... 

Maximize the web browser window * Use the minimize/maximize button in the top right corner of the browser 
window. 

Have 2 different users logged in to 
the i-Vu® system on the same 
computer * 

More Actions > New Window  

Clear browser cache More Actions > Settings > Clear browsing data > Clear 

* Does not apply to Microsoft Edge on a phone. 

 

 

To set up and use Mozilla Firefox 
NOTES 

• The instructions below are for Mozilla® Firefox® v60.0 on a Windows operating system. Other versions may 
vary slightly. See your web browser's Help if necessary. 

• If the menu bar is not visible, right-click on the window's title bar, and then select Menu bar. 

• If a message appears in the i-Vu® interface that includes the checkbox Prevent this page from creating 
additional dialogs, DO NOT check this box. 

  

Web browser settings To set in Firefox... 

Disable Pop-up blocker 1 Click Tools > Options > Privacy & Security.  

2 Under Permissions, click Exceptions next to Block pop-up windows.  

3 Type http:// (or https://) and then the server name or IP 
address of your system.  

4 Click Allow and then Save Changes. 

Enable JavaScript 

 

1 In the address bar, type about:config, and then press Enter. 

2 Click I accept the risk. 

3 In the Search bar, type javascript.enabled. 

4 If the value field shows true, JavaScript is enabled. If it shows false, 
right-click javascript:enabled, and then select Toggle. 



Setting up i-Vu® client devices and web browsers  
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Web browser settings To set in Firefox... 

 Add-ons Manager 

 

Select Tools > Add-ons > Extensions. On this page, you can 
enable/disable installed add-ons such as: 

• Adobe® Acrobat® Reader (to view PDF's) 

• QuickTime Plug-in (to play audible alarms) 

Only installed Firefox add-ons will show up in the list.  

  

To... Do the following... 

Maximize the web browser window Press F11 to turn full-screen mode on\off. 

Clear browser cache 1 Click Tools > Options > Privacy & Security. 

2 Under Cookies and Site Data, click Clear Data. 

3 Click Clear. 

Have 2 different users logged in to 
the i-Vu® system on the same 
computer 

Start a new web browser session. Select File > New Private Window. 

 

To set up and use Google Chrome 
NOTES   

• The instructions below are for GoogleTM ChromeTM v66.0. Other versions may vary slightly. See your web 
browser's Help if necessary.  

• If a message appears in the i-Vu® interface that includes the checkbox Prevent this page from creating 
additional dialogs, DO NOT check this box. 

  

On a computer 
Web browser settings To set in Chrome... 

Enable pop-ups 1 Click  on the browser toolbar.  

2 Select Settings.  

3 Click Advanced at the bottom of the page. 

4 Under Privacy and security, click Content settings.  

5 Under Pop-ups > Allow, click ADD, and then type http:// (or 
https://) and then the server name or IP address of your system. 

 

 

 

 

 

To... Do the following... 
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To... Do the following... 

Clear browser cache 1 Click  on the browser toolbar.  

2 Select More tools > Clear browsing data.  

3 Select a time range in the drop-down list. 

4 Check the types of information that you want to remove.  

5 Click CLEAR DATA. 

Maximize the web browser window Press F11 on your keyboard to turn full-screen mode on/off. 

Have 2 different users logged in to 
the i-Vu® system on the same 
computer 

Start a new web browser session. Click , then select New incognito 
window. 

  

On a Google Nexus 
Web browser settings In the Chrome menu... 

Turn off desktop mode Uncheck Request desktop site 

Disable pop-up blocker Settings > Advanced > Content Settings > uncheck Block  
pop-ups 

Enable JavaScript Settings > Advanced > Content Settings > check Enable JavaScript 

Enable Cookies Settings > Advanced > Content Settings > check Accept Cookies 

  

To... In the Chrome menu... 

Clear browser cache Settings > Advanced > Privacy > CLEAR BROWSING DATA 

 

 

To set up and use Safari 
NOTES   

• The instructions below are for Safari® v11. Other versions may vary slightly. See your web browser's Help if 
necessary. 

• We recommend that you do not run Safari in full-screen mode. If you do, i-Vu® pop-ups will open full-screen, 
covering the main application window. 
  

On an Apple® computer (Mac®) 
Web browser settings To set in Safari... 

Disable pop-up blocker Preferences > Security > uncheck Block pop-up windows 

Enable JavaScript Preferences > Security > check Enable JavaScript 

Enable Plug-ins Preferences > Security > check Enable plug-ins 
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Web browser settings To set in Safari... 

Prevent pop-ups from opening in a 
new browser tab 

Preferences > Tabs > uncheck Command-click opens a link in a new 
tab 

Prevent Safari from automatically 
opening zip files exported from the i-
Vu® application 

Preferences > General > uncheck Open "safe" files after downloading 

  

To... Do the following... 

Clear browser cache History > Clear History 

Have 2 different users logged in to 
the i-Vu® system on the same 
computer 

Start a new web browser session. Select Safari > Private Browsing > 
File > New window 

  

On an Apple® iPad 
Web browser settings To set on the iPad... 

Disable pop-up blocker Settings> Safari > set Block pop-ups to Off 

Enable JavaScript Settings > Safari > set JavaScript to On 

  

To... Do the following... 

Clear browser cache Settings > Safari > Clear History 

  

On an Apple® iPhone 6 
Web browser settings To set on the iPad... 

Enable JavaScript Settings > Safari > Advanced  

 

 

Install the Install self-signed certificates for network security 
For security purposes, you must install a self-signed certificate on every computer used to access the i-Vu® 
application using "https". A user who has the Installer Role and will be accessing the Management Tool needs a 
second certificate. 

You will get a browser certificate error when using "https" to access the i-Vu® application and the Management 
Tool until you install the certificates on your computer.  

IMPORTANT  We highly recommend that you have the appropriate browser certificates in place before finding and 
uploading your devices and building your system in the i-Vu® application.  

 

 CAUTION  If you ever change the Network Name, the IP address, or DNS IP address, you must download both 
certificates again.  
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The i-Vu® application 

1 After setting up the information on the Startup screen, log out. 

2 Launch your browser and type https://<your system name> or Server IP address. For ex.: https://ivu/ or 
https://172.21.319.123. 

NOTE  Use the TLS indicator https instead of http.  

3 There will be a certificate error in your browser. Follow the steps listed below to install a certificate for the 
browser you are using to access the i-Vu® application. 

 
 

The Management Tool 

After installing the certificate for browsing to the i-Vu® application, you must install another one for accessing the 
Management Tool. 

1 Log out of the i-Vu® application. 

2 Launch your browser and type your system name or Server IP address followed by :8080.  For ex.: 
https://ivu:8080/ or https://172.21.319.123:8080 

3 You will see a certificate error again. Follow the directions below for the browser you are using.   

 

Instructions to install a self-signed certificate  
 

Internet Explorer® 

1 If the page displays There is a problem with this website's security certificate, click Continue to this website. 

2 Enter your Username and Login. 

3 In the address bar, click Certificate Error.  
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4 Click View Certificates to open the Certificate dialog. 

 
 

5 On the Details tab, select Issuer, then click Copy to File. 

6 In the Certificate Export Wizard, click Next and Next again. 

7 Browse to the folder on your computer that you want to save the certificate in, enter a name, then click Next. 

8 Click Finish. 

9 Click OK to close the message The export was successful.  

10 Click OK to close Certificate window. 

11 To import the certificate, Select Tools or  > Internet Options. 

12 On the Content tab, click Certificates, and then select Trusted Root Certification Authorities tab. 

13 Click Import. 

14 Click Next in the Certification Import Wizard. 

15 Browse to the certificate you saved and click Open, then Next. 

16 Select Place all certificates in the following store. 

17 Click Browse and select Trusted Root Certification Authorities. 

18 Click Next. 

19 Click Finish. 

20 Click Yes in the Security Warning dialog box to install the certificate. 

21 Click OK. 

22 Click Close again and then OK. 

23 Close Internet Explorer, then open it again. 

24 Log in to the i-Vu® application. 
  

NOTE  Chrome and Windows browsers use the same Certificate store, so it is not necessary to install a certificate 
obtained through Internet Explorer in a Chrome Browser used on the same computer. 
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Google™ Chrome™ 

When connecting to the i-Vu® application or Management Tool without a self-signed certificate installed, you will 
see the following. 

 
 

1 Export certificate to a known location: 

a) In the address bar, click Not secure. 

b) Click Certificate (Invalid) to open the Certificate dialog. 

c) On the Details tab, select Issuer, then click Copy to File. 

d) In the Certificate Export Wizard, click Next and Next again. 

e) Browse to the folder on your computer that you want to save the certificate in, enter a name, click Save, 
then Next. 

f) Click Finish. 

g) Click OK to close the message The export was successful. and click OK again to close the Certificate 
dialog. 

2 Import saved certificate: 

a) Click  on the browser toolbar, then select Settings. 

b) Click Advanced. 

c) Scroll down to Privacy and security, then click Manage certificates. 

d) On the Trusted Root Certification Authorities tab, click Import. 

e) In the Certificate Import Wizard, click Next. 

f) Click Browse, then select the file you exported in step 2. 

g) Click Open. 

h) Click Next, and Next again, then Finish. 

i) Click Yes to the Security Warning popup, then OK to the Import was successful message. 

j) Close the Certificates window. 

k) Close Chrome, then open it again. 

NOTE Chrome and Windows browsers use the same Certificate store so it won’t be necessary to install this 
same certificate in a Window Browsers used on the same PC.  
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Mozilla® Firefox®   

1 Open the i-Vu® application or the Management Tool using Mozilla® Firefox®. 

2 Click the Advanced button on the page stating Warning: Potential Security Risk. 

3 Click Accept the Risk and Continue. 

4 Firefox displays the following icon near the URL window indicating that an exception has been made for this 
site 
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Computer and large-screen mobile interface 
 

 
  

  

Small-screen mobile interface 
Most of the i-Vu® interface is the same on small-screen mobile devices except for the differences shown below. 

 
 

Getting to know the interface 
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• When you click  to hide the tree, the button changes to . 

• Help and Print are in the  menu.  

    

NOTES 

• After you log in, you will see the page defined as your starting location on the My Settings page. To change 
your opening page, see To change My Settings (page 25). 

• Roles/privileges control what an operator can see or do in the i-Vu® system. If you cannot see or do 
something that you read about in Help, ask your System Administrator to check your role/privileges. 

• Use only the i-Vu® interface to navigate; do not use the web browser’s navigation buttons. 

• Click on any tab to refresh the page. 

 

 

Navigating the system 

To navigate in the i-Vu® interface: 

1 Select the item you want in the navigation tree. 

2 Select the action buttons and their drop-down lists. 

3 Use the tabs to filter the information further. 

NOTE  Use only the i-Vu® interface to navigate; do not use the browser’s navigation buttons. 

4 Click on any tab to refresh the page. 
 

System Options 

Click  and select System Options (page 24) to view or change the setup and maintenance of your system in 
your i-Vu® application.  
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To show, hide, or resize the navigation tree 

 

On a computer or large screen mobile device 
 

Click  at the top of the navigation tree to hide or show the tree.  

Click and drag the tab on the right side of the tree to adjust its width. 
 

 
In the Installer view, click and drag the tab at the top of Arrange User View to adjust the height of the window. 

 
  

On a small-screen mobile device 

Touch  at the top of the navigation tree to hide the tree. Touch  to show it. 

Double-tap the arrow on the right side of the tree to widen the tree. Double-tap again to return to the original size. 
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Zooming in and out 

On a computer 
• To zoom in and out on the i-Vu® interface: 

○ Hold down Ctrl and press + or -. Press Ctrl+0 to return to 100%. 

○ Hold down Ctrl while rolling your mouse wheel. 

○ Use your web browser's zoom functions. 

• If a graphic does not fit in the action pane, right-click it and select Scale to Fit to make it fit the action pane. 
Select Scale to Fit again to return the graphic to its original size.  

  

On a mobile device 
Apple® iPad and iPhone 

• Double-tap to zoom in/out. 

  

Microsoft® SurfaceTM 

• Pinch-zoom works on individual frames, instead of the whole screen. So, you can zoom and scroll the 
navigation pane and action pane separately. 

• If browser text is too small, use Ctrl + to increase Internet Explorer's zoom level, then reload the page. 

 

GoogleTM NexusTM and Nexus Lumia  

• Pinch-zoom to zoom in/out. 
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Using right-click menus 

On a computer 
You can right-click the following items to select options: 
 

A tree item  The action pane 

 

 

A property A trend 

 

 

  

On a mobile device 
To access the right-click menu for: 
• A tree item–Select the item first, then touch and hold the item for several seconds. 
• The action pane–Touch and hold the item for several seconds. 
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To print the action pane 

On a computer 

Click  at the top of the page to print the contents of the action pane. Set the print orientation to Landscape 
in the Print dialog box.  

 TIP  To print a Graphics page that exceeds the size of the action pane, right-click the graphic and select Scale 
to Fit. 

On a mobile device 

Touch  and then select Print. 

 

 

Colors and status in the i-Vu® interface 

The following colors indicate equipment status throughout i-Vu® interface. These colors are visible on Property 
pages, Graphics pages and in the setpoint graphs.  
  

Color Color Name Status Code Condition Indicated 

 Purple 0 or 15 In a controller—non-operational or no communications 
In equipment—a hardware or software error 

 Charcoal 14 In a controller—a download is required or is already in 
progress 
In equipment—a controller has stopped 

 Coral 13 Control program error 

 Red 2 or 9 Heating or cooling alarm 

 Orange 8 Maximum cooling 

 Dark blue 3 Maximum heating 

 Yellow 7 Moderate cooling 

 Light blue 4 Moderate heating 

 Grey 1 Unoccupied/inactive 

 White 10 Occupied/active 

 Light green 6 Free cooling 

 Green 5 In a controller—operational or operational read-only 
In equipment—No heating or cooling 
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Colors and setpoints 

Thermographic colors indicate how much a zone’s actual temperature differs from its setpoints.  

Five conditions may affect a zone’s thermographic color:  
• Setpoint adjust 
• Timed local override (TLO) 
• Optimal start 
• Demand level 
• Hysteresis 
In the examples below, a zone’s heating occupied setpoint is 70° and its cooling occupied setpoint is 74°. 
  

If you 
normally 
see... 

when the zone 
temp is... 

but... then you will 
see... 

green 

 

72.5° someone adjusts the setpoints (for example, with a setpoint 
adjust of two degrees, the new setpoints would be 68 and 
72°) 

yellow 

 

gray 

 

73° 
(unoccupied) 

someone presses the Override button on a zone sensor to 
use the occupied setpoints 

green 

 

gray 

 

77° 
(unoccupied) 

the zone is in optimal start and is ramping up to its 
occupied setpoint in the few hours before occupancy 

an occupied 
color 

yellow 

 

75°  the zone’s electric meter is in demand level 2 with relaxed 
setpoints of 68 and 76° 

green 

 

green 

 

73.5° cooling began when the temperature rose above 74° and 
the temperature has not yet dropped beyond the 1° 
hysteresis (to 73°) 

yellow 
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Click  and select System Options for the following tasks. On the: 

• My Settings (page 25) tab, change the Installer's: 

○ Password 
○ Starting view and page 
○ Preferences to automatically collapse trees, automatically download schedules on each change, and 

alarm notification 

•  Operators (page 25) tab, set up: 

○ Login names and passwords 
○ Logoff rules 
○ Starting locations 
○ Levels of access (roles) 

• General (page 29) tab 

○ View system statistics - number of devices in the system, number of trends, estimated time for importing 
or exporting system clipping. 

○ Download weekly logs 
○ Access the Management Tool (page 32)  
○ Set system date, time, timezone, and time/date format 
○ Enable time synchronization schedule  
○ Enable Alarm Notification Client 
○ Enable/Disable Schedules feature 
○ Import/Export Source Files, which include control programs, drivers, views, screen files, and report 

design files 
○ Enable or disable Full Source download to Open PIC controllers and select to include or not include 

graphics in download 
○ Import/export clipping files 
○ Set up the email server  

• Security (page 33) tab - Set advanced password and operator control 

• Update  (page 35)tab 

○ Install .update files 
○ Update SAL libraries 
○ View current Help updates and current libraries 

• Daylight Saving (page 37) tab - update scheduled DST dates 

• Add-ons (page 38) tab - Install add-ons such as Tenant Override Billing or Weather (i-Vu® Plus application 
only)  

 

NOTES 

• Some operators will not see all of the System Options tabs, depending on their assigned roles. 

• See the i-Vu® Help for more details on the System Options tabs. 
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My Settings tab 

To change your settings: 

1  Click , then select System Options > My Settings tab. 

2 See table below for explanation of settings.  

3 Click Accept or Apply. 

4 Changes become effective when operator logs in again. 

 

Field Notes 

Login Enable this field, then type your current and new password and confirm. Limit 
is minimum of 8 and maximum 40 characters of any type.  

Starting Location and 
Starting Page 

The i-Vu® location and page  that will display after you log in. Select the User 
or Installer tree, if you have Installer role. 

Automatically collapse trees Expands only one tree branch at a time. 

Automatically download 
schedules on each change 

Select to automatically download all new schedules that you create and 
schedules that you change 

Play sound at browser when 
server receives 

The system audibly notifies you when one of the selected alarms is received.  

Check Non-critical alarms or Critical alarms if you want the system to audibly 
notify you when that type of alarm is received.  

 

NOTE  An operator with the Guest role cannot edit any settings on this page. 

 

 

Operators tab 

Select the necessary settings and assign Roles (access rights) to set up operators. 

NOTES  

• Optimal number of simultaneous users:  

○ 2 in the i-Vu® Standard application 

○ 10 in the i-Vu® Plus application 

• We highly recommended that only 1 user at a time commission the system. 

 

 

To add or edit operators, passwords, and roles 

1 Click , then select System Options. 

2 Select Operators tab. 

3 Click Add to enter a new operator, or, select an operator to edit his settings. 
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4 Enter information as needed. The required fields are Name, Login Name, and Roles. See table below. 

5 Click Accept or Apply. 

  

Field Notes 

Login Name Must be unique within the system. 

Force user to change 
password at login 

Forces the operator to change his password immediately after his next login. 

NOTE  You can combine the use of this field and the Change Password field to create 
a temporary password that the operator must change after his next login. 

Starting Location Set the starting location for each individual operator by choosing the specific area or 
controller in the navigation tree and the starting page from the drop-down menu. 

Roles See table below. 

 

This privilege... allows an operator to... 

Installer   • Add, edit, and delete operators, operator groups, and privilege sets. 

• Update the i-Vu® system with service packs and patches. 

• Register the i-Vu® software.  

• Enable and set up the advanced password policy (page 35).  

• Add and remove i-Vu® add-ons. 

 

Access privileges 

     

The following can be accessed but not edited... 

     User tree  

     
Control program tables and Properties pages 

     Scheduling Groups pages in the User view navigation tree 

     System Options Items 

     Alarms 

     
Logic Pages 

 

 

 

 



 Using System Options for administrative utilities
  

 

 
 

i-Vu® Standard/Plus v7.0  CARRIER CORPORATION ©2020   
Help  All rights reserved 
 27 

 

Functional privileges 

     

The following allows an operator to... 

     
Manage Alarm Messages and Actions - add, edit, and delete alarm 
messages and actions. 

     
Maintain System Parameters - edit all properties on the System Options 
pages. 

     Maintain Schedules - add, edit, delete, and download schedules. 

     
Maintain Schedule Group Members - add, edit, and delete schedule 
groups. 

     Maintain Categories - add, edit, and delete categories. 

     Acknowledge Non-Critical Alarms - acknowledge all non-critical alarms. 

     Acknowledge Critical Alarms - acknowledge all critical alarms. 

     
Force Normal Non-Critical Alarms - force non-critical alarms to return to 
normal. 

     Force Normal Critical Alarms - force critical alarms to return to normal. 

     Delete Non-Critical Alarms - delete non-critical alarms. 

     Delete Critical Alarms - delete critical alarms. 

     
Execute Audit Log Report - run the Location Audit Log and System 
Audit Log reports. 

     
Download Controllers - mark equipment for download and initiate a 
download. 

     
System Shutdown - issue the Shutdown manual command that shuts 
down i-Vu® Server. 

     

Access Commissioning Tools: 
• Equipment Checkout 
• Airflow Configuration 
• Trend, Report, and Graphic categories that require this privilege 
• Discovery tool (i-Vu® Plus only) 

     
Maintain Graphs and Reports - add, edit, and delete trend graphs and 
reports. 

     
Remote Data Access-SOAP - retrieve i-Vu® data through an Enterprise 
Data Exchange (SOAP) application. (i-Vu® Plus only) 

     
Manual Commands/Console Operations - access the manual command 
dialog box and issue basic manual commands. 

     
Manual Commands/File IO - execute manual commands that access 
the server's file system. 

     
Manual Commands/Adv Network - execute manual commands that 
directly access network communications. 

     Change My Settings - edit preferences on operator's My Settings page. 
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Parameter privileges 

     

The following allows an operator to edit properties such as... 

     
Setpoint Parameters - occupied and unoccupied heating and cooling 
setpoints 

     

Setpoint Tuning Parameters - demand level setpoint offsets, color band 
offsets, heating and cooling capacities and design temperatures, color 
hysteresis, and learning adaptive optimal start capacity adjustment 
values 

     
Tuning Parameters - gains, limits, trip points, hysteresis, color 
bandwidths, design temperatures, and optimal start/stop. 

     
Manual Override Parameters - locks on input, output, and network 
point. 

     
Point Setup Parameters - point number, type, range, and network 
source and destination 

     
Restricted Parameters - properties the installer restricted with this 
privilege 

     
Category Assignments - Alarm, Graphic, Trend, and Report category 
assignments 

     
History Value Reset - elapsed active time and history resets, and 
runtime hours 

     
Trend Parameters - enable trend logging, log intervals, and log 
start/stop time. 

     Calibration Parameters - point calibration offsets 

     Hardware Controller Parameters - module driver properties 

     
Critical Configuration - critical properties the installer protected with this 
privilege 

     Area Name - area display names 

     Control Program Name - equipment display names 

     
Alarm Configuration - enabling/disabling alarms and editing alarm 
messages, actions, categories, and templates 

     Status Display Tables - tables available under Status 

     Maintenance Tables - tables available under Maintenance 

     User Config Tables - tables available under User Config 

     Service Config Tables - tables available under Service Config 

     Setpoint Tables - tables available under Setpoint 

     Time Schedule data Tables - tables available under Time Schedule 
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General tab 

1 Click , then select System Options > General tab. 

2 Enter information on this page as needed. 

3 Click OK or Apply.  

 

You can edit or use the following fields and buttons. 

 Field Notes 

System Statistics Check to Use metric units for CCN tables and control programs 

Click to see: 

• Numbers of controllers allowed and present in system 

• Number of trend sources and samples in the database 

• Estimated time to import/export clipping 

Levels displayed in paths The number of levels displayed in i-Vu® paths. For example, if Node Name 
Display Depth is set at: 

    2, a typical path might be  ..\AHU-1\RA Temp 

    3, a typical path might be  ..\Atlanta R&D\First Floor\AHU-1 

NOTE  Changing this field does not take effect until you restart the i-Vu 
Server application. 

Logs For troubleshooting, download a zip file that contains a log of system 
activity. Logs are available for a maximum of 4 weeks.  

Management Tool Select Management Tool (page 32) button to access the following:   

• Download weekly system logs  

• View or change system name and IP addresses    

• Port Configuration 

• Backup and Restore, Compress Trend Storage  

• Reset to Factory Defaults 

• Upgrade System Version 

• Reboot 

• NTP Configuration 



Using System Options for administrative utilities  
 

 

 
 

i-Vu® Standard/Plus v7.0  CARRIER CORPORATION ©2020   
Help  All rights reserved 
 30 

 

 Field Notes 

Time Time Format 
• 12-hour clock (Example:  4:34 pm) 
• 24-hour clock (Example:  16:34) 

• Daylight Saving Time is automatically controlled. To update Daylight 
Saving begin and end dates, go to System Options > Daylight Saving. 

• Enable time synchonization of controllers daily at - Automatically 
synchronizes the time on all equipment to the time on the i-Vu® web 
server, adjusting for different time zones and Daylight Saving Time. We 
recommend that you enable this field. 

CAUTIONS   

○ To prevent time sync problems when the transition to and from 
Daylight Saving Time occurs, set the time sync to occur at least 1 
hour after the last controller in the system is adjusted for DST. For 
example, your i-Vu® application and part of your system is in the 
Eastern Standard Time zone, but you also have controllers in the 
Pacific Time zone. Your server is adjusted for DST at 2:00 a.m. 
Eastern Standard Time, but the controllers in the Pacific Time 
zone are not adjusted until 3 hours later. So you would set the 
time sync to occur daily at 6:00 a.m. or later. 

○ Make sure that your i-Vu®’s time and time zone setting are 
correct.  

• Time Sync –  Sends a time broadcast to synchronize all controllers in 
the system with the i-Vu® web server's time. 

Alarms Select the checkbox to enable Alarm Notification functionality. See Alarm 
Popup (page 75) alarm action. 

Disable Schedules  If your system has no need to run schedules, check this box so that the 
Schedules feature is no longer visible in i-Vu® interface. 

Trends NOTE  Configurable for the i-Vu® Plus application only. The i-Vu® Standard 
application is 7 days. 

Import/Export Source Files Use to import or export source files in a .zip file that can be imported or 
exported to/from another i-Vu® or Field Assistant system. Source files 
include: 
• Control programs (.equipment files only) 
• Drivers 
• Graphics (.view files only) 
• Screen files 
• BACview® files 
• Report design files for Equipment Values or Trend Sample reports 
NOTE  If import detects a difference between a database file and an import 
file with the same name, import does not overwrite the database file. A 
message lists any file differences so that you can resolve them. 

See Commissioning equipment using Field Assistant (page 147). 
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 Field Notes 

Download You can increase download speed by checking Optimize download for 
Open PIC controllers. The full source files are not downloaded into the PIC 
controllers when this is checked.  

You can increase download speed by unchecking Include graphics in Open 
programmable controller download. If you are not changing the graphics, 
you may not want to include them in every download in order to save time. 

Clippings Click button to import clipping files, which include: 

• Navigation tree items including attached control programs, graphics, 
drivers, and screen files 

• Trend data 

• Reports 

• Alarm categories 

• Schedules and schedule group membership (including the entire 
schedule group and schedules, if it does not exist in the target system) 

• Alarm actions 

NOTES 

• Does not include operators or alarms 

• A clipping containing CCN controllers does not include the CCN tables. 
When importing a clipping containing CCN devices, you must re-scan 
the table. 

Email Server Configuration The information in this section is used by the Send email alarm action 
(page 78) and used to email a Scheduled Report (page 103). 

From Enter a valid address if required by your mailserver. 

Mail Host The mailserver's address. This can be an IP address or a system name, 
such as mail.mycompany.com. 

Mail Host Port Change this field if using a port other than the default port 25. 

Mail Host Security Options Select the type of security the mailserver uses. 

• Cleartext (SMTP) – Uses the SMTP protocol to send as clear text over 
TCP/IP 

• Secure SSL (SMTP with SSL) – Uses SSL, a communication protocol 
that provides data encryption 

• Secure TLS (STARTTLS) – Uses TLS, but does not begin encryption 
until the i-Vu® application issues STARTTLS command 

Specify Mail User for Mail Host 
Authentication 

Select if your mailserver requires a username and password. 

Test connection Click to have i-Vu® try to connect to the email server. A message will 
appear below this button stating if the connection was successful or if it 
failed. 
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Management Tool 

You can access Management Tool by either: 

• Clicking  and selecting System Options > General tab > Management Tool button   

• Launching your browser and typing your system name followed by :8080.  For ex.: http://ivu:8080/  

NOTE The Management Tool is password-protected and can only be accessed by a user with Installer role. 

 

System Status  

i-Vu is running at: This is used to troubleshoot server or LAN communications.  

Click the Stop Server button to stop the i-Vu® web server. When stopped, the button 
changes to Start Server. Do NOT close the Management Tool before restarting the server. 
Click to restart.  

Weekly system logs: • System - used for troubleshooting (same as logs available from System Options > 
General (page 29) tab). Logs are available for a maximum of 4 weeks.   

• Kernel - operating system logs  
Addressing 

 CAUTION  If you change the name or the IP address of your system, record the 
numbers in a secure place.  

• Name - Controls the name used to access your system from the Internet. Do not use 
special characters or spaces. 

• Obtain an IP address automatically - Uncheck this to manually assign addresses for 
the following: 

○ i-Vu Address 

○ Subnet Mask 

○ Default Gateway 

○ DNS Address - IP address of the Domain Name Server 

○ Domain - Host name of the domain (i.e. carrier.com) 

○ USB Network Type - Read-only field shows either CCN or BACnet types. 

○ USB Network Address - IP address of the internal BACnet router or the internal 
CCN Gateway  

i-Vu Port Configuration Changing these values forces a web server restart. 

Default values: HTTP: 80   HTTPS: 443 

Operation Status Message showing progress of background operations, such as backup and restore. 
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Manage Server Data • PC Backup -  Saves the entire database zipped into one file to your computer.  

• PC Restore - Replaces the current server data with a backup from your computer. 

• USB Backup -  Saves the entire database zipped into one file onto a USB inserted 
into the i-Vu® web server.  

• USB Restore - Replaces the current server data with a backup from your USB 
inserted into the i-Vu® web server. 

• Compress System - Creates more storage space for trend data. 

• Factory Defaults - Deletes all server data and resets the device to the original factory 
default values. 

NOTE  Executing this option does not delete configuration data under the Addressing 
and i-Vu Port Configuration sections of the Management Tool.  

Machine Maintenance • Management Version - Apply .update file from here. 

• Reboot - System restart 

 

Configuring NTP 

Network Time Protocol (NTP) is a networking protocol for clock synchronization. You can designate an NTP source 
that sends the correct time to the i-Vu® web server, ensuring constant accurate time. You can enter 2 static 
addresses (DNS name or IP) of NTP servers or use the default addresses provided by the i-Vu® application. If you 
do not enable NTP, the i-Vu® system clock must be monitored and updated regularly in System Options > General 
tab.  

You can configure DHCP servers to supply IP addresses of NTP servers to the i-Vu® web server. If you have 
checked Obtain an IP address automatically and Enable Time Synchronization, the i-Vu® web server tries to 
obtain an NTP server address from the DHCP server on site. If it cannot find one, the i-Vu® web server uses the 
User Assigned NTP addresses, if any, in the User Assigned fields. 

 CAUTION Contact your Network Administrator for guidance in entering these settings.  

You can access NTP from a local server, a remote server, or a website. To set up NTP: 

1 Verify that Enable time synchronization from an NTP server is checked. 

2 System Assigned NTP Server Address - To use this read-only field, make sure you have checked Obtain an IP 
address automatically to allow your system to search for an address for the NTP server and display a primary 
and alternate address. 

3 User Assigned NTP Server Address - You can use the default website addresses if your system allows it. 
Firewalls may prevent successful access to the default websites. Your Network Administrator can provide 
alternate addresses for a local server, a remote server, or a website. 

 

 

Security tab 

To adjust security settings, 

1 Click , then select System Options > Security tab. 

2 Enter information as needed. See table below. 

3 Click OK or Apply.  
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Field Notes 

Return operators to previous 
locations when server 
reconnects. 

Returns operators to current navigation tree locations when the 
server reconnects. 

 

Log off operators after _:_ 
(HH:MM) of inactivity 

The system automatically logs off an operator who has had no 
activity in the system for the time period specified. 

This is a default setting for the system. The Installer or 
Administrator can change this setting for an individual operator on 
the Operators (page 25) tab. 

Lock out operators after  __ 
minutes after __ failed login 
attempts 

Set the time that a user will be locked out of the system after the 
failed number of login attempts has been reached.  

NOTE  Restarting the i-Vu® application removes lockouts. 

Clear Lockouts  Remove lockouts for all users. 

Use advanced password policy You can place specific requirements on passwords to increase 
security. See Advanced password policy (page 35). 

Permissions  

Permissions When control programs, views, touchscreen, and BACview® files 
are created by an original equipment manufacturer (OEM), they 
cannot be used in the i-Vu® system without the creator's 
permission. However, the creator can produce a key for a system 
with a different license that will grant permission to the key's 
recipient. 

If you receive a key, put it in a convenient location on your 
computer. To activate a key, click Add, then browse to the key.  

To delete a key from your system, select the key in the table, then 
click Delete. 

Red text in the table indicates the key has a problem such as it 
does not apply or has expired. See the Notes column for an 
explanation. 
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Advanced password policy 

You can set up a password policy to meet your security needs.  

1 On the System Options tree, select the Security tab. 

2 Enter information in the fields described below.   

 

Field Notes 

Use advanced password policy Enable this field to put restrictions on passwords. 

An operator’s login name and password must be different when this 
policy is enabled. 

After you change the password policy, any operator whose password 
doesn't meet the new requirements will not be locked out of the system, 
but will be prompted to create a new password. 

Passwords must contain You can specify how many characters and which of the following types of 
characters a password must contain: 
• Numbers 
• Special characters—any keyboard character that is not a number or 

letter. 
• Letters—uppercase, lowercase, or both. 

Cannot be changed more than once 
every __ days. 

Enter a number to limit how often users can change their passwords. 
When set to 0, users can change them as often as they want. 

May not be reused until __ different 
passwords are used. 

Enter a number between 1 and 20. Enter 0 to reuse passwords without a 
delay. 

Expire after __ days Enable to set the number of days an operator can use his password 
before the system requires him to change it. Enter a number between 1 
and 999. 

Force expiration Click this button to force every user's password to expire. Each user will 
be prompted to change their password when they next attempt to log in 
to the i-Vu® interface. 

 

 

Update tab 

Select the Update tab to install .update files (patches, service packs, drivers, graphics libraries, and help updates). 

Click  next to Applied Updates and Current Libraries to view all currently applied updates and .SAL files currently 
and verify if the i-Vu® application has the latest updates or library files. 

i-Vu® Library 

The i-Vu® application is equipped with a complete library. There are occasionally library (.sal file) updates, which 
contain the following files: 

• graphic (.view) 
• control program (.equipment) 
• driver (.driver) 
• screen (.touch or .bacview)  
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NOTES 

• Get the latest updates from your Carrier representative. 
• The library update only changes default graphics. If you have edited your graphic in ViewBuilder, it is not 

updated. 
• Keep copies of the latest libraries in a safe place. In the event of a system restore, any updated .sal files 

must be reapplied. 
• The last digits in the sal library name are the release date of the library. 
 

Step 1: Update library  

1 Save the updated library (.sal file) to your computer. 

2 Click , then select System Options > Update tab. 

NOTE  Expand Current Libraries (.sal) to see the current SAL libraries and their revision. Compare them to 
what you downloaded from the Control Systems Support to determine if any of them have been updated. 

3 Click  and browse to the updated .sal file that you have saved on your computer, select the 
file, and click Open. 

4 Click Continue. 

5 When process is complete, the message appears File added successfully. 

6 Click Close. 

NOTE  These changes are not applied to the controllers until you have updated routers and controllers. 

Follow these steps to implement the new equipment library: 

Step 2: Update the files for the routers 
1 Select the router that you wish to update in the navigation tree. 

2 Right-click and select Driver Properties.  

3 Select Properties page > Update tab.  

4 If the database contains two or more routers, you must check Change for all controllers of this type? in the 
Controller section. 

5 Click Update. A message appears Changes the driver and screen file to use the current library version. 
Continue?  

NOTE  If more than one router exists, the additional routers are listed below the Update button. 

6 Click OK.  

7 Click Accept. 

Step 3: Update the files for Open controllers  
1 Double-click the controller in the navigation tree or right-click and select Configure.   

2 If you have multiple controllers of the same type, enable Change for all control programs of this type?. 

3 Click Update under Control Program. A message appears Changes the control program, view, driver, and 
screen file to use the current library version. Continue?  

4 Click OK. When the message Updated to the library version xx. appears, click Close. 

5 Repeat steps 1 - 4 for any additional types of controllers. 

6 Click Close again. 
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Step 4: Update the files for CCN controllers 

1 In the navigation tree, select the CCN device manager associated with the controllers that are to be updated. 

2 Select Devices > CCN Discovery and re-scan any controllers that need to be updated by checking Rescan 
Controllers Selected Below for Configuration Changes and clicking Start Scan. 

 

Step 5: Apply the update to the routers and controllers 

1 Select the site level in the navigation tree and then select the Downloads page. 

2 If you wish to apply the new SAL file to your entire system, you can use this page to compare to your 
navigation tree and verify that you have selected all of your routers and controllers for download. 

NOTE  Only the CCN Gateway and device managers require download, so the CCN controllers/equipment will 
not be listed. 

3 A network's controllers download in the order shown. To change the order, select a controller(s), then drag 
and drop or click Move to Top or Move to Bottom. 
EXCEPTION  If a controller's router requires a download, it will download first regardless of its position on the 
Download page.Click the Start button. 

NOTES 

○ Use Ctrl+click, Shift+click, or the Select All checkbox to select multiple controllers.  

○ Up to 5 routers can download simultaneously. 

4 See To download from the Downloads page (page 150) in Help for more details. 

 

 

Daylight Saving tab 

On this tab, you can adjust the Daylight Saving Time settings. 

Click Update to automatically set the table's Begin and End dates for the next 10 years based on the system's 
timezone. This marks all controllers for a Parameters download. 

If the updated dates are incorrect 
If you clicked Update but the dates are incorrect, your system's Java timezone data may be out-of-date. Do the 
following: 

1 Go to the Oracle Java SE Download site (http://java.sun.com/javase/downloads). 

2 Download the JDK DST Timezone Update Tool (tzupdater-version.zip) and unzip the file.  The zip file contains 
2 items: 

○ tzdata.tar.gz 

○ tzupdater.jar 

3 In the i-Vu® interface, click , then select System Options > Daylight Saving and then click Import. 

4 Browse to the tzupdater.jar file, select it, then click Open. 

5 Click Continue.  This restarts the i-Vu® application. 

6 After the restart, in the i-Vu® interface, click , then select System Options > Daylight Saving and then 
click Import. 

http://java.sun.com/javase/downloads
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7 Browse to the tzdata.tar.gz file, select it, and then click Open. 

8 Click Continue.  This restarts the i-Vu® application. 

9 On the System Options > Daylight Saving tab, click Update. 

 

 

Add-ons tab 

The i-Vu® Plus application supports add-ons, such as Tenant Override Billing or Weather, that retrieve and use i-
Vu® data. As of v7.0, the i-Vu® Plus application allows only add-ons that are supported by Carrier.  
  

To install an add-on 
1 Save the add-on's file (.addon or .war) to your computer.  

2 Click , then select System Options > Add-ons tab, and browse to the file. 

3 Click Install Add-on. After a few seconds, the add-on will appear in the Installed table, and will be enabled. 
The table below gives a description of each column. 
  

Column Notes 

Name The add-on's name. 

Path To open the add-on in a web browser, append this path to your i-Vu® 
system's address. 

For example, to start Tenant Billing, type 
http://<system_name>/override, or  
http://<system_IP_address>/override  

Version The version is shown if the author provided the information in the add-on. 

Status If this column shows: 
○ Running, you can open the add-on in a web browser. 
○ Disabled, click Enable to run the add-on. 
○ Startup error, select the table row to see an explanation of 

the error under Details. 
4 Select an add-on in the Installed table to disable or enable it, or to see the following Details. 

  

Add-on  
main page 

Click the main page link to open the add-on, if the author provided a main 
page. 

Description A description of the add-on, if the author provided one 

Vendor Name The add-on's author 

Public Data Directory This public directory contains data generated by the add-on. This data is 
visible in a web browser. 

Private Data Directory This private directory contains information such as configuration data. 
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To back up the add-on's private and public data directories 
NOTE  This procedure will not back up data stored in an external database.  

1 Select the add-on in the table. 

2 Click Save Data. 

3 Click OK. 

4 Click Save. 

5 Select the location where you want to save the data, then click Save. 
  

To update an add-on 
NOTE  Add-ons for i-Vu® v6.0 and later systems have a different folder structure than previous versions. 

1 Select the add-on in the table. 

2 Click Remove Add-on and Keep Data  

3 Follow the procedure above to install the new version of the add-on.  
   

To uninstall an add-on 
1 Select the add-on in the table. 

2 Click Remove Add-on and Data. 
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You can view and adjust equipment operation from the following pages: 
  

Devices pages 

Select the system level on the navigation tree to 
view the Devices page, where you can: 

• Upload source files or just parameters 

• Download source files, schedules, parameters, 
or BBMD tables 

• Check status and error messages 

• View model, IP address, drivers, device ID 

• Edit device names  

 

Graphics pages (page 41) 

You can view and adjust your essential building 
controls on most Graphics pages. 

Equipment drawings show the current status of 
mechanical equipment. 

Adjust setpoints (page 55) on a Graphics page. 

To upload a graphic from ViewBuilder, double-click 
the controller in the navigation tree or right-click and 
select Configure. 

 

Logic pages (page 45) 

Logic pages show the control program for a piece of 
equipment. Use the sequence of control and yellow 
status values on the Logic pages for troubleshooting 
your mechanical equipment. 

 

Working with equipment in the interface 
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Properties pages (page 44) 

You can monitor and control point sources. 

1 Select the equipment in the navigation tree. 

2 Click Properties page > Control Program tab. 

3 Expand the plus sign next to the desired table. 

 

 

Properties/Microblock popups  

Click a property or point to open the microblock 
popup to view and change details, including forcing 
or locking values. 

 

 

 

Graphics pages 

You can view and adjust your system from Graphics pages, which include navigation maps, floor plans, and 
equipment. 

 
Some typical controls that may appear on a graphics page are: 

• Button or switch to turn equipment on or off 

• Input field to set a property value 

• Drop-down list to select a state 
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• Interactive zone sensor to override an unoccupied schedule 

• Setpoint graph to adjust setpoints 

• Trend graph to view trend information 

• Link to jump to another i-Vu® page or to the Internet  
  

NOTES 

• Right-click a value, then select Details to view and change properties in the microblock pop-up.   

• Right-click a value, then select Global Modify (page 48) to view and change the property in other control 
programs.   

• A yellow dashed box around a value indicates the value is locked or forced.  

• If a graphic does not fit in the action pane, right-click it and select Scale to Fit to make it fit the action pane. 
Select Scale to Fit again to return the graphic to its original size. 

• When a chart that is based on a report is displayed on a Graphics page, you can hover over various points on 
the chart to see values. You can also click on each item in the legend to turn that information on and off. See 
Custom report as the source for a Graphics page (page 102). 
 

 

To attach a graphic in the i-Vu® interface 

1 On the navigation tree, right-click the item that you want to attach a graphic to, then select Configure. 

2 Do one of the following: 
  

If the graphic is...  

In the Graphic Page drop-down list a.  Select the graphic. 

b.  Click Accept. 

Not in the Graphic Page list a.  Click Add New. 

b.  Browse to select the view file. 

c.  Click Open. 

d.  Click Continue. 

e.  Click Close. 

f.  Click Close again. 

 

NOTE  You can click Delete Unused at the bottom of the Views section to delete all unattached graphic files 
from your system. 
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3 Equipment graphic only:  If the system has other control programs of this type, select which control programs 
you want to change.  

 
NOTES   

○ If the control program is in an IP router, the second option will change the graphic for all control 
programs of this type only on the IP network. 

○ If the control program is on the network below an IP router, the second option will not change the graphic 
for the router's control programs of this type. 

 

 

To edit a graphic from the i-Vu® application in ViewBuilder 

1 In the i-Vu® interface, double-click the controller in the navigation tree or right-click and select Configure. 

2 Click Edit Existing button under Views. 

3 Click Save as and place the file in an appropriate folder. 

4 Open ViewBuilder. 

5 Select File > Open.  Browse to your saved graphic and click to open. 

6 Edit and save with a new name - the original system name is locked and cannot be used for an edited 
graphic.  

NOTE  Names are case sensitive and should not have spaces and/or special characters. 

 

 

To control equipment using an interactive zone sensor 
An equipment graphic may include an interactive zone sensor that provides you with the following control.  

 

If the sensor is a...      You can... 

ZS  

 
  

  
• Click  to raise the setpoint or  to lower the setpoint.  

• Click    to override the schedule and put the zone in an occupied state. 
To cancel an override, continue clicking  until the display shows 0. 

• See that the zone is in an occupied state when the green LED is lit. 
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If the sensor is a...      You can... 

SPT Standard, Plus, or Pro  

 

  
• Click the WARMER or COOLER button to adjust the setpoint.  

• Click the MANUAL button to override the schedule and put the zone in an 
occupied state. 

• Click the INFO button to cycle through the following information: 

• Outside air temperature, if enabled in the control program 

• Override time remaining 

• Heating setpoint 

• Cooling setpoint 

• See the Occupied/Unoccupied state in the display. 
  

SPT Pro Plus  

 

  
• Click the WARMER or COOLER button to adjust the setpoint.  

• Click the MANUAL button to override the schedule and put the zone in an 
occupied state. 

• Click the INFO button to cycle through information such as: 

• Outside air temperature 

• Override time remaining 

• Heating setpoint 

• Cooling setpoint 

• Click the FAN button to adjust the fan speed. 

• Click the MODE button to perform customer-specific functions. 

• See the Occupied/Unoccupied state in the display. 
  

 

 

Properties pages 

Properties pages are automatically generated from control programs. Properties pages show the status of a piece 
of equipment and the points/properties currently stored in it. See Check out point setup (page 138) for details. 

Use Properties pages to: 

• View the status of a piece of equipment.  See Colors and status in the i-Vu® interface (page 22).  

• View or change the equipment point/properties currently stored in the controller. 

• Commission equipment (page 138) 

• Set up Linkage. 

Refer to your individual controller's Installation and Start-up Guide for detailed explanations of the 
points/properties. 
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To view or edit properties on a Properties page 

1 Select a controller on the navigation tree, click Properties, and then select the appropriate tab. 

NOTE  You must resolve any condition described in red text at the top of the page before a Properties page 
can obtain current information from its controller. 

2 Click  to show property details. 

 
 

3 Do one of the following to change a property: 

○ Select or clear a checkbox 

○ Select an item on a drop-down list 

○ Change text in a text field 

4 Click Accept. 

NOTES  

• Click the bold, underlined point name to open the editable microblock pop-up 
• Right-click a value, then select Details to view and change properties in the microblock pop-up. 
• Right-click a value, then select Global Modify (page 48) to view and change the property in other control 

programs. 
• Use Search/Replace on the Network Points tab to replace a term in the point address with another address. 
•  For the legend of status colors, see Colors and status in the i-Vu® interface (page 22).  
• A yellow dashed box around a value indicates the value is locked or forced. 
 
 

Logic pages 

The Logic page shows a custom control program for a programmable controller. The live data (yellow text) is 
updated every few seconds and when you click the Logic button. The control program uses exact property values 
for its calculations, but values are rounded to 2 decimal places when displayed on the Logic page. 

 TIP  Click anywhere on the Logic page, then use your keyboard's Page Up, Page Down, and arrow keys to 
scroll through the page. 

NOTE  If you find an unexpected value on a Properties page or a Logic page, you can use the Logic page to 
troubleshoot. 
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To view a Logic page 

1 Select a custom control program on the navigation tree. 

2 Click Logic. 

3 Click a microblock to view its details. 

 

 

To locate a microblock, section, or label 

1 Right-click the Logic page, then select Jump To. 

2 Do one of the following: 

○ On the Microblock or Section tab, select an item to have it located and highlighted. 

○ On the Label tab, select a label to display a reduced logic page outlined in yellow that shows all 
instances of the label. A red box indicates an output label; a yellow box indicates an input label. Click a 
red or yellow box to jump to that label in the full-size logic page. 
 
NOTE  You can also click a label on the full-size Logic page to display the reduced Logic page.  

 

 

To change properties, alarms, or trends 

1 Click a microblock on the equipment’s Logic page. 

2 In the microblock pop-up, click the Properties, Alarms, or Trends button. 

3 Change properties, alarms, or trends for that microblock in the same way that you would make changes on a 
regular Properties (page 44), Alarms (page 80), or Trends (page 90) page. 

4 Click Accept. 
  

NOTE  Right-click a value, then select Global Modify (page 48) to view and change the property in other control 
programs. 

 

 

Using a Logic page to troubleshoot 
The i-Vu® application monitors your system and provides feedback. If you get unexpected feedback, you can use a 
Logic page as a troubleshooting tool. On the Logic page, work your way backward (right to left) through the 
sequence in the control program to discover what caused the problem. See Microblock Reference to understand 
what each microblock in the sequence is doing. 
  

Unexpected feedback Possible cause 

Space temperature reads 
excessively high or low 

• The sensor has a short (or open) circuit. Verify wires are properly 
connected at the sensor and controller. 

• A sensor is missing or configured incorrectly. Open the sensor or input 
microblock from the Logic page to verify its configuration. 
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Unexpected feedback Possible cause 

Equipment displays an unexpected 
color - effective setpoints are 
different than the programmed 
setpoints 

NOTE  Equipment operates using effective setpoints. Open the Setpoint 
microblock from the Logic page and check the following: 

• Hysteresis 

• Demand Level 

• Optimal Start 

• Timed Local Override (TLO) 

• Setpoint Adjust 

Gaps in trend data on trend graph Usually gaps result if network communication was disrupted or a point was 
temporarily disabled. 

If the gap is not the result of interrupted communication, send reports 
more frequently. From the Logic page, open the trend microblock that 
displayed the gap in data, then decrease the notification threshold so that 
it is approximately 40% of the buffer size (allocated memory size) for that 
microblock. 

The i-Vu® application is not 
receiving alarms from a BACnet 
alarm microblock 

Locate the microblock on the Logic page. If the color square on the 
microblock is black, the alarm is disabled. To enable it: 

1 Click the microblock.  

2 In the microblock pop-up, click the Alarms button.  

3 On the Enable/Disable tab, select Potential alarm source. 

The equipment is on when I expect 
it to be off, or off when I expect it to 
be on 

Use the Logic page to determine whether the program is sending an 
unexpected signal and why, or if the problem is with the physical 
equipment. For example, the On-Off-Auto (OOA) switch on the controller for 
that equipment may be locked in the On (Hand) position. 

Sensor value on the Properties 
page does not match the reading 
from handheld sensor 

Calibrate the sensor.  

On the Logic page, check to see if the output point is locked on. 

 

 

Changing multiple microblock properties 

Two i-Vu® features, Global Modify and Global Copy, allow you to view and change multiple microblock properties 
at the same time. 

 CAUTION  Global Modify and Global Copy are convenient for making widespread changes in your system. 
But, because they do not take into account the operation of individual equipment, your changes could produce 
undesired results in your equipment or system operation. Use with caution because these features do not have an 
Undo function. 

 TIP  Click  to copy a microblock's reference path to the clipboard so you can paste it into another field or 
application. 
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To use Global Modify 
Use the Global Modify feature to: 

• View a microblock’s full path, control program name, and the privileges required to change its properties. 
• View or change a single property in several control programs at one time. 
• View errors on Graphics and Properties pages. 

  
1 Browse to any page that displays the property you want to view or change. 

2 Do one of the following to open Global Modify: 

○ Alt+click the property. 

○ Right-click the property and select Global Modify. 

3 Make changes to the Control Program field, if needed. 

NOTES 

○ Use wildcards in the Control Program field to broaden the search. 
For example: 

vav* matches vav, vav1, vavx, vav12345 

vav*z matches vavz, vav1z, vavxz, vav12345z 

vav*1*2 matches vav12, vavabc1xyz2 

vav?? matches vav11, vav12, vavzz, but does not match vav, vav1, vav123 

* matches any control program 

○ Click Show Advanced to view the location, value, and privileges associated with this property. 
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4 Select the tree item that you want to search under for every occurrence of that microblock in other control 
programs. 

5 Click Find All. 

6 Select the properties in the list that you want to change. 

7 Do one of the following: 

a) Type a New Value to the right of each selected item. 

b) Select Enable All, type a new value in b, then click Set All To. 

c) Select Enable All, type a new value in c, then click Change All By. 

 
 

8 Click Apply Changes. 

NOTE  To modify several properties in multiple control programs at the same time, use Global Copy. 

 

 

To use Global Copy 
Use Global Copy to copy any or all of the following from one control program to other equipment using the same 
control program: 
• Embedded trend graph settings 
• Custom trend graphs 
• Custom reports 
• Other editable properties to other pieces of equipment using the same control program. 

  
1 On the navigation tree, right-click the piece of equipment that has the properties you want to copy, then 

select Copy Control Program Properties. 

2 Click OK when you see This will copy this control programs properties to other control programs of the same 
type. Continue?. This opens the next screen and does not lock in any changes. 
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3 In the Global Copy dialog box, select the items that you want to copy. 

4 Select the area on the tree containing similar control programs that you may want to copy these properties to, 
then click Search. 

All instances at that level and below are listed in the expanded lower window. 

5 Check or uncheck items as needed. 

6 Do one of the following: 

○ Check Skip bad values to copy all values except a bad value (it cannot be copied because you do not 
have the necessary privilege, the property to be copied is undefined, etc.).  

○ Uncheck this field to prevent any values from being copied if a bad value is found. 

7 Click Apply Changes, then close the Global Copy dialog box.  

 

 

Checking controller status 

On the i-Vu® navigation tree, you can select a router or the system level and then click the Devices button to: 

• View the status of controllers (page 51) 

• View controller information such as address, model, driver, and .view files included in download 

• Download or upload to resolve a mismatch (page 54) 

• Troubleshoot network communication (page 170) 

• Download or upload files for Field Assistant (page 147) 

  

NOTES 
• Use Ctrl+click, Shift+click, or the Select All checkbox to select multiple controllers. 
• Click Hold to stop pending  downloads or uploads. Active downloads  or uploads  cannot be stopped. 
• Icons in the Tasks column indicate the following: 

  

 Active—The i-Vu® application is downloading to the controller. 

 Active—The i-Vu® application is uploading from the controller. 

 Pending—You initiated the download, and the controller is waiting for its turn to download. 

 Failed—The download failed. See If a controller fails to download (page 152). 

 On Hold—Indicates you clicked Hold to stop a pending  download. 

  
• Click  in the upper left-hand corner to view a log of activity on the Devices page in the current session. 

Copy to Clipboard lets you copy the text to paste it into another application. 
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Status messages 
On the i-Vu® navigation tree, you can select a router or the system level and select the Devices page to view the 
status of controllers. The Status column shows a description of the controller's current state. Hold your cursor over 
that description to see hover text with a more detailed description. 

If multiple conditions exist, the i-Vu® interface displays the message with the highest priority. 

The table below shows all possible messages. The message color indicates the following: 

Black—In process 
Red—An error occurred 
Blue—Requires action from the user 

 

i-Vu® Open routers/controllers 

Status column message Hover text message  Notes 

   
Black messages:   

Downloading The controller is downloading, 
communications may be disabled 

 

Uploading The controller is uploading, 
communications may be disabled 

 

Pending This controller is waiting to be processed.  

Processing Clipping Clipping operation in progress. Do not 
make changes during this operation, as 
they may corrupt your system. 

 

   

Red messages:   

Communications Error Cannot communicate with this controller.  

Connection Disabled The connection for this controller has been 
disabled. 

Occurs if someone stopped the 
connection.  

Connection Error The connection for this controller failed to 
start. 

Occurs if the connection is misconstrues 
or failed to start. 

Controller offline The controller is offline. This only appears for equipment 
controlling slave devices that it is 
unable to communicate with. 

Download Failed (Message depends on the cause of the 
failure.) 

 

Download Not Permitted This controller is not permitted to 
download. 

 

Error  An unknown error has occurred.  

Missing Files Upload failed. Server is missing the source 
files. 

 

Not Uploadable  This controller is not configured for 
content upload. 

Occurs if you attempt to upload a 
controller with a pre-4.x driver. 
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Status column message Hover text message  Notes 

Out of Service This controller is out of service.  

Unsupported Controller This controller does not support content 
upload. 

 

Upload Not Permitted This controller is not permitted to upload.  

USB Unplugged Cannot communicate with the controller 
because the USB cable is unplugged. 

Applies only to the i-Vu® Standard and 
Plus applications. 

   

Blue messages:   

Controller Replaced This controller has been replaced by 
another controller of the same type in the 
field. 

4.x driver only 

Download All Content Please download all content to the 
controller. 

 

Download Parameters To download parameters, highlight row 
and select Parameters from the Download 
Action menu and click Download. 

 

Download Schedule To download schedules, highlight row and 
select Schedules from the Download 
Action menu and click Download. 

 

Driver Parameter 
Mismatch 

Driver parameter differences detected. 
Upload parameters from the controller or 
download parameters to the controller. 

 

Network Ready for 
Upload 

To upload this network, select the router in 
the tree and Find Devices. 

 

Parameter Mismatch Control program parameter differences 
detected. Upload parameters from the 
controller or download parameters to the 
controller. 

 

Program Mismatch Content differences detected. Upload all 
content from the controller or download all 
content to the controller. 

4.x driver only 

Unprogrammed 
Controller 

Applies only to a programmable controller 
that does not have any control programs in 
it.  

To add control programs, click Add 
Control Program. 

Upload All Content Please upload all content from the 
controller. 

 

   

General messages:   

 This controller is ok.  

Cancelled  The last operation on this controller was 
cancelled 
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CCN controllers/equipment 

Status column message Hover text message  Notes 

<blank> This is a known control program from a 
previous discovery, but communications 
with it has not been attempted since the 
user logged in. 

 

 Successful rescan.  

Downloading Downloading changes. Communications 
will resume shortly. 

 

New Control Program A new controller was found at the scanned 
address and added to the system. 

 

New Version Applied This controller's program or views have 
been updated with a newer version. 

 

   

Red messages:   

Communications Error Cannot communicate with this controller.  

Download Failed <The message is specific to the failure.>  

USB Unplugged Cannot  communicate with the controller 
because the USB cable is unplugged. 

Applies only to the i-Vu® Standard and 
Plus applications. 

   

Blue messages   

Classification Mismatch The controller at this address was 
previously a Bridge routing to other 
controllers. 

 

Download All Content Please download all content to the 
controller. 

 

   

Model Mismatch The controller at this address is the wrong 
model. 

 

Rescan Required A configuration change was made to this 
control program therefore a rescan is 
required to get the correct graphic and 
control logic components. 
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Handling parameter mismatches 
A parameter mismatch occurs when a value in a controller does not match the value in the system database. This 
can be a driver or control program value.  

To find mismatches in your system 
You can find mismatches in the following places: 

• The Devices page > Manage tab > Status column will show Parameter Mismatch. 

• The Properties page for a controller, driver, control program, or point will show one of the following red 
messages at the top of the page stating: 

Control Program parameter differences detected. 
Driver parameter differences detected. 
Parameter download required. 
 
The value that has a discrepancy will appear with a purple box around it. Hover your cursor over the field to 
see: 

  

or 

 
○ Go to Reports > Equipment > Parameter Mismatch, and then click Run to get a report of any existing 

mismatches in your system. 

   
NOTE  The Downloads page > Tasks column will show Resolve Parameters for any mismatches that your 
system discovered in the 3 places listed above. 
  

To resolve a mismatch 
1 Go to one of the following:  

• Devices page - Click the Parameter Mismatch link 
• Properties page that shows one of the red messages above 

  
2 Click one of the following: 

○ Resolve to let the i-Vu® application download changes made in the i-Vu® interface or upload changes 
made in the controller. Click the Details button to see what the discrepancy is and whether Resolve will 
download or upload parameters. See NOTE below. 
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○ Upload to upload the parameters from the controller to the i-Vu® application 

○ Download to download the parameters from the i-Vu® application to the controller 

  
NOTE  On the Devices page with Show Control Programs unchecked, if a controller has simultaneous 
mismatches in the driver and control program, clicking Details will show that a control program mismatch 
exists but it will only show details for the driver mismatch. You must go to the control program in the tree to 
see details of that mismatch. However, clicking Resolve will resolve both mismatches. 

 

 

Managing setpoints 

The Setpoint graphic shown on a standard equipment graphic indicates the base setpoint values (Occupied 
High/Low, Unoccupied High/Low). The i-Vu® application reads these values back periodically, typically within 10 
seconds. The timing can vary based on network traffic, the number of controllers in the database, and several 
other variables. Setpoints that are changed in the field via another user interface are displayed in the i-Vu® 
interface as soon as they are detected.  

You can, at any time, change the setpoints from i-Vu® graphics by using the slider or by entering numeric values 
directly. Updated setpoints are transmitted to the controller when you Accept the changes. Setpoints can also be 
changed on the Properties page > Control Program tab > Space Temperature and Setpoints. or Configuration > 
Setpoints. 

NOTE  Power and Standard operators may only edit Occupied/Unoccupied and Heating/Cooling setpoints. They 
cannot edit Demand levels or more detailed setpoint parameters.    

The various color bars indicate adherence to or deviation from the setpoint. You can change the current default 
settings for setpoint deviation. Select a color band on the setpoint graph to see the current setpoints in the 
Heating and Cooling fields. The values in this graphic are Fahrenheit. See setpoint descriptions below. 

NOTE  This graphic is an example only. Your setpoints may differ. 

 
 

Color  Condition 

 Green Temperature is within the Occupied Low and High Setpoint 

 Gray Temperature is within the Unoccupied Low and High Setpoint 

 Light Blue Temperature is less than 2°F below the Occupied Low Setpoint  
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Color  Condition 

 Dark Blue Temperature is more than 2°F below the effective Low Setpoint but less 
than 4°F below the effective Low Setpoint 

 Yellow Temperature is less than 2°F above  the effective High Setpoint 

 Orange Temperature is more than 2°F above the effective High Setpoint but less 
than 4°F  above the effective  High Setpoint 

 Red Temperature is more than 4°F above or below the effective setpoints   
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Adjust setpoints 

• Programmed setpoints are set and changed by operators.  

• Effective setpoints reflect the impact of other system conditions on the programmed setpoints, such as 
setpoint adjustments, and hysteresis. Effective setpoints control the equipment.  

 

To change programmed setpoints: 

1 Navigate to a setpoint control in one of the following places: 

○ Properties page > Control Program tab > Configuration > Setpoints 

○ The setpoint microblock pop-up on a Logic page 

○ A Graphics page (Click a setpoint trend graph control to access the editable setpoint bar.) 

2 Make changes on a programmed setpoint bar by either:  

○ Clicking and dragging the segment or the gap between segments  

○ Typing new values in the Heating and Cooling fields 

3 Click Accept. 

 

 

Demand Control 
Demand Control is a cost-saving strategy that saves energy while maintaining comfort in the following ways: 

• Controlling energy use to avoid peak demand, ratchet, or time of use utility charges 

• Maintaining ventilation at relaxed setpoints rather than shutting down equipment (as with load shedding or 
duty cycling) 

Before you can use Demand Control effectively, you must: 

• Obtain details regarding past energy usage and peak demand, ratchet, and time of use charges from your 
energy provider. 

• Understand the demand profiles of the zones you are controlling. 

Demand Control can be customized at the zone level. For example, you may relax the setpoints in some zones, 
like break rooms and closets, by a few degrees, but you may not want to relax setpoints in computer rooms at all. 
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To define Demand Control properties 
1 On the navigation tree, select the electric meter. 

2 Select Properties > Control Program and expand the Demand Level Parameters section. 

3 Type the Start and End time to define the time period that you want demand control to be in effect for this 
zone. 

4 Type kilowatts per hour (kW/hr) in the Level columns to define the amount of power that the demand must 
exceed before the i-Vu® system calls for a higher demand level. 

NOTE  Levels are defined in the electric meter control program in the Snap application. You can test the Demand 
Levels by locking the meter to a value. 

In the example below, during Period 4, defined as 12:00 (noon) to 16:00 (4:00 p.m.), if the demand exceeds 800 
kW/hr, the i-Vu® system will use Demand Level 1 setpoints. If the demand exceeds 1000 kW/hr, the i-Vu® 
system will use Demand Level 2 level setpoints and so on. 

 
 

 

Configuring Optimal Start 

Enable and configure Optimal Start on the  Properties page > Control Program tab > Configuration > Setpoints. 
Your control program could be configured for Optimal Start or for both Optimal Start and Optimal Start Type.  

NOTES 

• The Optimal Start options depend on the revision date of the control program in your controller. 

• Optimal Start is automatically disabled when Properties > Control Program > Maintenance > Occupancy > 
BAS On/Off is set to either Unoccupied or Occupied.  

 

 

Optimal Start 
Optimal Start adjusts the effective setpoints to achieve the occupied setpoints by the time scheduled occupancy 
begins.The Optimal Start recovery period may begin as early as 4 hours prior to occupancy. The algorithm works by 
moving the unoccupied setpoints toward the occupied setpoints. The rate at which the setpoints move is based on 
the outside air temperature, design temperatures, and capacities. 
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The following conditions must be true for optimal start to operate: 

• On the Properties page > Control Program tab > Configuration > Setpoints > Optimal Start, the Default 
Value must be set greater than 0 and less than or equal to 4 (0.00 disables Optimal Start). 

• The system is unoccupied 

NOTE  If the Open controller does not have a valid outside air temperature, then a constant of 65° F is used. This 
value is not adjustable. 

 

The actual equation that the controller uses to calculate Optimal Start is nonlinear. An approximation of the result 
is shown below. 

 
 
To change Optimal Start settings: 

1 In the navigation tree, select the equipment that you want to change. 

2 Select Properties page > Control Program tab >  Configuration > Setpoints. 

 

 

Optimal Start Type 
If you have Optimal Start Type, you must choose from the following: 

• None 

• Temperature Compensated Optimal Start 

• Learned Adaptive Optimal Start 

 
To select the method used to change from unoccupied to occupied setpoints: 

1 In the navigation tree, select the equipment that you want to change. 

2 Click Properties page > Control Program tab >  Configuration > Setpoints. 

3 Select option from the Optimal Start Type drop-down list. 

4 See below to make further adjustments. 
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None – The unit will not start to control to the occupied setpoints until the unit goes into an occupied mode. 
Setpoints do not ramp, but change immediately from unoccupied to occupied values. When you select None, you 
must set all Learning Adaptive Optimal Start transition factors, identified by their themographic color, to 0. These 
are located directly above the Effective Set Points graph.   

Temperature Compensated – The unit changes to occupied setpoints at some time prior to the occupied time, not 
to exceed the hours you set for Optimal Start. The start time is determined by the current error between space 
temperature and the appropriate heating or cooling setpoint. At that time, the setpoints do not ramp, but change 
immediately from unoccupied to occupied values. When selecting Temperature Compensated, you must set all 
Learning Adaptive Optimal Start transition factors, identified by their thermographic color to 0. These are located 
directly above the Effective Set Points graph.  

When selecting Temp Compensated, you can adjust the following: 

• Heat Start K factor (min/deg) – If Optimal Start Type is Temp Compensated, this is the time in minutes per 
degree that the equipment starts before the occupied period when the space temperature is below the 
occupied heating setpoint (including any setpoint offset).  

• Cool Start K factor (min/deg) – If Optimal Start Type is Temp Compensated, this is the time in minutes per 
degree that the equipment starts before the occupied period when the space temperature is above the 
occupied cooling setpoint (including any setpoint offset).  

NOTE  The default value for the above is 15.00 and the range is 0 to 99.  

 

Learning Adaptive Optimal Start – This function gradually adjusts the unoccupied setpoints over a specified 
period of time to achieve the occupied setpoint by the time scheduled occupancy begins. This learning adaptive 
algorithm uses the learned heating capacity and learned cooling capacity values to calculate the effective 
setpoints prior to the occupied start time. The algorithm calculates a learned cooling and heating capacity during 
the previous unoccupied time. Set the Learning Adaptive Optimal Start recovery period from 1 to 4 hours in 
Optimal Start. When the Learning Adaptive Optimal Start routine runs, adjustments are based on the color that is 
achieved when occupancy begins. Adjustment amounts are defined in the thermographic color fields located 
directly above the Effective Setpoints graph under Setpoints. 

EXAMPLE  The heating capacity for a zone is 5° per hour (default). When the zone becomes occupied, the zone 
temperature is 1° below the occupied setpoint, indicating a need for additional heat. Because the zone 
temperature was low by 1°, the learned heating capacity is decreased by the value entered in the LtBlue 
thermographic color field (0.0600 default). As a result, the learned heating capacity is adjusted to 4.94° for the 
next optimal start period. Since the algorithm has calculated that the equipment has less capacity to bring the 
temperature to setpoint within the configured recovery period, the setpoint adjustment begins sooner in the next 
unoccupied period. 

To change the adjustment values in the Learning Adaptive Optimal Start routine: 

1 In the navigation tree, select the equipment that you want to change. 

2 Click Properties page > Control Program tab > Configuration > Setpoints. 

3 Adjust the color fields between the Zone Setpoints graph and the Effective Setpoints graph. 

  
When you determine that no further start time optimization is required, you can disable Heating and Cooling 
Capacity adjustments by setting the color field values to 0.0. 
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You can reset the learned heating and cooling capacities by entering a value into either the Heating Capacity or 
Cooling Capacity, located beneath the Zone Setpoints graph.   

 

 CAUTION  When using Learning Adaptive Optimal Start, be sure that all equipment is properly maintained so 
that your system does not “learn” to compensate for dirty filters or loose fan belts. 
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Using schedules, your equipment can maintain one set of setpoints during occupied periods to provide comfort, 
and it can maintain a different set of setpoints during unoccupied periods to reduce energy consumption. 
Schedules are an i-Vu® system's most effective cost-saving strategy. 

In the User view, you can apply a schedule to a single tree item or to a group of tree items. 

 

When you apply a schedule to a tree item, the schedule affects equipment 
at and below the area or equipment where the schedule was added. 

 

When you apply a schedule to a schedule group, the schedule affects all 
pieces of equipment in the group. 

For example, a school board meets every third Tuesday of the month and 
uses the lobby, main conference room, break room, and restrooms. You 
can create a schedule group to control these different areas with a single 
schedule. 

  
NOTES   

• When multiple schedules affect a tree item, the net result is the Effective schedule (page 66). 

• Do not include preheating or precooling time in your schedules. Optimal Start (page 58), another cost-saving 
strategy, automatically calculates and controls precise preheating and precooling routines.   

• If your system has no need to run schedules, you can turn off this feature. First, delete any existing 
schedules. Then go to the System Options (or System Settings) > General tab (page 29), and check the box 
Disable Schedules feature. 
  

 

 

To view schedules 

1 Select a navigation tree item (site, area, or equipment). 

2 Click Schedules > View tab. 

3 Optional:  Click a white Effective bar to view all the schedules that contribute to the resulting schedule. If the 
item has multiple schedules, the schedule closest to the Effective bar has the highest priority. You set a 
schedule's priority when you create the schedule. 

 

Schedules 
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NOTES   

• When multiple schedules affect a single area or controller, the i-Vu® application sorts the schedules by 
priority - the higher the priority, the closer the schedule is to the bar. You set a schedule's priority when you 
add a schedule. 

• You can also view schedules on the following detailed, printable schedule reports. These reports are 
accessible from the Schedules page > Reports tab or from the Reports button drop-down menu. 

 

This report... allows you to... 

Schedule Instances Find every schedule with its location that is entered at and below a selected tree 
item. This report can help you discover newly added and conflicting schedules. 

Effective Schedules View all equipment that may be scheduled and the net result of all schedules in 
effect for a selected date and time. See Effective schedules (page 66). 

 

 

To print schedules 

1 Select a navigation tree item and click Reports . 

2 Click Schedules > Schedule Instances or Effective Schedules. 

3 Click Run, then click PDF. 

 

This report... allows you to... 

Schedule Instances Find every schedule with its location that is entered at and below a selected tree 
item. This report can help you discover newly added and conflicting schedules. 

Effective Schedules View all equipment that may be scheduled and the net result of all schedules in 
effect for a selected date and time. 

 

 

To apply a schedule to equipment 

Schedules in the i-Vu® application are typically based on zone occupancy.  

1 In the User navigation tree, select the area or equipment you want to schedule.   

NOTES 

○ To schedule all equipment in a specified area, select the area you want. 

○ You can schedule individual controllers from the Installer view, but you must be in the User view to 
schedule areas and routers 

2 Click Schedules, then Configure tab. 

3 Click Add. 
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4 Select a Priority. A schedule's priority determines whether affected zones will use occupied or unoccupied 
setpoints. 
  

Select... For... 

Normal A typical occupied period 

Holiday An unoccupied period that overrides a Normal schedule 

Override An occupied period that overrides a Holiday schedule 

 

5 Select a Type. See table below. 

6 Type a schedule name in the Description field (50 characters maximum). 

7 Enter desired values in the fields below Description. 

8 On the graph, change a time segment's Start and End times by doing one of the following: 

○ Click the segment, then type the times in the Start and End fields. 

○ Click and drag either end of the segment or the entire segment.  

9 Optional:  Click Add Time Period to add one or more segments to the schedule. Or, select a segment and 
click Delete Time Period to delete that segment. 

10 Click Accept. 

   

Select this Type... To use the schedule... 

Weekly Every week on the specified days 

Date On a single, specified date 

Date Range Between 2 specified dates 

Date List On multiple, specified dates 

Wildcard According to a repeating pattern (For example, the second Tuesday of every 
month) 

Continuous Continuously between specified times on 2 separate dates 

Dated Weekly Weekly between a start date and an end date (For example, the summer break in 
the school year) 

 

NOTES   

• To automatically download all schedules that you create or change, click  > System Options > My 
Settings and, under Preferences, select Automatically download schedules on each change. If you want to 
manually download schedules, clear the Automatically download... field and then see Downloading system 
changes to controllers (page 149). 

• When you apply a schedule to an item on the navigation tree, the schedule affects that item and all children 
of that item. If you do not want an item to be affected by schedules from a higher level, select Ignore 
Schedules above this level on the Schedules > Configure tab. 
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To apply a schedule to a group of items 

You must create a group, then add members (areas, equipment, or other groups) to the group before you can 
apply a schedule to it. 

1 On the User navigation tree, select Scheduling Groups. 

Optional:  If you have created folders to organize your groups, select the appropriate folder. See "To organize 
groups using folders" below. 

2 Click Add Group. 

3 Type a name for the new schedule group in the Name field. 

4 Optional:  Change the default Reference name. A group's reference name must be unique throughout the 
system. 

5 Click Accept. 

6 Click Add Members to Group. 

7 On the Members page, select the areas, equipment, or other groups that you want to add to the group from 
the tree on the right. Use Ctrl+click, Shift+click, or both to select multiple items. 

8 Click Add. 

 TIP  Use the Raise and Lower buttons to reorder items in the Members list. Changing the order is for your 
viewing convenience and does not affect the system. 

9 Click Accept. 

10 You will see the question Execute download now?. Click OK. 

11 Click the Schedules button, then Configure. 

12 Add a schedule to the group. See To apply a schedule to equipment (page 63). 
 

To organize groups using folders 
You can create folders and sort your groups into them to organize the Schedule Groups tree. For example, a large 
school system that has a group for each school may want to create an Elementary School folder, a Middle School 
folder, and a High School folder, and put the appropriate groups in each folder. 

To create folders and add groups to them: 

1 On the User tree, select Scheduling Groups. 

2 Click Add Folder. 

3 Type a name for the new folder in the Name field. 

4 Optional:  Change the default Reference name. 

5 Click Accept. 

6 Repeat steps 1–4 for each folder that you want to add. 

7 Do one of the following to add a group to a folder: 
○ If you have already created the group, drag and drop it into the appropriate folder in the tree on the 

Scheduling Groups page, then click Accept. 
○ Select the folder in the tree on the Scheduling Groups page, then click Add Group to add a new group 

inside the folder. 
  
NOTE  You can also add a folder to a folder, or drag and drop a folder into another folder. 
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To edit or delete a schedule 

1 Do one of the following: 

○ On the navigation tree, select the tree item where the schedule was defined, then select Schedules > 
Configure tab. 

○ In the User tree, click Scheduling Groups, then select the group that has the schedule you want to edit or 
delete. 

2 Select the schedule you want to edit or delete. 

3 Edit the fields you want to change or click Delete. 

4 Click Accept. 

NOTE  Expired dated schedules are automatically deleted from the database at 3:30 AM every day. But expired 
schedules remain in the controller until the next time schedules are downloaded to the controller.  

 

 

Effective schedules 

The effective schedule that you see on the Schedules > View tab can be the result of multiple overlapping 
schedules. 
  

 
  

The following schedule features can influence an item's effective schedule. 

  

 Feature Description 

  
Hierarchy 

  
A schedule applied to an item on the i-Vu® tree affects that item and all of its children. A child 
item's combined schedule could be the result of multiple schedules applied at different levels 
above it. To change a child item's combined schedule: 

• Add a schedule at the child that overrides the current schedule. See the Priority feature 
below.  

• Set the child to ignore the parent schedules. To do this, select the child item on the tree, then 
go to Schedules > Configure. Select the schedule, then click Ignore Schedules above this 
level. You can then add a different schedule for the child. 

Any schedule change that you make to an item affects it and all of its children.  
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 Feature Description 

Priority You must assign one of the following priorities to every schedule. 
  

Use... For... 

Normal  A typical occupied period 

Holiday An unoccupied period that overrides a Normal schedule 

Override An occupied period that overrides a Holiday time 

 
EXAMPLE  For a school, you define: 

• A Normal schedule that has it occupied every Monday–Friday, 6 am–5 pm 

• A Holiday (unoccupied) schedule for the week of Spring Break 

• An Override schedule on the first day of Spring Break from 9 am–1 pm for the cafeteria only 
where a teacher's meeting will be held. 

Type You must assign one of the following types to every schedule.* 

Weekly 
Date 
Date Range 
Date List 

Wildcard 
Continuous 
Dated Weekly 

See To apply a schedule to equipment (page 63) for a description of each type. 

EXAMPLE  For a school, you define the following 3 schedules: 

• Full calendar year:  Normal, Weekly, Monday–Friday, 6am–5pm 

• Summer months:  Holiday, Continuous, 12am June 1st –11:59pm August 31st 

• Work days in summer months:  Override, Dated Weekly, Monday–Thursday, 9am–2pm 

  

Using the Priority and Type options, you can often accomplish the combined schedule you need in several 
different ways. For example, the combined schedule resulting from the 3 schedules described above for Type 
could also be accomplished with the following schedules: 

School year:  Normal, Dated Weekly, Monday–Friday, September 1st–May 31st, 6am–5pm 

Summer months:  Normal, Dated Weekly, Monday–Thursday, June 1st–August 31st, 9am–2pm 
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There are 2 types of CCN schedules: 
• 1 – 64 are local schedules that reside within the equipment   

• 65 – 99 are network or global schedules, which are sent over a CCN network and received by controllers that 
contain network schedules  

The i-Vu® application supports both local and global schedules.  

Most CCN equipment is shipped with the default schedule of 64. See exceptions below.  

Equipment i-Vu®'s default 
schedule number 

Comfort Controller/UC/Expansion Controllers 0 

Any controllers using a custom equipment file (*.equip) 
created with EquipmentBuilder 

0 

Gen III VVT, 48/50EJ (Conquest), FSM, CSM  1 
All PICs 64 

 CAUTION!  Confirm the actual schedule numbers that are used in the controller, as they may have been 
changed from their programmed default settings. 

In order to use i-Vu® schedules, the i-Vu® schedule number must match the CCN schedule number at the 
controller. This can be set in the i-Vu® interface by selecting the equipment in the navigation tree and clicking 
Schedules > CCN tab. It is also accessible at the area or site level. 

NOTE  To reduce start-up labor on a retrofit project, existing network schedules can be used by the i-Vu® 
application. However, switching to local schedules allows for schedule retention after a power failure and local 
schedule maintenance tables.  

If a controller uses a different schedule number, complete the following steps.  
CAUTION!  Failure to follow these steps may result in unexpected equipment operation. 

1 On the navigation tree, select the controller. 

2 Click the Schedules page, then CCN tab. 

3 Adjust the following fields: 

• Schedule number - enter the CCN schedule number in use at the controller.  

• Override time (optional) - enter the number of minutes of the desired override and verify that the controller 
override time is greater than or equal to this number 

• Override group - enter the number of the group, if you have established one  

 

 

 

i-Vu® CCN schedules 



 Alarms
  

 

 
 

i-Vu® Standard/Plus v7.0  CARRIER CORPORATION ©2020   
Help  All rights reserved 
 69 

 

A message is sent from an alarm source to i-Vu® to notify you that certain conditions exist, such as a piece of 
equipment that has stopped running or a temperature that is too high. When i-Vu® receives an alarm, it displays 
information about the alarm on the Alarms page. i-Vu® can also perform alarm actions (page 75) to inform 
personnel of the condition. An alarm source can also send a return-to-normal message when the alarm condition 
returns to its normal state. 

 
Alarm sources and the alarms they generate are assigned to categories, such as HVAC Critical or HVAC 
Maintenance, to help you work with related alarms.  

The application engineer usually sets up alarm sources in the Snap application. In the i-Vu® interface, you can: 

• View, troubleshoot, acknowledge, and delete alarms  (page 70) 

• Set up the alarm actions that the i-Vu® application performs (page 75) 

• Edit alarm sources that were set up in the Snap application or set up new alarm sources to generate alarms 
(page 80) 

NOTE  In addition to the alarms that you set up, i-Vu® has built-in system and equipment alarms.  

 

 

Alarms 
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Viewing, acknowledging, and deleting alarms 

The i-Vu® Alarms page displays alarms as they are received. If desired, an operator can set options on  > 
System Options > My Settings tab to have the i-Vu® application play an audio file when an alarm is received. 

An alarm's setup may require that it be acknowledged and/or the alarm condition returned to normal. The alarm, 
its return to normal, and any other alarms related to the incident are referred to as an alarm incident group. The i-
Vu® application closes an alarm incident group when all of the following have occurred: 
• You acknowledge the alarm (if required) 
• The i-Vu® application receives a return-to-normal (if required) 
• The i-Vu® application performs all alarm actions defined for the group 
You should delete alarms from your system as they are closed because large quantities of stored alarms can 
reduce the efficiency of your system. 

NOTE  The Installer view does not display all alarms on the system or site level, only on the router and controller 
level. Go to the User view or click the system-wide alarms button to see all of the alarms in the system.  

The color of the system-wide alarms button signifies one of the following conditions: 

•   Red  - Critical alarms need to be acknowledged. 

•   Yellow - Non-critical alarms need to be acknowledged. 

•   Gray - No alarms need to be acknowledged. 
You must acknowledge alarms that have been set up to require acknowledgement. Right-click alarm message to 
print. To save alarm information before deleting, select Alarms > Reports tab > Alarms > click Run button. 
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To view alarms in the i-Vu® interface 

• Click  at the top of the page to see all alarms in the system.  

or 

• Click the Alarms button and then select an item on the navigation tree to see all alarms at and below that 
level.  
 

 
  

NOTES   

• Alarms generated by the i-Vu® application appear at the system level. 

• Alarms generated by controllers appear at the system level in the User view. 

• An alarm's details include a path to the alarm source. Each section of the path is a link to that location. For 
example, in the path West TEMP LO at Router 41/Sunshine Corp, TEMP LO links to the microblock's 
Properties page, and Sunshine Corp links to the Sunshine Corp West Wing graphic, TEMP-LO links to the 
equipment graphic.  

• You may see any of the following alarms icons in i-Vu®.  
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Access control Red = Critical

Blue = Maintenance

Gray = General

Grayed out = Closed

These icons... Indicate...

Fire system

Lighting system

General alarm

System

Unknown

FDD

General message

Controller alarm

HVAC

Icon color indicates...

FDD comfort

FDD energy

 
 

 

To control which alarms you see 
   

Use these tools... To control the Alarms list 

 

Click the arrow buttons to display other alarms. 

 
  

Type a date and time or click  to select a date. Then 
click Go to show up to 50 alarms since that date/time. 

When finished, click  to display the 50 newest alarms 

or  to display the oldest 50 alarms. 
  

 

Date–Sorts list by date/time the alarms were generated 
with the most recent at the top. 
To Do–Shows only alarms that require one or more actions 
before they are closed. 
Incident Group–Sorts alarms by incident. For example, an 
alarm and its return-to-normal form an incident group. 
Brackets indicate a group. 
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Use these tools... To control the Alarms list 

 
  

Select the alarm categories that you want to see in the 
alarms list. Use Ctrl+click, Shift+click, or both to select 
multiple categories, or check Show all categories. 

 

 

To acknowledge alarms 
You must acknowledge alarms that have been set up to require acknowledgment. An alarm shows if it needs to 
be acknowledged. 

 
  

The table in the upper left corner of the page shows how many alarms need acknowledgment at the current 
location (Here) and in the entire system (Total). This table also shows how many alarms need a return-to-normal 
and how many are closed.  

 
  

To acknowledge an alarm 
1 On the Alarms page > View tab, select the checkbox of an alarm that shows Acknowledge. 

2 Click the Acknowledge button. 
  

To acknowledge all alarms in the alarms database for selected categories 
1 On the Alarms page > View tab in the left-hand column, select the categories whose alarms you want to 

acknowledge.  

NOTE  Use Ctrl+click, Shift+click, or both to select multiple categories, or select the Select All checkbox. 

2 Click Advanced. 

3 Click Acknowledge All. 

 TIP  Acknowledging many alarms simultaneously can take a long time. Acknowledge alarms as they occur to 
avoid long waits.  
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To delete alarms 
You should delete alarms from your system as they are closed because large quantities of stored alarms can 
reduce the efficiency of your system. To save alarm information before deleting, select Alarms > Reports tab > 
Alarms, then click the Run button. 
 

To delete an alarm 
1 On the Alarms page > View tab, select an alarm's checkbox. 

2 Click Delete under Manage List. 
 

To delete all alarms in the alarms database for selected categories 
1 On the Alarms page > View tab, click Filter View at the bottom of the page. 

2 Select the categories whose alarms you want to delete.  

NOTE  Use Ctrl+click, Shift+click, or both to select multiple categories, or select the Select All checkbox. 

3 Click Advanced. 

4 Click Delete All. 
 

To delete all closed alarm incident groups in the alarms database 
An incident group is all alarms related to a particular incident. For example, an alarm and its return-to-normal form 
an alarm incident group. An incident group is considered closed when all alarms in the group are closed. 

1 On the Alarms page > View tab, click Filter View at the bottom of the page. 

2 Select the categories whose alarms you want to delete.  

NOTE  Use Ctrl+click, Shift+click, or both to select multiple categories, or select the Select All checkbox. 

3 Click Advanced. 

4 Click Delete Closed Incidents. 
 

NOTE  An alarm source may be set up to generate an alarm and a return-to-normal. If an alarm occurs but the i-
Vu® application never receives the return-to-normal, you can select the alarm and then click Force Normal so that 
the alarm can be closed. Force Normal has no effect on the alarm condition that generated the alarm. 
 
 

To receive audible notification of alarms 
You can set up the i-Vu® application to play an audible alert on your workstation when it receives a critical or non-
critical alarm.  

1 Click , then select System Options > My Settings. 

2 Under Preferences, select Non-critical alarms or Critical alarms to be notified of them.  
 
When an alarm triggers the audible alert, you can click  and then select: 
• Snooze to temporarily stop the sound for 5 minutes 
• Silence to stop the sound 
The alarm sound is silenced until another alarm that triggers a sound is received. 
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Setting up alarm actions 

Alarm Action - An action that the i-Vu® application performs to notify personnel of an alarm or to record 
information about the alarm. You can assign alarm actions to an alarm source, a category of alarm sources, alarm 
sources from a certain location, or a combination of these criteria.  

To assign alarm actions to alarm sources: 
Although you can assign an alarm action to an individual alarm source, you typically assign an action to multiple 
alarm sources at the area or equipment level. The alarm action applies to all instances of the alarm sources at the 
selected location and below. Click an action’s Edit button to make any changes. 

To assign an alarm action to alarm sources: 

1 On the navigation tree, select the area or equipment, containing the alarm sources. 

2 Click Alarms > Actions tab and follow the 3 steps on the screen. 

NOTE  Use Ctrl+click, Shift+click, or both to select multiple items.  

3 Click Add. 

4 Set up the alarm action by editing the fields on the alarm action page. See the appropriate alarm action 
below for field descriptions. 

5 Click OK. 

 

 

Alarm Popup 
The Alarm Popup alarm action pops up a message on any computer with a Windows operating system that is 
running the i-Vu® Alarm Notification Client application. 
  

Field Notes 

To Operator 
To Group 

Select individual operators or operator groups who should receive alarm notification. 

Generate alarm if 
delivery fails 

Select this checkbox to generate a System Info alarm if the popup recipient is not 
currently running the Alarm Notification Client application. 

Message text Use punctuation, spaces, or returns to format the text. To add live data to the text, 
select field codes (page 84) from the Append Field Code list. 

Append Field Code Add field codes (page 84) to the message text if desired.  

Perform Action By default, the i-Vu® application performs an alarm action when the alarm source 
generates an alarm and when it returns to normal. Under Perform Action, you can 
choose to run the alarm action only when the alarm source generates an alarm or 
when it returns to normal. 

 

Using the Alarm Notification Client application 
The Alarm Notification Client application must be running on each client computer (Windows only) that should 
receive popup notifications. Keep the application minimized to the right side of the Windows task bar. The window 
will pop up with a message when an alarm occurs. 
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NOTE  To use the i-Vu® Alarm Notification Client application across a firewall, you must open UDP port 47806. 

Select an alarm message, then click  to open i-Vu® displaying the piece of equipment that generated the 
alarm. A grayed out alarm indicates that it was acknowledged in the i-Vu® interface. 

If the Alarm Notification Client is set up to play a continuous alarm sound, you can silence an alarm by clicking 
Silence!, by pressing Ctrl+S, or by acknowledging the alarm in the i-Vu® interface. 
 

 
  

Button Notes 

 Opens the i-Vu® interface displaying the equipment that generated the alarm. 

 
Copies the selected alarm information to the clipboard. 

 Removes the alarm information from the alarm popup list. Removing items from this list has no 
effect on the alarms list in the i-Vu® interface. 

 View information about the server connection. 

 
On this tab... You define... 

 Server Connection The i-Vu® web server and port, and the i-Vu® operator name and password 

 Browse To The i-Vu® page that you want to see first when browsing to the equipment 

 Notification 
Sounds 

• If you want to hear a sound when an alarm occurs 

• Which sound you want to hear for each type of alarm.  
NOTE  A Connection Failure occurs when the Alarm Notification Client 
loses communication with the i-Vu® application.  

• Whether you want the sound to continue until silenced 

NOTE  If multiple types of alarms occur simultaneously, the application plays 
the sound of the most critical alarm (Connection Failure first, then Critical, 
then Normal). 

 

To set up the i-Vu® application to support Alarm Popup clients 

1 Click , then select System Options > General tab, and then select Enable support for Alarm Notification 
Clients to connect to this server. 

2 Leave Restrict to IP Address field blank. 

3 Use the default port.  

4 Click Accept. 

NOTE  If the Alarm Notification Client application is not on the local network and will access i-Vu® alarms through 
a NAT router, your Network Administrator must port forward the TCP port you defined in step 3 above. 
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To install the Alarm Notification Client application 
Follow the steps below on each client computer that should receive alarm popups. 

PREREQUISITE  You must enable Alarm Popup support in System Options > General tab. See above topic. Click 

, then select System Options > General tab, and then check Enable support for Alarm Notification Clients to 
connect to this server. 

1 Install software from your Tech Tools USB drive or DVD. 

2 Click Alarm Popup Application. 

3 Click Run, then follow the on-screen instructions to install the Alarm Notification Client application. After you 
click Done, the application starts automatically.  

NOTE  To locate your applicable IP address, look in the Management Tool. 

4 In the Settings dialog box, enter appropriate values. You can also click  to open this box. See the table 
above for a description of each setting.  

NOTE  You can lock the Settings so that a user cannot edit them. See To lock a client's Settings feature 
below. 

5 Click OK. 

6 Minimize the Alarm Notification Client window. 
  

To lock a client's Settings feature 

To prevent a user from editing the Settings  :  

1 Right-click Alarm Notification Client in the Windows Start menu. 

2 Select Properties.  

3 On the Shortcut tab, type -lockconfig at the end of the Target path. 
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Send E-mail 
The Send E-mail alarm action sends a message to one or more e-mail accounts. The alarm action can also run a 
report and attach it to the e-mail as a PDF, HTML, or XLS file. 

 

Field Notes 

To and 
CC 

Type the address(es) that you want to send the alarm to. To enter multiple addresses, 
type a space or press Enter after each address. 

Subject Enter the text that you want to appear on the Subject line of the email. The subject 
can include field codes (page 84). 

Use default email 
server configuration 

Check this field to have this alarm action use the email server configuration settings 
defined on the System Options > General tab. Uncheck to enter settings specific to 
this alarm action. 

    From Enter a valid address if required by your mailserver. 

    Mail Host The mailserver's address. This can be an IP address or a system name, such as 
mail.mycompany.com. 

    Mail Host Port Change this field if using a port other than the default port 25. 

    Mail Host 
    Security Options 

Select the type of security the mailserver uses. 

• Cleartext (SMTP) – Uses the SMTP protocol to send as clear text over TCP/IP 

• Secure SSL (SMTP with SSL) – Uses SSL, a communication protocol that 
provides data encryption 

• Secure TLS (STARTTLS) – Uses TLS, but does not begin encryption until the i-Vu® 
application issues STARTTLS command 

    Specify Mail 
    User For Mail 
    Host 
    Authentication 

Select if your mailserver requires a username and password. 

Send mail as MIME 
attachment 

Select if your mailserver allows only MIME attachments. 

Message Text Use punctuation, spaces, or returns to format the text. To add live data to the text, 
select field codes (page 84) from the Append Field Code list. 

Attach Report Select to attach a report to the e-mail, then select the Report and the Format. The 
attached report will include the date and time. For example, Alarm Sources 2012 Jan 
01 1230. 

NOTE  The Report Name field shows a custom report only if it is accessible at the 
current level. 

Run as shows the name and login name of the operator creating the alarm action. The 
report will be run using the privileges and report options of this operator. 

 TIP  You may want to create a new operator with limited privileges for this 
purpose. 
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Field Notes 

Perform Action By default, the i-Vu® application performs an alarm action when the alarm source 
generates an alarm and when it returns to normal. Under Perform Action, you can 
choose to run the alarm action: 

• Only when the alarm source generates an alarm or when it returns to normal. 

• After a specified amount of time if the alarm has not been acknowledged or has 
not returned to normal. Use this option for alarm escalation.  

• If the alarm occurs during the occupied hours defined for a schedule group or run 
if the alarm occurs during the unoccupied hours defined for a schedule group.  
EXAMPLE  To have one alarm action performed during work hours and a different 
alarm action performed after work hours: 

1. Create a schedule group (page 65), but do not assign members to it.  

2. Create a schedule for the group. Set the occupied hours to be the same as 
the work hours. 

3. Create the alarm action that is to be performed during work hours. Under 
Perform Action, select If schedule group <your new group> is Occupied. 

4. Create the alarm action that is to be performed after work hours. Under 
Perform Action, select If schedule group <your new group> is Unoccupied. 

 

NOTE  You should not assign this alarm action to frequently-occurring alarms as this may cause problems on your 
network or the Internet. 

 

 

Send Web Service Request 
The Web Service Request alarm action sends a web service request to a third-party server when an alarm event 
occurs. For example, the i-Vu® application could send a request to a work order system so it could create a work 
order for someone to respond to the alarm condition. 
  

Field Notes 

Destination Address The URL of the server that will receive the request.  
Example:  https://192.168.168.102/workorder/bas 

Web Service Action Select the type of web service request required by the target server:   
GET or POST 

Content Type If you selected POST in the previous field, select the format required by the target 
server: 
Application/json   or   /x-www-form-urlencoded 

Web Service Request 
Parameters 

Optional–Create a parameter for each piece of information that the target server 
requires. You should be able to find information about required parameters in the 
target server's documentation. 

     Parameter Name Enter a name for the parameter. For example, Parm1 or Date.  

Click Add Parameter. 

     Value Text required for the parameter. To add live data to the request, select a field code 
(page 84) from the Append Field list.  



Alarms  
 

 

 
 

i-Vu® Standard/Plus v7.0  CARRIER CORPORATION ©2020   
Help  All rights reserved 
 80 

 

Field Notes 

Perform Action By default, the i-Vu® application performs an alarm action when the alarm source 
generates an alarm and when it returns to normal. Under Perform Action, you can 
choose to run the alarm action: 

• Only when the alarm source generates an alarm or when it returns to normal. 

• After a specified amount of time if the alarm has not been acknowledged or 
has not returned to normal. Use this option for alarm escalation.  

• If the alarm occurs during the occupied hours defined for a schedule group or 
run if the alarm occurs during the unoccupied hours defined for a schedule 
group.  
EXAMPLE  To have one alarm action performed during work hours and a 
different alarm action performed after work hours: 

1. Create a schedule group (page 65), but do not assign members to it.  

2. Create a schedule for the group. Set the occupied hours to be the same as 
the work hours. 

3. Create the alarm action that is to be performed during work hours. Under 
Perform Action, select If schedule group <your new group> is Occupied. 

4. Create the alarm action that is to be performed after work hours. Under 
PerformAction, select If schedule group <your new group> is Unoccupied. 

 

 

Setting up an alarm source in the i-Vu® interface 

In the i-Vu® interface you can: 

• Edit an alarm source’s settings or set up a new alarm source to generate alarms. 

• Select Properties page > Alarm Sources tab to set up all alarms associated with a particular piece of 
equipment 

• Simulate an alarm to test its setup. 

 

  

To set up, edit, or disable alarm sources 

To set up, edit, or disable a single alarm source 
1 On the navigation tree, select the control program. 

2 Click Alarms, then select the Enable/Disable tab. 

3 Make changes to the fields as needed. The fields can vary for different types of alarm sources. See table 
below. 

4 Click Accept. 

 TIP  To set up all the alarms for a piece of equipment at once, click Properties, then select Alarm Sources. 
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Field Notes 

Potential alarm source Check to enable the alarm source to generate alarms. Uncheck to disable the alarm 
source. 

Alarm enabled Check to have the alarm source generate an alarm when the specified conditions 
occur.   

• For a binary input, enter the conditions for generating an alarm. 

• For an analog input, type the low and high limits that, when exceeded, will 
generate an alarm.  
 

Deadband  The amount inside the normal range by which an alarm condition must 
return before a return-to-normal notification is generated. 

EXAMPLE 

 
NOTE  If the Status checkbox is selected, the alarm condition currently exists. 

Return to Normal Check to have the alarm source generate a return-to-normal when the alarm 
condition returns to a normal state. 

Alarm requires 
acknowledgement 

Check to have the i-Vu® application require that an operator acknowledge the 
alarm. 

Return requires 
acknowledgement 

Check to have the i-Vu® application require that an operator acknowledge the 
return-to-normal. 

Classified as critical This property determines the color of the system-wide alarm button when the alarm 
comes in. 

 = Critical       = Non-critical 

Event State The current state of the alarm source can be: 
• Normal—value is normal 
• Off normal—the value is not normal (binary only) 
• Fault—the alarm source microblock may be misconfigured 
• High Limit—the value exceeds the normal range (analog only) 
• Low Limit—the value is below the normal range (analog only) 

BACnet 
Configuration: 
  

Dial on alarm 

 N/A  
 

Notification Class Do not change this field. 
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To set up, edit, or disable multiple alarm sources simultaneously 
1 On the navigation tree, select the area, equipment, or controller containing the alarm sources.  

2 Click Alarms, then select the Enable/Disable tab. 

3 In step 1, select the categories that contain the alarm sources. 

NOTE  In step 1 and step 2, Ctrl+click, Shift+click, or both to select multiple items, or select the Select All 
checkbox. 

4 In step 2, select the alarm sources. 

5 Make appropriate changes in step 3. 

6 Click Accept. 

NOTE  Click View Selected Sources to view or change settings for each alarm. 

 

 

To view all instances of an alarm source 
To find all instances of an alarm source at and below a selected area: 

1 On the navigation tree, select an area. 

2 Click Alarms and select the Actions, Enable/Disable, or Category tab. 

3 Select an alarm source from the list in step 2. 

4 Click View Selected Sources. 

NOTE  You may be able to change settings that relate to the tab you selected. 

 

 

To simulate an alarm 
To test the setup of an alarm source and its alarm actions (page 75), you can simulate an alarm or its return-to-
normal. 

1 On the navigation tree, select the alarm source whose alarm you want to simulate. 

2 Click Properties > Alarm Sources tab. 

3 Click on an alarm point that is labeled as (BALM) or (CALM) and is enabled as a Potential Alarm Source (fifth 
column from the left). 

4 In the dialog box that opens, select Alarms and then the Enable/Disable tab. 

5 Check Enable next to Alarm or Return to Normal. 

6 Click Simulate next to Alarm or Return to Normal. 



 Alarms
  

 

 
 

i-Vu® Standard/Plus v7.0  CARRIER CORPORATION ©2020   
Help  All rights reserved 
 83 

 

7 Click Accept. 

 
 

8 Select the controller on the navigation tree, then select the Alarms > View tab to see the alarm. 

 

 

Alarm categories 
Alarm categories sort related alarm sources and their alarms into groups such as HVAC Critical and Access Control 
General. Alarm categories let you: 

• View, acknowledge, or delete selected categories of alarms (page 70) received by the i-Vu® application 

• Assign alarm actions (page 75) to selected categories of alarm sources  

• Set up alarm sources (page 80) in selected categories 

Each alarm source is assigned to an alarm category in either the Snap application or in the i-Vu® interface. 
   

To assign alarm sources to a category in the i-Vu® interface 
1 On the navigation tree, select the area, equipment, or controller containing the alarm sources. 

2 Click Alarms, then select the Category tab. 

3 In step 1, select the category that currently contains the alarm sources. 

NOTE  In step 1 and step 2, Ctrl+click, Shift+click, or both to select multiple items, or check Select All. 

4 In step 2, select the alarm sources whose category you want to change. 

5 In step 3, select a category from the drop-down list, then click Change. 

6 Click Accept. 
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Edit alarm messages 

To edit the message for an alarm source 
1 On the navigation tree, select the controller. 

2 Select Properties > Alarm Sources tab and double-click the underlined name of point to open the microblock 
popup. 

3 In the dialog, select Alarms > Messages tab. 

NOTE   Sample Alarm Message and Sample Return Message show the messages as they are currently 
defined. 

4 Enter the edited message you want to appear in the field for Alarm or Return. You can add live data to the 
text by selecting field codes (page 84) from the Append Field Code list. 

5 Click Accept. 

 

 

Using field codes 

Use field codes to insert live data into:  

• The message on an alarm action  

• Text displayed on the Alarms page > View tab 

• Alarm information archived to a text file when an alarm is deleted 

You can customize the setup of each of these items by appending field codes. For example, to have the message 
in an alarm action include the device that generated the alarm, append the Device field code to the action's 
message.  

 

 

Formatting field codes 
You can type a formatting command after a field code to format the field code in one of the following 3 ways:  

• Format a number field code (Example: ##.##)  

• Format a date/time field code (Example: MM/dd/yyyy hh:mm:ss)  

• Left, right, or center align a field code and set the field width 

A formatting command must have the following syntax: 

 
Use the table below to determine the format_type and style for a formatting command. 
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  format_type   style 
Example 

To format a 
number 

N  The actual formatting, such 
as ##.##. The basic format 
uses the pound sign (#) to 
represent a number. For 
more information, search 
the Internet for "customizing 
number formats with java". 

To always round a setpoint value 
to two digits to the right of the 
decimal, the field code is: 
$setpoint_value%N:##.##$ 
For example, 78.9935 becomes 
78.99. 

To format 
date/time 

D  The actual formatting, such 
as MM/dd/yyyy hh:mm:ss. 
For more information, 
search the Internet for 
"customizing date time 
formats with java".  

To show the date and time when 
an alarm is generated in a format 
like 03/15/2004 10:50:43, the 
field code is: 
$generation_time%D:MM/dd/yyyy 
hh:mm:ss$  

To set alignment 
and field width  

L for left align 
R for right align 
C for center align  

Indicate the field width by 
number of characters. 

To left align the name of the 
device that generated the alarm 
and set the field width to 15 
characters, the field code is: 
$device%L:15$ 

 

Using multiple formatting commands  
You can type multiple formatting commands for a field code. For example, you can format a number and then set 
the alignment and field width. The syntax for multiple formatting commands is:  

$fieldcode%format_type1:style%format_type2:style$  

EXAMPLE  To format the alarm date and time, center it and set the field at 20 characters, the field code is: 
$generation_time%D:MM/dd/yyyy hh:mm:ss%C:20$  

NOTE You must enter the date/time or number formatting command before the alignment/field width command. 

 

 

Field Codes 
  

Field Code Name Field Code Description 

Acknowledge 
Operator 

$acknowledge_operator$  The operator who acknowledged the alarm.  
EXAMPLE  John Doe 

Acknowledge Time  $acknowledge_time$  The time when the operator acknowledged the alarm.   
EXAMPLE  Nov 12, 2012 6:46:31 PM 

Alarm Category  $alarm_category$  The alarm category that the alarm is assigned to.  
EXAMPLE  HVAC Critical 

Alarm Priority  $alarm_priority$ The priority number associated with the alarm's priority 
(Off-Normal, Fault, or Normal) on the controller's Driver > 
Notification Class page. 

Alarm Type  $alarm_type$  The alarm type of the alarm source.  
EXAMPLE  CHANGE OF STATE 
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Field Code Name Field Code Description 

Character $c$ A single ASCII character. Often used for form feeds and 
other printer escape sequences. 
EXAMPLE  $C:65$ displays A 

Command Value $command_value$  The commanded value from the alarm source. Valid only 
for alarm type COMMAND FAILURE.     
EXAMPLE  3 

Control Program $equipment$  The display name of the equipment where the alarm 
came from.   
EXAMPLE  Chiller 

Controller $device$  The display name of the device where the alarm came 
from.   
EXAMPLE  UPC Open 

Dead Band  $deadband$  The deadband value from the alarm source. Valid only for 
alarm type OUT-OF-RANGE. 
EXAMPLE  5 

Deletion Operator  $deletion_operator$  The operator who deleted the alarm.   
EXAMPLE  John Doe 

Deletion Time  $deletion_time$  The time the alarm was deleted.   
EXAMPLE  Nov 12, 2012 6:46:31 PM 

Error Limit  $error_limit$  The error limit, from the alarm source. Valid only for alarm 
type FLOATING LIMIT.   
EXAMPLE  90 

Event Values $event_values$ Returns a string of alarm values associated with the 
alarm.    

Exceeded Limit  $exceeded_limit$  The exceeded limit value from the alarm source. Valid only 
for alarm type OUT-OF-RANGE.   
EXAMPLE  90 

Exceeding Value  $exceeding_value$  The exceeding value from the alarm source. Valid only for 
alarm type OUT-OF-RANGE.   
EXAMPLE  91 

Fault  $fault$  The status of the fault condition from the alarm source.   
EXAMPLE  True or false 

Field Message  $field_message$  Text generated in the alarm by the controller.   

Feedback Value $feedback_value$  The feedback value from the alarm source. Valid only for 
alarm type COMMAND FAILURE.   
EXAMPLE  10 

From State  $from_state$  The previous state of the alarm source.   
EXAMPLES  NORMAL, FAULT, OFF NORMAL, HIGH LIMIT, 
LOW LIMIT 

Generation 
Operator 

$generation_operator$  The operator who forced the alarm to return to normal.   
EXAMPLE  John Doe 

Generation Time  $generation_time$  The time in the controller when the alarm was generated.   
EXAMPLE  Nov 12, 2012 6:35:18 PM 

In Alarm  $in_alarm$  The in alarm status from the alarm source.   
EXAMPLE  True or false 
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Field Code Name Field Code Description 

Incident Closed 
Time 

$incident_closed_time$  The time the alarm's entire incident group closed.  
EXAMPLE  Nov 12, 2012 6:46:31 PM 

Location Path  $location_path$  Displays the path display names from root to source.  
EXAMPLE  Building B / Basement / VAV AHU B / 
SSP_STOP 

Long Message  $long_message$ The formatted alarm long text displayed by double-clicking 
the alarm on the Alarms page.     

Message Details $message_details$ The message details displayed on the Alarms page View 
tab.    

Message Prefix $message_prefix$ The message prefix displayed on the Alarms page View 
tab.    

Message Text $message_text$ The message text displayed on the Alarms page View tab. 
   

New State  $new_state$  The status of new state from the alarm source. Valid only 
for alarm type CHANGE OF STATE. 
EXAMPLE  Alarm, Fault 

New Value  $new_value$ The new value from the alarm source. Valid only for alarm 
type CHANGE OF VALUE.   
EXAMPLE  70 

Notification Class $notification_class$ The notification class assigned denotes how the received 
alarm was generated. For example, if set to 1, the alarm 
would typically be sent to i-Vu® by Carrier controllers.    

Object ID  $object_ID$  Object ID of the alarm source.   
EXAMPLE  5:26 

Out of Service  $out_of_service$  The status of 'out of service' from the alarm source.   
EXAMPLE  True or false 

Overridden  $overridden$  The status of 'overridden' from the alarm source.   
EXAMPLE  True or false 

Program ID  $program_id$  The address of the control program that generated the 
alarm. 

BACnet program address format: 
device ID, program number  
EXAMPLE  2423101,1 

Receive Time $receive_time$  The time at the workstation when the alarm was received.   
EXAMPLE  Nov 12, 2012 6:46:31 PM 

Recipient Device 
ID  

$device_id$ The device ID of the device where the alarm came from.  
EXAMPLE  8:2423101 

Reference Path  $reference_path$  Path to alarm source. Available in all alarm actions.  
EXAMPLE  #e_b_vav_ahu_b/ssp_stop 

Reference Value  $reference_value$  The 'reference value' from the alarm source. Valid only for 
alarm type FLOATING LIMIT.   
EXAMPLE  83 
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Field Code Name Field Code Description 

Referenced 
Bitstring 

$referenced_bitstring$  The value of the 'referenced bitstring' value from the 
alarm source. Valid only for alarm type CHANGE OF 
BITSTRING.   
EXAMPLE  1011011101101 

RTN Time $RTN_time$  The time when the alarm returned to normal.  
EXAMPLE  Nov 12, 2012 6:46:31 PM 

Setpoint Value $setpoint_value$  The 'setpoint value' from the alarm source. Valid only for 
alarm type FLOATING LIMIT.   
EXAMPLE  72 

Short Message $short_message$  The formatted alarm short text.     

Site  $site$  The display name of the site the alarm came from.   
EXAMPLE  Kennesaw 

Source  $source$ The display name of the alarm source microblock that 
generated the alarm.   
EXAMPLE  SAT_HI 

Source description  $source:description$  The Description field of the alarm source microblock that 
generated the alarm.  
EXAMPLE  High Cooling Supply Air Temp 

Source Path $source:<path>$  Substitute <path> with the path to the value your want to 
display. See Defining i-Vu® paths (page 175). 

Example to add text value: 
$source:~equipment.display-name$ 

NOTE  You can use Global Modify (page 48) to get the 
path. 

System Directory  $system_dir$  i-Vu® Pro only: 

The system folder name.   
EXAMPLE  c:\<i-Vu_Pro_>x.x\webroot\ world_corporation 

To State $to_state$ The current state of the alarm source.  
EXAMPLES  NORMAL, FAULT, OFF NORMAL, HIGH LIMIT, 
LOW LIMIT 
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The i-Vu® system can read and store equipment status values over time and then display this information in a 
trend graph to help you monitor the equipment’s operation.  

 
You can collect trend data for any point value in the i-Vu® system. The controller reads point values at intervals 
that you define and then stores that data in the controller for up to 7 days . A controller has limited memory for 
storing trend data, so you can set up historical trending to archive the trend data from the controller to the 
database.  

A trend graph can display data from the controller and the database, or it can display only data stored in the 
database. 

When the storage capacity of your system is running low from too much historical trend data, you will receive an 
error message. To create more storage space, go to the Management Tool (page 32) and click Compress System. 

After you set up the desired points for trend data collection (page 90), you can:  
• View built-in trend graphs that show a single point (page 91) 
• Create custom trend graphs with multiple points (page 92)  

  

 
  

 

Trends 
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To collect trend data for a point 

Before you can see a point's trend graph, you must enable trending for that point and then define how you want 
the controller to collect the point's data. This can be done in Snap or you can do it in the i-Vu® interface using the 
instructions below. 

NOTE  I/O microblocks have trending capability built-in, and you enable trend logging in the I/O microblock. Any 
other microblock value must have a trend microblock attached in the control program, and you enable trend 
logging of the value in the trend microblock.  
  

To set up a point's trending in the i-Vu® interface: 

1 On the navigation tree, select the equipment that has the point you want to trend. 

2 Click the Trends button drop-down arrow, select Disabled Points, then select the point. 

3 Click the Enable/Disable tab, then select Enable Trend Log to have the controller collect trend data. 

4 Enter information in the appropriate fields. See table below. 

5 Click Accept. 

 TIP  You can set up all trends for a piece of equipment at once on the Trend Sources tab of the equipment's 
Properties page. 

  

Field Notes 

Sample every _:_:_ (hh:mm)  Records the point’s value at this interval. 

NOTES  

• Set this field to one minute or greater. 

• This setting should be longer than the CCN bus poll interval. To 
determine the poll interval: 

1.  In the Installer tree, right-click the device polling the CCN 
     controller, and then select Driver Properties. 
2.  Go to Protocols > CCN. 
3.  Scroll down to the Program Status heading. 
4.  In the first row of the table, subtract the third column  
     value from the fourth column value to get the poll interval. 

Sample on COV 
(change of value) 

This method records the point’s value only when the value changes by at 
least the amount you enter in the COV Increment field. 

NOTE  Use this method for a binary point or for an analog point that has 
infrequent changes in value. 

Enable Trend Historian  Archives trend data to the system database. 

Store Trends Now Writes all trend data in the controller to the system database without having 
to enable trend historian. 
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Field Notes 

 Keep trends for _ days Enter a number between 1 and 62 in this field to override the default number 
of days that trends for this point are stored. The trend storage default settings 
are:  

• 62 days of override trends stored to accommodate Tenant Override 
Billing (available for i-Vu Plus only) 

• 7 days of all other system trends stored  

NOTE  Saving more than 62 days will affect system performance and could 
result in alarm messages instructing you to compress trend storage in the 
Management Tool (page 32). You can also create more space by using the 
next option Delete trend samples. 

BACnet Configuration The Object Name is a unique alphanumeric string that defines the BACnet 
object. Although the Object Name field can be edited, it is not recommended. 
The Notification Class is set to 1 to receive alarms generated by Carrier 
controllers. 

  
NOTE  Run a Trend Usage report (page 96) to view trend data. 

 

 

Viewing a built-in, single-point trend graph 

1 On the navigation tree, select the equipment whose trend you want to view. 

2 Click the Trends button drop-down arrow, select Enabled Points, and then select the graph you want to view. 

3 Select the View tab. See Using trend graphs (page 94). 

  
NOTE  On the Configure tab, you can: 
• Enable/disable the grid. 
• Set the time range for the X axis. For example, enter 7 days to see the data for the last week. 
• Turn off autoscaling so that you can define a range for the Y-axis 
• Type a Y-axis label that will appear on the right side of the graph. 
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Creating a custom trend graph 

When creating a custom trend graph, you can select up to 16 points. If you select more than 4 points or points 
with different units, the i-Vu® application splits the data into subgraphs. Each subgraph can show a maximum of 
4 points with similar units.  

 
  
NOTE  You must enable trending for points that you want to include in the custom trend graph. See To collect 
trend data for a point (page 90). 

 

 

To create a custom trend graph 
1 On the navigation tree, select the area or equipment where you want to see the graph. 

2 Click the Trends button drop-down arrow, then select New Trend Graph. 

NOTE  If the Trends button does not have a drop-down arrow, the New Trend Graph page is already displayed. 

3 In the tree on the New Trend Graph page, use Ctrl+click or Shift+click to select the points (16 maximum) that 
you want to see on a graph.  

NOTE  The tree shows only points that have trending enabled. See To collect trend data for a point (page 90). 

4 Click Save. 

5 Type a Name for the graph that will appear at the top of the graph and in the Trends button drop-down list. 

6 Click OK.  

7 Select: 

○ The View tab to see the custom trend graph. See Using trend graphs (page 94). 

○ The Configure tab to edit the trend graph. See To edit a custom trend graph (page 93). 
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To edit a custom trend graph 

1 On the navigation tree, select the area or equipment where you created the graph. 

2 Select the Trends > Configure tab. On this page, you can: 
• Change the name of the custom trend graph 
• Enable/disable the grid 
• Set the time range for the X axis 
• Edit a subgraph's Y-axis label that will appear on the right side of the graph 
• Turn off autoscaling so that you can define a range for the Y-axis 
• Add/delete subgraphs (see instructions below) 
• Add/delete points (see instructions below) 
• Change a point's name on the graph 
• Change a binary point's active/inactive text on the graph 
• Click Delete Trend Graph to delete the entire custom trend graph 

  

To add a subgraph to a custom trend graph 
1 Click Add below the Subgraphs list. 

2 Type a Y-axis label. 

3 Click Add below the Points list. 

4 Select a point in the Data source tree. 

NOTE  The tree shows only points that have trending enabled. See To collect trend data for a point (page 90). 

5 Repeat steps 3 and 4 to add up to 4 points to the subgraph. 

6 Click Accept. 

NOTE  To delete a subgraph, select it in the Subgraphs list, click Delete below the list, and then click Accept. 
  

To add a point to a subgraph 
1 Select the subgraph in the Subgraphs list. 

2 Click Add below the Points list. 

3 Select a point from the Data source tree. 

NOTE  The tree shows only points that have trending enabled. See To collect trend data for a point (page 90). 

4 Click Accept. 

NOTE  To delete a point, select the appropriate subgraph, select the point, click Delete below the Points list, and 
then click Accept. 
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Using trend graphs 

 
  

 NOTES   

• A gray triangle at the top of a graph indicates a note from the system. Hover your cursor on the triangle to see 
which of the following occurred: 

○ Equipment received a time synchronization from its network router or from the i-Vu® application.  

○ Trend Historian has been enabled or disabled.  

○ Trend Log has been enabled or disabled. 

○ The trend object ID of a third-party trend source has been changed. For information only, you do not 
need to do anything. 

• Click  at the top of the i-Vu® page to print the graph. You may need to set your printer's orientation to 
Landscape. 

• Toolbar options are also accessible by right-clicking a trend graph. 

• You can check Display gap in graph line for missing data on an individual trend graph page, or you can go to 
the System Options (or System Settings) > General tab (page 29) to set this for all future trend graphs. 
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To view trend data in a spreadsheet program 
You can save trend data as csv data that you can open in a spreadsheet program such as Microsoft® Excel®. 

1 On the Trends > View tab, select  > Save as CSV data. 

2 Save the data (.zip file) wherever you want. The .zip file contains the following: 
• A .csv file for each trend source (point). The filenames match the point names. 
• A Combined folder containing a file with the combined data for all of the graph's trend sources. 

3 Open the .csv file in a spreadsheet program. 

  
NOTES 

• You will need to convert the data in the spreadsheet's Time column to a readable date/time format. 

• If you use Microsoft® Excel® on a Mac and the converted date shows the wrong year, do the following: 

1. In Excel, go to File > Options > Advanced. 

2. Scroll down to the section When calculating this workbook, and then uncheck Use 1904 date system. 
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Use reports to monitor and troubleshoot your system. Your i-Vu® edition determines which of the following things 
you can do in the i-Vu® interface.  
  

Reports feature  i-Vu® Standard i-Vu® Plus 

Run preconfigured reports                      

Run custom reports            

Schedule reports            

  

 

 

Preconfigured reports 

The preconfigured reports shown in the Reports button drop-down list vary depending on which tree you selected.  
   

In the User tree: In the Installer tree: 

 
 

              
  

 

  
A preconfigured report shows data for the selected tree item and all of its children. 
  

This preconfigured report... allows you to... 

  
Alarms 

 

Alarm Actions Create a summary of the information configured on the Alarms > Actions (page 
75) tab. 

Alarm Sources Create a summary of potential alarm sources as configured on the Alarms > 
Enable/Disable (page 80) tab. 

Alarms View, sort, and filter the information on the Alarms View (page 70) tab. 

Reports 



 Reports
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This preconfigured report... allows you to... 

  
Commissioning 

 

Equipment Checkout View the information on the Equipment Checkout tab of the equipment's 
Properties page during commissioning. Also, find equipment that has not been 
fully commissioned. 

Test & Balance View the damper calibration parameters.  

Run this report after performing Test and Balance to upload all calibrations and 
resolve parameter mismatches.  

• Running the report at the equipment level of the navigation tree uploads to 
that location 

• Running the report at the system or router level will upload to all equipment 
that contain one or more airflow microblocks.  

CAUTION! After performing Test and Balance, you must run the Test and Balance 
report to upload the values from the controller to the i-Vu® application. You will 
lose all your calibrations if you download to the controller before running this 
report. 

  
Equipment 

 

Locked Values Find all locked points and locked values. 

NOTE  Locks in the Airflow microblock are not reported. 

Network IO Verify the programming and status of all network points—especially useful for 
commissioning controllers used for third-party integration. 

Parameter Mismatch Discover where your system has parameter mismatches that need to be 
resolved. 

Point List View the details of all points. Verify that all points have been checked out during 
commissioning. Also, create custom lists for other contractors. For example, 
create a list of BACnet IDs. 

Trend Usage Creates a summary of the information configured on the Trends > 
Enable/Disable (page 90) tab. 

  
Schedules 

 

Effective Schedules View all equipment that may be scheduled and the net result of all schedules in 
effect for a selected date and time. 

Schedule Instances Find every schedule with its location that is entered at and below a selected tree 
item. This report can help you discover newly added and conflicting schedules. 
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This preconfigured report... allows you to... 

  
Security 

  
NOTE  You must have the Advanced Security package to run these reports.  

Location Audit Log View chronological lists of changes, the operators that made them, and the 
reasons for the changes. This report includes changes such as property edits, 
downloads, driver changes, and view changes.  

Select the Options tab to choose whether to show the changes made by All 
Operators, System, Installer, or specific operators. You can show administration, 
system, and schedule group changes.  

System Audit Log View chronological lists of system-wide changes, the operators that made them, 
and the reasons for the changes. This report includes changes such as any 
change made on the tree, login/logout, and scheduled processes like deleting 
expired trends. 

Select the Options tab to choose whether to show the changes made by All 
Operators, System, Installer, or specific operators. 

  
Network 

 

Controller Status Discover network communication problems (shown as purple squares on the 
report) that need troubleshooting. The report also shows boot and driver version, 
download information, and if controller has 4.x or later driver, the report shows 
the serial number and Local Access port status.  

Equipment Status Display the thermographic color, status, and prime variable of each control 
program. 

 

 

To run a preconfigured report 

1 Select an item on the navigation tree. 

2 Click the Reports button drop-down arrow, then select a report. 

3 On the Options tab, define the layout and content of the report. 

NOTES 

○ Changing the size and orientation of the printed page also changes the report layout on the View tab. 

○ To create a CSV (Comma Separated Values) file after you run the report, select Support CSV text format. 
See To create a report PDF, XLS, or CSV file (page 102). 

○ The current operator's report options are saved so that when that operator logs in again, the same 
options are used. 

4 Click Run. 
  

NOTE  i-Vu® Plus and Pro only - Click Schedule to schedule the report to run on a recurring basis. See Scheduling 
reports (page 103). 
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To run an ad hoc Alarms or Security report 
Follow these steps to run a single ad hoc version of an Alarms, or Security report. 

1 Click the Reports drop-down arrow, and then select the report that you want to schedule. 

○ Alarms > Alarms 

○ Security > Location Audit Log 

○ Security > System Audit Log 

2 Go to the Options tab. 

3 In the Ad Hoc Report section, select the time span of the report. 

Date range option  Description 

Unrestricted The report contains all data for the entire duration of available dates. 

Continuous Data (Date) The report contains all data occurring between the specified Start and End 
dates. 

Continuous Data (Date and 
Time) 

The report contains only the data occurring between the specified Start 
Date and Time and End Date and Time. 

Shift Report 

 
The report contains only the data occurring between the specified Shift 
Start and End Times within the specified date range. 

4 Click Accept, and then click Run. 

  Changes made here affect ad hoc report settings for the selected Alarms or Security report in all locations. 

 

 

To configure scheduled Alarms and Security reports 
The following reports have additional scheduling options available.  Scheduling these reports without configuring 
schedule options results in an error; see View History in To manage scheduled reports (page 104). 

• Alarms > Alarms 

• Security > Location Audit Log 

• Security > System Audit Log 

 

1 Go to the Options tab, open Scheduled Report, and check Enable schedule options for this location. 

2 Select the time span of the report. 

Date range option  Description 

Continuous Data (Date) The report contains all data occurring between the specified Start and End 
dates. 

Continuous Data (Date and 
Time) 

The report contains only the data occurring between the specified Start 
Date and Time and End Date and Time. 

Shift Report The report contains only the data occurring between the specified Shift 
Start and End Times within the specified date range. 

3 Select the number of Days, Weeks, Months, Quarters, or Years the report will contain. 



Reports  
 

 

 
 

i-Vu® Standard/Plus v7.0  CARRIER CORPORATION ©2020   
Help  All rights reserved 
 100 

 

NOTES 

○ The use of "previous":  Selecting "previous week" returns data for the previous full calendar week, 
Sunday through Saturday.  Select "previous 7 days" to see the most recent week of data. For example, 
selecting "previous 7 days" on a Wednesday returns data from last Wednesday through the current 
Tuesday. 

○ Checking include current causes the report to contain data for the most recent iteration of the report. 
For example, a report for the previous week with the include current option checked contains only the 
data for the current week, even if it is not a complete week.  In order to get the last week and the current 
week, it would be necessary to specify the previous 2 weeks. 

4 Click Accept. 

NOTE  Changes made here affect the selected Alarm or Security scheduled report in the current location only. 

 

 

Custom reports 

i-Vu® Plus only - If custom reports have been created for your system, you can click the Reports button drop-down 
arrow, and then select Report Manager to see a list of all custom reports in your system.  

In the Report Manager, you can: 
• Import a custom report(s) into your system (page 101) 
• Export a report(s) to a file so that it can be imported into another system (page 101) 
• Delete an existing report (page 101) 

  
NOTES   

• A custom report may appear in the Report Manager but not appear in the Reports button menu because its 
only purpose may be to provide data to a table, chart, or color map on a Graphics page.  

• To support upgraded systems, you can still create and access legacy (v6.5 and earlier) custom reports (page 
104). These reports appear only in the Reports button drop-down menu, but not in the Reports Manager. 
 

 

To run a custom report 
i-Vu® Plus only  

1 Select an item on the navigation tree where the report you want to run is accessible.  

2 Click the Reports button drop-down arrow, and then select the report. 

3 Optional:  If the report was designed with variables, you can change the variables' values at the top of the 
page.   

NOTE  Click Reset if you want to change the variables back to the value that was assigned when the report 
was created. 

4 Click Run. 

  
NOTE  Click Schedule to schedule the report to run on a recurring basis. See Scheduling reports (page 103). 
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To delete a custom report 
i-Vu® Plus only 

1 Click the Reports button drop-down arrow, and then select Report Manager. 

 TIP  Click on the Display Name or ID heading to sort the column. 

2 Select the report, and then click Delete. 

3 Click OK.  

 

 

To export or import a custom report 
i-Vu® Plus only - You can export one or more reports from one system, copy them to another system, and then 
import the reports into the i-Vu® interface. 
  

To export reports 
1 Click the Reports drop-down arrow, and then select Report Manager. 

2 Click Export. 

3 Select the checkbox(es) for the report(s) that you want to export, or check Select All. 

4 Click Export. 

NOTE  A single report is exported as a .table file. Multiple reports are exported as a .zip file. 

 TIP  In the Report Manager or Export Report window, you can click on the Display Name or ID heading to sort 
the column. 
  

To import reports 
1 Copy the .table or .zip file to the computer where you are importing them. 

2 In the i-Vu® interface, click the Reports drop-down arrow, and then select Report Manager. 

3 Click Import. 

4 Browse to the file that you are importing. 

5 If a report ID that you are importing matches an existing report ID, select how you want to handle the 
situation: 
  

Rename Rename the report that you are importing. 

Replace Replace the existing report with the report you are importing. 

Skip Do not import the report with the duplicate name. 

  

6 Click Import. 
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Custom report as the source for a Graphics page 
i-Vu® Plus only — A custom report may appear in the Report Manager but not appear in the Reports button menu 
because its only purpose may be to provide data to a table, chart, or color map on a Graphics page. 

For example, this report... 

 

...supplies data to the chart and data table on this graphic 

 

 

 

To create a PDF, XLS, or CSV file 

 

These reports... Can be output as... Notes 

v7.0 custom reports • A PDF file 
• A CSV file 

 

Preconfigured reports and 
v6.5 and earlier custom reports 

• A PDF file 
• An XLS file 
• A CSV file 

For a v6.5 and earlier CVS file, you must 
enable Support CSV text format on the 
Reports > Options tab before you run the 
report. 

 

To output a file: 
1 Run a report.  

2 Click PDF, XLS, or CSV to download the file. 

NOTE To create a CSV file when using Safari, see instructions below. 
  

To create a CSV file when using Safari  
1 Run a report.  

2 Click CSV. A pop-up displays the results. 
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3 Select File > Save As. 

4 In the Format field, select Page Source. 

5 Add the .csv extension to the file name. 

6 Select the save location in the Where field. 

7 Click Save. 

8 Close the popup. 

 
NOTE  If you need a digitally signed PDF to comply with 21 CFR Part 11, open the PDF in a program that supports 
digital signing such as the Adobe® Acrobat® application, then sign the PDF. The i-Vu® application does not 
support digital signing because 21 CFR Part 11 requires that the signature be added manually, not through an 
automated process. 

 

Scheduling reports 

i-Vu® Plus only - You can schedule a report so that it runs on a recurring basis. The report is saved as a file (PDF, 
CSV, or XLS), and you can choose to have it automatically emailed to someone. 
  

NOTE  You can also use the Send E-mail alarm action (page 78) to run any i-Vu® report, generate it as a PDF, 
HTML, XLS, or CSV file, and attach it to an email.  

 

 

To schedule a report 

1 Click the Reports drop-down arrow, and then select the report that you want to schedule. 

2 Click the Schedule button. 

3 Enter the information in each field.  

 Fields Notes 

Description Enter a brief description of the report or how this schedule will be used. 

Operator The report will be run based on the selected operator's privileges. 

Run report Define when the report will run by selecting options in the drop-down lists. 

At __:__ __ Enter the time of day that you want the report to run. 

Save report as v7.0 reports can be output as a PDF or CSV file. Preconfigured reports and v6.5 
reports can also be output as an XLS file. Select the type of report file that you 
want.  
NOTE  See Output tab for a description of the PDF options that are available in the 
Report Editor. 

Keep latest Enter the number of files and Schedule History entries that you want to keep for 
this report. As a new file or entry is saved, the oldest one is deleted. 

Email report Enter the information needed to email the report each time it runs. 

NOTE  For the i-Vu® application to email a report, you must define the Email 
Server configuration on the System Settings > General tab. 

4  Click Accept. 
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NOTE  The following reports have additional scheduling options available.  Scheduling these reports without 
configuring schedule options results in an error; see View History in To manage scheduled reports (page 104). 

• Alarms > Alarms 

• Security > Location Audit Log 

• Security > System Audit Log 

See To configure scheduled Alarms and Security Reports (page 99). 

 

 

To manage scheduled reports 
Click the Reports drop-down arrow, and then select Scheduled Reports. The table shows any report that was 
scheduled on the report's page.* 
  

Select a schedule 
and then click... 

To... 

Edit  Change the report's schedule in the Schedule Editor. 
NOTE You can also double-click a schedule in the table to open the Schedule Editor. 

View History See when the report ran. Click PDF, CSV, or XLS in the Results column to download 
the report that was produced. 
NOTE  The XLS option is not available for v7.0 custom reports. 

Delete Remove the schedule. This removes its history and all associated files. 

 *  You can also access this table by going to System Options and selecting Scheduled Reports.   

 

If a report fails 
The table below will show a red X and a system alarm will be generated. 

 
Select the schedule in the table above, and then click View History. Hold the cursor over the word Failure to see 
hover text describing what failed. 

 

 

Working with legacy (v6.5 and earlier) custom reports 

i-Vu® Plus only - Although the i-Vu® Plus v7.0 application has a new method of managing reports, you can still 
create or edit the following reports that were available in i-Vu® v6.5 and earlier systems. These reports will be 
accessible from the Reports button drop-down list, but not the Report Manager. 
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This report... allows you to... 

Equipment Summary View the following information for equipment at or below the location where the 
report was created: 

• Color 
• Active alarm 
• Locked values 
• Current value of selected points 
• Combined schedule 
See To create an Equipment Summary report (page 105). 

Equipment Values Compare point information. See To create an Equipment Values report (page 
106). 

Trend Samples View trend values for a particular time frame. See To create an Trend Samples 
report (page 108). 

  
NOTE  You can schedule a report to run on a recurring basis. See Scheduling reports (page 103). 

 
 

To create an Equipment Summary report 
An Equipment Summary report can provide the following information for equipment at or below the location 
where the report is created. 
• Color 
• Active alarm 
• Locked values 
• Current value of selected points 
• Combined schedule 

  
To create an Equipment Summary report: 

1 On the navigation tree, select the location where you want to view the report. 

2 Click the Reports button drop-down arrow, then select Add Legacy Report. 

3 Select Equipment Summary. 

4 Type a name for the report. 

5 Click Create. 

6 Define the Title, Page Size and orientation, and the Maximum number of rows. 

7 Select or clear the Optional Sections checkboxes as needed. 

8 Optional:  Select Include only specific control programs at or below this location, then type the names of the 
control programs. 

9 Select Available Points that you want to include in the report. Use Ctrl+click, Shift+click, or both to select 
multiple items. 

10 Click Add. 

11 Click Accept. 

12 Click Run. 

NOTE  To run this report later, go to the location where the report was created. Click the Reports button drop-down 
arrow, select the report, then click Run. 
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To create an Equipment Values report 
An Equipment Values report allows you to compare point information. 

To create an Equipment Values report: 

1 On the navigation tree, select the location where you want to view the report. 

2 Click the Reports button drop-down arrow, then select Add Legacy Report. 

3 Select Equipment Values. 

4 Type a name for the report. 

5 Click Create. 

6 Click  next to Rows. 

7 On the selection tree, select the pieces of equipment you want to view in the report. (Use Ctrl+click, 
Shift+click, or both to select multiple items.) Then click Add. 

8 Optional: Select the Highlight alternate rows checkbox to make the report easier to analyze. 

9 Click Next or   next to Columns. 

10 Verify or change the report Title, Page units of measure for defining column widths, and Outer border 
characteristics. 

11 Select a column in the report preview.  

NOTE The selected column is light blue. 

12 Under Column Header, define how you want the column header to look. 

13 Under Column Data, define the data you want in the column and how you want it to look. See table below. 

NOTE  Select General from the Format drop-down list unless you want to define the number of places to the 
right of the decimal point for the displayed value. 

14 Optional:  Use the Add, Delete, and arrow buttons below the report preview to manipulate the columns. 

15 Optional:  Click  next to Page to change the page size and orientation. 

NOTE  Changing the size and orientation of the printed page also changes the report layout on the View tab.  

16 Click Accept. 

17 Click Run. 

NOTE  To run this report later, go to the location where the report was created. Click the Reports button drop-down 
arrow, select the report, then click Run. 
  

Type of Column Data 

Point Displays point data in the column. 

 Display Select the property to show in this column. 

 Data is named 
differently in some 
control programs 

Select this checkbox if similar points have different names in 
different control programs. Then add each of the names to the 
Name to use list. 

For example, if a point is named Zone Temp in one control 
program and Zone Temperature in different control program, add 
both names to the list. 

 Point to use Select the name of the point to show in the column.  
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Type of Column Data 

Trend Sample Display Select First, Minimum, Maximum, or Last recorded trend value. 

 Data is named 
differently in some 
control programs 

Select this checkbox if similar points have different names in 
different control programs. Then add each of the names to the 
Name to use list. 

For example, if a point is named Zone Temp in one control 
program and Zone Temperature in different control program, add 
both names to the list. 

 Trend to use Select the name of the point to show in the column. 

 Set Click to have all columns in the report use the same time range. 

 Time Range Select the time range to run the report for. 

Trend Calculation Display Select the type of calculation to show in the column, Average or 
Total. 

 Data is named 
differently in some 
control programs 

Select this checkbox if similar points have different names in 
different control programs. Then add each of the names to the 
Name to use list. 

For example, if a point is named Zone Temp in one control 
program and Zone Temperature in different control program, add 
both names to the list. 

 Trend to use Select the name of the point to show in the column. 

 Set Click to have all columns in the report use the same time range. 

 Time Range Select the time range to run the report for. 

Control Program Display Select Color, Display Name, Display Path, Notes, Prime Variable, 
or Reference Name to show in the column. 

Expression Data is named 
differently in some 
control programs 

Select this checkbox if similar points have different names in 
different control programs. Then add each of the names to the 
Name to use list. 

For example, if a point is named Zone Temp in one control 
program and Zone Temperature in different control program, add 
both names to the list. 

 Expression Type the path relative to the current control program. The path 
must return a string value. See Defining i-Vu® paths (page 175) 
for more information on paths. 

To display the Notes on an equipment's Properties page, type 
.notations in this field. 
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To create a Trend Samples report 
A Trend Samples report provides trend values for a particular time frame. 

To create a Trend Samples report: 

1 On the navigation tree, select the location where you want to view the report. 

2 Click the Reports button drop-down arrow, then select Add Legacy Report. 

3 Select Trend Samples. 

4 Type a name for the report. 

5 Click Create. 

6 Select a Time Range from the drop-down list, then refine that option by selecting an option from the drop-
down list(s) to the right. 

7 Define the trend data. 

NOTES   

○ Calculate values for missing samples calculates a value based on the 2 closest values to the time 
interval. 

○ Find the closest sample displays the value closest to the time interval selected.  

8 Optional:  Select the Highlight alternate rows checkbox to make the report easier to analyze. 

9 Click Next or  next to Columns. 

10 Verify or change the report Title, Page units of measure for defining column widths, and Outer border 
characteristics. 

11 Select a column in the report preview.  

NOTE  The selected column is light purple. 

12 Under Column Header, define how you want the column header to look. 

13 Under Column Data, select the source of the trend data and how you want the data to look. 

NOTE  Select General from the Format drop-down list unless you want to define the number of places to the 
right of the decimal point for the displayed value. 

14 Optional:  Use the Add, Delete, and arrow buttons below the report preview to manipulate the columns. 

15 Optional:  Click  next to Page to change the page size and orientation. 

NOTE  Changing the size and orientation of the printed page also changes the report layout on the View tab.  

16 Click Accept. 

17 Click Run. 

NOTE  To run this report later, go to the location where the report was created. Click the Reports button drop-down 
arrow, select the report, then click Run. 
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To save a v6.5 or earlier custom report's design 
You can save the design of an Equipment Values report or a Trend Samples report for reuse in another location. 
Or, you can create a library of different report designs to pull from as needed. 

To save a report's design 
1 Create the Equipment Values (page 106) or Trend Samples (page 108) report. 

2 On the Reports > Design tab, click the Save Report Design button.  

NOTE  The .reportdesign file includes the report name. If you save multiple report designs in your system, 
each of those reports must have a unique name. 

To use the report design at a different location in the system 
1 Select the location in the navigation tree. 

2 Select Reports > Add Legacy Report. 

3 In step 1, select Report design, then select the report name in the drop-down list. 

4 In step 2, type a report Name. 

5 In step 3, click Create. 

 

 

To edit or delete a custom report 

1 Select the item on the navigation tree where the report was created.  

2 Click the Reports button drop-down arrow, then select the report you want to edit or delete. 

3 Do one of the following on the Design tab: 

○ Edit the report, then click Accept. 

○ Click the Delete Report button, then click OK.  
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Setting up i-Vu® Open or i-Vu® XT/TruVu devices in the i-Vu® application 

These procedures differ for CCN devices. See Setting up CCN devices in the i-Vu® application (page 116). 

From the system level in the navigation tree, select Devices page > Manage tab to:   

• Search the network to populate the system with BACnet routers and controllers (page 110) 

• Upload control programs, drivers, graphics, and screen files (page 110) 

• Build, edit, and arrange the navigation tree for the User view (page 152) 

• Perform downloads to individual or multi-selected controllers (page 149)  

 

 

Find and upload routers and controllers 

1 Select the System in the navigation tree.  

2 On the Devices page > Manage tab, click Find Devices to discover your routers. 

3 Once routers are found, select one router at a time in the left-hand navigation tree and click Find Devices 
again.  

4 Once controllers are found, you must upload content from the routers and controllers. Select one or more in 
the list on the Manage tab and click Upload All Content to upload drivers, graphics, touch files, and control 
programs to the i-Vu® application. Use Ctrl+click, Shift+click, or both to select multiple items. 

NOTE  If Show Control Programs is checked, all control programs are listed. If you have multiple control 
programs in one controller, you will see every control program in the list. If it is not checked, the list only 
shows the individual controllers and their model. The same information is uploaded, this option just controls 
what you see on the Manage tab and you can switch at will.  

5 Click OK when you see the message This will upload all content for the controller. Are you sure you want to 
do this?. When complete, a check mark under Status indicates a successful upload.  

NOTES 

○  If an error message appears, click on the message to view an explanation. 

○ Uploading can be time consuming, especially for multiple controllers. You may want to create the 
navigation tree for the User view while waiting. See Create navigation tree. (page 152) 

○ The MAC address shows to the left of the controller name in the Installer navigation tree only. Controllers 
may show multiple equipment listings with the same MAC address, based on control programs 
downloaded from EquipmentBuilder or Snap. 

○ To view the driver names after uploading, select the Advanced tab or right-click the controller in the 
navigation tree and select Driver Properties or Module Status. 
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  TIPS  

• Click the i symbol   in the upper left corner to display the status of the latest operation. 

• Status messages are color coded as follows: 
○ Red - reports an error 
○ Blue - requires action 
○ Green - indicates an upload or download is in process 

 

 

Verify network and device settings 

  CAUTION  The i-Vu® application automatically assigns a BACnet Network IP number and the Server Device 
Id for the application. Do not change these addresses unless absolutely necessary!   

NOTE  If you have more than 99 routers, you must set your own addresses. 

 

To change an address: 

1 Select the system, a router, or the USB network in the navigation tree and then go to the Devices page > 
Advanced tab.  

2 Click Accept after making changes.   

 

Verify and edit the following fields only as necessary.  

System level 

○ BACnet/IP network — default is 1600 (The maximum number allowed is 65,534) 

NOTE  Typically, you should not need to change this. 

○ Server Device Id — address of the i-Vu® web server (default is 169999) 

○ Communications Time-out (in milliseconds) — increase this value only if downloads to controllers or 
routers fail with communication time-out errors.  

○ Communication Retries — default is 3 

○ Group Cache Controller — select the peer caching router. See To set up peer caching for details (page 
156). 

○ BACnet Discovery — locates all accessible BACnet networks, BACnet devices, and BACnet objects on a 
BACnet network. Typically used to integrate BACnet third-party devices into the i-Vu® system. See To 
discover third-party BACnet networks, devices, and objects (page 129). 
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Router level  

○ Router to Arcnet network and Auto-Assign 

○ Router to MS/TP network and Auto-Assign 

○ Device Identifier  

 

USB Network  

○ Baud Rate - recommended rate is 76,800 

○ Router to Network 

 

 

Working with control programs 

In the navigation tree, you can double-click the controller, or right-click and select Configure, then select one of 
the following options: 

• Edit Exisiting - Downloads files to your computer for programmable controllers to edit in Snap or 
EquipmentBuilder  

• Add New - Obtains files for the i-Vu® application to add to a blank controller or to replace an existing control 
program 

• Delete Unused - Deletes unused control programs  

 

Update - Go to System Options > Update tab to install .update files or to update the SAL library version. See 
Update the equipment library (page 163) for complete instructions. 

You can use EquipmentBuilder or Snap to create your control programs (.equipment files). 

• EquipmentBuilder can also produce a graphic (.view file), screen file, and a sequence of operation, based on 
the equipment options you select.   

• If using Snap, you must create your graphics separately in ViewBuilder. See Snap Help for detailed 
instructions on creating a custom control program. 

After creating your control program, load it into i-Vu® and download it into the controller. See Add or delete a 
custom control program to a controller and to i-Vu® (page 114).  

 

 

 

Reload, create, or edit a control program in EquipmentBuilder or Snap 
If the control program has already been uploaded to the i-Vu® application and loaded into the programmable 
controller, you must save it to your computer to be able to edit it in EquipmentBuilder or Snap.  

To reload a control program 
In the navigation tree, right-click the controller and select Reload Control Program. Reloading updates all 
instances of a control program throughout the system and marks the controller(s) for an All Content download. 
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To create your control program in EquipmentBuilder 
1 Start EquipmentBuilder. (Windows Start > All Programs > i-Vu Tools x.x) 

2 Click Create Equipment and then click Next. 

3 Select the .sal library from the Library: drop-down list.   

4 Select the equipment type from the list and click Next. 

5 In the Equipment Name field, edit the name, if desired. 

NOTE  Your name must not exceed 21 characters. 

6 Select options on the Summary tab and, if applicable, edit setpoints on the Sequence tab. 

NOTE  The Points and Sequence tabs change based on your choices on the Summary tab. 

7 Click Next. 

8 Check the files you wish to generate from the list. 

9 Check to select saving your control program files to a folder of your choice or a folder linked to a system. 

10 Click Next. 

 

To save the control program you want to edit 

1 Double-click the programmable controller in the navigation tree, or right-click and select Configure.  

2 Select the control program you want to edit in the Control Program drop-down list. 

3 Click Edit Existing in the Control Programs box. A new dialog window appears. 

4 Save the file to a location of your choice. 

5 Click Close. 

 

To edit the control program in EquipmentBuilder or Snap. 

1 Click Windows Start < All Programs > i-Vu Tools x.x > EquipmentBuilder or Snap. 

2 In EquipmentBuilder, click Open Equipment or, in Snap, select File > Open. 

3 Open the .equipment file that you saved and edit it. 

4 Save your revised control program with a different name. 

5 Open the i-Vu® application. 

6 Double-click the programmable controller in the navigation tree, or right-click and select Configure. 

7 Click Add New in the Control Programs box. A new dialog window appears. 

8 Browse to your edited control program and click Continue. When message appears File added successfully, 
click Close. 

9 Click Close again. 

NOTE  If you change a control program in the Snap application and it does not display correctly in the i-Vu® 
interface, Ctrl+right-click the i-Vu® action pane, and then select Refresh. 
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Apply these changes to the controllers 
1 Select the router in the navigation tree. 

2 On the Devices page > Manage tab, select any controllers with a File Mismatch error message. (CTRL+click 
or Shift-click to multi-select.) 

3 Right-click and select Download All Content. You now have the updated control programs, graphics, drivers, 
and screen files in your routers and controllers. 

 

To change the control program for all controllers of one type when adding new controllers 
1 Select the Devices page > Manage tab 

2 To upload one or more controller's graphics, screen files, and control programs, select one or more controller 
(Shift-click or enable Select all) and click the Upload button. 

 

To change the control program for all controllers of one type when updating the current library 
See Update the equipment library (page 163). 

NOTE  If you change a control program and it does not display correctly in the i-Vu® interface, Ctrl+right-click the i-
Vu® action pane, and then select Refresh. 

 

 

Add or delete a custom control program 
To save time when testing custom control programs, you can use DEBUG MODE (page 174) in the i-Vu® interface 
for one controller at a time. 

  CAUTION  Never leave your i-Vu® system without unchecking DEBUG MODE first and and then downloading 
all content. The source files are not in the controller until you complete both steps.  

To add a new control program to a programmable controller 
1 Select the router in the navigation tree. 

2 Select Devices > Manage tab. 

3 Select the controller in the list on the page. 

4 If you are adding a new control program, click the Add Control Program button . A dialog 
window appears. 

5 Enter a name for your control program in Display Name and select your controller in the Controller drop-down 
list. 

NOTES 

○ If you already have the maximum number of control programs for a controller, it will not appear in the 
list.  

○ Optional:  You can change the control program's Reference Name if needed. 
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6 Do one of the following: 
  

If the control program is...  

In the Control Program drop-down list Select the control program. 

Not in the Control Program drop-down list a.  Click Add New. 

b.  Browse to select the control program. 

c.  Click Open. 

d.  Click Continue. 

e.  Click Close. 

 

7 To upload a graphic, click Add New under Views and browse to your .view file. 

8 Click Continue. When message appears File added successfully, click Close. 

9 Click Close again. 

10 Right-click on the programmable controller in the controller list and select Check Status from the list. The 
status of the controller should say File Mismatch. 

11 Click the Download All Content (page 149) button.  

 

NOTE  If you need to edit the Object Instance, right-click the control program in the navigation tree and then select 
Configure. Click  next to the field for additional information. 
 

To delete a single control program in a programmable controller 
1 Select the router in the navigation tree. 

2 Right-click the the desired controller/control program in the list on the Devices page > Manage tab and click 
Delete Selected from the list.  

3 The message appears Do you wish to remove a controller and all its descendants? Click OK. 

IMPORTANT!  The process is not finished until you complete the following steps. 

4 Highlight the programmable controller in the controller list again, and select Check Status. The status of the 
controller should say File Mismatch. 

5 Click File Mismatch and click the Download button. This deletes the files from the controller. 
 

To delete all control programs in a programmable controller 
1 Select the router in the navigation tree. 

2 Right-click the desired controller/control program in the list on the Devices page > Manage tab and select 
Delete Programs. Click OK when the following message appears This will delete all programs in this 
controller. Are you sure? 

IMPORTANT!  The process is not finished until you complete the following steps. 

3 Highlight the programmable controller in the controller list again, and select Check Status. The status of the 
controller should say File Mismatch. 

4 Click File Mismatch and click the Download button. This deletes the files from the controller. 
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To edit a control program on an i-Vu® Pro client 
On an i-Vu® client, you can get a copy of a control program from the server, edit it, then put it back on the server. 

To get the control program 
1 In the navigation tree, right-click the equipment, then select Configure. 

2 In the Control Programs section, click Edit Existing. 

3 Click Save. 

4 Browse to the folder you want to put the file in. 

5 Click Save. 

6 Click Close. 

7 Click Close again. 
  

To put the edited control program back on the server 
1 In the navigation tree, right-click the equipment, then select Configure. 

2 In the Control Programs section, click Add New. 

3 Browse to select the control program. 

4 Click Open. 

5 Click Continue. 

6 Click Close. 

7 Click Close again. 

 

 

Setting up CCN devices in the i-Vu® application 

Connect to the Gateway on the Devices > CCN Setup tab. 

Select the Gateway in the navigation tree > Devices > CCN Discovery tab to: 

• Scan the network to populate the system with CCN device managers and controllers (page 117) 

• Download control programs, drivers, graphics and BACview files (page 117) 

• Build, edit, and arrange the navigation tree for the User view (page 152) 

• Perform downloads to individual or multi-selected controllers (page 149)  

 

NOTES 

• On the System Options > General tab, you can check to Use metric units for CCN tables and control 
programs.  

•  You must use Network Service Tool to change addresses. 
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To find and download CCN devices 
If you are using: 

• A Carrier® ChillerVu™ as a CCN device, follow all of the steps on this page  

• An i-Vu® CCN Router or i-Vu® Link, start with Connect to a CCN system 

 

Connect to a Carrier® ChillerVu™ 

1 In the navigation tree, from the system level, go to the Devices page > Manage tab.   

2 Click Find Devices. 

3 Select the Carrier® ChillerVu™ in the list on the Manage tab and click Upload All Content.  

4 You must set the Carrier® ChillerVu™ to be the Gateway or Bridge.  

a) Right-click the router, select Driver Properties.  

b) Expand Protocols and select CCN.  

c) Select the correct baud from drop-down list.  

d) If it is the Gateway, select CCN Gateway for Device Type. If it is a Bridge, select CCN Bridge. 

e) Fill in Element number. 

5 Continue with the steps below.  

 

Connect to a CCN system 

1 In the i-Vu® interface, select the system in the navigation tree. 

2 On the Devices page > CCN Setup tab, enter your CCN Gateway IP address and click Connect to Gateway.  

NOTE  If the server has more than 1 NIC, type the IP address the server will use to connect to controllers. 

3 After connecting to the Gateway, select it in the navigation tree.  

4 On the Devices page > CCN Discovery tab, verify that Discover Tables is checked.  

NOTE  The scanning time for discovering tables increases based on the number of devices. You may choose 
to discover tables at a later time for a faster scan. 

5 Enter the Bus and Element ranges that encompass all your devices.  

NOTE  Depending on your number of devices, it could be faster to scan several small ranges.   

6 Click Start Scan. When the process is complete, a message appears showing the number of control programs 
found.  

NOTES 

○ If the scan does not begin, wait a minute and try again. There may be a delay when first starting the 
system. 

○ If an error message appears, click on the message to view an explanation. 

7 Click Download CCN to download the control programs, drivers, and parameters. 

NOTE  This process can be time consuming. While waiting, you may want to create the navigation tree for the 
User view. See Create navigation tree. (page 152) 

8 If you have programmable controllers and want to add a .equipment file made in EquipmentBuilder or Snap, 
see Assign and download a custom equipment file (page 118).  
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TIPS  

•  indicates you need to download the device by clicking Download CCN. 

• Click  to view a log of activity on the Devices page in the current session. Copy to Clipboard lets you copy 
the text to paste it into another application. 

• Status messages are color coded as follows: 

○ Red - reports an error 

○ Blue - requires action 

○ Green - indicates an upload or download is in process 

 

 

To assign and download a custom CCN equipment file 
To add a custom control program to the list of available programs: 

1 In the i-Vu® navigation tree, right-click the controller you want to associate the equipment or control program 
with. 

2 Either double-click the controller in the navigation tree, or right-click and select Configure in the list. 

3 Enter the Display Name. 

4 To add a control program to the list of possible .equipment files in i-Vu®, do one of the following: 

 

If the control program is...  

In the Control Program drop-down list a.  Select the control program that you generated in 
EquipmentBuilder or Snap. 

b.  Click Accept. 

Not in the Control Program drop-down list a.  Click Add New. 

b.  Browse to select the equipment file. 

c.  Click Open. 

d.  Click Continue. 

e.  Click Close. 

f.  Click Close again. 
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5 To add a graphic, do one of the following: 

  

If the graphic is...  

In the Views Available list a.  Select the graphic, then click Attach. 

b.  Click Accept. 

Not in the Views Available list a.  Click Add New. 

b.  Browse to select the view file. 

c.  Click Open. 

d.  Click Continue. 

e.  Click Close. 

f.  Click Close again. 

 

6 When finished, select the Gateway in the navigation tree and select the Devices page. 

7 Click Download CCN to finalize your changes. 

 

For additional pieces of equipment controlled by your Universal Controller/Comfort Controller 
(expansion controllers)  
1 In the navigation tree, select the device manager that the controller is associated with. 

2 Select the Devices page and click Add Control Program. 

3 Enter the Display Name. 

4 Select the controller or Gateway that you want to associate the new equipment with. If you select CCN 
Controller, enter the Bus and Element number of the controller.    

5 Do one of the following: 

 

If the control program is...  

In the Control Program drop-down list a.  Select the control program that you generated in 
EquipmentBuilder. 

b.  Click Accept. 

Not in the Control Program drop-down list a.  Click Add New. 

b.  Browse to select the view file. 

c.  Click Open. 

d.  Click Continue. 

e.  Click Close. 

f.  Click Close again. 

 

6 Add a graphic or, if finished, select the Gateway in the navigation tree and, on the Devices page, click 
Download CCN to finalize your changes. 
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7 To add a graphic, do one of the following: 

  

If the graphic is...  

In the Views Available list a.  Select the graphic. 

b.  Click Accept. 

Not in the Views Available list a.  Click Add New. 

b.  Browse to select the view file. 

c.  Click Open. 

d.  Click Continue. 

e.  Click Close. 

f.  Click Close again. 

 

8 When finished, select the Gateway in the navigation tree and, on the Devices page, click Download CCN to 
finalize your changes. 

 

 

To view an equipment's CCN tables 

1 In the navigation tree, select the equipment. 

2 Click  next to the equipment to expand it.  

3 Select the table you want to view. 

 

 

Working with Universal and Comfort Controllers (CCN) 
Universal Controllers (UC) and Comfort Controllers (CC) are assigned a generic equipment and view file, which 
have setpoint control, but no additional pre-mapped I/O. To generate additional I/O points for graphic display, you 
must use EquipmentBuilder to create custom equipment files that support your application. These files map the 
CCN variables to i-Vu® BACnet points. 

In EquipmentBuilder, you can create CCN Values Only, Read Integration, or Link Integration custom equipment 
for UC/CC's that are tailored for your specific application. 

EquipmentBuilder can also create some stand-alone applications for Consumable Reports for: 

• Energy Meters 

• Non-linear flow meters 

• Energy (BTU) consumption 

• Equipment Runtime 

NOTE  You can add these options to CCN Values Only and Link Integration custom equipment and require 
mapping just the points to be monitored. 

Once the equipment files and the view file are added to a device in the i-Vu® interface (page 118), you can assign 
these points to custom graphic elements created in ViewBuilder.  
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Because CC’s will likely control multiple pieces of HVAC equipment, expansion controllers associated with CC’s 
must be added to the i-Vu® Devices page (select the Gateway in the navigation tree.) You can control separate 
setpoints and schedules for multiple physical equipments from a single CC. The expansion controllers support the 
additional equipment and view files required for these systems. 

 

 

Create custom equipment files in EquipmentBuilder for UC/CC's that link only to CNN points 
You create an equipment file in EquipmentBuilder for the UC/CC, which maps the I/O points required for one or 
more applications. Once you have created the files, you can associate the linked I/O points with ViewBuilder 
graphics.  

NOTE  To have a Prime Variable, (a temperature displayed in a color oval when the UC/CC is shown in a site or 
area equipment list), you must select the Schedule and Setpoint option when creating the equipment file.  

 

1 Start EquipmentBuilder. (Windows Start > All Programs > i-Vu_Tools_x.x) 

2 Click Create Equipment. 

3 Select i-Vu EquipmentBuilder SAL from the Library drop-down list. 

4 Select equipment type: Custom Equipment > CCN Values Only. 

5 Click Next. 

6 In Equipment Name, type a name for the custom equipment (i.e., Hot Water system). 

7 Enable English or Metric units. 

8 Select options from the drop-down lists. 

9 Select Schedule and Setpoint in the first drop-down list to use the setpoint slidebar graphic in the i-Vu® 
interface and to have a Prime Variable (a temperature displayed in a color oval when the UC/CC is shown in a 
site or area equipment list).  

10 Click Next. 

11 Choose the type of element, quantity, and click  . 

 

Add Elements to your application  
NOTE   Elements are a collection of input/output points that perform a specific operation. The input/output 
point that is reading or writing to the UC/CC is called a CCN point.  

The available Elements that you can add to your custom equipment in EquipmentBuilder are: 

 

Point type Used for 

Read CCN Point Reading an analog or binary value from the UC/CC 

Carrier Text Point Reading a text string from the UC/CC 

Analog - Setpoint Write  Reading and writing individual variables 

Demand Limit Load to Shed !/O points for Demand Limiting 
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1 As you add Elements, enter the requested information for the CCN points: 

○ Display Text - the description of the point as it appears in the i-Vu® interface (i.e., Pump status) 

○ Reference Base - the name of the point used when linking the point to a graphic element. All points have 
a unique identifier (i.e.,input_pumpstat, trendPumpstat) 

○ Input Address - enter the CCN path to link to this point. In the i-Vu® interface, all CCN tables have a Copy 
Path symbol  at the far right of the display. Clicking on this symbol places a copy of the path on the 
clipboard. In EquipmentBuilder, paste the path into the Input Address field, using Ctrl+v. 

2 When you are finished adding Elements for your application, click Next. 

3 Type a new Equipment Name, if desired. 

4 In Save Location, browse to a location where you would like to save the new custom equipment. 

5 Click Save. 

 

Custom graphic 
Use ViewBuilder to edit the graphic. 

 

 

Map to Point procedures for the UC/CC 
I/O Points that are included in a custom equipment file are automatically mapped to their associated CCN points 
once the file is downloaded in the i-Vu® application. The following procedure is not required for those points.  

This procedure is necessary to map associated points with the Setpoint Support option:   

1 In the navigation tree, select the UC/CC and click + to expand tables. 

2 Click + next to the table headings (Setpoint, Status Display, Maintenance, etc.) to see additional tables.  

3 Select the table you want. 

4 Click the drop-down list under Map to Point in the far right column and select the variable to be mapped.  

NOTE  Not Mapped erases any previously selected information. 

5 Click Accept. The Map to Point entry changes to the mapped point's description. 

 

 

Create custom equipment files for UC/CC's that link to TPI points 
You create an equipment file In EquipmentBuilder for the UC/CC, which maps the I/O points required for one or 
more applications. In this type of equipment, you can link CCN to TPI points in a UC/CC.  Once you have created 
the files, you can associate the linked I/O points with ViewBuilder graphics.  

NOTE  To have a Prime Variable, (a temperature displayed in a color oval when the UC/CC is shown in a site or 
area equipment list), that comes from a TPI point, you must select the Link to Third Party to Prime Variable option 
when creating the equipment file. You must not select he Schedule and Setpoint option for this equipment.  

 

1 Start EquipmentBuilder. (Windows Start > All Programs > i-Vu Tools x.x) 

2 Click Create Equipment. 

3 Select i-Vu ApplicationBuilder. 
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4 Select equipment type: Custom Equipment > CCN Link Integration. 

5 Click Next. 

6 In Equipment Name, type a name for the custom equipment (i.e., Hot Water system). 

7 Select options from the drop down menus. 

8 Click Next. 

9 Choose the type of element, quantity and click the  . 

 

Add Elements to your application  
NOTE   Elements are a collection of input/output points that perform a specific operation. The input/output 
point that is reading or writing to the UC/CC is called a CCN point.  

The available Elements that you can add to your custom equipment in EquipmentBuilder are: 

 

Point type Used for 

Read CCN Point Reading an analog or binary value from the UC/CC 
 

Read Integration Point Reading an analog or binary value from a TPI 
 

Carrier Text Point Read a text string from the UC/CC 
 

Analog - Setpoint Write Reading and writing individual variables 
 

Analog - Link CCN to Integration Writes CCN variables to TPI 
 

Analog – Link Integration to CCN Writes TPI variables to CCN 
 

Analog – Link CCN Passive to Integration Writes CCN variables to TPI 
 

Analog – Link Integration to CCN Passive Writes TPI variables to CCN 
 

Analog – BACnet Value to CCN Writes BACnet variable to CCN 
 

Analog - CCN to Integration Setpoint Write 
 

Writes CCN to TPI setpoint 

Analog - Manual TPI output/setpoint 
 

Manual control from UI to TPI/CCN 

Demand Limit Load to Shed 
 

I/O points for Demand Limiting 

Binary – Link CCN to Integration Writes CCN variables to TPI 
 

Binary – Link Integration to CCN Writes TPI variables to CCN 
 

Binary – Link CCN Passive to Integration Writes CCN variables to TPI 
 

Binary – Link Integration to CCN Passive Writes TPI variables to CCN 
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Point type Used for 

Binary – Link BACnet Value to CCN Writes BACnet variable to CCN 
 

Binary - Manual Control 
 

Manual Control from UI to TPI/CCN 

Binary - Time Manual Control 
 

Delay on Make Control 

 

1 As you add Elements, enter the requested information for the CCN or TPI points: 

○ Display Text - the description of the point as it appears in the i-Vu® interface (i.e., Pump status) 

○ Reference Base - the name of the point which is used when linking the point to a graphic element. All 
points have a unique identifier (i.e.,input_pumpstat, trendPumpstat) 

○ Input Address - enter the CCN path to link to this point. In the i-Vu® interface, all CCN tables will have a 
Copy Path symbol  at the far right of the display. Click on this symbol to place a copy of the path on 
the clipboard. In EquipmentBuilder, paste the path into the Input Address field, using Ctrl+v. 

2 When you are finished adding Elements for your application, click Next. 

3 Type a new Equipment Name, if desired. 

4 In Save Location - browse to a location where you would like to save the new custom equipment. 

5 Click Save. 

 

Custom graphic 
Use ViewBuilder to edit the graphic. 

 

 

Create stand-alone applications 
In EquipmentBuilder,  you can create some pre-engineered, stand-alone equipment applications with a view for 
Consumable Reports for Energy Meters (electric, gas, water, steam, generic), non-linear flow meters, energy (BTU) 
consumption, and equipment runtime.   

These options can be added to CCN Values Only and Link Integration custom equipments. Mapping the points 
allows monitoring.   

NOTES  

• 1 meter and 1 Runtime may be added to equipment. 

• There is an application for a CCN Vertical Pack unit. This is a CC with special software and BEST++. While this 
controller can be discovered in the i-Vu® application in CCN Setup as a Vertical Pack, none of the possible 
selected options can be auto-discovered, so only a base view is generated. This application allows your to 
generate a correct equipment and view file, based on the selected options. 
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Working with Terminal System Managers 
A Terminal System Manager (TSM) that is scanned into the system is assigned an auto-generated equipment that 
represents Group 1 in the TSM. Group 1 is the default group which can control the setpoints and occupancy for all 
of the existing zones, or up to 16 specifically selected zones. This equipment is pre-mapped and requires no 
further action. 

All other Groups or Zone equipment must be added as expansion equipments. You must use EquipmentBuilder to 
create the necessary additional Group or Zone equipment files. These files map the CCN variables to i-Vu® 
BACnet points and replace the default equipment in the expansion equipments that have been added for the 
additional Groups or Zones. 

Once the equipment files are created and uploaded to the i-Vu® application, these points can be assigned to 
custom graphic elements, which you create in ViewBuilder. 

Expansion equipment associated with a TSM must be added to the i-Vu® application on the Devices page to 
support additional Groups and Zones. You must create separate equipment and view files in EquipmentBuilder for 
each expansion equipment.  

Important points when setting up your TSM in the i-Vu® application  

• You must add each group or zone as a new equipment.  

• TSM’s can only be on Bus 0. 

• Only the Gateway can be Bus 0. 

• The Gateway can support 140 devices and 200 equipments 

• A fully utilized TSM (12 Groups/64 Zones) takes 76 equipment files. 

NOTE  If you have 2 TSM’s with 8 Groups and 37 Zones in each, it takes 45 equipment files for each TSM, or 
a total of 90 equipment files from a possible 200. This allows another 110 equipments for every other 
controller on Bus 0. 

 

 

Create custom equipment files in EquipmentBuilder for Terminal System Managers (TSM) 
EquipmentBuilder creates .equipment and .view files for the TSM temperature zones and control groups. The 
.equipment file contains points that you finish formatting in the i-Vu® interface after uploading. 

You specify the air source(s) that the TSM communicates with by configuring its Linkage function. A system can 
consist either of 1 TSM communicating with 1 to 4 air sources, or 1 to 4 TSM's communicating with a single air 
source. 

 

1 Start EquipmentBuilder. (Windows Start > All Programs > i-Vu_Tools_x.x) 

2 Click Create Equipment. 

3 Select your equipment type:  

○ TSM II Plus Group 

○ TSM II Plus Zone 

○ TSM II Group 

○ TSM II Zone 

4 Click Next. 

5 In Equipment Name, type a name for the custom equipment (i.e., Hot Water system).  

6 Enable English or Metric units. 
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7 Click Next. 

8 Check the files that you want to generate. 

9 Browse to the desired location to store your files and click Open. 

10 Click Next. 

11 Click Save. 

12 Click Exit to close or Start Over to create another equipment file. 

 

Custom graphic 
Use ViewBuilder to edit the graphic or make a custom graphic. 

 

 

Assign and download a TSM equipment file in the i-Vu® application 
When you scan equipment in the i-Vu® application, each TSM is assigned Group 1. You must: 

• Add a new separate equipment for each additional zone and group that you want a graphic for 

• Create the .equipment file for each in EquipmentBuilder 

• Upload the .equipment and .view file for the new equipment that was added in the i-Vu® application   

The group or zone that you create in EquipmentBuilder contains setpoint support, schedules, and a Group or 
Zone's points configuration. The CCN path information is automatically configured, however, it is incomplete and 
you must use a Search and Replace function to exchange the generic Groups or Zones for your specific Group or 
Zone number.  

To upload an equipment file to a TSM Group or Zone that is already present in the i-Vu® application 
1 Either double-click the controller in the navigation tree, or right-click and select Configure in the list. 

2 Enter the Display Name. 

3 To add a control program to the list of possible .equipment files in i-Vu®, do one of the following: 

 

If the control program is...  

In the Control Program drop-down list a.  Select the control program that you generated in 
EquipmentBuilder or Snap. 

b.  Click Accept. 

Not in the Control Program drop-down list a.  Click Add New. 

b.  Browse to select the equipment file. 

c.  Click Open. 

d.  Click Continue. 

e.  Click Close. 

f.  Click Close again. 
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4 To add a graphic, do one of the following: 

  

If the graphic is...  

In the Views Available list a.  Select the graphic, then click Attach. 

b.  Click Accept. 

Not in the Views Available list a.  Click Add New. 

b.  Browse to select the view file. 

c.  Click Open. 

d.  Click Continue. 

e.  Click Close. 

f.  Click Close again. 

 

5 When finished, select the Gateway in the navigation tree and select the Devices page. 

6 Click Download CCN to finalize your changes. 

 

To add expansion equipment for additional groups and zones controlled by your TSM (expansion 
controllers) 
1 In the navigation tree, select the device manager that the controller is associated with. 

2 Select the Devices page and click Add Control Program. 

3 Enter the Display Name. 

4 Select the controller or Gateway that you want to associate the new equipment with. If you select CCN 
Controller, enter the Bus and Element number of the controller.    

5 Do one of the following: 

 

If the control program is...  

In the Control Program drop-down list a.  Select the control program that you generated in 
EquipmentBuilder. 

b.  Click Accept. 

Not in the Control Program drop-down list a.  Click Add New. 

b.  Browse to select the view file. 

c.  Click Open. 

d.  Click Continue. 

e.  Click Close. 

f.  Click Close again. 

 

6 Add a graphic or, if finished, select the Gateway in the navigation tree and, on the Devices page, click 
Download CCN to finalize your changes. 
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7 To add a graphic, do one of the following: 

  

If the graphic is...  

In the Views Available list a.  Select the graphic. 

b.  Click Accept. 

Not in the Views Available list a.  Click Add New. 

b.  Browse to select the view file. 

c.  Click Open. 

d.  Click Continue. 

e.  Click Close. 

f.  Click Close again. 

 

8 When finished, select the Gateway in the navigation tree and, on the Devices page, click Download CCN to 
finalize your changes. 

 

 

Configure the path to the source of the point for TSM Groups and Zones 
A generic list of points is created in the i-Vu® application when the TSM Group or Zone is scanned into the system 
or when you upload the .equipment file.  

You must initially revise the address of the path for every point!  

1 Select the TSM Group or Zone in the navigation tree, then click Properties > Network Points tab. 

2 To substitute the correct Group or Zone number where the double X (XX) is in each path, click the 
Search/Replace button under the Address column. 

3 Enter "XX" in the Search field and enter the appropriate Zone or Group number in the Replace field. This 
updates all of the paths for that Zone or Group. 

 

IMPORTANT! 

TSM Zone 1 requires an extra step because 1 point has a slightly different name than in Zones 2 thru 64. The 
setpoint offset point in Zone 1 is inadvertently named STPOFF, while it is named SPTOFF in the remaining Zones. 

This causes an error because the point is incorrectly mapped in the template for Zone 1, even though it is 
correctly mapped for Zones 2 through 64. 

You must change SPTOFF to STPOFF for this one zone! 

Example:  

CCN://LINK/TZDSP01/SPTOFFST must be changed to CCN://LINK/TZDSP01/STPOFFST. 
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Integrating third-party data into the i-Vu® v7.0 system 

This feature not available in the i-Vu® Standard application. 

You can integrate third-party devices into the i-Vu® Plus system if the following are true: 
• The third-party devices are physically connected on the i-Vu® Plus system’s network 
• You have a Carrier controller that supports third-party integration 
• You have the correct Carrier driver for the third-party protocol 
• You have enabled a port for a third-party protocol on the Carrier controller’s driver page 

  
To read from or write to a third-party device, you need the following information from the third-party vendor: 
• Protocol 
• Third-party device’s network address 
• Memory location of the object in the device you want to read from or write to 
If you are integrating with BACnet devices, you can use the i-Vu® Plus BACnet Discovery (page 129) feature to 
gather this information. 
  

Before you begin a third-party integration, study the Carrier controller’s Installation and Start-up Guides and the 
third-party protocol’s Integration Guide. Both are available on the Carrier website. 
  

The following Carrier routers let you integrate the allowed number of third-party points into your i-Vu® Plus system: 

This router... 

i-Vu® Link   

i-Vu® Open Link 

Carrier® ChillerVu™ 

i-Vu® XT BACnet Link 

Allows this number of non-BACnet third-party points... 

500  

500 

1000 

1500 

   
NOTE  The point allowance of a router that provides third-party points applies to only itself. For example, if you 
purchase an i-Vu® Open Link and download control programs that use 125 third-party Network I/O points, you 
cannot apply the unused 125 points to a different router.   
 
 

To discover third party BACnet networks, devices, and objects 
The i-Vu® BACnet Discovery feature locates all accessible BACnet networks, BACnet devices, and BACnet objects 
(including devices in your i-Vu® system) on a BACnet network. The information gathered in this process is typically 
used to integrate third-party BACnet devices and their BACnet objects into the i-Vu® system. 

 

To use BACnet Discovery: 

1 Select the System  in the navigation tree and then the Devices page > Advanced tab.  

2 Click the BACnet Discovery Start button to discover BACnet sites for the system. An item called Discovered 
Networks appears in the tree. After all sites are found, close the status dialog box. 

3 To discover BACnet networks, select Discovered Networks, then click Go. A list of all BACnet networks 
appears in the navigation tree. After all networks are found, close the status dialog box. 

 TIP  Run a commstat manual command to determine which device routes to each network. The BACnet 
Bind Show Network section of the Commstat window shows the IP address of the router to each network.   
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4 To discover BACnet devices on a network, select a network in the navigation tree, then click Go. After all 
devices are found, close the status dialog box. Click  beside an item to expand the list of devices.  

5 To discover BACnet objects on a device, select the device on the navigation tree, then click Go. After all 
objects are found, close the status dialog box. A list of all BACnet objects in this device appears on the 
navigation tree.  

 TIP  Make sure you are discovering objects in the correct device. It may take some time to discover 
objects in devices with more than 100 objects. 

6 Optional:  Do the following to export the BACnet information so that it can be used in the Snap application: 

a) On the navigation tree, select a discovered network with devices or a single device. 

b) Click Export. 

c) Name and save the .discovery file in any folder. 

 

NOTES 

• Some third-party BACnet devices may not be discovered because they do not support the BACnet methods 
required for auto discovery. 

• If the discovery process returns ambiguous information, such as multiple points with similar names, contact 
the third-party manufacturer's representative for clarification. 

• Device configuration or network load can prevent the i-Vu® interface from showing all BACnet devices. If you 
do not see a BACnet device that you expect to see, check the system's BBMD configurations. If the 
configurations are correct, try the discovery process again. 

 

 

To determine the number of third-party points used in a controller 

i-Vu® Pro application only - SiteBuilder 
Right-click the controller on the Network tree, then select Run Point Count. 
  

In the i-Vu® application 
1 On the navigation tree, right-click the controller.                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  

2 Select Driver Properties > Properties page > Settings tab, and then scroll to the bottom of the page. 

3 Number of integration points requested and Number of integration points active show how many non-
BACnet third-party Network I/O microblocks the controller is using. These two counts will differ if you exceed 
the product's integration point limits. For example, if your control program includes 27 Modbus points, your 
Integration points requested will be 27 and your Integration points active will be 25. 
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To configure LonWorks points using the LonWorks Integration Tool 

1 Log in to the i-Vu® application. 

2 Double-click the third party controller in the navigation tree. A dialog window appears. 

3 Click Export.erl under Integration Points. 

4 Click Save. 

5 Browse to a location on your computer to save the file. (The file will have a .erl extension.) 

6 Start the LonWorks Integration Tool (Lonworks_Integration_Tool.jar).  

7 Click  to start the wizard 

8 Follow the wizard's instructions to create your LonWorks addresses. 

9 Click  to save the file to your PC. (The file will be saved with a .erl extension.) 

10 Return to i-Vu®.  

11 In the navigation tree, double-click the i-Vu® to open the Configure dialog box. 

12 Navigate to Integration Points at the bottom of the screen and click Import .erl. 

13 Browse to the .erl file that you saved in the LonWorks Integration Tool. 

14 Click Open and then Continue to upload the file. 

15 Click Close. The LonWorks addresses are now set. 

 

 

Configuring your system 

Work with controllers, set up Linkage, and perform Test and Balance 
Refer to your individual controller's Installation and Start-up Guide for detailed explanations and procedures on 
configuration, sequence of operation, and Linkage. 

 

 

i-Vu® network connection options and requirements 
You can use any of the following common network configurations (see below for details): 

• Option 1 - Connect directly from a computer to the i-Vu® web server 

• Option 2 - Connect to the Intranet for internal network access only 

• Option 3 - Connect to the Internet through the Intranet for both internal and external access 

• Option 4 - Connect to the Internet through a dedicated broadband account 
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Option 1 - Connect directly from a computer to the i-Vu® web server 

 
Requirements: 

• Windows-based computer with supported web browser and available Ethernet port 

• LAN Cable (either straight or crossover) 

Email Options - None 

 

Option 2 - Connect to a LAN for internal network access only 

 
Requirements: 

• Windows-based computer with supported web browser and Ethernet port 

• Access to Ethernet LAN 

• For i-Vu® Standard and Plus systems, you need a (DHCP or static) IP address for each of the following: 

○ One IP address for the i-Vu® web server (required) 

○ One IP address for the i-Vu® web server's internal router (optional) 

○ One IP address for each external i-Vu® router (if applicable) 

Email Options - Email can be sent from a local or an Internet mail server if network policies allow this. 
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Option 3 - Connect to the Internet through an Intranet for both internal and external access 

 
 

Requirements: 

• Windows-based computer with supported web browser and Ethernet port 

• Access to Ethernet LAN 

• For i-Vu® Standard and Plus systems, you need a (DHCP or static) IP address for each of the following: 

○ One IP address for the i-Vu® web server (required) 

○ One IP address for the i-Vu® web server's internal router (optional) 

○ One IP address for each external i-Vu® router (if applicable) 

• Internet IP address provided by the site’s IT personnel 

• Open firewall port for HTTP/HTTPS traffic to the i-Vu® web server's IP address (default is port 80/443 
respectively) 

Email Options - Email can be sent from both Internet and Intranet mail servers. To send email off of the LAN, the 
DNS and domain field must be properly configured in the i-Vu® web server. 

 



Setting up devices in the i-Vu® application  
 

 

 
 

i-Vu® Standard/Plus v7.0  CARRIER CORPORATION ©2020   
Help  All rights reserved 
 134 

 

Option 4 - Connect to the Internet through a dedicated broadband account 

 

 
• Window-based computer with supported web browser and Ethernet port 

• Broadband Internet connection (internet IP address provided by the Internet Service Provider) 

• IP router (w/Integrated Switch if computer or external i-Vu® routers will be used) 

• For i-Vu® Standard and Plus systems, you need a (DHCP or static) IP address for each of the following: 

○ One IP address for the i-Vu® web server (required) 

○ One IP address for the i-Vu® web server's internal router (optional) 

○ One IP address for each external i-Vu® router (if applicable) 

• Open firewall port for HTTP/HTTPS traffic to the i-Vu® web server's IP address (default is port 80/443 
respectively) 

Email Options - Email can be sent from a local or an Internet mail server if network policies allow this. 
 
 

Network security 
Your i-Vu® building automation system's controllers and server should be as secure as possible. However, 
achieving this security can be challenging because of the complexities of networks, firewalls, and virtual private 
networks (VPN's).  

While the i-Vu® server was designed to be secure, BACnet is an open protocol that can pose risks for the 
controllers. The most secure system is one that is completely isolated from the Internet, but that is not always 
possible. The v6-02 or later drivers for Carrier controllers with Ethernet capability have a BACnet firewall feature 
that allows you to restrict communication with the controller to all private IP addresses and/or to a whitelist of IP 
addresses that you define. To set this up, go to the navigation tree > right-click the router > Driver Properties > 
Bacnet Firewall. Follow the instructions in the interface. 

For information on secure network configurations, options, and best practices, see the following documents on 
the Carrier support website. 

• Security Best Practices  

• Security Letter 
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Using a Modstat to troubleshoot your system 
A Modstat (Module Status) provides information about a controller and verifies proper network communication 
with the controller. 

 

 

To obtain a Modstat 
You can get a controller's ModStat in the following places: 

• Open device—In the i-Vu® application 

• i-Vu® XT or TruVu™ device—In the i-Vu® application or the controller's setup pages 
  

In the i-Vu® application 
Use one of the following methods:  

• Right-click a router or control program in the navigation tree, then select Module Status. 

• Select a router on the navigation tree. On the Properties page, click Module Status. 
  

In the controller's setup pages (i-Vu® XT or TruVu™ device only) 
1 Connect an Ethernet cable from a computer to the controller as shown below. 

 

 
  

2 Turn off the computer's Wi-Fi if it is on. 

3 If your computer uses a static IP address, use the following settings: 

○ Address: 169.254.1.x, where x is 2 to 7 

○ Subnet Mask: 255.255.255.248 

○ Default Gateway: 169.254.1.1  

4  If it uses a DHCP address, leave the address as it is. 

5 Open a web browser on the computer.  

6 Navigate to http://local.access or http://169.254.1.1 to see the Service Port controller setup pages. 
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Modstat field descriptions 
NOTE  Modstats vary for different types of controllers. The list below describes all information that could appear 
on any Modstat. If a description differs between different generations of controllers, the generation is noted. 
  

Field Description 

Date/Time Date and time the Modstat was run 

CM The controller's rotary switch address (MAC address) 

Model Name Identifies the Product Type 

Device Instance A unique ID assigned to the controller 

Driver built When the driver was built 

Downloaded by When and where the last download was performed 

Application Software Version The name of the first control program that is downloaded 

Flash Archive Status Shows the validity, date, and time of the most recent archive of 
parameters and status to the controller's permanent flash memory. The 
archive takes place once a day. 

# PRGs initialized 
# PRGs running 

If applicable, the number of control programs that were downloaded vs. 
the number that are running. If these numbers are not the same, the 
controller has a problem such as lack of memory. 

Firmware sections in flash 
memory 

The name, version, and date of the driver 

Reset Counters: Open device: The number of times each of the following events have 
occurred since the last time the controller was formatted. 

i-Vu® XT or TruVu™ device: The number of times each of the following 
events have occurred since the last time the controller was commanded to 
clear the reset counters. 
See NOTE below this table. 

         Power failures Interruption of incoming power 

         Brownouts Low-level incoming power 

         Commanded boots Includes commands issued from the i-Vu® interface such as the zap 
manual command, plus commands issued during a memory download. 

         System errors Error in the controller's firmware or hardware 

         Watchdog timeouts Watchdog is firmware that monitors the firmware for normal operation. If 
watchdog detects a problem, it restarts the firmware. 

         S/W Watchdog 
         timeouts 

Watchdog is firmware that monitors the application firmware for normal 
operation. If the watchdog firmware detects a problem, it restarts the 
application firmware. 

         H/W Watchdog 
         timeouts 

H/W Watchdog will restart the controller if it detects a severe problem with 
the controller's operating system 

System status Gives the current status of the controller's operation.  

Network status Gives the current status of the controller's networks. 
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Field Description 

System error message history Open device: High-severity errors since the last memory download or 
format. Shows the first 5 and last 5 messages. 

i-Vu® XT or TruVu™ device: High-severity errors since the last memory 
download. Shows the most recent 10 messages. 
See NOTE below this table. 

Warning message history Open device: Low-severity errors and warning messages since the last 
memory download or format. Shows the first 5 and last 5 messages. 

i-Vu® XT or TruVu™ device: Low-severity errors and warning messages 
since the last memory download. Shows the most recent 10 messages. 
See NOTE below this table. 

Information message history Open device: Information-only messages since the last memory download 
or format. Shows the first 5 and last 5 messages. 

i-Vu® XT or TruVu™ device: Information-only messages since the last 
memory download. Shows the most recent 10 messages. 
See NOTE below this table. 

Manifest revision Firmware revision 

Installed bundles Components of the firmware 

ARC156 reconfigurations during 
the last hour 

An ARCNET network normally reconfigures itself when a controller is added 
to or taken off the network. The Total field indicates the number of 
reconfigurations in the last hour. Initiated by this node indicates the 
number of reconfigurations initiated by this controller. Typical sources of 
the problem could be this controller, the controller with the next lower 
rotary switch address, any controller located on the network between 
these two controllers, or the wiring between these controllers. An excessive 
number in these fields indicates a problem with the network.  

BACnet comm errors in the last 7 
days 

BACnet communication errors usually indicating dropped packets caused 
by high traffic on network. 

Core (or Main) and Base board 
hardware 

Gives the following information about the controller's boards: 
• Type and board numbers that are used internally by Carrier. 
• The manufacture date and serial number. 
• Open device only: The core board's RAM and Flash memory. 

RAM is used for driver and control program executables. 
Flash memory is used for firmware and file storage. See Flash storage 
size below. 

Number of BACnet objects The number of BACnet objects that were created in the device and the 
number of those objects that are network visible. 

Largest free heap space Size of the largest piece of unused dynamic memory 

Database size Open device: Size of the controller's memory designated for running 
programs. Database memory is used for control program parameters, 
status and history; trends, schedules, and alarms; and driver parameters, 
status and history. 

i-Vu® XT or TruVu™ device: Size of the controller's memory. 

Flash storage size The size of the flash memory that is not used by the firmware. This 
memory is used for file storage and archiving. 

 Archive storage size The amount of flash memory remaining for archival after files are 
downloaded. 
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Field Description 

 File storage size The size of all files (control programs, graphics, driver, etc.) downloaded to 
the controller. How much information is in these files depends on whether 
the controller's Download source files option is selected in i-Vu®. 

Raw physical switches The readings used to test the DIP or rotary switches 

Network Information Open device: The various network addresses for a controller installed on 
an Ethernet. The Current and Assigned  addresses will be the same 
unless: 
• The Assigned addresses were changed in PuTTY. 
• The controller's DHCP/Assigned DIP switch was moved to the DHCP 

position after the Assigned addresses were defined. 
• The Enable IP configuration changeover on the BACnet Router 

Properties page is being implemented. 
 

i-Vu® XT or TruVu™ device: The various network addresses for the 
controller. The Current and Assigned addresses will be the same unless 
the Enable IP configuration changeover on the BACnet Router Properties 
page is being implemented. 

Route Information BACnet networks that a router is currently routing traffic to. The list 
changes as BACnet routers are added or removed from the system. 

Ethernet statistics Diagnostic counters directly related to the ethernet communications 
hardware. 

  

NOTE  i-Vu® XT or TruVu™ device only—If you want to clear the Reset counters and the three message history 
fields, click the Clear Counts/Logs button on the controller's Properties page in the i-Vu® application or in the i-
Vu® XT or TruVu™ device's setup pages that you access through the Service Port. 

 

 

Commissioning equipment 
Follow the process below to commission system equipment. 

 

 

Step 1:  Check out point setup 
1 On the i-Vu® navigation tree, select the piece of equipment you want to check out. 

2 Click Properties. 

3 View and change properties on the I/O Points, Alarm Sources, Trend Sources, Network Points, BACnet 
Objects, and Rnet Points tabs. See "Property descriptions" below. 

4 After completing the equipment checkout, click the Checkout tab. 

5 Select Checked Out. This field is for your reference only. 
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6 Optional: Type notes. 

○ Notes typed in this field appear in the Equipment Checkout report and can also be changed from the 
Properties page Notes field for this piece of equipment. 

○ Notes remain in this field until an operator deletes them. 

7 Optional: Click the Reports drop-down arrow button, then select and run each of the following reports to verify 
your work: 

○ Equipment > Point List 

○ Alarms > Alarm Sources 

○ Equipment > Trend Usage 

○ Equipment > Network IO 

  

 TIP  You can export the calibrated data so that you can import it into another control program. See Optional: 
Import/export calibration data (page 145). 

  

Property descriptions 

I/O Points 
Name Click the name to display the microblock pop-up. 

NOTE  A red name indicates a fault condition where the point may be misconfigured. 
EXAMPLE  No input/output number or a nonexistent input/output number. 

Type Type of Input or Output point. See Point types (page 145). 

Value The point's present value. 

Offset Allows for fine calibration of the present value of an analog point. 

Polarity Determines the point’s binary normal polarity in the control program. 
NOTE  Polarity is not the hardware normally open/normally closed position. 

Locked Select the checkbox to lock the present value at the value you specify. 

Exp:Num Expander numbers and input or output numbers associated with where the physical point 
wires, such as a sensor wire, are physically connected to a controller. 

I/O Type Selects the bank of physical inputs or outputs on the controller. 

Sensor Selects how the physical input is mapped to the engineering units. 

Min/Max is used with the sensor type of linear to scale the input to engineering units. 
NOTE  This field is ignored for sensor types other than linear. 

 EXAMPLE: AI linear sensor type 
min 
max 

  
-10 
50 

  

  when input reads 100% 
50% 
0% 

the value is 50 
20 
-10 
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Actuator Selects how the present value in engineering units is mapped to the physical output.  

Min/Max is used with the actuator type of linear to scale the output from engineering 
units. 
NOTE  This field is ignored for actuator types other than linear. 

 EXAMPLE: AO linear sensor type 
min 
max 

  
-10 
50 

  

  when input reads 50 
20 
-10 

the output is 100% 
50% 
0% 

Resolution Amount by which the present value will change.  
EXAMPLE  If a physical input changes by 1, but the resolution is set at 2, then the present 
value remains the same. If the input changes by 2, the present value will then change by 
2. 

Checked Out 

Checkout Notes 

These fields are for your reference only. 

 

Alarm Sources 
Name Click the name to display the microblock pop-up. 

Type Type of point that is an alarm source. See Point types (page 145). 

Alarm Shows Alarm in red if a current alarm exists.  

Network Visible Select to allow the microblock to be seen by the i-Vu® application and third-party BACnet 
controllers on the network. 

Potential alarm 
source 

Select to enable the microblock to generate alarms. 

Alarm Enabled Alarm—Select to generate an alarm when conditions exceed the limits set in the Condition 
column. 
Return—Select to generate a return-to-normal message when the alarm condition returns 
to a normal state.  
Fault—Select to have an alarm generated if the alarm source is not configured correctly. 
For example, a misconfigured channel number produces a no sensor fault. 

Requires ack Alarm—Select to require that the alarm be acknowledged. 
Return—Select to require that the return-to-normal message be acknowledged. 

Critical Select if the alarm is critical. 

Category You can change the alarm category assigned to the microblock. 
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Condition An alarm will be generated if conditions exceed the low or high limits set.  

Deadband: 
The amount inside the normal range by which an alarm condition must return before a 
return-to-normal notification is generated. 

EXAMPLE 

 

Delay Delay time in seconds for notification after an alarm is generated. 

  

Trend Sources 
Name Click the name to display the microblock pop-up. 

NOTE  A red name indicates a fault condition where the point may be misconfigured. 
EXAMPLE  No input/output number or a nonexistent input/output number. 

Type The type of point being trended.  

Sample Interval The interval or COV (Change of Value) increment that triggers the trend sample. 

COV Increment  

The increment, or interval, that triggers the trend sample on Change of Value 

 

Network Points 
Name Click the name to display the microblock pop-up. 

NOTE  A red name indicates a condition where the point may be misconfigured. 

Type Type of network point.  

Value The point's present value.  
EXAMPLE  For a Maximum point type, Value is the maximum value of all the target BACnet 
object properties the point is communicating with. 

Locked Select the checkbox to lock the present value at the value you specify. 

Default Value The value that the control program will use as the point’s value when communication with 
the target defined in the Address column is lost or communication is disabled. 

Com Enabled Select to enable this point’s network communications. Disable this property for 
troubleshooting. 

NOTE  Select All in the column header to quickly enable all points in the control program. 



Setting up devices in the i-Vu® application  
 

 

 
 

i-Vu® Standard/Plus v7.0  CARRIER CORPORATION ©2020   
Help  All rights reserved 
 142 

 

COV Enable Select to make: 

• A digital network output point write a value to the target defined in the Address 
column only when the value changes. 

• An analog network output point write a value only when the value changes by the 
specified increment. 

Refresh Time 
(mm:ss) 

The time interval at which the network point writes or retrieves the value to or from the 
target. For network output points, this time is used when COV is not enabled or when COV 
is enabled but fails. 

NOTE  If COV fails and the Refresh Time is zero, the value is sent once per second. 

Address The address of the target BACnet object property or third-party value that the point 
communicates with. 

NOTE  Click Search/Replace at the top of the Address column to have the i-Vu® 
application replace all instances of specific text in the addresses with different text. This is 
especially useful when copying a control program to use for multiple third-party devices. 

Error The error code and error if the point cannot communicate with the target. 

Present Value Current value of the target defined in the Address column. 

Checked Out 

Checkout Notes 

These fields are for your reference only. 

 
Notes typed in this field appear in the Equipment Points List Report. 

 

BACnet Objects 
Name Click the name to display the microblock pop-up. 

NOTE  A red name indicates a condition where the point may be misconfigured. 

Reference 
name 

A unique identifier that allows the point to be referenced for used for graphics, source tree 
rules, or network links.  

Type The BACnet object type.  

Present Value The object's current value. 

Locked Check to lock the third-party object to a specific value.  

Device A device alias. See "To reuse a control program" in Device Alias. 

Object Name An alpha-numeric string that is unique within the third-party device. 

Object ID A combination of the object type and a unique instance number. The object ID must be 
unique within the device. 

Address The address of the third-party object that the microblock references. 

Network Visible Allows other BACnet equipment to read or change the microblock's present value. Must be 
enabled for this microblock to generate alarms. 

 

 

 



 Setting up devices in the i-Vu® application
  

 

 
 

i-Vu® Standard/Plus v7.0  CARRIER CORPORATION ©2020   
Help  All rights reserved 
 143 

 

Rnet Points 
This tab shows varying information for the different point types. Below are all possible properties that may appear 
on this tab and a list of the applicable points. The following list is arranged alphabetically. 

 

Combination 
Algorithm 

(Analog Sensed Values) 
The method used to combine the ZS sensors' values to determine the microblock's 
output value. 

Default Value (Analog Parameters, Binary Parameters, Multi-State Parameters) 
The value the control program uses until a user changes the value in the system 
interface. 

Display 
Resolution 

(Analog Sensed Values, Analog Statuses, Analog Parameters) 
Defines the resolution of the value to be displayed on the ZS sensor.  For example, 1 
displays only integers (example: 74) and 0.5 displays values to the nearest 0.5 (example: 
74.5). 

Edit Increment (Analog Parameters) 
The amount that you want each press of the sensor's  or  button to change the 
microblock's value. 

Editable (Analog Parameters, Binary Parameters) 
When enabled, the microblock's value is editable on the ZS sensor. 

Lock Present 
Value to 

(Binary Parameters) 
Check to output the locked value from the microblock instead of the microblock's 
calculated value. 

Maximum (Analog Parameters) 
The highest amount that this value can be changed to on the ZS sensor or in the i-Vu® 
interface. 

Menu 
Configuration 

(All points) 
Shows which sensor screens display the value. 

Minimum (Analog Parameters) 
The lowest amount that this value can be changed to on the ZS sensor or in the i-Vu® 
interface. 

Minimum off 
time 

(Binary Parameters) 
The minimum period (seconds) that the microblock sends an off signal to the controller, 
regardless of the input signal to the microblock. 

Minimum on 
time 

(Binary Parameters) 
The minimum period (seconds) that the microblock sends an on signal to the controller, 
regardless of the input signal to the microblock. 

Object Id (All points) 
A combination of the object type and a unique instance number. 

Object Name (All points) 
A unique alphanumeric string that defines the BACnet object. Although the Object Name 
field can be edited, it is not recommended. 

Reference name (All points) 
A unique identifier that allows the point to be referenced for used for graphics, source 
tree rules, or network links.  
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Rnet Tag (All points) 
Defines what type of information this value represents and determines how the sensor 
will display the value. For example, for the Rnet Tag Fan Status, the sensor automatically 

displays  on the Home screen when the microblock is active.   

Show on sensors (Analog Sensed Values) 
Defines whether the ZS sensors are to display their individual sensed values, or the value 
determined by the Combination Algorithm. 

Type (All points) 
Type of Input or Output point.  

Value (All points) 
The point's present value. 

 

Protocol Mapping 
If a control program was built with Protocol Mapping information in Snap, this tab will appear showing third-party 
protocol configuration information. 

 

 

Step 2:  Check controller communication 
1 On the navigation tree, select the network that the controller is on. 

2 On the Devices page, view the status of all controllers on that network. 
  

 TIPS   

• Navigate to a network or router further down in the tree to show its controllers on the Devices page. 

• In the Reports button drop-down list, select Network > Equipment Status, then click Run to see the status of 
all controllers below the selected tree item. 

 

 

Step 3:  Check equipment operation 
Refer to the sequences of operation in the system specifications to verify that the equipment operates in each 
operational mode (for example, occupied and unoccupied) as specified. 

 TIP  If needed, you can import calibration data that you exported from another control program. See Optional: 
Import/export calibration data (page 145). 

 

 

Step 4:  Check the commissioned status 
1 In the i-Vu® interface, select the system. 

2 Click the Reports drop-down arrow button, then select Commissioning > Equipment Checkout. 

3 Run the report. 
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Optional: Import/export calibration data 
You can export I/O point calibration data from a control program and import it into the same control program or 
another control program with the same I/O point configuration. 

To export calibration data 
1 On the i-Vu® navigation tree, select the control program whose data you want to export. 

2 Scroll to the bottom of the Properties page I/O Points tab, and then click Export. The file <control program 
name>_<ref name>.xml is saved in your browser's Downloads folder. 
  

To import calibration data 
NOTE  We recommend that you export existing data as a backup before you import new data. 

1 On the i-Vu® navigation tree, select the control program that you want to import the data into. 

2 Scroll to the bottom of the Properties page I/O Points tab, and then click Import. 

3 Browse to the file you want to import. 

4 Click Continue. A side-by-side comparison of existing data and the new import data will appear. Red text 
indicates one of the following errors: 
• Duplicate data—Existing data has duplicate I/O numbers so that import cannot determine its match. 
• I/O type mismatch—I/O Type in existing data does not match I/O Type in import data. 
• Missing import data—Existing data has a point that import data does not have. 
• Missing system data—Import data has a point that existing data does not have. 

5 Click OK to complete the import. Existing data that does not show an error will be overwritten by the imported 
data. 

 

 

Adjust airflow configuration for VAV or VVT controllers 
To enter airflow parameters for a VAV Zone, VVT Zone or VVT Bypass controller, right-click on the controller in the 
navigation tree and select Airflow Config in the menu.  

For more information, see the following microblock details. 

• VAV Zone, VAV Zone II, Zone Ctrl, VAV Zone II Secondary Duct - Airflow Control  

• VVT Zone, VVT Zone II - PD Airflow Control 

• VVT Bypass, VVT Bypass II - BACnet Bypass Control 

 

 

 

Point types 
A point name on the Properties page is followed by a code that tells you the point type. The table below describes 
each code. 
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Code Point type 

AI Analog Input 

ANI Analog Network Input 

ANI2 Analog Network Input 2 

ANO Analog Network Output 

ANO2 Analog Network Output 2 

AO Analog Output 

ASVI BACnet Analog Sensed Value Input 

AV Analog Value 

BAI BACnet Analog Input 

BALM BACnet Alarm 

BAO BACnet Analog Output 

BAV BACnet Analog Value 

BBI BACnet Binary Input 

BBO BACnet Binary Output 

BBV BACnet Binary Value 

BFM Floating Motor 

BI Binary Input 

BMSV BACnet Multi-State Value 

BNI Binary Network Input 

BNI2 Binary Network Input 2 

BNO Binary Network Output 

BNO2 Binary Network Output 2 

BO Binary Output 

BPTA Pulse to Analog Input 

BPWM Pulse-Width Output 

BRS RS Sensor 

BRSF RS Sensor Fan 

BSVI BACnet Binary Sensed Value Input 
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Code Point type 

BTLO Timed Local Override 

BTRN Trend Log 

BV Binary Value 

DI Digital Input 

DO Digital Output 

EVT BACnet Alarm 

POLLAVG Average Analog Properties 

POLLMAX Maximum Analog Properties 

POLLMIN Minimum Analog Properties 

POLLTOT Total Analog Properties 

PTA Pulse to Analog Input 

TLO Timed Local Override 

 

 

Commissioning equipment using Field Assistant 
PREREQUISITES  Your controllers have v4.x or later drivers. 
  

To start up and commission a piece of equipment or a network of controllers, you can run Field Assistant on: 

• A laptop connected to a controller's or sensor's Local Access port. See Communicating locally with Open 
devices. 

• A laptop connected to a controller's or sensor's Rnet port. See Communicating locally with the i-Vu® XT or 
TruVu™ devices. 

• A laptop or computer connected to an IP network if your controllers are communicating on the network.  

See Field Assistant Help for information on using Field Assistant. 

 

 

Providing source files to Field Assistant 
Field Assistant requires a controller's source files. Source files include: 
• Control programs (.equipment) 
• Drivers (.driver) 
• Graphics (.view) 
• Touchscreen files (.touch) 
• BACview® files (.bacview) 
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To provide Field Assistant with source files, do one of the following: 

• Download source files from the i-Vu® application (page 148) to the controller so that they can be uploaded in 
Field Assistant.  
NOTES 

○ All Open PIC's arrive from the factory containing all their source files. They will no longer have the source 
files if they have been optimized for download in the i-Vu® application and then downloaded.   

○ To make sure the controller has the source files in it, verify that in the System Options > General tab > 
Download section that Optimize download for Open PIC controllers is unchecked (the default) before 
downloading from the i-Vu® application. 

• Export the source files from the i-Vu® application (page 148) to a zip file so that they can be imported in Field 
Assistant. This option exports all source files for all controllers in the i-Vu® system.  

 TIP  If you download source files to a controller, you may still want to export files from the i-Vu® application. 
Importing the files in Field Assistant reduces the time required to upload the controllers. 

 
If the technician using Field Assistant changes or adds source files, he can get the new source files back to the i-
Vu® application by doing one of the following: 

• Download the source files to the controller in Field Assistant so that you can upload the files in the i-Vu® 
application (page 149). 

• Export the source files from Field Assistant to a zip file so that you can import the files in the i-Vu® 
application (page 149).  
This option exports the source files for all controllers in the system to the zip file. 
  

See Field Assistant Help for instructions on uploading, downloading, importing, or exporting source files in Field 
Assistant. 

 

 

To download source files from the i-Vu® application 

1 Click , then select System Options > General tab > Download section and verify that Optimize 
download for Open PIC controllers is unchecked (the default setting). 

2 Select a system or a router on the navigation tree. 

3  On the Devices page, select the controller that you want to download. 

NOTE  Shift+click or Ctrl+click to select multiple controllers to download. 

4 Select All Content in the Download drop-down list, then click the Download button. 

NOTE  If a programmable controller does not have enough memory for the files, the download will fail and an error 
message displays. You must remove or edit the control programs.  

 

 

To export source files from the i-Vu® application 
Export the source files from the i-Vu® application (page 148) to a zip file so that they can be imported in Field 
Assistant. This option exports all source files for all controllers in the system.  

1 Click , then select System Options > General tab > Source Files section and click the Export button.  

2 Save to your desired location. 
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To upload source files to the i-Vu® application 
1 Select a router in the navigation tree. 

2 On the Devices page, select the controller whose files you want to upload. 

NOTE  Shift+click or Ctrl+click to select multiple controllers to upload. 

3 Select All Content in the Upload drop-down list and then click the Upload button. 

NOTE  If an equipment has multiple views attached, the views will be uploaded with a display name of Default. To 
change the names, right-click the equipment in the tree, select Configure, then select the view in the Views > 
Attached list. The Display Name field appears for you to edit. 

 

 

To import source files in the i-Vu® application 

1 Click , then select System Options > General tab > Source Files section and click the Import button.  

2 Browse to the *sourcefiles.zip file. 

3 Click Continue. 

4 Click Close. 

NOTE  If the import detects a difference between a database file and an import file with the same name, import 
does not overwrite the database file. A message lists any file differences so that you can resolve them. 

 

 

Downloading to controllers 
If you make any of the following changes, you must download the new data from the i-Vu® application to the 
affected controllers.  
  

In the i-Vu® interface • Change or reload a control program 
• Change or reload a driver 
• Change a schedule 

NOTE  A schedule change automatically downloads unless you uncheck 
Automatically Download Schedules on each change on the My Settings page. 

• Change a screen file 

  
The i-Vu® application automatically marks the affected controllers as requiring a download. You can download 
these controllers from the Properties page (page 151) for the controller, the equipment, or a microblock.  

When the i-Vu® application marks a controller for download, it determines what information needs to be 
downloaded based on the type of information that changed. See Download Options (page 150). 
  

By default, Full Source files are downloaded to Open PIC controllers because Optimize download for Open PIC 
controllers is unchecked in the System Options (or System Settings) > General tab > Download section. If you 
have multiple sites, you can adjust this for each site individually. Check this option if you do not want Full Source 
downloaded. 

 CAUTION  If you want this option checked and purposely had it checked in your previous system, it is 
automatically unchecked after upgrading and you must check it again. 
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NOTES   

• A property change in the i-Vu® interface is automatically downloaded to the controller. If the download fails, 
the controller is added to the Downloads page with the reason for the failure.  

• To see who downloaded a controller last, go to the navigation tree, select the controller, then do one of the 
following: 

○ Select Properties > Control Program > and click the underlined Controller: name  (Controller 1, 
Controller 2...) at the top left. This opens the Controller Information page, where you click the Module 
Status button. 

○ Select Reports > Network > Controller Status and then click Run. 

○ Right-click the controller in the tree and select Module Status.  

 

 

Download Options 
When the i-Vu® application marks a controller for download, it determines what information needs to be 
downloaded based on the type of information that changed. Below are the options that can be downloaded. 

 

 This option... Downloads... 

All Content •  The names and executable portion of the driver and control programs 
•  The names and full content of Equipment Touch and BACview® files 
•  The names of any .view files that are marked to be included in a  
    download 
•  Parameters 
•  Schedules 

NOTE  An All Content download also: 
•  Synchronizes the controller's time to the i-Vu® web server. 
•  Overwrites trends in the controller. 
•  Restarts the controller. 

Only Schedules All schedules that are not set for automatic download 

Only Parameters All editable properties 

Only BBMDs BBMD tables (.bdt file) that you have updated but have not yet written to the controller 

 

NOTES   

• An All Content download clears trend, history, and alarm data from the affected controllers. At the beginning 
of the download process, trends that have the Trend Historian enabled are saved to the system database. 

• If Field Assistant will be used with your system, you can choose to have the All Content option download the 
full source files instead of only their names. See Commissioning equipment using Field Assistant (page 147). 

 

 

To download from the Downloads page 
The Downloads page shows any controllers that the i-Vu® application marked for download. But if needed, you 
can add other controllers to the list.  
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To download: 

1 On the navigation tree, select an item to download controllers at and below that item. 

2 Click Downloads.  

3 Click  to the left of a Location to see controllers that require a download. 

4 Optional:  To add controllers to the list: 

a) Click Add. 

b) Select the controller(s). 
NOTE  Use Ctrl+click or Shift+click to select multiple controllers. 

c) Select a Download Option (page 150). 

d) Click Add, then click Close. 

5 Select the controllers that you want to download.  

NOTES   

○ Use Ctrl+click, Shift+click, or the Select All checkbox to select multiple controllers. 

○ A network's controllers download in the order shown. To change the order, select a controller(s), then 
drag and drop or click Move to Top or Move to Bottom. 
EXCEPTION  If a controller's router requires a download, it will download first regardless of its position on 
the Download page. 

6 Click Start.  
   

NOTES 

• Click Hold to stop pending  downloads. Active downloads  cannot be stopped. 
• Up to 5 routers can download simultaneously. 
• A controller is removed from the list when its download is complete. 
• Icons in the Tasks column indicate the following: 

  

 Active—The i-Vu® application is downloading to the controller. 

 Pending—You initiated the download, and the controller is waiting for its turn to download. 

 Failed—The download failed. See If a controller fails to download (page 152). 

 On Hold—Indicates either of the following: 

•  The controller requires a download 
•  You clicked Hold to stop a pending  download. 

  
• Click  in the upper left-hand corner to view a log of download activity in the current session. Copy to 

Clipboard lets you copy the text to paste it into another application. 
• To remove an item from the download list, right-click the item, then select Remove selected tasks. 
 

 

To download from a Properties page 
If a controller requires a download, a red download message and a Download button appear at the top of the 
Properties page for the controller, the equipment, or a microblock. Click the button to start the download. 

Downloading from the Properties page downloads All Content to the controller. 
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If a controller fails to download 

A controller that fails to download appears on the Downloads page with this icon .  

1 Review the reason for the failure: 

○ Hold your cursor over the failed task to see hover text giving the reason.  

○ Click  in the upper left-hand corner of the page to see information on all failed downloads. Copy to 
Clipboard lets you copy the text to paste it into another application. 

2 Correct the problem that caused the failure. 

3 Select the controller on the Downloads page, then click Start. 

 

 

Create navigation tree for the User view 
The navigation tree is a hierarchical representation of the areas or locations at your site and the mechanical 
equipment in your system.  

1 Use the Arrange User View window in the Installer view to add, delete, rename, or move items in your tree. 
You can also select a system or controller in the tree and right-click to configure change it.   

 

2 Right-click on your system name at the top of the tree in the Arrange User View window and select Add Area 

(or click  in the toolbar above the navigation tree). Type in the name of an area, location, or building that 
contains mechanical equipment.  

3 Repeat the above until all required areas have been added to the navigation tree. The following is an 
example: 

 

4  To move one or more controllers to a specific area, select the icon in the User tree, (use Ctrl+click, 
Shift+click, or both to select multiple controllers) and: 

○ Use the Move Up or Move Down arrows in the toolbar 

○ Use Move Up or Move Down arrows in right-click menu 

○ Drag and drop 
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NOTES  

• A user with the Administrator role can change the display name in the User view by selecting the item in the 
navigation tree and double-clicking, or right-clicking and selecting Configure. The Installer must make all 
other changes. 

• In the Installer view, click and drag the tab at the top of Arrange User View to adjust the height of the window. 
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You can monitor and control your equipment from: 
• The Open and i-Vu® XT controller's Properties (page 44) pages  
• The CCN controller's Properties (page 44) pages and the tables that are available when you expand the 

categories under the controller in the navigation tree   
• The equipment graphic (page 41) (if applicable) 

 

 

To lock a BACnet point or value 

You can lock certain editable parameters to a specified setting from the Properties page or microblock popup.  

1 Select the Lock checkbox. 

2 Type the value you want to send to the controller. 

3 Click Accept. 

NOTE  Locked values are indicated by a dashed yellow line on graphics. 

  

On Properties page > Control Program tab, click  to locate the point you wish to lock. 
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On the microblock popup: 

1. Click on the underlined Name or Reference Name of the point on any of the Properties tabs to open the 
microblock popup.  

2. Click Properties page > Details tab to lock a value. 

 
 

 

To force a CCN point value 

You can force certain editable point values to a specified setting from: 

• Equipment tables - click  next to the equipment to expand tables 

• A graphic - hold down Ctrl and, using your mouse, click on the point value on the graphic. A microblock popup 
appears. 

• Properties pages 

Forced values are indicated by a dashed yellow line on graphics. 

  

1 Select the Force checkbox. 

2 Type the value you want to send to the device. 

3 Click Accept or Apply. 
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To set up peer caching 

On the Devices page > Advanced tab, you can select a Group Cache Controller from the drop-down list. Choose 
the router closest to the i-Vu® server to be the peer caching router. The peer caching router will poll other routers 
on the IP network for colors and prime variables. 

Peer caching also checks the communication status of the peer caching router and any routers for which it is 
caching. If any of the routers cannot communicate, a Dead Module Timeout alarm is issued. 
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You can make the following changes to a driver in the i-Vu® interface.  

• Change or upgrade a driver for controllers. See topic below. 

• Routers only:  

Reload a driver if it becomes corrupt (for example, a driver page is missing). On the i-Vu® navigation tree, 
right-click the router or driver, then select Reload Driver. Reloading updates all instances of the driver 
throughout the system and marks the router for an All Content download. Changes you made on the driver 
pages in i-Vu® remain in effect.  

After you make these changes, you must Download All Content (page 149) to the affected devices. 

 

 

To view or change a driver 

To view the driver 

• In the Installer view, select the router in the navigation tree and select Devices > Advanced tab. 

• Right-click the controller in the navigation tree and select Driver Properties. 

 

To change a driver 

1 Right-click the controller in the navigation tree and select Driver Properties. 

2 Select the Properties page > Update tab. 

3 In the Controller section, if other controllers in the system use this driver, select which controllers you want to 
change.  
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4 Do one of the following: 
  

If the driver is...  

In the Driver Version drop-down list a.  Select the driver. 

b.  Click Accept. 

Not in the Driver Version drop-down list a.  Click Add. 

b.  Browse to select the driver. 

c.  Click Open. 

d.  Click Continue. 

e.  Click Close. 

f.  Click Close again. 

 

5 You can continue and also change the screen file, or, if finished, Download All Content (page 149) to the 
controller. 

6 See Update the equipment library (page 163) for details on implementing a new library version of drivers and 
screen files. 

  CAUTION  Selecting the Delete Unused button permanently removes the files from the database. 

 

To change a screen file 

1 If other controllers in the system use this screen file, select which controllers you want to change.  

2 Do one of the following: 

 

If the Screen file is...  

In the Screen file drop-down list a.  Select the screen file. 

b.  Click Accept. 

Not in the Screen file drop-down list a.  Click Add. 

b.  Browse to select the screen file. 

c.  Click Open. 

d.  Click Continue. 

e.  Click Accept.. 

   

3 Download All Content (page 149) to the controller. 
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To use a touchscreen device or BACview® to view or edit a controller's property values, you must download a 
screen file (.touch, .bacview, .S37, or.kpd) to the controller. The screen file is typically downloaded with the initial 
download to the controller, but you can select a different file in the i-Vu® interface. 

 

 

To select a different screen file 

1 On the i-Vu® navigation tree, right-click the controller, then select Driver Properties > Update tab. 

2 If other controllers in the system use the current screen file, select which controllers you want to change.  

 
3 Do one of the following: 

  

If the screen file is...  

In the Screen file drop-down list a) Select the file.  

b) Click Accept. 

Not in the Screen file drop-down list a) Click Add. 

b) Browse to select the screen file. 

c) Click Open. 

d) Click Continue. 

e) Click Close. 

f) Click Close again. 

   

4 Download All Content (page 149) to the controller. 
  

NOTE  You can click Delete Unused in the Screen File section to delete all unused screen files. 
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To edit a screen file on an i-Vu® client 

On an i-Vu® client, you can get a copy of a screen file from the server, edit it, then put it back on the server. 

To get the screen file  
1 On the i-Vu® navigation tree, right-click the controller that uses the screen file, then select Driver Properties 

> Update tab. 

2 Under Screen File, click Edit. 

3 Click Save as. 

4 Browse to the folder you want to put the file in. 

5 Click Save. 

6 Click Close. 
  

To put the edited file back on the server 
1 On the i-Vu® navigation tree, right-click the controller that uses the screen file, then select Driver Properties 

> Update tab. 

2 Under Screen File, click Add. 

3 Browse to select the file. 

4 Click Open. 

5 Click Continue. 

6 Click Close. 

7 Click Close again. 
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Although the i-Vu® application is a reliable front-end, you must perform periodic backups of the i-Vu® database to 
ensure a quick recovery in case of failure. To make sure that your controllers have the latest version of software, 
you must install periodic library upgrades. The sections below describe how to backup and restore the i-Vu® 
database and how to install the library updates. 

 

 

Backup data from Management Tool 

Access the Management Tool using one of the following methods: 

• Click , then select System Options > General tab > Management Tool.  

• Launch your browser and type your system name followed by :8080. For ex.: https://ivu:8080/. 

 

Use either of the following methods to backup your data: 

Backup data to your computer 

1 Click PC Backup under Manage Server Data to save the entire database zipped into one file to your 
computer. 

2 Click OK when you see the message The system will be stopped and restarted. Do you wish to proceed? 
Watch Operation Status to see the progress. 

3 Click the message Save/Download Backup File to Your Local Hard drive when it appears.  

4 Click Save when asked Do you want to open or save this file? 

5 Save this system.backup.tgz file to a convenient location on your computer.  

CAUTION! Do not alter the name of this file! 

6 Exit from Management Tool. 

 

Backup data to a USB drive 

1 Plug your own USB drive into any available USB port on your i-Vu® web server. 

 CAUTION  Do not use the i-Vu® Restore USB drive!   

2 Click USB Backup under Manage Server Data. 

3 Click OK when you see the message The system will be stopped and restarted. Do you wish to proceed?  

4 When Operation Status says No Background Operations Currently Active, remove USB drive from the i-Vu® 
web server.  

5 Exit from Management Tool. 
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Restore data from backup 

1 Click PC Restore or USB Restore under Manage Server Data in the Management Tool. 

○ PC Restore - Browse to your backup file and click Perform Restore. 

○ USB Restore - Place your backup USB drive in any port on thei-Vu® web server. Select the backup file 
and click Perform Restore. 

2 Restore is complete when Operation Status displays No Background Operations Currently Active.  

3 If you wish to change the name of your i-Vu® system from the default ivu, enter the new name in the Name 
field under Addressing. The restore process does not automatically reinstate your previous name. 

 

 

Restore factory defaults 

Restoring factory defaults deletes your existing data and restores your system to factory defaults. This restore 
process is quicker than using the Restore CD or Restore USB drive.  

1 Access the Management Tool in System Options > General tab > Management Tool or via your browser by 
typing your system name followed by :8080.  

For ex.: http://ivu:8080. 

2 Click Factory Defaults. This deletes all server data and resets the device to the original factory default values. 

3 NOTE  Executing this option will not delete configuration data under the Addressing and i-Vu Port 
Configuration sections of the Management Tool.  

4 Begin setting up your system. 

 

 

Restore i-Vu® system 

  CAUTION!  Placing the Restore USB drive in the i-Vu® web server USB port reformats your system and 
restores it to factory defaults. Library updates are lost and you must reapply them. 

 

1 Insert the Restore USB drive into any i-Vu® web server USB port. 

2 Shut down 

○ i-Vu® web server - Shut down  the web server by pushing the On/Off button. 

○ Older i-Vu® web server - Shut down the web server by holding down the On/Off button for several 
seconds. Then wait for the blue lights to go out before restarting. 

3 Press the On/Off button again to restart. The restore process starts automatically and takes several minutes. 
The web server shuts off when finished.   

NOTE  Do not turn the power off during reformatting!  

4 Remove the Restore USB drive. 

5 Wait another minute or two before accessing the new system using a browser. 
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Update the SAL library 

The i-Vu® SAL files update youri-Vu® controllers. The SAL libraries contain control programs, graphics, drivers, 
screen files, and other important controller data.  

Carrier periodically provides updates, which include enhancements and bug fixes. 

NOTES 

• The library update only changes default graphics. If you have edited your graphic in ViewBuilder, it is not 
updated. 

• The last digits in the SAL library name are the release date of the library. 

• All of the SAL files will not necessarily have the same <date> revision. 

• To ensure that your installation is running the latest software, we recommend that you check Control Systems 
Support  http://www.hvacpartners.com/, https://accounts.ivusystems.com/ for updates. Download the 
latest SAL files and apply them to all new installations. 

• If you are changing to an older SAL file than the current one being used, a warning asks you if you are sure 
you want to apply an older version. 

NOTE  Keep copies of the latest libraries in a safe place. In the event of a system restore, the updated .sal file 
must be reapplied. 

 

To check current SAL library version 

1 Login to the i-Vu® application. 

2  Click , then select System Options > Update tab. 

3 Click Current Libraries (.sal) to view the current SAL libraries and their revision date. 

  

Step 1: Update library  

1 Save the updated library (.sal file) to your computer. 

2 Click , then select System Options > Update tab. 

NOTE  Expand Current Libraries (.sal) to see the current SAL libraries and their revision. Compare them to 
what you downloaded from the Control Systems Support to determine if any of them have been updated. 

3 Click  and browse to the updated .sal file that you have saved on your computer, select the 
file, and click Open. 

4 Click Continue. 

5 When process is complete, the message appears File added successfully. 

6 Click Close. 

NOTE  These changes are not applied to the controllers until you have updated routers and controllers. 

 

Follow these steps to implement the new equipment library: 
Step 2: Update the files for the routers 

1 Select the router that you wish to update in the navigation tree. 

2 Right-click and select Driver Properties.  

http://www.hvacpartners.com/
https://accounts.ivusystems.com/
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3 Select Properties page > Update tab.  

4 If the database contains two or more routers, you must check Change for all controllers of this type? in the 
Controller section. 

5 Click Update. A message appears Changes the driver and screen file to use the current library version. 
Continue?  

NOTE  If more than one router exists, the additional routers are listed below the Update button. 

6 Click OK.  

7 Click Accept. 

 

Step 3: Update the files for the controllers  

1 Double-click the controller in the navigation tree or right-click and select Configure.   

2 If you have multiple controllers of the same type, enable Change for all control programs of this type?. 

3 Click Update under Control Program. A message appears Changes the control program, view, driver, and 
screen file to use the current library version. Continue?  

4 Click OK. When the message Updated to the library version xx. appears, click Close. 

5 Repeat steps 1 - 4 for any additional types of controllers. 

6 Click Close again. 

 

Step 4: Update the files for CCN controllers 

1 In the navigation tree, select the CCN device manager associated with the controllers that are to be updated. 

2 Select Devices > CCN Discovery and re-scan any controllers that need to be updated by checking Rescan 
Controllers Selected Below for Configuration Changes and clicking Start Scan. 

 

Step 5: Apply the update to the routers and controllers 

1 Select the System  in the navigation tree and then select the Downloads page. 

2 If you wish to apply the new SAL file to your entire system, you can use this page to compare to your 
navigation tree and verify that you have selected all of your routers and controllers for download. 

NOTE  Only the CCN Gateway and device managers require download, so the CCN controllers/equipment will 
not be listed. 

3 A network's controllers download in the order shown. To change the order, select a controller(s), then drag 
and drop or click Move to Top or Move to Bottom. 
EXCEPTION  If a controller's router requires a download, it will download first regardless of its position on the 
Downloads page. Click the Start button. 

NOTES 

○ Use Ctrl+click, Shift+click, or the Select All checkbox to select multiple controllers.  

○ See To download from the Downloads page (page 150) in Help for more details. 
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Synchronize to system time 

To update all routers and controllers to the system time: 

1 Click , then select System Options > General tab. 

2 Click  to immediately synchronize all controllers. 

3 To adjust the time when controllers are automatically synchronized each day, click Enable time 
synchronization of controllers daily at and fill in time. 
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Troubleshooting and communications 

 

 

Troubleshooting BACnet bindings 
Every controller has a Device Binding Table that contains all Device IDs that the controller communicates with and 
the network address of each device. This typically includes the Device ID of the BACnet Alarm Recipient.  

If the i-Vu® application is not receiving alarms/trends or if the a point's value is incorrect, you can view this table 
to see where the controller is looking for its data. 

1 On the i-Vu® navigation tree, select the router that has incorrect or missing data. 

2 On the Properties page,click the Show Bindings button. 
 

 

 

Communicating using PuTTY 
You can connect a computer to a controller's Local Access port and then use PuTTY, a free open source terminal 
emulation program, to: 

• Set the baud rate for ports S1 on the i-Vu® Open Router, i-Vu® Open Link, or Carrier® ChillerVu™ 

• Set controller properties, such as IP address and network information 

• Retrieve a Modstat (page 135) 

NOTE  Use Network Service Tool V to set the CCN baud rate and configure IP settings for an i-Vu® CCN Router, i-
Vu® Link, or Carrier® ChillerVu™. 

PREREQUISITES 

• A computer with a USB port 

• A USB Link cable   
The USB Link driver is installed with an i-Vu® v5 or later system. But if needed, you can get the latest driver 
from http://www.silabs.com/products/mcu/Pages/USBtoUARTBridgeVCPDrivers.aspx. Install the driver 
before you connect the USB Link to your computer. 

   

 CAUTION   If multiple controllers share power but polarity was not maintained when they were wired, the 
difference between the controller's ground and the computer's AC power ground could damage the USB Link and 
the controller. If you are not sure of the wiring polarity, use a USB isolator between the computer and the USB 
Link. Purchase a USB isolator online from a third-party manufacturer. 
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1 Download and install PuTTY from the PuTTY website 
(http://www.chiark.greenend.org.uk/~sgtatham/putty/download.html). 

2 Connect the laptop to the local access port of the controller, ZS sensor, or an SPT sensor using the USB Link 
cable(s). 
  

USB Link

Connect to
Local Access port

12 ft

Connect to
USB port

7 3/4 in.

 
  
NOTE  If using a USB isolator, plug the isolator into your computer's USB port, and then plug the USB Link 
cable into the isolator. 

3 To change a router's IP address, subnet mask, or default gateway, set its IP Address DIP switch to Assigned. 

4 Start PuTTY. 

5 Under Category > Connection, select Serial. 

6 Under Options controlling local serial lines, enter the following settings: 
  

Field Value 

Serial line to connect to Replace X with the computer's port number that the USB Link cable is 
connected to.  

NOTE  To find the port number, select Start > Control Panel > System > 
Device Manager > Ports (Com & LPT). The COM port number is beside 
Silicon Labs CP210x USB to UART Bridge.  
 

 

Speed (baud) 115200 

Data Bits 8 

Stop Bits 1 

Parity None 

Flow Control None 

    

7 Click Open. A window similar to the one below appears. 

 

http://www.chiark.greenend.org.uk/%7Esgtatham/putty/download.html
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8 Do one of the following: 

○ To change a property value: 
a.  Type the number of the property, then press Enter. 
b.  Type the new value, then press Enter. 

○ To take an action, type number of the action, then press Enter. 

9 If you changed a value, type 1, then press Enter to restart the controller. 

10 Close PuTTY. 
 
 

Communicating using HyperTerminal 
You can connect a computer to a controller's Local Access port and then use HyperTerminal, an application 
installed with Windows XP and older operating systems, to: 
• Set the baud rate for ports S1 or S2 on the i-Vu® Open Router or i-Vu® Open Link 
• Set controller properties, such as IP address and network information 
• Retrieve a Modstat (page 135) 
NOTE  Use Network Service Tool V to set the CCN baud rate and configure IP settings for an i-Vu® CCN Router or i-
Vu® Link, or Carrier® ChillerVu™. 

  

PREREQUISITES 

• A computer with a USB port 

• A USB Link cable   
NOTE  The USB Link driver is installed with an i-Vu® v5 or later system. But if needed, you can get the latest 
driver from http://www.silabs.com/products/mcu/Pages/USBtoUARTBridgeVCPDrivers.aspx. Install the 
driver before you connect the USB Link to your computer. 

 

 CAUTION   If multiple controllers share power but polarity was not maintained when they were wired, the 
difference between the controller's ground and the computer's AC power ground could damage the USB Link and 
the controller. If you are not sure of the wiring polarity, use a USB isolator between the computer and the USB 
Link. Purchase a USB isolator online from a third-party manufacturer. 

  

1 Connect the computer to the local access port of the controller, ZS sensor, or an SPT sensor using the USB 
Link cable(s). 
  

USB Link

Connect to
Local Access port

12 ft

Connect to
USB port

7 3/4 in.

 
 

NOTE  If using a USB isolator, plug the isolator into your computer's USB port, and then plug the USB Link 
cable into the isolator. 

2 Verify that the baud rate is set to 115,200. 
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3 To change a router's IP address, subnet mask, or default gateway, set its IP Address DIP switch to Assigned. 

4 Start Windows HyperTerminal located under Start > Programs > Accessories > Communications. 

5 NOTE  This option is not available in Windows v7 or later. You can download it from the Internet. 

6 Select an icon for this connection file, then click OK. 

7 In the Connect to dialog box, set the Connect using field to ComX, where X is the number of the computer's 
Com port that the USB Link cable is connected to, then click OK. 

8 In the Com Properties dialog box, set the Port Settings for your local access port, then click OK. 

Port Setting Value  

Bits per second 

 
i-Vu® Open Link 
i-Vu® Open Router 
i-Vu® Link 
i-Vu® CCN Router 
Carrier® ChillerVu™ 

115200  

  

Data Bits 8  

Parity None  

Stop Bits 1  

Flow Control None  

 

1 From the main HyperTerminal screen, press Enter to view a router configuration screen like the one below.  

 
 

2 Do one of the following: 

○ To change a property value: 
a.  Type the number of the property, then press Enter. 
b.  Type the new value, then press Enter. 

○ To take an action, type number of the action, then press Enter. 

3 If you changed a value, type 1, then press Enter to restart the controller. 

4 Close HyperTerminal. 
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Troubleshooting networks 

If a controller is not communicating, click the router on the i-Vu® navigation tree, then click Devices. This page 
shows the communication status of all controllers on the network. If all controllers on the network are not 
communicating, you have a network problem. Begin moving up the tree, checking communication status at each 
level to determine the starting point of the communications problems. 

 

 

Manual commands 

To run a manual command:  

1 Click  and then select Manual Command. 

2 Type the manual command in the dialog box, then click OK. 

 TIP   Ctrl+Shift+M also opens the dialog box. 

  
You must have the Installer or Admin role to access the manual commands dialog box. Some commands are 
restricted to the Installer role only. 
  

Command Description 

addon Opens a dialog box where you can upload, start, stop, or remove an add-on 
program. 

bacnet bind show Shows the selected device's current BACnet bindings. 

bacnet bind clear Clears the selected device's BACnet bindings so that they can be 
rediscovered. 

bacnet showindex Displays all files (file name, size, date) downloaded to the selected 
controller. 

bbmd commands: You must have the Installer Role to run bbmd commands. 

   bbmd read <IP address> Reads the BBMD table of the controller at the given IP address. 

For example, to display the BBMD table in the BACnet device router at IP 
address 154.16.12.101, type:  
       bbmd read 154.16.12.101 

 bbmd update <network  
        number> 

Selects BBMDs on the specified network and marks them for download. If 
no network is entered at the end of the command, all networks in the 
system are scanned.  

For example, if the network number is 888, type: 
       bbmd update 888 

   bbmd view <network  
       number> 

Views the list of BBMDs that have been selected for the network number 
at the end of the command. Assumes the update has been run. 

For example: 
       bbmd view 888 
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Command Description 

 bbmd write <table file> <IP  
        address>  

Writes the BBMD table into the controller at the given IP address.  

For example, to write the BBMD table in dallasbbmd.bdt into the BACnet 
device router at IP address 154.16.12.101, type: 
       bbmd write dallasbbmd.bdt 154.16.12.101 

   bbmd clear <IP address> Clears the BBMD for the specified controller. 

For example: 
       bbmd clear 154.16.12.101 

 bbmd dump <network>  
       <file> 

Writes to a file the BBMD from the specified controller. 

For example: 
       bbmd dump 888 dallasbbmd.bdt 

checkurls 1 Finds all network point exp: expressions for the selected item on the 
navigation tree. 

2 Converts the exp: expressions to bacnet:// equivalent expressions that 
the controllers use. 

3 Compares the equivalent bacnet:// expressions to the bacnet:// 
expressions currently downloaded in the controllers. 

4 Displays any mismatches. 

checkurls -p Does the same as checkurls, then adds any mismatches to the download 
queue as parameter downloads. 

checkurls -v Does the same as checkurls, but displays the exp: and bacnet:// 
expressions for all network points that were checked. 

commstat Gives a complete set of diagnostic information for all defined connections 
as well as information regarding all modems in the system. 

copy Displays a global copy utility that allows you to selectively copy trend 
graphs, custom reports and all editable properties from the selected 
equipment to other equipment in the system with the same control 
program. See To use Global Copy (page 49). 

download commands: Each of these commands performs an immediate download to a controller 
for the selected control program, device, or driver. 

   download m Downloads all content, including parameters, schedules, and BBMDs (if 
applicable). 

   download p Downloads parameters only. 

   download s Downloads schedules only. 

go commands:  

  go <refname or path> Goes to the point in the system that is referenced. 

For example: 
       go #oa_conditions 
or 
       go vav_1/m28 

go ~network Takes you to the network the selected object’s controller is associated to. 
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Command Description 

go -logicpopup <refname> Goes to the microblock pop-up for the microblock that is referenced. You 
must run this command from the microblock’s equipment on the 
navigation tree. 

For example: 
      go -logicpopup rs 

go <device ID>/<object  
        ID> 

Goes to a device and object on the navigation tree. 

For example: 
      go 300550/AI:3 

 go <object ID> Goes to an object for the current device on the navigation tree. 

For example, if a module alarm reports a control program Locked I/O 
Alarm and references an error in program 11, click the link to go to the 
device, then go to the object by typing: 
      go PRG:11 

localhost Shows the IP address of the i-Vu® web server 

logoffuser Logs off a user (without warning the user). 

Type a whoson manual command to view the IDs of logged in operators, 
then type logoffuser x, where x is the user's ID. 

markdownload commands: These commands place the controller for the selected tree item on the list 
to download at a later time. The download list can be viewed at the System 
level on the Downloads page. 
 

markdownload Marks for an All Content download, that includes parameters, schedules, 
and BBMDs (if applicable). 
 

markdownload p Marks for a Parameters download. 
 

markdownload s Marks for a Schedules download. 
 

memory Shows the amount of server memory allocated for the i-Vu® application 
and the amount being used.  

memory -free Releases unused server memory, then shows the i-Vu® memory usage 
before and after the release. 

modstat commands: These commands display a Modstat (page 135) report. 

NOTE  It is not necessary to download a controller before running a 
Modstat on it. Binding takes place when you run the modstat. 

   modstat Displays status of the controller at the current location, including: 

• Hardware components of the device 

• Software components of the device 

• Error conditions that may exist in the device 

• Date and time the device is using 
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Command Description 

   modstat 8:<device instance  
        number> 

Displays status for a specific controller in the IP network using the 
controller’s ID. Your location in the system does not have to be the 
controller you are querying. 

For example: 
       modstat 8:489202 

   modstat mac:<network  
   number>,<media type>: 
   <mac address> 

Displays a Modstat for a specific controller in the system using the 
controller’s MAC address. Network number is the number of the network 
this controller is on; media type is the type of network the controller is on; 
MAC address can be either the controller address or the IP address and 
depends on the controller’s media type.  

Media types allowed are: 

• bacnet/ip  or  b 

• ms/tp       or  m 

• ethernet   or  e 

For example: 
       modstat mac:48161,arcnet:2 
                   or 
       modstat mac:888,bacnet/ip: 172.16.101.119 

notify Sends a message to all operators currently logged in to the system. For 
example, "The server is going to shut down in 5 minutes. Please log off." To 
run this command, type:   notify <your message>. The message 
must use only alphanumeric characters. You must have the Installer role 
to run this command. 

paramupload Uploads parameters (editable properties) to the i-Vu® application from the 
equipment or driver at the current location and below. If you want to 
upload editable properties for all equipment under a particular router, 
navigate to the router or the network on the navigation tree. You must 
have the Installer role to run this command. 

ping Ping to verify communication between IP devices. You cannot ping devices 
on non-IP networks. To run this command type: ping <hostname> 
where <hostname> is the IP address or device name. 

For example: 
       ping 192.168.168.1 
(will ping the IP address 4 times)                 

rebootserver Restarts the i-Vu® application. You must log back in to the i-Vu® interface 
if you want to continue. You must have the Admin or Installer role to run 
this command. 

rebuild Rebuilds a Properties page. If you make changes to control program 
property text in the Snap application, navigate to a control program in the i-
Vu® tree, and then run this command to see your changes. 

reload Reloads a control program. Use if you make changes to control program in 
the Snap application. Reloading updates all instances of the control 
program throughout the system and marks the controller(s) for download. 
The i-Vu® application determines the type of download based on what 
changed in the control program. You must have the Installer role to run 
this command. 
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Command Description 

restartmodule Restarts the current controller. You must have the Installer role to run this 
command. 

revert Resets the selected driver or control program to its default values. 

setdefault Sets the current page as the default view for the selected action button 
and the selected tree location. You must have the Installer role to run this 
command. 

shutdown Shuts down the i-Vu Server application. This stops communication 
between the server and the client, but does not close any open i-Vu® 
pages. You must have the Admin or Installer role (System Shutdown 
privilege) to run this command. 

storetrends Uploads trend data from the controller(s) to the database for all equipment 
at and below the selected item on the navigation tree. This command 
stores trend data for points that have Trend Historian enabled. 

timesync Synchronizes the time on all controllers at the current location and below 
to the time on the server. Run this command only from a location on the 
navigation tree. You must have the Installer role to run this command. 

NOTE  For CNN networks, executing a timesync on a controller sends the 
timesync to its Gateway, and all the controllers under that Gateway. 

whereami Displays the full path for the current location and gives the display and 
reference names of the action button, category, instance and tab. If the 
selected tree location differs from the location shown in the action pane 
(for example, a point trend page), whereami returns information on both 
locations. 

Use this command when you create links in ViewBuilder. 

whoson Shows the list of users currently logged in to the i-Vu® system, the IP 
addresses from where they are logged on, what kind of interface they are 
using (for example, lvl5 for a web browser on a computer), and how long it 
has been since they have actively interfaced with the i-Vu® system. 

zap Restarts the current controller. You must have the Installer role to run this 
command. 

 

 

Using DEBUG MODE 

DEBUG MODE saves considerable time when troubleshooting custom control programs for programmable 
controllers. Typical operating mode in the i-Vu® application always downloads full source, which is time-
consuming. While operating in DEBUG MODE, Full Source is kept in the database and is not downloaded to the 
controller.  

  CAUTION  Never leave your i-Vu® system without unchecking DEBUG MODE first and and then downloading 
all content. The source files are not in the controller until you complete both steps. 
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To use DEBUG MODE 

1 Select the custom control program in the navigation tree and either double-click it or right-click and select 
Configure.  

2 Check DEBUG MODE. 

3 Download the new or edited control program. See Working with control programs (page 112).  

4 Before logging out or switching to a different controller, select the control program in the navigation tree and 
either double-click it or right-click and select Configure.  

5 Uncheck DEBUG MODE. 

6 Download All Content from the Downloads page, Devices page > Manage tab, or any page that has a 
Download button.  

 

 

Defining i-Vu® paths 

A path tells the i-Vu® application the route through the system hierarchy to an item in the system. For example, a 
path tells the i-Vu® application where to find a microblock property value to display on a graphic or where to jump 
to when the operator clicks a link on a graphic.  

In ViewBuilder, you use paths in:  
• Controls 
• Links 
• Conditional expressions 
In i-Vu®, you use paths in :  
• The source field code (page 84) in alarm actions and messages 
• An Equipment Values report (page 106) 
• The go manual command (page 170) 
• i-Vu® Pro only: Autopilot 
 
You can do one of the following to get the path: 
• In ViewBuilder, let ViewBuilder write the path. 
• In the i-Vu® interface, determine the path yourself (page 176). 
A path consists of the reference name of each tree item included in the path, separated by a forward slash (/). For 
example, first_floor/zone_1/rs. 

A path can be absolute (page 175) or relative (page 176). 

i-Vu® paths are based on parent-child hierarchy.  
 
 

Absolute path 
An absolute path begins at a specific point in the system hierarchy and is followed by the children below it down to 
the object or property of interest. An absolute path can begin with either of the following: 

• A global reference name—a reference name that is unique within the entire system and begins with a # sign. 
EXAMPLE If OA Conditions has a global reference name of #oa_conditions, the absolute path to OA 
Conditions is simply #oa_conditions. The absolute path to any child of OA Conditions, such as OA 
Temperature, begins with #oa_conditions. For example, #oa_conditions/oa_temp. 

• The top of the i-Vu® tree. 
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Relative path 
A relative path is useful for items such as graphics or alarm messages that you will reuse in multiple i-Vu® 
locations because the path is relative to the item that contains the path. 
  

A relative path going down the tree 
A relative path going down the tree begins with the reference name of the item below the location where the path 
is used. Examples using the system shown above:  
• To display the Lobby’s zone temperature on the Lobby’s graphic, the path is rs.  
• To display the Lobby’s zone temperature on the Atlanta-R&D Facility graphic, the path is 

first_floor/zone_1/rs. 
  

A relative path going up the tree 
A relative path going up the tree begins with a ~ followed by one of the options below: 
  

 Use... To go... Examples using the system shown above 

~parent Up one level 1 To put a link on the Lobby graphic that goes to the First 
Floor graphic, the path is ~parent.  

2 To put a link on the Lobby graphic that goes to the 
Atlanta R&D Facility (up 2 levels), the path is 
~parent/~parent. 

3 To display the Lobby’s zone temperature on the Boiler 
graphic, the path is ~parent/~parent/ 
first_floor/zone_1/rs/present_value. 

~equipment To the microblock's control 
program 

To display the Lobby zone temperature in a High Temp 
alarm message, the path is ~equipment/rs/present_value. 

~device From a control program to its 
device 

To show the device name on an equipment graphic, use 
~device.display-name. 

 

 

Determining a path or microblock property 
A path tells the i-Vu® application the route through the system hierarchy to an item in the system. Paths are used 
in graphics, links, alarm messages, alarm actions, network microblock address, and other items. 
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To get the path to an area, equipment, or microblock 
In the i-Vu® interface, right-click the item on the tree, then select Copy Path. Paste the path where you need it. 

  

To get the path to a microblock property value 
1 In the i-Vu® interface, right-click the value, then select Global Modify. 

2 Click Show Advanced to see the full path to the property value. 
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Important changes to this document are listed below. Minor changes such as typographical or formatting errors are not 
listed. 
  

 Date Topic Change description Code* 
10/6/20 Cover Updated logo C-D 
1/22/20 
 

To schedule a report Added additional scheduling options X-AE-LO-O-LO 
 To configure scheduled Alarms and 

Security reports 
New topic 

To run an ad hoc Alarms or Security 
report 

New topic 

Daylight Saving Tab Updated steps to require unzipping the file X-AE-EH-BR-RD 
10/24/19 Update Tab Removed reference to Language Packs C-TS-RD-E-RD 
10/3/19 What is the i-Vu® Standard/Plus 

application? 
Deleted location-dependent access - it is not available for i-Vu® 
Standard or Plus. 

C-TS-OC-E-RD 

8/23/19 
 

To schedule a report Added additional scheduling options X-AE-LO-O-LO 
 To configure scheduled Alarms and 

Security reports 
New topic 

To run an ad hoc Alarms or Security 
report 

New topic 

1/25/19 System Options > General tab Added fields System Language and Levels displayed in paths C-R-SS-BR 
8/13/18 What’s new in the i-Vu® Standard/Plus 

application 
Custom reports - Changed wording in first paragraph. C-TS-RD-E 

8/13/18 Formatting field codes The example for "To format a number" in the table stated "To 
always truncate a setpoint value…".  Changed to "To always 
round a setpoint value…". 

X-O-JD-E 

  
*  For internal use only 
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