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An i-Vu® Pro system is a web-based building automation system that can be accessed from anywhere in the world 

through a web browser, without the need for special software on the workstation. Through the web browser, you 

can perform building management functions such as:  

• adjust setpoints and other control parameters 

• set and change schedules 

• graphically trend important building conditions  

• view and acknowledge alarms 

• run preconfigured and custom reports on energy usage, occupant overrides, and much more 

 

NOTE  If you are upgrading your i-Vu® Pro application from v6.0 or earlier, see the i-Vu® Application Upgrade 

Guide. You must convert your trends, which is not described in this document. 

  

  
 

A typical i-Vu® Pro system 

An i-Vu® Pro system uses a network of microprocessor-based controllers to control heating and air conditioning. A 

web-based server communicates with these controllers and generates the i-Vu® Pro interface that the user can 

access through a web browser. Through the interface, you can gather information, change operating properties, 

run reports, and perform other building management functions on a single building or an entire campus. 

The i-Vu® Pro client uses a supported web browser to access i-Vu® Pro Server as a website.  

i-Vu® Pro supports: 

• Unlimited simultaneous users 

• Multiple operating systems and databases 

• CCN, Open, and third-party devices 

• Built-in alarming, trending, and reporting 

• Third-party integration 

• Secure server access using TLS 
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i-Vu® Pro tools 

Develop and configure graphics and a system database for your i-Vu® Pro system using the following i-Vu® Pro 

tools. 

NOTE  The i-Vu® Pro v9.0 Tech Tools and Customer Tools USB drives have a built-in license that expires 2 years 

after the software is released. When prompted during installation, browse to the i-Vu® Pro v9.0 non-expiring 

license that you obtained from Carrier.  

 

Use... To... 

ViewBuilder Create or edit graphics 

SiteBuilder Create and modify the system database 

Build a system for multiple CCN Gateways 

 

Tech tools for the Installer only: 

Use... To... 

EquipmentBuilder Build or edit control programs (.equipment files) for programmable 

controllers. Can also produce graphics, sequence of operation, and 

screen files  

Alarm Notification Receive a message on any networked computer that is running the 

i-Vu® Pro Alarm Notification Client application 

Virtual BACview® View and change property values and the controller's real time clock 

BBMD Configuration Tool Configure BACnet/IP Broadcast Management Devices (BBMDs) 

NOTE  If your system has multiple routers that reside on different IP 

subnets, you must set up one router on each IP subnet as a BACnet/IP 

Broadcast Management Device (BBMD).  

MSTP Capture Utility Capture BACnet traffic on MS/TP. It is intended for situations where 

Carrier Control Systems Support needs a network capture to 

troubleshoot communications.  

Test & Balance • Calibrate airflow in a VAV or VVT Zone controller  

• Calibrate the static pressure in a VVT Bypass controller  

• Commission air terminals 

• Override reheat and terminal fans 

NOTE  Use Test & Balance to manipulate the controllers associated with 

an air source, but not the air source itself, or heating and cooling 

equipment, such as chillers and boilers. 

Snap Build custom control programs using individual blocks of programming 

code called microblocks 

LonWorks Integration Tool Generate the microblock addresses automatically for third-party 

LonWorks points 

AppLoader Use to download .clipping files to restore factory defaults and check 

Module Status (Modstat) through the Rnet port 

Field Assistant Service or start up and commission a piece of equipment or a network of 

controllers. 
 



 What's new in v9.0

  

 

 

 
i-Vu® Pro v9.0  ©2025 Carrier. 

Installation Guide  All rights reserved. 

 3 

 

What's new in the i-Vu® Pro v9.0 application 

 

Feature Improvement 

Simultaneous downloads i-Vu® Pro now supports multiple simultaneous downloads for faster sub-networks. 

Java i-Vu® Pro now supports Java 17. 

Alarm Summary The alarm Summary provides a high-level view of all the alarms in a system to aid 

in troubleshooting and configuration. It contains the same alarms as the View tab 

with enhanced filtering and sorting. 

Alarms View Added View column. View is the total count for the view selection at that location 

(filtered by View and selected Categories) 

Security Review Security Review provides important security information in a single preconfigured 

report. 

API keys Create an API key to use with a REST API such as SystemServiceProvider or 

AlarmServiceProvider. 

Remote file management Manage graphics, drivers, and equipment files in your system directory. 

Licenses & Add-ons The following functions have moved to Licenses & Add-ons. 

• Add-ons 

• Registering and downloading your i-Vu® Pro software 

• To determine the number of third-party points required for a controller. 

 
 

What's new in v9.0 
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You must complete the following steps BEFORE installing i-Vu® Pro. 

  

  
 

Step 1: Install Tools and have documentation ready 

1 Follow the rest of this document to set up your entire system. 

2 Insert the Tech Tools USB drive into your computer and wait until the Installation screen appears. If this 

screen does not appear, open My Computer and double-click Tech Tools.  

3 Click the utilities you wish to install. Depending on how security and permissions are configured on your 

Windows computer, you may need to right-click the executable file and select Run as Administrator. For 

example, to install Tech Tools, right-click i-Vu_Tools_v9.0_windows_setup.exe and select Run as 

Administrator. 

 

NOTE  Some utilities are not copied to the hard drive. We recommend that you copy the Tech Tools USB 

contents to a folder on your hard drive. This ensures that you have the utilities when you need them. 

 

  

  
 

Step 2: Install device managers and routers 

○ If you haven't already, download the Installation and Start-up Guides from the Carrier support website. 

○ Mount and wire your CCN device manager(s)*, Open, XT, or TruVu™ routers.  

○ Wire the ports for communication and set DIP switches. 

○ Set up IP addressing, including BACnet/IP Broadcast Management Devices (BBMDs). 

NOTE  If your system has multiple routers that reside on different IP subnets, you must set up 1 router 

on each IP subnet as a BACnet/IP Broadcast Management Device (BBMD's). See the BBMD Utility User 

Guide for details. 

○ Configure BACnet device instance and network number using PuTTY or Hyperterminal connected to the 

Rnet or S2 port. See Communicating using PuTTY (page 39) or Communicating using Hyperterminal 

(page 41). 

 

*If you have multiple CCN Gateways, you must obtain the required license and then use SiteBuilder to set up a 

site and BACnet/IP network per Gateway. See i-Vu®-Pro and SiteBuilder Help. 
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Step 3: Use Network Service Tool V to ensure hardware is 

communicating on the CCN network 

1 Connect the 3-terminal connector of the Network Service Tool's USB to CCN Converter to Port S1 on the i-Vu® 

device manager. 

 

Carrier USB to CCN converter 

(top CCN Port)  

i-Vu® device manager 

(Port S1) 

+ Net+ (Pin 1) 

G Signal Ground (Pin 5) 

- Net- (Pin 2) 

 

2 Launch Network Service Tool and connect to the i-Vu® device manager. Each i-Vu® device manager defaults 

to Gateway functionality and has a CCN address of 0, 1.  

 CAUTION  Every CCN device must have a unique CCN address on the CCN network! Do not use Bus 0, 

Element 238, as it is automatically assigned to the i-Vu® Pro web server. 

3 Find the device manager at 0,1 using Address Search and change the device manager’s CCN address as 

desired. 

NOTE  We do not recommend leaving a device manager’s CCN address at 0,1, because this is the address 

that it defaults to when formatted.  

4 Upload the i-Vu® device manager. 

5 Access the Service Configuration Table IP_CONF to enter the following configuration options: 

NOTE  A static IP address is required, as DHCP is not supported. 

○ Host IP Address - enter the device manager's IP address, provided by the LAN administrator (allowable 

entries for xxx.xxx.xxx.xxx: xxx is a decimal number between 0 - 255) 

○ Subnet Mask - enter the device manager's IP address, provided by the LAN administrator (allowable 

entries for xxx.xxx.xxx.xxx: xxx is a decimal number between 0 - 255) 

○ Default Gateway - enter the IP Gateway's IP address, provided by the LAN administrator (typically a 

router on the Ethernet LAN).  

CCN ENET Configuration  

Device Type   

○ Select 0 if this device manager is the Gateway. (NOTE  Only 1 Gateway is permitted per system.) 

○ Select 1 if this device manager is the Bridge. 

If using the router as a Bridge, enter CCN/Ethernet Gateway IP (the IP address of the i-Vu® device manager 

that is configured as the Gateway). This is the same address that was entered in the Host IP address for the 

CCN Gateway.  

NOTE  Record the IP address of the Gateway, because you need it to install your i-Vu® Pro system. 

6 Repeat the above steps for every i-Vu® device manager used in the CCN system.  
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Step 4: Get your systems ready 

CCN 

1 Have the IP address of the external Gateway. 

2 Have a list of all of the devices at your job site, along with the name of each device, the bus and element 

numbers, and their respective locations. 

3 For a retrofit project, which is already using CCN global and network schedules, you must have a list of all 

existing CCN schedule numbers, systems using global and network schedules, and all global schedule 

masters. 

4 Verify that each device has a unique element number because duplicates will not install correctly.  

 CAUTION  Do not use Bus 0, Element 238. It is automatically assigned to the i-Vu® Pro web server. 

BACnet 

1 Create a list of all of the i-Vu® Open, XT, or TruVu™ routers and controllers at your job site, with their BACnet 

Device ID's, IP addresses (where applicable), BACnet network numbers, and the physical location of all 

devices. 

2 Verify that every router has a unique address because duplicates will not install correctly.  

 

See i-Vu® Pro Help for more information about setting schedules in the i-Vu® Pro interface. 
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The i-Vu® Pro system can be viewed on the following client devices and web browsers. 

  

Computers  

The client computer should have at least: 

• Quad core processor  

• 4 GB RAM 

• Communications link of 100 Mbps or higher 

The i-Vu® Pro application will work with slower computers and slower links, but the results may not be 

satisfactory. 

 

A computer with this 

operating system... 

Supports these web browsers... 

Windows® GoogleTM ChromeTM v84.0 or later 1 

Microsoft® Edge v84 or later 

Mozilla® Firefox® v79.0 or later 

Mac® OS X® 

(Apple® Mac only) 
Safari® v11 or later 2 

Google Chrome v84.0 or later 

Mozilla Firefox v79.0 or later 

1 Best performance 

2 Best performance unless browser is running on a Mac® Mini or a MacBook: 

 WARNING If machine is running Mountain Lion 10.8x with an integrated Intel HD 400 graphics card, 

it will experience display issues. Use one of these workarounds for better performance: 

• If an additional NVIDIA graphics card is available, manually switch the graphic card setting in MAC® OS 

X® to use that card. 

• If not, use GoogleTM ChromeTM v84.0 or later. 

 

Mobile devices 

Device type Platform support 

Smart phone AndroidTM, iOS 

Tablet AndroidTM, iOS, SurfaceTM 

 

NOTE  Some functionality may be limited by the capability of the mobile device and operating system. 
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Setting up and using a computer with the i-Vu® Pro system 

• Set the monitor's screen resolution to a minimum of 1920 x 1080 with 32-bit color quality 

• You may want to disable the computer's navigation sounds. 

 

Mac only 

NOTE  The instructions below are for a Mac OS X 10.8. Other versions may vary slightly. See your computer's Help 

if necessary. 

 

Computer settings To change setting... 

Enable right-clicking to see right-click 

menus: 

 

     On a Mac 1 Select System Preferences > Mouse. 

2 Click the drop-down list that points to the mouse's right-click button, 

then select Secondary Button. 

     On a MacBook 1 Select System Preferences > Trackpad. 

2 Enable Secondary click. 

 

The instructions in Help are for a Windows computer. For instructions that include the Ctrl key, replace Ctrl with 

Command. For example, replace Ctrl+click with Command+click. 

 

 
 

Setting up and using a web browser to view the i-Vu® Pro interface 

To set up and use Microsoft Edge 

The instructions below are for Microsoft® Edge. 

 

Web browser settings To set in Microsoft Edge... 

Do not block cookies 1 Click  . . . to display the Actions droplist. 

2 Select Settings > Site Permissions > Cookies. 

Disable web browser's pop-up 

blockers * 
1 Click  . . . to display the Actions droplist. 

2 Then select Settings > Site Permissions > Pop-ups and redirects. 
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To... Do the following... 

Maximize the web browser window * Use the minimize/maximize button in the top right corner of the browser 

window. 

Have 2 different users logged in to 

the i-Vu® Pro system on the same 

computer * 

1 Click  . . . to display the Actions droplist. 

2 Select New Window. 

Clear browser cache 1 Click  . . . to display the Actions droplist. 

2 Select Settings > Privacy, Search, and Services > Clear browsing 

data. 

3 Click Choose what to clear. 

4 Click Clear now. 

* Does not apply to Microsoft Edge on a phone. 

 

 
 

To set up and use Mozilla Firefox 

NOTES 

• The instructions below are for Mozilla® Firefox® v60.0 on a Windows operating system. Other versions may 

vary slightly. See your web browser's Help if necessary. 

• If the menu bar is not visible, right-click on the window's title bar, and then select Menu bar. 

• If a message appears in the i-Vu® Pro interface that includes the checkbox Prevent this page from creating 

additional dialogs, DO NOT check this box. 

 

Web browser settings To set in Firefox... 

Disable Pop-up blocker 1 Click Tools > Options > Privacy & Security.  

2 Under Permissions, click Exceptions next to Block pop-up windows.  

3 Type http:// (or https://) and then the server name or IP 

address of your system.  

4 Click Allow and then Save Changes. 

Enable JavaScript 

 

1 In the address bar, type about:config, and then press Enter. 

2 Click I accept the risk. 

3 In the Search bar, type javascript.enabled. 

4 If the value field shows true, JavaScript is enabled. If it shows false, 

right-click javascript:enabled, and then select Toggle. 

Add-ons Manager Select Tools > Add-ons > Extensions. On this page, you can 

enable/disable installed add-ons such as: 

• Adobe® Acrobat® Reader (to view PDF's) 

• QuickTime Plug-in (to play audible alarms) 

Only installed Firefox add-ons appear in the list.  
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To... Do the following... 

Maximize the web browser window Press F11 to turn full-screen mode on\off. 

Clear browser cache 1 Click Tools > Options > Privacy & Security. 

2 Under Cookies and Site Data, click Clear Data. 

3 Click Clear. 

Have 2 different users logged in to 

the i-Vu® Pro system on the same 

computer 

Start a new web browser session. Select File > New Private Window. 

 

  
 

To set up and use Google Chrome 

NOTES 

• The instructions below are for GoogleTM ChromeTM v66.0. Other versions may vary slightly. See your web 

browser's Help if necessary. 

• If a message appears in the i-Vu® Pro interface that includes the checkbox Prevent this page from creating 

additional dialogs, DO NOT check this box. 

 

On a computer 

Web browser settings To set in Chrome... 

Enable pop-ups 
1 Click  on the browser toolbar.  

2 Select Settings.  

3 Click Advanced at the bottom of the page. 

4 Under Privacy and security, click Content settings.  

5 Under Pop-ups > Allow, click ADD, and then type http:// (or 

https://) and then the server name or IP address of your system. 

 

To... Do the following... 

Clear browser cache 
1 Click  on the browser toolbar. 

2 Select More tools > Clear browsing data. 

3 Select a time range in the drop-down list. 

4 Check the types of information that you want to remove. 

5 Click CLEAR DATA. 

Maximize the web browser window Press F11 on your keyboard to turn full-screen mode on/off. 

Have 2 different users logged in to 

the i-Vu® Pro system on the same 

computer 

Start a new web browser session. Click , then select New incognito 

window. 
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On Chrome for Android 

NOTE  The following settings are based on Android v11 - options may vary with versions. 
 

Web browser settings In the Chrome menu... 

Turn off desktop mode Uncheck Request desktop site 

Disable pop-up blocker Settings > Advanced > Site Settings > uncheck Block  

pop-ups 

Enable JavaScript Settings > Advanced > Site Settings > check Enable JavaScript 

Enable Cookies Settings > Advanced > Site Settings > check Accept Cookies 

 

To... In the Chrome menu... 

Clear browser cache Settings > Basics > Privacy > CLEAR BROWSING DATA 

 

 
 

To set up and use Safari 

NOTES 

• The instructions below are for Safari® v11. Other versions may vary slightly. See your web browser's Help if 

necessary. 

• We recommend that you do not run Safari in full-screen mode. If you do, i-Vu® Pro pop-ups open full-screen, 

covering the main application window. 

 

On an Apple® computer (Mac®) 

Web browser settings To set in Safari... 

Disable pop-up blocker Preferences > Security > uncheck Block pop-up windows 

Enable JavaScript Preferences > Security > check Enable JavaScript 

Enable Plug-ins Preferences > Security > check Enable plug-ins 

Prevent pop-ups from opening in a 

new browser tab 

Preferences > Tabs > uncheck Command-click opens a link in a new 

tab 

Prevent Safari from automatically 

opening zip files exported from the 

i-Vu® Pro application 

Preferences > General > uncheck Open "safe" files after downloading 

 

To... Do the following... 

Clear browser cache History > Clear History 

Have 2 different users logged in to 

the i-Vu® Pro system on the same 

computer 

Start a new web browser session. Select Safari > Private Browsing > 

File > New window 
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On an Apple® iPad 

Web browser settings To set on the iPad... 

Disable pop-up blocker Settings> Safari > set Block pop-ups to Off 

Enable JavaScript Settings > Safari > set JavaScript to On 

  TIP  Re-enable popup blocking on your device when not using our software. 

 

To... Do the following... 

Clear browser cache Settings > Safari > Clear History 

 TIP  Re-enable popup blocking on your device when not using our software. 

 

On an Apple® iOS 12.2 

Web browser settings To set on the iPhone... 

Enable JavaScript Settings > Safari > Advanced 
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i-Vu® Pro client requirements 

The i-Vu® Pro system can be viewed on the following client devices and web browsers. 

  

Computers  

The client computer should have at least: 

• Quad core processor  

• 4 GB RAM 

• Communications link of 100 Mbps or higher 

The i-Vu® Pro application will work with slower computers and slower links, but the results may not be 

satisfactory. 

 

A computer with this 

operating system... 

Supports these web browsers... 

Windows® GoogleTM ChromeTM v84.0 or later 1 

Microsoft® Edge v84 or later 

Mozilla® Firefox® v79.0 or later 

Mac® OS X® 

(Apple® Mac only) 
Safari® v11 or later 2 

Google Chrome v84.0 or later 

Mozilla Firefox v79.0 or later 

1 Best performance 

2 Best performance unless browser is running on a Mac® Mini or a MacBook: 

 WARNING If machine is running Mountain Lion 10.8x with an integrated Intel HD 400 graphics card, 

it will experience display issues. Use one of these workarounds for better performance: 

• If an additional NVIDIA graphics card is available, manually switch the graphic card setting in MAC® OS 

X® to use that card. 

• If not, use GoogleTM ChromeTM v84.0 or later. 

 

Mobile devices 

Device type Platform support 

Smart phone AndroidTM, iOS 

Tablet AndroidTM, iOS, SurfaceTM 

NOTE  Some functionality may be limited by the capability of the mobile device and operating system. 
 

i-Vu® Pro v9.0 client, server, operating system, and database 
requirements 
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i-Vu® Pro server requirements 

The recommended minimum for an i-Vu® Pro server: 

 

• Dual core processor 

• 4 GB RAM 

• 30 Gigabyte hard drive 

• Communications link of 10 Mbps or higher 

• 64-bit server (See Upgrading from a 32-bit server to a 64-bit server (page 17).) 

 

The i-Vu® Pro application will work with slower computers and slower links, but the results may not be 

satisfactory. 

 

A i-Vu® Pro server must be 64-bit. Memory requirements vary, based on the: 

• number of pieces of equipment and device instances 

• size of the control programs 

• number of simultaneous users logged in to the i-Vu® Pro application 

  

 

For this 

size 

system... 

With this number of... The computer should have at least a dual core processor and... 

 

Instances of 

equipment 

and devices 
1 

Physical 

Points and 

Display 

Objects 

Passmark 

Total 

Score 2 

Passmark 

Single- 

threaded 

Score 

RAM 

Minimum/ 

Recom- 

mended 

JVM Memory 

Minimum/ 

Recom- 

mended 

Disk Mark4 

Small 0 - 250 0 - 1000 2000 800 4 / 8GB 4 / 4GB 3000 

Medium 250 - 1000 1000 - 

5000 

3000 1000 8 / 12GB 4 / 8GB 5000 

Large 1000 - 

10,000  

5000 - 

50,000 

5000 1400 12 / 16GB 8 / 12GB 15000 

Huge more than 

10,000 

more than 

50,000 

6500 1600 16 / 24GB 
3 

16 / 24GB 30000 

1   Total number of control programs and controllers. 

2   For more information, see www.CPUbenchmark.net. 

3   For a huge system with minimal user activity, the average piece of equipment or instance device requires 

approximately 300KB of server RAM. Contact Technical Support for server sizing recommendations. 

4   SATA SSDs are recommended as baseline performance for i-Vu® Pro on all systems. Large systems benefit 

from the faster PCIe interface SSDs on both the i-Vu® Pro and database servers. Passmark’s Disk Rating “Disk 

Mark” can be useful in gauging disk performance when designing new servers. 

Rotational Drives:  900-1500 

SATA SSDs:  3000-5000 

PCIe SSDs:  10000-30000 
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Operating system and database requirements 

 

To determine which operating system and database management system (DBMS) to use, consider: 

• Operating systems and DBMS's already in use in your customer’s organization 

• Project size and trending requirements. See "Trend archival requirements" below. 

• Project budget 

• Your skill with the operating system and DBMS  

  

The i-Vu® Pro v9.0 system use of database resources may require a moderate increase in the number of allowed 

connections if your database management system is set to the default value for the maximum allowed 

connections.  

Supported operating systems and database management systems 

A i-Vu® Pro v9.0 or later system is supported on the following 64-bit operating systems. The table below shows 

which operating systems can be used with each DBMS. 

• Windows® 10 Professional and Enterprise 

• Windows® 8.1 Professional and Enterprise 

• Windows® Server 2019 

• Windows® Server 2016 

 

 

Database Operating 

systems 

supported 

Speed Supports 

multiple 

servers  

Dynamic 

defrag- 

mentation 

Database 

replication 

Notes 

SQL Server® 

Express 

2019, 2017, 

2016 

Windows®  

 

Fast No Yes Yes Database cannot exceed 10 

GB. 

SQL Server® 

2019, 2017, 

2016 

Windows®  Fast Yes Yes Yes SQL Server® 2016 

Enterprise, Business 

Intelligence, and Standard 

editions can be used - only 

SP2 supported. 

MySQL 8.0 Windows® 

 

Fast Yes No Yes This open source database is 

free under the GNU Public 

License. 

PostgreSQL 

12 and 13 

Windows® 

 

Fast Yes Yes Yes This open source database is 

free under the BSD Public 

License. 
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Database Operating 

systems 

supported 

Speed Supports 

multiple 

servers  

Dynamic 

defrag- 

mentation 

Database 

replication 

Notes 

Apache Derby Windows® Slow No No Yes • The i-Vu® Pro Installs for 

Windows include all the 

files needed to use an 

Apache Derby database. 

• Only one application can 

access the database at 

one time. Example: 

ViewBuilder cannot 

access the database if 

SiteBuilder is already 

running. 

• Do not use Derby if total 

historical trend capacity 

will exceed 2 GB. 

• Audit database cannot 

contain an entry of more 

than 32,700 characters; 

compact the database 

before migrating to 

Derby. 

 

Trend archival requirements 

Trend archival (historical trending) requirements are the most significant factors in database selection. Alarms are 

not usually an issue unless large quantities (10,000+) will be kept for online access.  

 

For each archived trend sample, the i-Vu® Pro application stores approximately 30 bytes of data. Disk space 

requirements per trended point are: 

Sample interval for 1 week for 1 month for 3 months for 1 year 

1 minute 300 kB 1.5 MB 5 MB 18 MB 

5 minutes 60 kB 250 kB 1 MB 4 MB 

15 minutes 21 kB 85 kB 250 kB 1 MB 

1 hour 5 kB 20 kB 60 kB 240 kB 

For example, a system with 2000 points archiving at 15 minute intervals for one year will require as much as 5.6 

GB (2000 x 2.8 MB) disk space. 

  

NOTES 

• To limit disk space required for trend storage, archive trend data only for important system points. 

• If your archival requirements are 5 GB or greater, you should consider using a separate server for the trend 

database. 
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i-Vu® Pro v9.0 will not run on a 32-bit server. To upgrade, first install i-Vu® Pro v9.0 on a 64-bit server. The 

method for upgrading your system depends on the database type or size. 

 

Derby database 

1 Copy your existing system's i-Vu Prox.x\webroot\<system name> folder. 

2 Paste the copied folder under a folder of your choice on the 64-bit server. For example, i-Vu 

Prox.x\programdata\systems. 

3 Open the system in SiteBuilder.  

4 Select File > Upgrade > i-Vu Pro system and follow the prompts to upgrade the system. 

 

All Non-Derby databases 

1 Open your existing system in SiteBuilder. 

2 Select File > Manage Database > Migrate/Replicate, and then select Replicate database to create a copy of 

the system in a Derby database. 

3 Copy the replicate system's i-Vu Prox.x\webroot\<system name> folder. 

4 Paste the copied folder under a folder of your choice on the 64-bit server. For example, i-Vu 

Prox.x\programdata\systems. 

5 Open the system in SiteBuilder. 

6 Select File > Upgrade > i-Vu Pro system and follow the prompts to upgrade the system. 

7 Select File > Manage Database > Migrate/Replicate, and then select Migrate to a different database type to 

change the system back to the original database type. 

 

Very large databases 

If you are moving a very large system to a 64-bit server, contact Carrier Control Systems Support for assistance. 
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The system folder can be saved in any location. The default location is \i-Vu_Pro_x.x\programdata\systems\. The 

actual databases may be located in another location if you are using MySQL, MS SQL Server, or PostgreSQL. See 

any of the following topics for more information: 

PostgreSQL on Windows (page 18) 

MySQL on Windows (page 20) 

SQL Server and SQL Server Express on Windows (page 23) 
 

PostgreSQL 13.x on Windows for the i-Vu® Pro v9.0 system 

To set up the databases for a new i-Vu® Pro system, complete all 4 steps below. 

Step 1:  Install PostgreSQL on Windows 

a Download the appropriate PostgreSQL installer from the PostgreSQL downloads page. 

b Save postgresql-<latest version>-windows.exe to your hard drive.  

c If you saved the postgresql-<latest version>-windows.exe  file to a machine other than the PostgreSQL 

server, move the file to the PostgreSQL server.  

d On the PostgreSQL server, run the postgresql-<latest version>-windows.exe file to start the PostgreSQL 

install. 

e Accept the defaults until you are asked for a password. 

f Enter a password for the service account, then retype the password. 

g Enter the port number you wish to use or leave it at the default port of 5432. 

h Continue the installation process, accepting all defaults until you reach the Finish screen; then clear the 

checkbox regarding Stack Builder. 

i Click Finish. 

Step 2: Create database user in PostgreSQL 

a Go to Start > All Programs > PostgreSQL 12.x > pgAdmin 4. 

b In the Browser pane, expand Servers and then double-click PostgreSQL 12.  

c Type the service account password that you created in step 1f above. 

d In the Browser pane, right-click Login Roles/Group Roles, then select Create > Login/Group Role. 

e On the General tab, in the Name field, type a name (all lowercase) for the user, such as xxx_user; this 

will be your Database User Login in SiteBuilder. 

f On the Definition tab, in the Password field, type a password for the user; this will be your Database User 

Password in SiteBuilder. 

g On the Privileges tab, enable Can Login and Create Databases. 

NOTE  Verify that Inherit rights from the parent is enabled (default). 

h Click Save. 
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Step 3:  Create database instances in PostgreSQL 

a In the Browser pane, right-click on Databases, then select Create Database. 

b In the Database field, type a name for the database such as xxx_main; this will be your Database 

Connect String Instance in SiteBuilder. Record the name below. 

c In the Owner field, select the name that was created in Step 2e. 

d On the Security tab, click the Privileges plus sign. In the Grantee column, select the name that was 

created in Step 2e. 

e Click the blank space under the Privileges column and click the All checkbox.  

f Click Save. 

g Repeat steps a-f to create the Alarms, Trends, and Audit Log databases. 

NOTE  Database names are case-sensitive and must be 18 characters or less in length. 

h Close pgAdmin 4. 

Step 4:  Set up the PostgreSQL databases in SiteBuilder 

a In SiteBuilder, select File > New. 

b Type a name for the system. 

c Select PostgreSQL from the Database Type drop-down list. 

d Select Make this the default system for i-Vu Pro if you want the i-Vu® Pro application to automatically 

run this system each time it starts. 

e Complete the remaining fields, then click Next. 

f Enter the Database Connect String information for each i-Vu® Pro database and the Database User 

information. See table below. 

g Select your system language. 

h Click Finish. 

NOTE  To change Database Connect Strings for an existing system, select Modify database connection 

parameters in the File > Open dialog box and then click Next. 

   

Main Database Connect String: 

     Server Type one of the following:  

• localhost if the i-Vu® Pro application and the database are on the same 

machine 

• The name or IP address of the machine that the database is on if different than the 

i-Vu® Pro application 

     Port Do one of the following: 

• Type the default port of 5432.   

• Type the port number that the database uses for communication that you set up in 

step 1g if different than the database default. 

     Instance The names that you gave the i-Vu® Pro databases in step 3b. 

  

Database User: 

     Login  The user name that you entered in step 2e. 

     Password The password that you entered in step 2f. 
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MySQL 8.0 on Windows for an i-Vu® Pro v9.0 system 

To set up the databases for a new i-Vu® Pro system, complete the following steps: 

Step 1:  Install MySQL  

a Download the appropriate MySQL Community Server  > MySQL Installer MSI from the MySQL 

Downloads page. 

b Save mysql-<installer-community-latest version->msi to your hard drive.  

 TIP  If you saved the file to a machine other than the MySQL server, move the file to the MySQL server.  

c On the MySQL server, run mysql-<installer-community-latest version->-.msi to start the MySQL install.   

d In the Choosing a Setup Type window, select Custom and click Next. 

e Select the following in the Available Products column and then click on the arrow to move them to the 

Product/Features column: 

○ MySQL Server  x86 or -x64  (use x86 for 32 bit operating systems) 

○ MySQL Workbench 

○ Connector/J (latest version)   

f Click Next. 

g If there are entries in the Check Requirements window, click Execute and follow the Install Wizard for 

each application, until all of them are completed.  

NOTE  When all applications are installed, the Execute button disappears.  

h Click Next.  

i In the Installation window, verify that the 3 products from step f are listed and then click Execute.  

j When the Status column shows all items as Complete, click Next, then click Next again. 

k Select Server Computer from the Config Type drop-down list.  

l If the site requires a specific TCP port, enter this port number in the Port Number field.  

m Accept defaults for the remaining configurations, then click Next. 

n On the Authentication Method page choose either Strong Password authentication (recommended) or 

Legacy Password authentication. 

o Click Next. Then type in a root password, confirm it, and click Next.  

p Accept the Windows Service default settings.  

NOTE  If the site requires that the MySQL service run under a particular user account, select Custom User 

and enter in the user name and password supplied by the IT department.  

The account that the MySQL service runs with can be changed later in the Windows Service Control Manager.  

q Click Next and then click Execute. 

r Click Finish.  

s In the product Configuration window, click Next, and then click Finish to complete the MySQL installation 

and to launch MySQL Workbench. 
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Step 2:  Create i-Vu® Pro database instances  

a Click + next to MySQL Connections and enter a connection name, such as the name of your server.  

b Click Test Connection and OK.  

c In the list of connections on the Workbench, double-click your new connection to open. 

d Click + on the cylindrical database icon to add a new Schema (database). 

e In the Name field, type a name for the database such as xxxmain, which will be your Database Connect 

String Instance in SiteBuilder. Record the name below. 

f Click Apply, click Apply again, then click Finish. 

g Repeat steps f-h to create the Alarms, Trends, and Audit Log databases. 

NOTE  Database names are case-sensitive and must be 18 characters or less in length. 

h Close all Schema Creation tabs. 

 

Step 3:  Create a database user 

a Click Users and Privileges. At the bottom of the window, click Add Account. 

b On the Login tab, type a Login Name and Password.  

NOTE  These will be your Database User Login and Database Password in SiteBuilder. 

c Click Apply. 

d On the Schema Privileges tab, select the user you created. 

e Select the Add Entry button. 

NOTE  You may have to resize the window to see the button at the top-right. 

f Under Schema, select Selected Schema and then select the Main database schema you added in step 

2e. 

g Click OK. 

h Select the row you added in the Users and Privileges table, then click Select "ALL" under the privilege 

check boxes. 

i Click Apply. 

j Repeat steps g through j to give the database user privileges to the Alarms, Trends, and Audit Log 

databases. 

k Close MySQL Workbench. 

 

Step 4:  Install a MySQL database driver 

a Locate the mysql-connector-java-.xx.jar file in the Program (x86)\MySQL\Connector J  folder.  

NOTE  This is the default location for the JAVA connector file. Search your designated location if you changed 

the default.  

b Copy the mysql-connector-java-.xx.jar to thei-Vu Pro\database-drivers folder under the i-Vu® Pro install 

folder. 
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Step 5:  Set up the MySQL databases in SiteBuilder 

a In SiteBuilder, select File > New. 

b Type a name for the system. 

c Select MySQL from the Database Type drop-down list. 

d Select Make this the default system for i-Vu Pro if you want the i-Vu® Pro application to automatically 

run this system each time it starts. 

e Complete the remaining fields, then click Next. 

f Enter the Database Connect String information and the Database User information for each i-Vu® Pro 

database. See table below. 

g Click Next. 

h Select your system language. 

i Click Finish. 

NOTE  To change Database Connect Strings for an existing system, select Modify database connection 

parameters in the File > Open dialog box and then click Next. 

 

Database Connect Strings: 

     Server Type one of the following:  

• localhost if the i-Vu® Pro application and the database are on the same machine 

• The name or IP address of the machine that the database is on if different than the 

i-Vu® Pro application 

     Port Type 3306. 

     Instance The name that you gave the i-Vu® Pro database in step 2e. 

  

Database User: 

     Login  The user name that you entered in step 3c. 

     Password The password that you entered in step 3c. 

 

Step 6:  Disable MySQL automatic updates 

1 Open the MySQL Installer - Community under Start > All Programs > MySQL. 

2 Click the wrench icon at the top right. 

3 Uncheck Check for updates to the MySQL Installer product catalog. 

Click Accept then exit the Installer – Community window. 
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SQL Server 2016, 2017, and 2019 on a Windows for the i-Vu® Pro 

system 

SQL Server versions currently supported are 2016, 2017, and 2019. 

1 If you do not already have MS SQL installed, install one of the supported versions and any applicable SQL 

service packs. For instructions on how to install any version of SQL Server, go to 

http://msdn.microsoft.com/en-us/library/default.aspx and, in the Search window, type Install <your SQL 

Version >.  Select Authentication Mode - Mixed Mode during setup and enable TCP/IP on port 1433.  

NOTE  As you install MS SQL Server, you must select certain options to use with i-Vu® Pro. For all other 

options, you may keep the defaults or select your own values. Select the following: 

○ SQL Server Database Services 

○ Workstation components, Books Online, and development tools  

○ Authentication Mode - Mixed Mode (Windows Authentication and SQL Server Authentication)  

NOTE  The password you specify grants extensive privileges.  

○ Service Account for database engine – NT Authority\System 

○ Enable TCP/IP on port 1433 

2 If already installed, you must have selected Authentication Mode - Mixed Mode during setup and have TCP/IP 

enabled on port 1433. 

 

If you are the database administrator and TCP/IP is not enabled on port 1433, or you are unsure of the port, 

follow the procedure below, 'To enable TCP/IP on port 1433' and then proceed to Step 1. 

Install the program and follow the instructions below. 

 

To enable TCP/IP on port 1433 

a Click Start > All Programs > Microsoft SQL Server <your SQL version> > Configuration Tools > SQL 

Server Configuration Manager. 

b Expand the SQL Server Network Configuration. 

c Select Protocols for <server instance> where <server instance> is the SQL Server running the i-Vu® Pro 

application. 

d In the next window, under Protocol Name, double-click TCP/IP. 

e On the Protocol tab, under General, next to Enabled, select Yes. 

f On the IP Address tab, scroll down to the IPAll section. 

g Clear any values from the TCP Dynamics Port field. 

h In the TCP Port field, enter 1433, then click OK. 

i Close the SQL Server Configuration Manager. 

j Restart the SQL Server Service. 

 

 

 



Installing and setting up databases  

 

 

 

 
i-Vu® Pro v9.0  ©2025 Carrier. 

Installation Guide  All rights reserved. 

 24 

 

Step 1:  Connect to the database engine for i-Vu® Pro SQL Server 

a Determine if Microsoft SQL is running on the i-Vu® Pro server: 

○ If Microsoft SQL is running on the i-Vu® Pro server, select Start > Programs > Microsoft SQL Server > 

SQL Server <your SQL version> > Management Studio. 

○ If Microsoft SQL is running on a different computer, download the SQL Management Studio and install it 

on the i-Vu® Pro server. 

b In the Connect to Server dialog box, select or enter the information using the table below. 

c Click Connect. 

 

To set up the databases for a new i-Vu® Pro system, complete steps 2, 3, and 4 below. 

 

Field Notes 

Server type Database engine. 

Server Name The address or name of the computer running the SQL Server service. Get from your 

database administrator. 

Authentication Get from your database administrator. 

Username Get from your database administrator. 

Password Get from your database administrator. 

 

Step 2:  Create a database instance 

a In the Object Explorer pane, right-click Databases, then select New Database.  

b In the Database name field, type a name such as xxx_main; this will be your Main Database Connect 

String Instance in SiteBuilder. Record the name below. 

c Under Select a Page, select the Options page.  

d From the Recovery model drop-down list, select Simple.  

e Click OK. 

f Repeat steps a-e to create the Alarms, Trends, and Audit Log databases. 

NOTE  Database names are case-sensitive and must be 18 characters or less in length. 
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Step 3:  Create a database user 

a In the Object Explorer pane, click the plus sign to the left of Security.  

b Right-click Logins, then select New Login.  

c In the Login name field, type in a login name for i-Vu® Pro, such as xxx_User; this will be your Database 

User Login in SiteBuilder. 

d Select SQL Server authentication.  

e In the Password and Confirm password fields, type a password; this will be your Database User 

Password in SiteBuilder. 

f Clear the following checkboxes:  

○ Enforce password policy  

○ Enforce password expiration  

○ User must change password at next login 

g  In the Default database drop-down list, select master.  

h In the Select a page pane, select the User Mapping.  

i Under Users mapped to this login, select the Map checkbox next to a database name you created in Step 

2. 

j Under Database role membership for: section, select the following checkboxes:  

○ db_owner  

○ public 

k Click OK. 

l Repeat steps i-k for each remaining database. 

m Close SQL Server Management Studio. 

 

Step 4:  Set up the SQL Server databases in SiteBuilder 

a In SiteBuilder, select File > New. 

b Type a name for the system. 

c Select SQL Server from the Database Type drop-down list. 

d Select Make this the default system for i-Vu® Pro if you want the i-Vu® Pro application to automatically 

run this system each time it starts. 

e Complete the remaining fields, then click Next. 
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f Enter the Connect String information for each i-Vu® Pro database. See below. 

 

g Click Finish. 

 

NOTE  To change Database Connect Strings for an existing system, select Modify database connection 

parameters in the File > Open dialog box and then click Next. 

 

Database Connect Strings: 

     Server Type one of the following:  

• localhost if the i-Vu® Pro application and the database are on the same machine 

• The name or IP address of the machine that the database is on if different than the 

i-Vu® Pro application 

     Port Do one of the following: 

• Type the default port of 1433. 

• Type the port number that the database uses for communication if different than the 

database default. 

     Instance The name that you gave the i-Vu® Pro database in step 2b. 

NOTE  If the 4 i-Vu® Pro databases do not reside under the default instance of SQL, then 

the instance name must be specified under the Instance column. The syntax for specifying 

the instance name of the SQL server is <Database>;instance=<instance name>. 

For example, if the SQL instance name is hvac, the syntax for the Instance field for the main 

database called i-Vu Pro_Main would be i-Vu Pro_Main;instance=hvac. 

  

Database User: 

     Login  The username that you entered in step 3c. 

     Password The password that you entered in step 3e. 
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To register your software, you must obtain a license from Carrier and then apply it in the i-Vu® Pro interface.  

1 Log in to the Carrier Community Portal website. 

NOTES 

○ Only Carrier authorized personnel may access the Community Portal website. To set up your account, 

please contact Control Systems Support with the following information: name, phone number, e-mail 

address, office address, and your password of choice. 

○ If you are an end-user or contractor, please contact your local Carrier office to obtain your license. 

 

2 Click Order Management > Licenses & Subscriptions > Software Licenses, then click the link. 

3 Expand the section containing the unregistered license(s) indicated by the  symbol on the right side of 

the blue bar. 

4 Click on the row that shows unregistered in the Registration Status column. 

5 In License Details, complete the fields under Owner Information and Site Information. 

6 Click Register License. 

7 Check I agree to the terms of use. 

8 Click Download License and then save the .properties file to a convenient location to use when installing the 

i-Vu® Pro application. 

 

To apply the license to the i-Vu® Pro application 

During the i-Vu® Pro installation, in the Setup Wizard, on the Product License screen, check Browse to a different 

license, and select the site license you obtained.  

NOTES   

○ Selecting the default license results in a prompt appearing every few minutes in the i-Vu® Pro interface 

to remind you to apply your site license. 

○ Do not edit any part of this registered license file. Editing a license file invalidates the license. 

○ Store the license in a safe location. 

 

To apply the site license after the installation: 

1 In the i-Vu® Pro interface, select System Options > License Administration. 

2 Browse to the license file. 

3 Click Apply. 

4 Restart i-Vu® Pro Server using the rebootserver manual command. 
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PREREQUISITES  

• SiteBuilder v9.0 no longer supports Access, MSDE, or SQL Server Express database types. 

• Installer must have Windows Administrator-level user rights.  

• Have the site's i-Vu® Pro license saved on the computer. 

• USB Link driver - If your computer does not already have the CP210x driver for the USB Link, a prompt to 

install it will appear. You must install it before you connect the USB Link to your computer. Please refer to the 

Silicon Labs website and search "CP210x USB to UART Bridge VCP Drivers" for the most current device 

drivers. 

• For more technical details, see i-Vu® Pro v9.0 client, server, operating system, and database requirements 

(page 13).  

 

Step 1:  Install the i-Vu® Pro application 

1 Insert the Installation USB drive into your computer and click Install i-Vu Pro and the Setup Wizard starts. 

2 In the Setup Wizard, click Next, check I accept the agreement and click Next again. 

3 On the Product License screen, check Browse to a different license, and select the site license.  

NOTE  You can select the default license, but it causes a prompt to appear every few minutes in the i-Vu® 

interface to remind you to apply your site license.  

4 Continue to follow the Setup Wizard. 

NOTE  If running on Windows Server 2008 R2, verify that there are no Failed to Update errors in <logs > 

launcher.txt>. 

 

Step 2:  Install the service 

NOTE  We highly recommend you configure the i-Vu® Pro server to Run as a Service to ensure the i-Vu® Pro 

server starts after a computer reboot.  

1 Click the Windows Start button, then select All Programs > Accessories. 

2 Right-click Command Prompt and select Run as Administrator. 

3 Type:  cd <path to the i-Vu install directory> 

For example, cd c:\i-Vu_Pro_v9.0. 

4 Press Enter. 

5 Type: "i-Vu Pro Service.exe" to install. 

6 Press Enter. 
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Step 3:  Launch i-Vu® Pro service as Administrator 

By default, the i-Vu® Pro Server Service runs under the built-in Local System account that has extensive system 

privileges. If the i-Vu® Pro application runs on its own computer or virtual machine, then running the i-Vu® Pro 

Service under the Local System is acceptable, unless local site policies restrict the Local System account from 

being used for running services. In this case, you can run the i-Vu® Pro application under a user account with 

Administrator privileges, as described below.  

NOTES 

• If you need the Print Alarm Action, the i-Vu® Pro Service must run under an Installer account, not the Local 

System account.  

• If using an Administrator account, ensure that the password for this account does not expire. 

 

1 Click the Windows Start button, then select Control Panel. 

 TIP  If you do not see this option on your Control Panel, click View by: and select Small icons. 

2 Select Administrative Tools and double-click Services. 

3 Double-click i-Vu Pro Service v9.0. 

4 On the Log On tab, select This Account. 

5 Enter the password for a user who is a member of the Administrator Group on that computer. 

 

To uninstall the service 

1 Click the Windows Start button, then select All Programs > Accessories. 

2 Right-click Command Prompt and select Run as Administrator. 

3 Type:  cd <path to the i-Vu install directory> 

For example, cd c:\i-Vu_Pro_v9.0. 

4 Press Enter. 

5 Type: "i-Vu Pro Service.exe"-remove.  

6 Press Enter. 
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Use SiteBuilder to begin setting up your system 

Before starting the i-Vu® Pro application for the first time, you must use SiteBuilder to create a database that the 

i-Vu Pro Server uses to communicate with the system. Follow the steps to Create a new SiteBuilder database. The 

i-Vu® Pro application uses this information to scan your system and find the components.   

PREREQUISITE  For any database type except Apache Derby, you must install and set up the database application 

before creating your system database. An Apache Derby database is installed with your i-Vu® Pro system. As of 

v6.5, SiteBuilder no longer supports Access and MSDE database types. As of v7.0, SiteBuilder no longer supports 

SQL Server Express. 

Follow the procedures below to create your system database in SiteBuilder. 

  

  
 

To create a new SiteBuilder database 

After you create a database in SiteBuilder, you should use the i-Vu® Pro application to automatically discover 

Open, XT, or TruVu™ controllers and/or a system with a single CCN Gateway.  However, you must use SiteBuilder 

to build a system with multiple CCN Gateways. 

 

1 Click File > New. 

2 Enter appropriate values in each of the New Database fields. See table below. 

3 Click Next.  

4 Do one of the following: 

○ If you selected a MySQL, PostgreSQL, or SQL Server® Database Type, enter the Database Connect 

Strings, Login and Database User info. See table below. Then click Next. 

○ If you selected an Apache Derby, go to step 5. 

5 Make language selections. See table below. 

6 Click Next. 

7 Click File > Close. 

8 If you have multiple CCN Gateways, use SiteBuilder to build a Network tree for them. See To build a Network 

tree for a CCN system (page 32).   

9 For BACnet, or single CCN Gateway systems, use the i-Vu® Pro interface to populate your database. You do 

not need to set up the information in SiteBuilder.  

a) Launch the i-Vu Pro Server. Wait for it to finish opening the database. 

b) Browse to http://localhost to open the i-Vu® Pro interface. 

c) Use the login and password you set up in SiteBuilder. 

d) Find your devices and networks and upload the files. See i-Vu® Pro Help for details. 
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 Field Notes 

System Name Enter the name for this system that will be displayed at the top of the i-Vu® Pro 

navigation tree. 

System Parent Directory You can specify a parent directory folder. The default is 

C:\i-Vu_Pro_x.x\programdata\systems. 

System Directory Name The name of the folder within the system parent directory that contains all the system 

files.  

Ex: i-Vu_Pro_x.x\programdata\systems\<system_directory_name> 

This name is automatically generated from the System Name, but it can be edited. 

The System Directory Name must have:  

•  less than 80 characters 

•  only alphanumeric characters, dashes, and underscores 

•  no spaces 

Administrator 

Login Name, Password, 

and 

Confirm Password 

Type a Login Name and Password (8-character minimum) for the Administrator 

operator. 

 CAUTION  To increase the security of your system, do not use "Administrator" as 

the Login Name. 

NOTE  You can change the password requirements in the i-Vu® Pro interface. See 

"Advanced password policy" in i-Vu® Pro Help. 

Database Type Select the type of database your system will use. 

NOTE  If you select Derby, SiteBuilder automatically creates the necessary files and 

folder structures under the i-Vu_Pro_x.x folder. Do not move or rename system files 

or folders. 

Make this the default 

system for iVu 

Select this box to open this system when you start the i-Vu® Pro application.  

Starting Base Network 

Number 

Starting Base Device 

Instance Number 

SiteBuilder automatically assigns sequential numbers to BACnet networks and 

devices as you add them to the database. Choose starting numbers that will generate 

unique network and device instance numbers across all systems that this system will 

communicate with. 

Server BACnet  

Device Instance 

Must be unique to the BACnet network. Unique Server Device IDs are important if you 

are running multiple copies of the i-Vu® Pro application on the same network. 

Languages Select all languages that you want your system to support. 

System Select the language that you want to use for: 

• The default language for new operators 

• Alarms sent to the database 

• State text and object names downloaded to the field 

• The default language for the i-Vu® Pro login page.  

NOTE  You can select a different language on the login page. 

All other information is displayed in the operator's language. 
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For MySQL, PostgreSQL, or SQL Server® Database Types 

Database Connect Strings: 

     Server Type one of the following:  

• localhost if the i-Vu® Pro application and the database are on the same 

machine 

• The name or IP address of the machine that the database is on if different than 

the i-Vu® Pro application 

     Port Do one of the following: 

• Type the appropriate default port number from the list below. 

• Type the port number that the database uses for communication if different than 

the database default.  

 Default ports are: 

MySQL 

PostgreSQL 

SQL Server 

  

3306 

5432 

1433 

     Instance The name that you gave the i-Vu® Pro database in the database application. 

  

Database User: 

     Login  The user login that you set up in the database application. 

     Password The password that you set up in the database application. 

  

NOTE  To change Database Connect Strings for an existing system, select the Modify database connection 

parameters in the File > Open dialog box, then click Next.  

  

  
 

To build a Network tree for a CCN system 

See details on the following in SiteBuilder Help and i-Vu® Pro Help. 

 

If your CCN system has... You must... 

A single CCN Gateway Use the i-Vu® Pro application to find and download the Gateway and system 

An i-Vu® Integrator Add it in SiteBuilder, even if it is the only CCN Gateway. See "To add an i-Vu® 

Integrator" in SiteBuilder Help. 

 

Multiple CCN Gateways without 

a NAT router 
1 In the SiteBuilder Network tree, add one site with one BACnet/IP network 

for each Gateway.  

2 In the i-Vu® Pro interface, discover all the Gateways, Bridges, and 

controllers.  

NOTES 

• You must have the Multi-CCN license for this feature to work. 

• Supports up to 50 CCN Gateways in one system 

• Every Gateway must be Bus 0. 

• Every BACnet/IP Network Number must be the same.  
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If your CCN system has... You must... 

Multiple CCN Gateways with a 

NAT router 
1 In SiteBuilder, configure the NAT information. 

2 In the Network tree, add one site with one BACnet/IP network per 

Gateway. 

3 Add one CCN Gateway and all its Bridges to each site you set up. 

4 In the i-Vu® Pro application, discover the rest of your controllers under the 

Bridges. 

NOTES 

• You must have the Multi-CCN license for this feature to work. 

• Supports up to 50 CCN Gateways in one system 

• Every Gateway must be Bus 0. 

• Every BACnet/IP Network Number must be the same. 

  

 

CCN Gateways and Bridges can be any of the following: 

• i-Vu® Link 

• i-Vu® CCN Router 

• i-Vu® Integrator 

• Carrier® ChillerVu™  

 

NOTE  For your i-Vu® Control System, use the i-Vu® Pro application to find your i-Vu® Open, XT, and TruVu™ 

routers and controllers. You do not need to set up the information in SiteBuilder. 

 

  

  
 

Options for running the i-Vu® Pro system 

Running i-Vu Pro Server without connecting to controllers 

To verify links between graphics and to set up properties, schedules, alarms, and trends before you connect to the 

network, run i-Vu Pro Design Server instead of i-Vu Pro Server. Then view the i-Vu® Pro interface in a web browser. 

 

NOTE  Question marks indicate correct microblock paths. Missing data indicates errors. 

 
 

Switching i-Vu Pro Server to a different system 

Design engineers working on multiple projects can switch systems in the i-Vu Pro Server application. 

1 In the i-Vu Pro Server application, select Server > Change Active System. 

2 Select a different system and mode. 

3 Click Select. 
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Running i-Vu Pro Server as a Windows® service 

For Windows 8.1, 10, 11, 2012R2, 2016, 2019, 2020, and 2022 

Run i-Vu Pro Server as a Windows service if you want i-Vu Pro Server to automatically start up when the server 

computer is restarted.  

NOTE  If your i-Vu® Pro system uses a database other than Derby and the database is located on the same 

computer as i-Vu Pro Server, you must set up Windows to delay starting i-Vu Pro Server until the database service 

has started. See "How to delay loading of specific services" on the Microsoft® website. 

 
 

To install i-Vu® Pro Server service 

NOTE  If you are not sure if the service was previously installed, see To determine if i-Vu Pro Server service is 

installed (page 36). 

 

1 In the Windows Start menu, select All Programs > Accessories. 

2 Right-click Command Prompt, then select Run as administrator. 

3 Select Yes in the User Account Control message. 

4 In the Command Prompt window, type:  cd <path to the i-Vu Pro install directory> 

For example, type:  cd c:\i-Vu_Pro_x.x 

replacing x.x with your current version number. 

5 Press Enter. 

6 Type:  "i-Vu Pro Service.exe" 

7 Press Enter. 

 
 

To start i-Vu® Pro Server as a Windows service 

1 In the Windows Start menu, select Control Panel. 

2 Select Administrative Tools, then double-click Services. 

3 In the Services (Local) list, double-click i-Vu Pro Service X.X. 

4 In the Startup type drop-down list, select Automatic. 

5 On the Log On tab, do one of the following: 

○ Use the defaulted Local System account. 

○ Select This account, then browse to select a user who is a member of the Administrator Group on that 

computer. 
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6 Optional:  If you selected Local System account in step 5 and you want to be able to access i-Vu Pro Server 

on the server computer's desktop, check Allow service to interact with desktop. 

NOTES   

○ If you do not check this field, the computer screen will give no indication that i-Vu Pro Server is running; 

you must view the computer's Services page to see if it is running. 

○ This checkbox applies only to a user logged in on the server. A Windows Remote Desktop user cannot 

access i-Vu Pro Server running as a service. 

○ If you check this field, you cannot use the instructions below to set up printing to a network printer. Ask 

your Network Administrator to set up Local System account to use a network printer. 

○ If you check this field and the i-Vu® Pro application is to run email alarm actions, ask your Network 

Administrator to set up Local System account to send emails. 

7 On the General tab, click Start. 

8 Click OK. 

NOTE  If i-Vu Pro Server does not start after you click Start, you may have a Windows permissions problem. Follow 

the procedure below in To set up the i-Vu Pro service for network printing (page 35) to set up the Windows user 

name and password. 

 

 
 

To set up the service for network printing 

If i-Vu Pro Server runs as a service on a computer that is using a network printer, you must set up the Windows 

user name and password for the service. The Print alarm action requires this setup to be able to print. 

1 In the Windows Start menu, select Control Panel. 

2 Select Administrative Tools > Services. 

3 Double-click i-Vu Pro Service x.x. 

4 On the Log On tab, select This account. 

5 Browse to the computer's domain, then select the user that the service will log in as. 

NOTE  Contact your network administrator if you need help determining the domain. 

6 Type the user's password in the Password and Confirm password fields. 

 

 
 

To stop or uninstall i-Vu® Pro Server service 

To stop i-Vu Pro Server service 

1 In the Windows Start menu, select Control Panel. 

2 Select Administrative Tools, then double-click Services. 

3 In the Services (Local) list, double-click i-Vu Pro Service X.X (where x.x is the i-Vu Pro version number. 

4 In the i-Vu Pro Service x.x Properties dialog box, click Stop on the General tab. 

5 Click OK. 
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To uninstall i-Vu Pro Server service 

1 In the Windows Start menu, right-click Command Prompt, then select Run as administrator. 

2 Select Yes in the User Account Control message. 

3 In the Command Prompt window, type:  cd <path to the i-Vu Pro install directory> 

For example, type:  cd c:\i-Vu_Pro_x.x 

4 Press Enter. 

5 Type:  "i-Vu Pro Service.exe" -remove 

6 Press Enter. 

 

 
 

To determine if i-Vu® Pro Server service is installed 

If you do not know if the service was previously installed, follow the appropriate steps below. 

 

1 In the Windows Start menu, right-click Command Prompt, then select Run as administrator. 

2 Select Yes in the User Account Control message. 

3 In the Command Prompt window, type:  cd <path to the i-Vu Pro install directory> 

For example, type:  cd c:\i-Vu Prox.x 

4 Press Enter. 

5 Type:  "i-Vu Pro Service.exe" -check 

6 Press Enter. 
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Update the SAL library 

The i-Vu® Pro SAL files update your i-Vu® Pro controllers. The SAL libraries contain control programs, graphics, 

drivers, screen files, and other important controller data.  

Carrier periodically provides updates, which include enhancements and bug fixes. 

NOTES 

• The library update only changes default graphics. If you have edited your graphic in ViewBuilder, it is not 

updated. 

• The last digits in the SAL library name are the release date of the library. 

• All of the SAL files will not necessarily have the same <date> revision. 

• To ensure that your installation is running the latest software, we recommend that you check Control Systems 

Support  http://www.hvacpartners.com/ for updates. Download the latest SAL files and apply them to all 

new installations. 

• If you are changing to an older SAL file than the current one being used, a warning asks you if you are sure 

you want to apply an older version. 

NOTE  Keep copies of the latest libraries in a safe place. In the event of a system restore, the updated .sal file 

must be reapplied. 

 

To check current SAL library version 

1 Login to the i-Vu® Pro application. 

2  Click , then select System Options > Update tab. 

3 Click Current Libraries (.sal) to view the current SAL libraries and their revision date. 

 

Step 1: Update library  

1 Save the updated library (.sal file) to your computer. 

2 Click , then select System Options > Update tab. 

NOTE  Expand Current Libraries (.sal) to see the current SAL libraries and their revision. Compare them to 

what you downloaded from the Control Systems Support to determine if any of them have been updated. 

3 Click  and browse to the updated .sal file that you have saved on your computer, select the 

file, and click Open. 

4 Click Continue. 

5 When process is complete, the message appears File added successfully. 

6 Click Close. 

NOTE  These changes are not applied to the controllers until you have updated routers and controllers. 

 

System Management 
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Follow these steps to implement the new equipment library: 

Step 2: Update the files for the routers and controllers 

1 On the i-Vu® Pro navigation tree, right-click the router or controller to update and select Driver Properties. 

2 Select Properties tab > Update tab > Add New Driver tab. 

3 If the database contains two or more controllers, select which routers to change: 

○ This controller only 

○ All controllers on this network that use the current driver version 

○ All controllers in the system that use the current driver version 

4 Click Update. 

5 Click Save. 

NOTES 

• Check Stage driver in controller to stage the driver to the controller before installing it. Use this option to 

avoid interrupting controller function when installing the driver. 

• Click Delete Unused to delete all unused drivers in <system_name>\drivers. 

 

Step 3: Update the files for CCN controllers 

1 In the navigation tree, select the CCN device manager associated with the controllers that are to be updated. 

2 Select Devices > CCN Discovery and re-scan any controllers that need to be updated by checking Rescan 

Controllers Selected Below for Configuration Changes and clicking Start Scan. 

 

Step 4: Apply the update to the routers and controllers 

1 Select the System  in the navigation tree and then select the Downloads page. 

2 If you wish to apply the new SAL file to your entire system, you can use this page to compare to your 

navigation tree and verify that you have selected all of your routers and controllers for download. 

NOTE  Only the CCN Gateway and device managers require download, so the CCN controllers/equipment are 

not listed. 

3 A network's controllers download in the order shown. To change the order, select a controller(s), then drag 

and drop or click Move to Top or Move to Bottom. 

EXCEPTION  If a controller's router requires a download, it will download first regardless of its position on the 

Downloads page. Click the Start button. 

NOTES 

○ Use Ctrl+click, Shift+click, or the Select All checkbox to select multiple controllers.  

○ See To download from the Downloads page in Help for more details. 
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To back up a system 

The type of database your system uses determines the method you use to back up the system. 

 CAUTION  Do not use SiteBuilder's Replicate feature to back up your database. 

 

For Apache Derby 

1 Shut down the SiteBuilder and i-Vu Pro Server applications. 

2 Copy your system folder. 

3 Paste the copy to a new location. 

 TIP  Zip the copy before transporting it over a network or to a USB drive.  

 

For MySQL, MS SQL Server, PostGreSQL, or SQL Server Express 

1 Copy your system folder. 

2 Use the database management system's backup method. See To safely shut down the i-Vu® Pro application 

for database server maintenance before doing any maintenance on your database server. 

 

 
 

Communicating using PuTTY 

You can connect a computer to a controller's Local Access port and then use PuTTY, a free open source terminal 

emulation program, to: 

• Set the baud rate for ports S1 on the i-Vu® Open Router, i-Vu® Open Link, or Carrier® ChillerVu™ 

• Set controller properties, such as IP address and network information 

• Retrieve a Modstat 

NOTE  Use Network Service Tool V to set the CCN baud rate and configure IP settings for an i-Vu® CCN Router, 

i-Vu® Link, or Carrier® ChillerVu™. 

PREREQUISITES 

• A computer with a USB port 

• A USB Link cable   

The USB Link driver is installed with an i-Vu® Pro v6 or later system. Please refer to the Silicon Labs website 

and search for "CP210x USB to UART Bridge VCP Drivers"  for the most current device drivers. Install the 

driver before you connect the USB Link to your computer. 

   

 CAUTION  If multiple controllers share power but polarity was not maintained when they were wired, the 

difference between the controller's ground and the computer's AC power ground could damage the USB Link and 

the controller. If you are not sure of the wiring polarity, use a USB isolator between the computer and the USB 

Link. Purchase a USB isolator online from a third-party manufacturer. 
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1 Download and install PuTTY from the PuTTY website 

(http://www.chiark.greenend.org.uk/~sgtatham/putty/download.html). 

2 Connect the laptop to the local access port of the controller, ZS sensor, or an SPT sensor using the USB Link 

cable(s). 

  

USB Link

Connect to

Local Access port

12 ft

Connect to

USB port

7 3/4 in.

 

  

NOTE  If using a USB isolator, plug the isolator into your computer's USB port, and then plug the USB Link 

cable into the isolator. 

3 To change a router's IP address, subnet mask, or default gateway, set its IP Address DIP switch to Assigned. 

4 Start PuTTY. 

5 Under Category > Connection, select Serial. 

6 Under Options controlling local serial lines, enter the following settings: 

  

Field Value 

Serial line to connect to Replace X with the computer's port number that the USB Link cable is 

connected to.  

NOTE  To find the port number, select Start > Control Panel > System > 

Device Manager > Ports (Com & LPT). The COM port number is beside 

Silicon Labs CP210x USB to UART Bridge.  

 

 

Speed (baud) 115200 

Data Bits 8 

Stop Bits 1 

Parity None 

Flow Control None 

    

7 Click Open. A window similar to the one below appears. 

 

http://www.chiark.greenend.org.uk/~sgtatham/putty/download.html


 System Management

  

 

 

 
i-Vu® Pro v9.0  ©2025 Carrier. 

Installation Guide  All rights reserved. 

 41 

 

8 Do one of the following: 

○ To change a property value: 

a.  Type the number of the property, then press Enter. 

b.  Type the new value, then press Enter. 

○ To take an action, type number of the action, then press Enter. 

9 If you changed a value, type 1, then press Enter to restart the controller. 

10 Close PuTTY. 

  

  
 

Communicating using HyperTerminal 

You can connect a computer to a controller's Local Access port and then use HyperTerminal, an application 

installed with Windows XP and older operating systems, to: 

• Set the baud rate for ports S1 or S2 on the i-Vu® Open Router or i-Vu® Open Link 

• Set controller properties, such as IP address and network information 

• Retrieve a Modstat 

NOTE  Use Network Service Tool V to set the CCN baud rate and configure IP settings for an i-Vu® CCN Router or 

i-Vu® Link. 

 

PREREQUISITES 

• A computer with a USB port 

• A USB Link cable   

NOTE  The USB Link driver is installed with an i-Vu® Pro v6 or later system. Please refer to the Silicon Labs 

website and search "CP210x USB to UART Bridge VCP Drivers" for the most current device drivers. Install the 

driver before you connect the USB Link to your computer. 

 CAUTION  If multiple controllers share power but polarity was not maintained when they were wired, the 

difference between the controller's ground and the computer's AC power ground could damage the USB Link and 

the controller. If you are not sure of the wiring polarity, use a USB isolator between the computer and the USB 

Link. Purchase a USB isolator online from a third-party manufacturer. 

1 Connect the computer to the local access port of the controller, ZS sensor, or an SPT sensor using the USB 

Link cable(s). 

 

NOTE  If using a USB isolator, plug the isolator into your computer's USB port, and then plug the USB Link 

cable into the isolator. 

2 Verify that the baud rate is set to 115,200. 

3 To change a router's IP address, subnet mask, or default gateway, set its IP Address DIP switch to Assigned. 
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4 Start Windows HyperTerminal located under Start > Programs > Accessories > Communications. 

5 NOTE  This option is not available in Windows v7 or later. You can download it from the Internet. 

6 Select an icon for this connection file, then click OK. 

7 In the Connect to dialog box, set the Connect using field to ComX, where X is the number of the computer's 

Com port that the USB Link cable is connected to, then click OK. 

8 In the Com Properties dialog box, set the Port Settings for your local access port, then click OK. 

Port Setting Value  

Bits per second 

 

i-Vu® Open Link or i-Vu® Open 

Router 

i-Vu® Link or i-Vu® CCN Router 

115200  

  

Data Bits 8  

Parity None  

Stop Bits 1  

Flow Control None  

 

9 From the main HyperTerminal screen, press Enter to view a router configuration screen like the one below.  

 

 

10 Do one of the following: 

○ To change a property value: 

a.  Type the number of the property, then press Enter. 

b.  Type the new value, then press Enter. 

○ To take an action, type number of the action, then press Enter. 

11 If you changed a value, type 1, then press Enter to restart the controller. 

12 Close HyperTerminal. 
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Important changes to this document are listed below. Minor changes such as typographical or formatting errors are not 

listed. 

  

 Date Topic Change description Code* 

4/14/25 Update the SAL library Updated procedure for new interface X-PM-RD-E-RD 

  

*  For internal use only 
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