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Prerequisite 

Verify that you have the latest version of all the add-ons that are currently used. Some have been updated for the 
i-Vu v7.0 application. Be sure to have those updated add-ons ready to install during the upgrade process. 

 

Follow these upgrade procedures: 

Upgrading a single system to the i-Vu Standard/Plus v7.0 application (page 2) 

Upgrading a mixed system to the i-Vu Plus v7.0 application (page 17)  

Upgrading to the i-Vu Pro v7.0 application (page 34) 

 

 

 

Upgrading to the i-Vu v7.0 application 



Upgrading a single system to the i-Vu Standard/Plus v7.0 application  
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Use the following instructions to upgrade a single i-Vu CCN or i-Vu Open system.  

NOTES 

• If you are running a mixed CCN and Open system, see To merge a mixed system to the i-Vu Plus v7.0 application. 
(page 17)  

• You cannot downgrade an i-Vu CCN Pro database to the i-Vu Standard/Plus v7.0 application. 

• The i-Vu CCN v4.0 application must be upgraded to v4.2 before you can install v7.0. 

 

i-Vu web server models  
You MUST check your model to ascertain if you need to upgrade and purchase a new one. The model number is 
on the bottom of your web server.  

 

i-Vu web server model number System limits 

MP945-xx or MP965-xx You must purchase a new web server to accommodate v7.0. 

MP45-xx or MP65-xx 
or 
NUC5i3MYHE or NUC7iDNHE 

USB Router -  

• 140 CCN controllers 

or  

• 60  i-Vu Open controllers 

 
External routers - 750 controllers 

Total combined - 750 controllers 

The table below is a quick outline of steps. Each step is explained in detail in the sections that follow. 

 

Existing system Procedure 

i-Vu CCN Standard v4.0 application You MUST upgrade to i-Vu CCN v4.2 application before you can 
install v7.0. Also, you must replace web server model MP945-xx or 
MP965-xx. See table above for details. 

Upgrade to v4.2: 

1 Backup system to your PC or USB from Management Tool. 

1 Connect upgraded web server to your network. 

2 Install i-Vu v4.2 application on the web server using the DVD or 
USB drive.  

3 Restore system to upgraded web server from the Management 
Tool. 

4 Follow instructions to upgrade v4.2 to v7.0. 

Upgrading a single system to the i-Vu Standard/Plus v7.0 application 
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Existing system Procedure 

Any of the following: 

• i-Vu CCN Standard v4.2 application with 
USB CCN  Adapter 

• i-Vu CCN Plus v4.2 application with i-Vu 
CCN Router or i-Vu Link 

• i-Vu Open Standard v5.0 or v5.1 
application with USB Open Adapter 

• i-Vu Open Standard or Plus v5.0 and later 
application with an i-Vu Open Router, i-
Vu Open Link, or i-Vu XT or TruVu 
routers. 

1 Backup system to your PC or USB from Management Tool. 

2 Install i-Vu v7.0 application on your web server from the 
Installation USB drive.  

3 Restore system to upgraded web server from the Management 
Tool. 

NOTE  If you purchase a new web server, follow steps 1 and 3 above. 

 

 

Capture current i-Vu web server settings 

Access the Management Tool using one of the following methods: 

• Click , then select System Options > General tab > Management Tool.  

• Launch your browser and type your system name followed by :8080. For ex.: http://ivu:8080/. 

 

Print the Management Tool screen or record all of the information under Addressing and i-Vu Port Configuration. 

•  i-Vu Standard v4.2 addresses 

 
 

• i-Vu Plus v4.2 addresses 
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• i-Vu Standard or Plus v5.1 addresses 

  
 

• i-Vu Standard or Plus v6.0 and later addresses 
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Backup data from Management Tool 

Access the Management Tool using one of the following methods: 

• Click , then select System Options > General tab > Management Tool.  

• Launch your browser and type your system name followed by :8080. For ex.: https://ivu:8080/. 

 

Use either of the following methods to backup your data: 

 

Backup data to your computer 

1 Click PC Backup under Manage Server Data to save the entire database zipped into one file to your 
computer. 

2 Click OK when you see the message The system will be stopped and restarted. Do you wish to proceed? 
Watch Operation Status to see the progress. 

3 Click the message Save/Download Backup File to Your Local Hard drive when it appears.  

4 Click Save when asked Do you want to open or save this file? 
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5 Save this system.backup.tgz file to a convenient location on your computer.  

CAUTION! Do not alter the name of this file! 

6 Exit from Management Tool. 

 

Backup data to a USB drive 

1 Plug your own USB drive into any available USB port on your i-Vu web server. 

 CAUTION  Do not use the i-Vu Restore USB drive!   

2 Click USB Backup under Manage Server Data. 

3 Click OK when you see the message The system will be stopped and restarted. Do you wish to proceed?  

4 When Operation Status says No Background Operations Currently Active, remove USB drive from the i-Vu 
web server.  

5 Exit from Management Tool. 

 

 

Install new i-Vu v7.0 software 

  CAUTION  If you are using a USB CCN or Open Adapter with an upgraded web server, you must connect the 
cable to your network and the web server before you start the i-Vu v7.0 application.  

 

1 Remove the i-Vu web server from the network by disconnecting the LAN cable. 

2 Insert the USB Installation drive into the USB port on the web server. 

3 Shut down the i-Vu web server by pushing the On/Off button once.  

NOTE  For MP model number i-Vu web servers, wait for the blue light to turn off (could take as long as 2 
minutes). 

4 Press the On/Off button again to restart the web server. The installation begins automatically. 

5 The USB Installation drive's light goes off when the installation is complete. This process takes several 
minutes. 

NOTE  Do not power off during the installation. 

6 Remove the USB drive.  
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Access updated system 

  CAUTION  If you are using a USB CCN or Open Adapter with an upgraded web server, you must connect the 
cable to your network and the web server before you start the i-Vu v7.0 application.  

 

1 Connect a LAN cable between the computer and the i-Vu web server. 

2 Make sure that the computer is set up for DHCP. 

3 Allow about a minute after connecting the LAN cable for the IP addressing to complete. 

4 Launch Internet Explorer to access your system. Type http://ivu.   

NOTES 

○ Use only the i-Vu interface to navigate through the i-Vu interface; do not use the browser’s navigation 
buttons. 

○ Disable all popup blockers. IE > Tools > Turn Off Popup Blocker.   

5 Enter login name and password. 

6 Accept License Agreement. 

 

On the Startup page:  

1 You must carefully select the USB Network Type. If you change from using a router to a cable at a later time, 
you will lose all your settings and have to restore to factory defaults. 

NOTE  Do not fill in any other blank fields on the Startup page. Restoring your system in will automatically fill 
in the other information. 

 
2 Click Link to Management Tool at the bottom of the screen.   
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Restore data from backup 

1 Click PC Restore or USB Restore under Manage Server Data in the Management Tool. 

○ PC Restore - Browse to your backup file and click Upload File, then click Perform Restore. 

○ USB Restore - Place your backup USB drive in any port on the i-Vu web server. Select the backup file and 
click Perform Restore. 

2 Restore is complete when Operation Status displays No Background Operations Currently Active. 

 

 

Restore Addressing and set NTP (Network Time Protocol) 

1 Refer to the data recorded from your original i-Vu web server. See Capture current i-Vu web server settings. 
(page 5) 

2 Enter your previous Name. 

3 If your original setup did not have Obtain an IP address automatically checked, then enter ALL of the IP 
address information from the original configuration. 

4 Enter your original settings in i-Vu Port Configuraton. 

 

Configuring NTP 

Network Time Protocol (NTP) is a networking protocol for clock synchronization. You can designate an NTP source 
that sends the correct time to the i-Vu web server, ensuring constant accurate time. You can enter 2 static 
addresses (DNS name or IP) of NTP servers or use the default addresses provided by the i-Vu application. If you do 
not enable NTP, the i-Vu system clock must be monitored and updated regularly in System Options > General tab.  

You can configure DHCP servers to supply IP addresses of NTP servers to the i-Vu web server. If you have checked 
Obtain an IP address automatically and Enable Time Synchronization, the i-Vu web server tries to obtain an NTP 
server address from the DHCP server on site. If it cannot find one, the i-Vu web server uses the User Assigned NTP 
addresses, if any, in the User Assigned fields. 

 CAUTION Contact your Network Administrator for guidance in entering these settings.  

You can access NTP from a local server, a remote server, or a website. To set up NTP: 

1 Verify that Enable time synchronization from an NTP server is checked. 

2 System Assigned NTP Server Address - To use this read-only field, make sure you have checked Obtain an IP 
address automatically to allow your system to search for an address for the NTP server and display a primary 
and alternate address. 

3 User Assigned NTP Server Address - You can use the default website addresses if your system allows it. 
Firewalls may prevent successful access to the default websites. Your Network Administrator can provide 
alternate addresses for a local server, a remote server, or a website. 

 

After entering address and/or NTP settings 

1 Click Apply Changes to save your updated settings. The web server automatically reboots. 

2 Close the Management Tool. 

3 Disconnect the LAN cable between the computer and the i-Vu web server and reconnect the web server to the 
customer’s LAN. 
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Start the i-Vu application 

1 If necessary, reconfigure the computer to access the i-Vu web server over the customer’s network. 

2 Launch your browser, access the i-Vu interface, and login.  

3 Since the database was restored, the you must adjust the following: 

○ Timezone, Date  - select appropriate options 

○ Time - enter the correct time! The i-Vu web server will not automatically read the time from your 
computer. 

 
4 Click Next. 

5 Review entries. Click Submit. Wait for your system to launch. It will take a minute. If you get an error, type 
http://<your system name> in your browser and refresh. 

 

 

Update the SAL library 

The i-Vu SAL files update youri-Vu controllers. The SAL libraries contain control programs, graphics, drivers, screen 
files, and other important controller data.  

Carrier periodically provides updates, which include enhancements and bug fixes. 

NOTES 

• The library update only changes default graphics. If you have edited your graphic in ViewBuilder, it is not 
updated. 

• The last digits in the SAL library name are the release date of the library. 

• All of the SAL files will not necessarily have the same <date> revision. 

• To ensure that your installation is running the latest software, we recommend that you check Control Systems 
Support  http://www.hvacpartners.com/, https://accounts.ivusystems.com/ for updates. Download the 
latest SAL files and apply them to all new installations. 

• If you are changing to an older SAL file than the current one being used, a warning asks you if you are sure you 
want to apply an older version. 

NOTE  Keep copies of the latest libraries in a safe place. In the event of a system restore, the updated .sal file 
must be reapplied. 

 

Check current SAL library version 

1 Login to the i-Vu application using the Installer role. 

2  Click , then select System Options > Update tab. 

3 Click Current Libraries (.sal) to view the current SAL libraries and their revision date. 

http://www.hvacpartners.com/
https://accounts.ivusystems.com/
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Update library 

1 Save the updated library (.sal file) to your computer. 

2 Click , then select System Options > Update tab. 

NOTE  Expand Current Libraries (.sal) to see the current SAL libraries and their revision. Compare them to 
what you downloaded from the Carrier Control Systems support website to determine if any of them have 
been updated. 

3 Click  and browse to the updated .sal file that you have saved on your computer, select the 
file, and click Open. 

4 Click Continue. 

5 When process is complete, the message appears File added successfully. 

6 Click Close. 

NOTE  These changes are not applied to the controllers until you have updated your routers and controllers. 

 

 

Install self-signed certificates for network security in v7.0 

For security purposes, you must install a self-signed certificate on every computer used to access the i-Vu 
application using "https". A user who has the Installer Role and will be accessing the Management Tool needs a 
second certificate. 

You will get a browser certificate error when using "https" to access the i-Vu application and the Management Tool 
until you install the certificates on your computer.  

IMPORTANT  We highly recommend that you have the appropriate browser certificates in place before finding and 
uploading your devices and building your system in the i-Vu application.  

 

 CAUTION  If you ever change the Network Name, the IP address, or DNS IP address, you must download both 
certificates again.  

 

The i-Vu application 

1 After setting up the information on the Startup screen, log out. 

2 Launch your browser and type https://<your system name> or Server IP address. For ex.: https://ivu/ or 
https://172.21.319.123. 

NOTE  Use the TLS indicator https instead of http.  

3 There will be a certificate error in your browser. Follow the steps listed below to install a certificate for the 
browser you are using to access the i-Vu application. 
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The Management Tool 

After installing the certificate for browsing to the i-Vu application, you must install another one for accessing the 
Management Tool. 

1 Log out of the i-Vu application. 

2 Launch your browser and type your system name or Server IP address followed by :8080.  For ex.: 
https://ivu:8080/ or https://172.21.319.123:8080 

3 You will see a certificate error again. Follow the directions below for the browser you are using.   

 

Instructions to install a self-signed certificate  
 

Internet Explorer® 

1 If the page displays There is a problem with this website's security certificate, click Continue to this website. 

2 Enter your Username and Login. 

3 In the address bar, click Certificate Error.  

4 Click View Certificates to open the Certificate dialog. 

 
 

5 On the Details tab, select Issuer, then click Copy to File. 

6 In the Certificate Export Wizard, click Next and Next again. 

7 Browse to the folder on your computer that you want to save the certificate in, enter a name, then click Next. 

8 Click Finish. 

9 Click OK to close the message The export was successful.  

10 Click OK to close Certificate window. 

11 To import the certificate, Select Tools or  > Internet Options. 

12 On the Content tab, click Certificates, and then select Trusted Root Certification Authorities tab. 

13 Click Import. 

14 Click Next in the Certification Import Wizard. 
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15 Browse to the certificate you saved and click Open, then Next. 

16 Select Place all certificates in the following store. 

17 Click Browse and select Trusted Root Certification Authorities. 

18 Click Next. 

19 Click Finish. 

20 Click Yes in the Security Warning dialog box to install the certificate. 

21 Click OK. 

22 Click Close again and then OK. 

23 Close Internet Explorer, then open it again. 

24 Log in to the i-Vu application. 
  

NOTE  Chrome and Windows browsers use the same Certificate store, so it is not necessary to install a certificate 
obtained through Internet Explorer in a Chrome Browser used on the same computer. 

 

 

Google™ Chrome™ 

When connecting to the i-Vu application or Management Tool without a self-signed certificate installed, you will 
see the following. 

 

 
 

1 Export certificate to a known location: 

a) In the address bar, click Not secure. 

b) Click Certificate (Invalid) to open the Certificate dialog. 

c) On the Details tab, select Issuer, then click Copy to File. 

d) In the Certificate Export Wizard, click Next and Next again. 
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e) Browse to the folder on your computer that you want to save the certificate in, enter a name, click Save, 
then Next. 

f) Click Finish. 

g) Click OK to close the message The export was successful. and click OK again to close the Certificate 
dialog. 

2 Import saved certificate: 

a) Click  on the browser toolbar, then select Settings. 

b) Click Advanced. 

c) Scroll down to Privacy and security, then click Manage certificates. 

d) On the Trusted Root Certification Authorities tab, click Import. 

e) In the Certificate Import Wizard, click Next. 

f) Click Browse, then select the file you exported in step 2. 

g) Click Open. 

h) Click Next, and Next again, then Finish. 

i) Click Yes to the Security Warning popup, then OK to the Import was successful message. 

j) Close the Certificates window. 

k) Close Chrome, then open it again. 

NOTE Chrome and Windows browsers use the same Certificate store so it won’t be necessary to install this 
same certificate in a Window Browsers used on the same PC.  

  

Mozilla® Firefox®   

1 Open the i-Vu application or the Management Tool using Mozilla® Firefox®. 

2 Click the Advanced button on the page stating Warning: Potential Security Risk. 

3 Click Accept the Risk and Continue. 

4 Firefox displays the following icon near the URL window indicating that an exception has been made for this 
site 
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Update your routers and controllers 

 CAUTION  Update your routers and controllers only once. Use either the i-Vu application or Field Assistant. 

Router and controller configurations are maintained when you update them using the procedure below. 

Step 1: Update the files for routers 

1 Select the router that you wish to update in the navigation tree. 

2 Right-click and select Driver Properties.  

3 Select Properties page > Update tab.  

4 If the database contains two or more routers, you must check Change for all controllers of this type? in the 
Controller section. 

5 Click Update. A message appears Changes the driver and screen file to use the current library version. 
Continue?  

NOTE  If more than one router exists, the additional routers are listed below the Update button. 

6 Click OK.  

7 Click Accept. 

 

Step 2: Update the files for controllers 

1 Double-click the controller in the navigation tree or right-click and select Configure.   

2 If you have multiple controllers of the same type, enable Change for all control programs of this type?. 

3 Click Update under Control Program. A message appears Changes the control program, view, driver, and 
screen file to use the current library version. Continue?  

4 Click OK. When the message Updated to the library version xx. appears, click Close. 

5 Repeat steps 1 - 4 for any additional types of controllers. 

6 Click Close again. 

 

Step 3: Update the files for CCN controllers 

1 In the navigation tree, select the CCN device manager associated with the controllers that are to be updated. 

2 Select Devices > CCN Discovery and re-scan any controllers that need to be updated by checking Rescan 
Controllers Selected Below for Configuration Changes and clicking Start Scan. 
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Step 4: Apply the update to routers and controllers 

1 Select the System  in the navigation tree and then select the Downloads page. 

2 If you wish to apply the new SAL file to your entire system, you can use this page to compare to your 
navigation tree and verify that you have selected all of your routers and controllers for download. 

NOTE  Only the CCN Gateway and device managers require download, so the CCN controllers/equipment will 
not be listed. 

3 A network's controllers download in the order shown. To change the order, select a controller(s), then drag 
and drop or click Move to Top or Move to Bottom. 
EXCEPTION  If a controller's router requires a download, it will download first regardless of its position on the 
Downloads page. Click the Start button. 

NOTES 

○ Use Ctrl+click, Shift+click, or the Select All checkbox to select multiple controllers.  

○ See To download from the Downloads page in Help for more details. 

 

 

 

Upgrade v4.2 Standard with USB Gateway connection to v7.0 with 
external i-Vu CCN Gateway 

1 Verify that the i-Vu CCN Router or i-Vu Link you are planning to use for the CCN Gateway is turned on and the 
IP address is set to the same IP address as the internal USB Gateway in i-Vu v4.2 Standard and the same 
CCN address.  

NOTES 

○ Do not connect it to the LAN or the CCN bus at this time! 

○ Document all users, passwords, and security levels. The clipping file does not include the Operator data 
and it will be lost. 

2 Disconnect the USB converter from the server and follow the instructions to upgrade the i-Vu 4.2 server to i-
Vu v7.0. See To upgrade a single system to the i-Vu Standard/Plus v7.0 application (page 2).  

3 After verifying that the database was properly restored, go to System Options > General tab, expand 
Clippings and click Clipping file: Export. It could take several minutes for the file to generate. 

4 Click Save. Click Save as, select a location on your computer and type a file name. Click Save. 

5 On the System Options > General tab, click Management Tool.   

6 Click Factory Default to restore the server back to factory defaults.  

7 On the i-Vu Startup screen, accept the agreement, enter an Installer name and password, enter the same site 
name that you are importing and check This server will connect to a BACnet network through a USB adaptor.  

8 Select the correct time zone, adjust the time, and then click Submit and Submit again to start the system. 

9 Go to System Options > General tab and click Management Tool. 

10 In the Management Tool, change the USB Network Address: to 127.0.0.1 and click Apply Changes. Close the 
Management Tool. 

11 Connect the external i-Vu CCN Router/Link, that you set up in step 1, to the LAN and the CCN bus. 

12 On to System Options > General tab, expand Clippings and click Clipping file: Import.  
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13 Navigate to the clipping you saved, select the file, and click Next. After uploading, all of the areas to be 
imported are displayed. Select Next to continue. The clipping import progress is displayed, followed by any 
issues encountered during the import.  

14 Click Non-Critical Errors to verify that the internal Gateway has been converted to an external Gateway. Select 
Next to continue. 

 
 

15 Select Finish. The message Committing import changes to system displays. The screen closes when 
complete.  

16 On the Installer tree, select the controller at the top of the navigation tree and then select Devices > Manage 
tab to verify that the i-Vu CCN Router/Link is listed. 

17 Select the i-Vu CCN Router/Link in the list on the page and click Download All Content to download all the 
programs, including the updated driver, if applicable. 

18 Go to System Options > Operators and add the operators that you recorded in step 1. 
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Terms to know: 

• Restore files – restores all settings, including database, operators, alarms, and trends  

• Source files – includes drivers, .equipment, .view, .bacview files, and .touch files 

• Clipping files –  

○ Navigation tree items including attached control programs, graphics, drivers, and screen files 

○ Trend data 

○ Reports 

○ Alarm categories 

○ Schedules and schedule group membership (including the entire schedule group and schedules, if it 
does not exist in the target system) 

○ Alarm actions 

NOTES 

○ Does not include operators or alarms 

○ A clipping containing CCN controllers does not include the CCN tables. When importing a clipping 
containing CCN devices, you must re-scan the table. 

NOTE  A system clipping file takes time to import. You can see the estimated time for each database in 
System Options > General tab > System Statistics. 

• Primary database - This is the database that is restored and not added using a clipping. Primary includes 
database, operators, alarms, and trends. See Before you start the upgrade process below to determine if the 
CCN or Open system should be your primary database.  

• Target web server - the web server you decide to use for the i-Vu v7.0 application 

NOTE  Web server model numbers and memory - see To upgrade a single system to the i-Vu Standard/Plus v7.0 
application (page 2). 
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i-Vu web server models  
You MUST check your model to ascertain if you need to upgrade and purchase a new one. The model number is 
on the bottom of your web server.  

 

i-Vu web server model number System limits 

MP945-xx or MP965-xx You must purchase a new web server to accommodate v7.0. 

MP45-xx or MP65-xx 
or 
NUC5i3MYHE or NUC7iDNHE 

USB Router -  

• 140 CCN controllers 

or  

• 60  i-Vu Open controllers 

 
External routers - 750 controllers 

Total combined - 750 controllers 

Before you start the upgrade process    

• The limit for the i-Vu Standard or Plus v7.0 application is 750 devices. The amount of memory in your web server 
determines your system's actual capacity. If your combined system devices are going to exceed 750, you 
must upgrade to the i-Vu Pro v7.0 application. See To upgrade to the i-Vu Pro v7.0 application (page 34). 
Even if you upgrade to an i-Vu Pro system, you must first upgrade both of your web servers and systems to 
the i-Vu Plus v7.0 application. After installing the v7.0 application and restoring your databases to both web 
servers, verify the number of devices in both of your systems. Select System Options > General tab > 
Statistics to see the actual number of your devices. Check both systems for a sum.  

• If you use one of your current web servers and are not purchasing a new one, you must select the web server 
with the most memory for running the i-Vu v7.0 application. This is referred to as your target web server in 
these instructions. See table above. 

• If you are currently using both a USB CCN and an Open Adapter, you must replace one of them with an external 
router. i-Vu v7.0 application does not support 2 USB cables on the single web server.  

NOTE  Replace a USB CCN Adapter with an i-Vu Link or an i-Vu CCN Router. Replace a USB Open Adapter with 
an i-Vu Open Link, i-Vu Open Router, i-Vu XT Router, or i-Vu XT BACnet Link. During the upgrade process, the i-
Vu application will automatically find the new router and connect it to the network.  

• Decide which database will be primary. A  system that is connected with a USB Adapter (CCN or Open), must be 
primary. If you are not using a USB Adapter, select the larger database. The primary system is the first one 
you restore on the target web server with the v7.0 application. All settings are restored in your primary 
database, including, alarms, trends, and operators. The secondary system is installed using a clipping, which 
does not include operators or alarms. 
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Example of merging i-Vu databases to v7.0 

The following example is an overview of the steps to upgrade and merge systems. Review this process to become 
familiar with the concepts. See proceeding topics for specific details on how to execute these steps. 

Assumptions in this example 

• An i-Vu CCN Plus v4.2 web server system is connected to the network using a USB CCN Adapter 

• An i-Vu Open v5.0 or 5.1 system is connected to an i-Vu Open Link or an i-Vu Open Router 

• You are using one of the web servers you already own and not purchasing a new one 

• The i-Vu Open v5.1 web server is more powerful 

• See the illustration below for explanations of the terms used in the steps. 
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1 Capture current web server settings. 

2 Backup DB1 and DB2 from Management Tool to PC or USB (page 23).  

3 Install v6.0 on both boxes from the USB drive or CD. 

4 Connect and power up your target web server (page 25).  

5 Restore DB1 to WS2 from Management Tool (page 25).  

6 Restore DB2 to WS1 from Management Tool. (page 25) 

7 Check number of devices on both systems in System Options > General tab > Statistics to ensure your 
merged system will not have more than 750 devices. 

8 Fix potential conflicts between both databases. (page 25) 

1. Export DB2 Source files from WS1. 

2. Import DB2 Source file into WS2. 

3. Resolve conflicts.  

9 Export DB2 Clippings from WS1. 

10 Import DB2 Clippings into DB1 in the target web server WS2. 

11 Verify that the imported devices are communicating.  

12 Back up the merged database 

 

To merge a mixed system onto a new i-Vu v7.0 web server 

1 Capture current web server settings. 

2 Backup DB1 and DB2 from Management Tool to PC or USB (page 23).  

3 Connect and power up your target web server (page 25).  

4 Restore primary database to the new web server from the Management Tool. 

5 Check number of devices on both systems in System Options > General tab > Statistics to ensure your 
merged system will not have more than 750 devices. 

6 Fix potential conflicts between both databases. (page 25) 

1. Export DB2 Source files from WS1. 

2. Import DB2 Source file into WS2. 

3. Resolve conflicts.  

7 Export DB2 clipping from secondary database. 

8 Import DB2 clipping into new web server. 

9 Verify that the imported devices are communicating by obtaining a Module Status (Modstat).  

10 Back up the merged database. 
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Capture current i-Vu web server settings (merge) 

You need to record the Addressing information from the i-Vu web server Management Tool that is physically 
residing where you are going to place your i-Vu v7.0 web server (whether it is the same web server, a new one, or 
the one currently located elsewhere). 

• If you will be using a USB Adapter (CCN or Open), your v7.0 web server needs to be where the cable is located.  

• If you have external routers, you probably want to use the location of the web server that connects to the system 
you choose for your primary database. 

• If you enable Obtain an IP address automatically, the only setting you need to record is the i-Vu Port 
Configuration. 

 

Access the Management Tool using one of the following methods: 

• Click , then select System Options > General tab > Management Tool.  

• Launch your browser and type your system name followed by :8080. For ex.: http://ivu:8080/. 

 

Print the Management Tool screen or record all of the information under Addressing and i-Vu Port Configuration. 

•  i-Vu Standard v4.2 addresses 

 
 

• i-Vu Plus v4.2 addresses 



Merging a mixed system to the i-Vu Plus v7.0 application  
 

 

 
 

i-Vu® Application  CARRIER CORPORATION ©2020   
Upgrade Guide to v7.0  All rights reserved 
 22 

 

 
 

• i-Vu Standard or Plus v5.1 addresses 

  
 

• i-Vu Standard or Plus v6.0 and later addresses 
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Backup data from Management Tool 

Access the Management Tool using one of the following methods: 

• Click , then select System Options > General tab > Management Tool.  

• Launch your browser and type your system name followed by :8080. For ex.: http://ivu:8080/. 

 

Use either of the following methods to backup your data from both databases.  

Backup data to your PC 

1 Click PC Backup under Manage Server Data to save the entire i-Vu database zipped into one file to your PC. 

2 Click OK when you see the message The system will be stopped and restarted. Do you wish to proceed? 
Watch Operation Status to see the progress. 

3 Click the message Save/Download Backup File to Your Local Hard drive when it appears.  

4 Click Save when asked Do you want to open or save this file? 
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5 Save the file (system.backup.tgz) to a convenient location on your computer.  

CAUTION! Do not alter the name of this file! 

6 Exit from Management Tool. 

7 You must reboot the web server before proceeding. 

 

Backup data to a USB drive 

1 Plug your USB drive into any available USB port on your i-Vu web server. 

2 Click USB Backup under Manage Server Data to save the entire i-Vu database zipped into one file to your 
USB drive. 

3 Click OK when you see the message The system will be stopped and restarted. Do you wish to proceed? The 
Operation Status message updates as the i-Vu application prepares and creates the backup. Wait for 
Operation Status to state No Background Operations Currently Active.,  

4 Remove USB drive from the web server. 

NOTES 

○ A check of the USB drive will show a backup file named system.backup 

○ An error may be displayed under the Management Tool title stating The USB device failed to mount and 
initialize. Connect the USB drive to the first USB port. In this case, try a different USB drive or try 
rebooting the i-Vu web server, as there was an issue accessing the USB drive. 

5 Exit from Management Tool. 

6 You must reboot the web server before proceeding. 

 

 

Install i-Vu v7.0 software 

Use the following steps to install the i-Vu v7.0 application on both of your web servers, even the one you will no 
longer use. 

 

1 Remove the i-Vu web server from the network by disconnecting the LAN cable. 

2 Insert the USB Installation drive into the USB port on the web server. 

3 Shut down the i-Vu web server by pushing the On/Off button once.  

NOTE  For MP model number i-Vu web servers, wait for the blue light to turn off (could take as long as 2 
minutes). 

4 Press the On/Off button again to restart the web server. The installation begins automatically. 

5 The Installation USB drive's light goes off when the installation is complete. This process takes several 
minutes. 

NOTE  Do not power off during the installation. 

6 Remove the USB drive. 
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Connect and power up target i-Vu web server 

If you are currently using both a USB CCN and an Open Adapter, you must replace one of them with an external 
router. i-Vu v7.0 application does not support 2 USB cables on the single web server.  

 

1 If necessary, re-locate the i-Vu web server that you have chosen as the web server for i-Vu v7.0. For instance, 
if you are using a USB Adapter cable, you most likely need to move the target web server with the largest 
memory to the physical location of the cable.    

2 Plug the power cable into the back of the i-Vu web server and into an electrical outlet. 

NOTE  We highly recommend using a UL Certified power surge/RFI suppression device. 

3 Connect an Ethernet cable from the laptop computer’s network port, or the customer's LAN, to the Ethernet 
jack on the back of the i-Vu web server.  

4 Connect your the selected i-Vu web server to your CCN and Open networks using routers and/or a USB 
Adapter cable (CCN or Open). If you are using a USB Adapter cable, plug the adapter into the USB port and 
connect to your network.  

 

 

Restore data from backups 

When merging an existing CCN and Open system, the database that you restore on the target web server becomes 
the primary database. Restoring includes all settings, including database, operators, alarms, and trends. You 
merge the second database using a clipping, which does not include operators or trends. 

On your target web server: 

1 Click PC Restore or USB Restore under Manage Server Data in the Management Tool. 

○ PC Restore - Browse to your backup file and click Perform Restore. 

○ USB Restore - Place your backup USB drive in any port on the i-Vu web server. Select the backup file and 
click Perform Restore. 

2 Restore is complete when Operation Status displays No Background Operations Currently Active. 

 

 

Troubleshoot, import secondary database, and resolve conflicts 

Export source files (drivers, .equipment, .view, and .bacview files) from the secondary database and import them 
into the primary database to identify and fix any equipment file names that may be duplicated in both databases. 
After you fix the conflicts, you export a clipping file (Source Files, database, and trends) from the secondary 
database and import it into the primary database on the target web server.   

If you skip using source files for removing conflicts and proceed directly to exporting and importing the clipping 
file, when duplicate file names are encountered during the clipping process, your must delete one of the files 
completely or stop the entire import process, fix the conflict, and start importing all over again. 

NOTE  A system clipping file takes time to import. You can see the estimated time for each database in System 
Options > General tab > System Statistics. 
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Fixing potential conflicts 

1 Export source files from your secondary database, which is residing in the web server that you are not using 
for your target system. Select System Options > General tab > Source Files > Export button. 

2 Close System Options.  

3 Access the target web server. 

4 Import the source files into the primary database. Select System Options > General tab > Source Files > 
Import button. 

5 Browse to the source files you just exported and click Open. 

6 Click Continue. You can copy the list of conflicts to use for a troubleshooting reference.  

7 Resolve conflicts before proceeding. To change the name of a custom equipment file: 

○ If the control program was made in Snap, open it in Snap and save with a different name. 

○ If the control program was produced in ApplicationBuilder, open the equipment file in EquipmentBuilder 
and save the file with another name.    

 

Import the secondary database into the target web server 

Clippings include source files, database, and trends. They do not include operators or alarms.  

1 Export a clipping file from the secondary database, which is residing in the web server that you are not using 
for your target system. Select System Options > General tab > Clippings > Export button.  

2 Click Save.  

3 Import the clipping file into the primary database on the target web server. Select System Options > General 
tab > Clippings > Import button.  

4 Browse to the exported clipping. 

5 Click Next. 

NOTE  You must resolve conflicts or problems that are displayed during the clipping import. In the case of 
duplicate file names, your only options are to delete one of the files completely or stop the entire import 
process, fix the conflict, and start the entire clipping import again. 

6 Verify that the imported devices are communicating. In the i-Vu v7.0 interface, select one router at a time in 
the navigation tree and click the Devices tab. 

7 Back up the merged target system from the Management Tool (page 23).  

 

 

Update your routers and controllers 

 CAUTION  Update your routers and controllers only once. Use either the i-Vu application or Field Assistant. 

Router and controller configurations are maintained when you update them using the procedure below. 

Step 1: Update the files for routers 

1 Select the router that you wish to update in the navigation tree. 

2 Right-click and select Driver Properties.  

3 Select Properties page > Update tab.  
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4 If the database contains two or more routers, you must check Change for all controllers of this type? in the 
Controller section. 

5 Click Update. A message appears Changes the driver and screen file to use the current library version. 
Continue?  

NOTE  If more than one router exists, the additional routers are listed below the Update button. 

6 Click OK.  

7 Click Accept. 

 

Step 2: Update the files for controllers 

1 Double-click the controller in the navigation tree or right-click and select Configure.   

2 If you have multiple controllers of the same type, enable Change for all control programs of this type?. 

3 Click Update under Control Program. A message appears Changes the control program, view, driver, and 
screen file to use the current library version. Continue?  

4 Click OK. When the message Updated to the library version xx. appears, click Close. 

5 Repeat steps 1 - 4 for any additional types of controllers. 

6 Click Close again. 

 

Step 3: Update the files for CCN controllers 

1 In the navigation tree, select the CCN device manager associated with the controllers that are to be updated. 

2 Select Devices > CCN Discovery and re-scan any controllers that need to be updated by checking Rescan 
Controllers Selected Below for Configuration Changes and clicking Start Scan. 

 

Step 4: Apply the update to routers and controllers 

1 Select the System  in the navigation tree and then select the Downloads page. 

2 If you wish to apply the new SAL file to your entire system, you can use this page to compare to your 
navigation tree and verify that you have selected all of your routers and controllers for download. 

NOTE  Only the CCN Gateway and device managers require download, so the CCN controllers/equipment will 
not be listed. 

3 A network's controllers download in the order shown. To change the order, select a controller(s), then drag 
and drop or click Move to Top or Move to Bottom. 
EXCEPTION  If a controller's router requires a download, it will download first regardless of its position on the 
Downloads page. Click the Start button. 

NOTES 

○ Use Ctrl+click, Shift+click, or the Select All checkbox to select multiple controllers.  

○ See To download from the Downloads page in Help for more details. 
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To register your software, you must obtain a license from Carrier and then apply it in the i-Vu® Pro interface.  

1 Login to i-Vu Systems website (http://accounts.ivusystems.com). 

NOTES 

○ Only Carrier authorized personnel may access accounts.ivusystems.com. To set up your account, please 
contact Control Systems Support with the following information: name, phone number, e-mail address, 
office address, and your password of choice. 

○ If you are an end-user or contractor, please contact your local Carrier office to obtain your license. 

 

2 Click the License Manager tab. 

3 Click i-Vu Pro License Manager link. 

4 Expand the applicable section under Available Licenses and select the site/project to register it. 

NOTE  All your Sites Names/Project Names are listed. 

5 In License Details, fill in the Owner and Site information and click Register License. 

6 Check I agree to the terms of use. 

7 Click Download License and then save the .properties file to a convenient location to use when installing the 
i-Vu® Pro application. 

 

To apply the license to the i-Vu application 

During the i-Vu installation, in the Setup Wizard, on the Product License screen, check Browse to a different 
license, and select the site license you obtained.  

NOTES   

○ Selecting the default license results in a prompt appearing every few minutes in the i-Vu interface to 
remind you to apply your site license. 

○ Do not edit any part of this registered license file. Editing a license file invalidates the license. 

○ Store the license in a safe location. 

 

To apply the site license after the installation: 

1 In the i-Vuinterface, select System Options > License Administration. 

2 Browse to the license file. 

3 Click Apply. 

4 Restart i-Vu Server using the rebootserver manual command. 
 

 

 

Registering and downloading your i-Vu license 

http://accounts.ivusystems.com/
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• Server requirements—Verify that the i-Vu server computer meets the v7.0 i-Vu server requirements (page 30). 
  

• Trends— i-Vu Pro v6.5 and later systems have a different Trends database structure than earlier systems. If you 
are upgrading a v6.0 or earlier system, use one of the following methods to convert your current trends: 
• Before upgrading, use the Trend Conversion Utility (highly recommended for large trend databases) 
• As part of the upgrade process in SiteBuilder's upgrade wizard 
See Converting your trend database (page 31). 
  

• BACnet Bindings—i-Vu v6.0 and later uses only dynamic binding for communication between devices. Before you 
upgrade from v4.2 or earlier, uncheck Use Static BACnet Bindings on the System Settings > 
Communications tab, restart the BACnet connection, and then immediately run the Reports > Network > 
Controller Status report to verify that you have no communication problems. If you do, contact Carrier Control 
Systems Support.  
  

• Access® and MSDE databases—As of v6.5, SiteBuilder no longer supports Access and MSDE database types. If 
your system uses one of these, you need to migrate to a Derby database in your current i-Vu version before 
upgrading to v7.0 
NOTE  Derby became a supported database type in v6.0. If your current system is v5.1 or earlier, you will 
need to upgrade to v6.0 or v6.5 (32-bit only), migrate to Derby, and then upgrade to v7.0 (64-bit). 

 

• SQL Server® Express database—If your system is currently using an SQL Server Express database running on a 
32-bit i-Vu server, you must do the following before upgrading to v7.0: 

1. Shut down i-Vu Server application. 

2. On the server's Start menu, select All Programs > Microsoft SQL Server > Configuration Tools > SQL 
Server Configuration Manager. 

3. In the left pane, select Protocols for SQLEXPRESS. 

4. In the right pane, right-click Named Pipes, and then select Enable. 

5. In the left pane, select SQL Server Services. 

6. In the right pane, right-click SQL Server (SQLEXPRESS), and then select Restart. 
 

• Backup—Always back up your database before upgrading. A failed upgrade could corrupt your data. 

Back up a Derby or SQL Server Express database by copying the system folder in i-Vu_Pro_x.x\webroot. 

• Back up a MySQL, MS SQL Server, Oracle, or PostGreSQL using the database management system's backup 
method. Also, copy the system folder in i-Vu_Pro_x.x\webroot. 

 CAUTION  Do not use SiteBuilder's Replicate feature to back up your database. 
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i-Vu server requirements 

The recommended minimum for an i-Vu server: 
 

• Dual core processor 

• 4 GB RAM 

• 30 Gigabyte hard drive 

• Communications link of 10 Mbps or higher 

• 64-bit server (See Upgrading from a 32-bit server to a 64-bit server (page 36).) 

 
The i-Vu application will work with slower computers and slower links, but the results may not be satisfactory. 

 
A i-Vu server must be 64-bit. Memory requirements vary, based on the: 
• number of pieces of equipment and device instances 
• size of the control programs 
• number of simultaneous users logged in to the i-Vu application 

  
 

For this 
size 
system... 

With this number of... The computer should have at least a dual core processor and... 

 

Instances of 
equipment 
and devices 1 

Physical 
Points and 
Display 
Objects 

Passmark 
Total 
Score 2 

Passmark 
Single- 
threaded 
Score 

RAM 
Minimum/ 
Recom- 
mended 

JVM Memory 
Minimum/ 
Recom- 
mended 

Disk Mark4 

Small 0 - 250 0 - 1000 2000 800 4 / 4GB 1 / 1GB 3000 

Medium 250 - 1000 1000 - 
5000 

3000 1000 4 / 8GB 2 / 4GB 5000 

Large 1000 - 
10,000  

5000 - 
50,000 

5000 1400 6 / 12GB 4 / 8GB 15000 

Huge more than 
10,000 

more than 
50,000 

6500 1600 16 / 16GB 3 12 / 12GB 30000 

1   Total number of control programs and controllers. 
2   For more information, see www.CPUbenchmark.net. 
3   For a huge system with minimal user activity, the average piece of equipment or instance device requires approximately 

300KB of server RAM. Contact Technical Support for server sizing recommendations. 
4   SATA SSDs are recommended as baseline performance for WebCTRL on all systems. Large systems benefit from the 

faster PCIe interface SSDs on both the WebCTRL and database servers. Passmark’s Disk Rating “Disk Mark” can be 
useful in gauging disk performance when designing new servers. 
Rotational Drives:  900-1500 
SATA SSDs:  3000-5000 
PCIe SSDs:  10000-30000 
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Converting your trend database 

If you are upgrading from v6.0 or earlier, you must convert your current trend database to the trend database 
structure for v6.5 and later systems. 
 

• For a Derby database, the trends are converted as part of the upgrade process in SiteBuilder's upgrade wizard. 

• For an SQL Server, MySQL, or PostgreSQL database, use one of the following methods to convert your current 
trends: 
• As part of the upgrade process in SiteBuilder's upgrade wizard. The i-Vu system is not running during the 

upgrade. 
○ Before upgrading using the Trend Conversion Utility (highly recommended for large trend databases. See 

"To determine the size of your trend database" below.) This method is faster and the utility can run while 
the i-Vu system is running.  

Before using either of these methods, verify that the trend database management system user has 'drop' 
authority.  

  

NOTES 

• If your trend database is on a different server than the i-Vu system, you have the option of installing and running 
the Trend Conversion Utility on either server. However, the conversion will run faster if you run it on the trend 
database server. 

• If you created any custom software to access the i-Vu trend data, it may not work with the new trend database 
structure. Contact Carrier Control Systems Support for assistance. 

• Upgrading to and/or running a i-Vu v6.5 or later system uses more database resources than previous versions. 
  

 CAUTIONS    

• If you use the Trend Conversion Utility, back up your system before you run the utility and again before you 
upgrade the system in SiteBuilder. Make the backup using the database management system's backup 
method, and also copy the system webroot folder.   

• Disable trend expiration in your source trend database. In i-Vu, go to System Settings > Scheduled Tasks, and 
uncheck Remove expired historical trends daily at ___. 

  

To determine the size of your trend database 
In the i-Vu interface, select System Options > System Settings > General tab > System Statistics button. 
  

Size Small Medium Large X-Large 

Trend Samples < 100M 100M - 500M 500M - 650 > 650M 

Conversion time using  
Trend Conversion Utility 

1 hour 1 - 4 hours 4 - 6 hours > 6 hours 
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Options for migrating and upgrading the database 

NOTE  The "system folder" refers to the folder with the name of your site in the webroot folder, as in the following 
example, i-Vu_Pro_x.x > webroot > acme_corp. 

 

 From  To Steps to migrate to the 64-bit i-Vu Pro v7.0 application on a new computer 

Access Access 
or 
MSDE 

SiteBuilder v6.5 and later no longer supports Access and MSDE database 
types. If a system uses one of these, we recommend that you migrate to a 
Derby database in the 32-bit v6.0 i-Vu application before upgrading to the 
v7.0 version. 

Access Derby 1 Install the i-Vu Pro v6.0 32-bit application from the DVD on your existing 
computer. 

2 Upgrade database in SiteBuilder. Select File > Upgrade i-Vu System. 

3 In SiteBuilder, select File > Manage Database > Migrate/Replica > 
Migrate. Select Derby. 

4 Copy upgraded i-Vu system folder to your own USB drive. 

5 On your new computer, install the 64-bit i-Vu Pro v7.0 application from 
the Installation USB drive. 

6 Upgrade database in SiteBuilder. Select File > Upgrade i-Vu System. 

7 Copy the system folder from your USB drive into the webroot folder. 

8 Upgrade database in SiteBuilder. Select File > Upgrade i-Vu System. 

Access MS SQL SiteBuilder v6.5 and later no longer supports Access and MSDE database 
types. If a system uses one of these, we recommend that you migrate to a 
Derby database in the 32-bit v6.0 i-Vu application before upgrading to the 
v7.0 version. 

1 On your existing computer, install the 32-bit i-Vu Pro v6.0 application 
from the DVD. 

2 Upgrade database in SiteBuilder. Select File > Upgrade i-Vu System. 

3 In SiteBuilder, select File > Manage Database > Migrate/Replica > 
Migrate. Select Derby. 

4 Copy upgraded i-Vu system folder to your own USB drive. 

5 On your new computer, install the 64-bit i-Vu Pro v7.0 application from 
the Installation USB drive. 

6 Install 2005/8/12 MS SQL. See Upgrade to MS SQL Server 2005-8-12 
on a new computer. 

7 Copy the system folder from your USB drive into the webroot folder. 

8 In SiteBuilder, select File > Manage Database > Migrate/Replica > 
Migrate. Select MS SQL. 
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 From  To Steps to migrate to the 64-bit i-Vu Pro v7.0 application on a new computer 

MSDE MS SQL SiteBuilder v6.5 and later no longer supports Access and MSDE database 
types. If a system uses one of these, we recommend that you migrate to a 
Derby database in the 32-bit v6.0 i-Vu application before upgrading to the 
v7.0 version. 

1 On your existing computer, install the 32-bit i-Vu Pro 6.0 application 
from the DVD. 

2 Upgrade database in SiteBuilder. Select File > Upgrade i-Vu System. 

3 In SiteBuilder, select File > Manage Database > Migrate/Replica > 
Migrate. Select Derby. 

4 Copy upgraded i-Vu system folder to your own USB drive. 

5 On your new computer, install the 64-bit i-Vu Pro v7.0 application from 
the Installation USB drive. 

6 Install 2005/8/12 MS SQL. See Upgrade to MS SQL Server 2005-8-12 
on a new computer. 

7 Copy the system folder from your USB drive into the webroot folder. 

8 In SiteBuilder, select File > Manage Database > Migrate/Replica > 
Migrate. Select MS SQL. 

MS SQL MS SQL 1 Copy existing i-Vu system folder on your own USB drive. 

2 Backup 4 databases in MS SQL on your USB drive. 

3 On your new computer, install the 64-bit i-Vu Pro v7.0 application from 
the Installation USB drive. 

4 Install 2012, 2014, or 2016 MS SQL. See Upgrade to MS SQL Server 
2005-8-12 on a new computer.  

5 Restore above databases to upgraded MS SQL (page 43).  

6 On your new computer, install the 64-bit i-Vu Pro v7.0 application from 
the Installation USB drive. 

7 Upgrade database in SiteBuilder v7.0. Select File > Upgrade i-Vu 
System. 
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To begin, see To register and download your i-Vu Pro license (page 28). 

If you are upgrading from an i-Vu Standard or Plus system that uses a USB Adapter cable (CCN or Open), you must 
replace the cable with a router. Use an i-Vu CCN Router or i-Vu Link for a CCN network or an i-Vu Open Router, i-Vu 
Open Link, i-Vu XT Router, or i-Vu XT BACnet Link.  

If your web server is model MP945-D or MP965-D, you must purchase a new web server in order to convert your 
system to an i-Vu v7.0 application. Your model number is on the bottom of your web server. 

If your database is Access®, MSDE, or SQL Server Express, be sure you have followed the instructions in Before 
you upgrade (page 29). 

The table below is a quick outline of steps. Each step is explained in detail in the sections that follow. 

 Existing system Notes Procedure 

i-Vu CCN Standard v4.2 
or i-Vu Open Standard 
v5.1   

You must first upgrade to i-Vu 
Standard v7.0 application and 
then convert that to the i-Vu Pro 
v7.0 application.  

 

 

1 Backup system to your PC or USB from 
Management Tool. 

2 Install i-Vu Standard v7.0 application on 
your web server.  

3 Restore system to upgraded web server 
from the Management Tool. 

4 Export clipping file. Go to System Options 
> General tab > Clippings > and click the 
Export button. 

5 On your new computer, install the 64-bit i-
Vu Pro v7.0 application from the 
Installation USB drive. 

6 Open SiteBuilder v7.0 and import 
clipping. File > Clipping > Import. 

i-Vu CCN Plus v4.2 or i-
Vu Open Plus v5.1  

You must first upgrade to i-Vu Plus 
v7.0 application and then convert 
that to i-Vu Pro v7.0 application 

1 Backup system to your PC or USB from 
Management Tool. 

2 Install i-Vu Plus v7.0 application on your 
web server. 

3 Restore system to upgraded web server 
from the Management Tool. 

4 Export clipping file. Go to System Options 
> General tab > Clippings > and click the 
Export button. 

5 On your new computer, install the 64-bit i-
Vu Pro v7.0 application from the 
Installation USB drive. 

6 Open SiteBuilder v7.0 and import 
clipping. File > Clipping > Import. 

Upgrading to the i-Vu Pro v7.0 application 
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 Existing system Notes Procedure 

Mixed i-Vu CCN Plus 
v.4.2 and i-Vu Open 
Plus v5.1 

 Follow instructions in To merge a mixed 
system to the i-Vu Plus v7.0 application (page 
17). Once you have both databases merged in 
a single web server that is running the i-Vu 
v7.0 application, do the following: 

1 Backup system to your PC or USB from 
Management Tool. 

2 Export clipping file. Go to System Options 
> General tab > Clippings > and click the 
Export button. 

3 On your new computer, install the 64-bit i-
Vu Pro v7.0 application from the 
Installation USB drive. 

4 Open SiteBuilder v7.0 and import 
clipping. File > Clipping > Import. 

i-Vu Standard or Plus 
v6.0 and later  

You must first upgrade to the v7.0 
application and then convert that 
to i-Vu Pro v7.0 application. 

1 Backup system to your PC or USB from 
Management Tool. 

2 Install i-Vu Standard or Plus v7.0 
application on your web server.  

3 Restore system to upgraded web server 
from the Management Tool. 

4 Export clipping file. Go to System Options 
> General tab > Clippings > and click the 
Export button. 

5 On your new computer, install the 64-bit i-
Vu Pro v7.0 application from the 
Installation USB drive. 

6 Open SiteBuilder v7.0 and import 
clipping. File > Clipping > Import. 

i-Vu CCN Pro v3.1 You must install the latest driver 
in all i-Vu Integrators. They 
download automatically with the 
installation. 

See Upgrade v3.1 or v4.2 
database in SiteBuilder.   

                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                         

SiteBuilder v6.5 and later no longer supports 
Access and MSDE database types. If a system 
uses one of these, we recommend that you 
migrate to a Derby database in the 32-bit v6.0 
i-Vu application before upgrading to the v7.0 
version. 

1 On your new computer, install the 64-bit i-
Vu Pro v7.0 application from the 
Installation USB drive. 

2 Upgrade database in SiteBuilder. Select 
File > Upgrade i-Vu System. 

3 Upgrade graphics in ViewBuilder, using 
the plug-in.   
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 Existing system Notes Procedure 

i-Vu CCN Pro v4.2 See Upgrade v3.1 or v4.2 
database in SiteBuilder.   

 

 

 

SiteBuilder v6.5 and later do not support 
Access and MSDE database types. If a system 
uses one of these, we recommend that you 
migrate to a Derby database in the 32-bit v6.0 
i-Vu application before upgrading to v7.0. 

1 On your new computer, install the 64-bit i-
Vu Pro v7.0 application from the 
Installation USB drive. 

2 Upgrade database in SiteBuilder. Select 
File > Upgrade i-Vu System. 

i-Vu Pro v6.5  1 If you have a 32-bit system, you can only 
run v7.0 on a 64-bit server. See 
Upgrading from a 32-bit server to a 64-bit 
server (page 36). 

2 Follow the steps in Install the i-Vu Pro 
application and use SiteBuilder to 
upgrade database. (page 37) 

 

For more details on upgrading to the i-Vu Pro v7.0 application and migrating to different databases, see Options 
for migrating and upgrading the database. 

 

 

Upgrading from a 32-bit server to a 64-bit server 

i-Vu v7.0 will not run on a 32-bit server. To upgrade, first install i-Vu v7.0 on a 64-bit server. The method for 
upgrading your system depends on the database type or size. 

  

Derby database 
1 Copy your existing system's i-Vux.x\webroot\<system name> folder. 

2 Paste the copied files into the i-Vu7.0\webroot folder on the 64-bit server. 

3 Open the system in SiteBuilder.  

4 Select File > Upgrade > i-Vu system and follow the prompts to upgrade the system. 

  

All Non-Derby databases 
1 Open your existing system in SiteBuilder. 

2 Select File > Manage Database > Migrate/Replicate, and then select Replicate database to create a copy of 
the system in a Derby database. 

3 Copy the replicate system's i-Vux.x\webroot\<system name> folder. 

4 Paste the copied files into the i-Vu7.0\webroot folder on the 64-bit server. 
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5 Open the system in SiteBuilder. 

6 Select File > Upgrade > i-Vu system and follow the prompts to upgrade the system. 

7 Select File > Manage Database > Migrate/Replicate, and then select Migrate to a different database type to 
change the system back to the original database type. 

  

Very large databases 
If you are moving a very large system to a 64-bit server, contact Technical Support for assistance. 

 

 

Install the i-Vu Pro v7.0 application and use SiteBuilder to upgrade 
database 

SiteBuilder v6.5 and later do not support Access and MSDE database types. If a system uses one of these, we 
recommend that you migrate to a Derby database in the 32-bit v6.0 i-Vu application before upgrading to v7.0. See 
Options for migrating and upgrading the database. 

Typically, the file path for an i-Vu Pro system is the default path: C:\i-Vu_Pro_x.x. 

1 Back up your system before upgrading. Once a system is upgraded, you cannot retrieve or access the 
database with your previous i-Vu installation.   

2 Install the i-Vu Pro v7.0 application from the Installation USB drive. 

3 Open SiteBuilder v7.0 and select File > Upgrade i-Vu System. 

4 Click Browse and select the system folder for your previous i-Vu Pro system: C:\i-Vu_Pro_x.x\webroot. 

5 Check Make this the default system for iVu and click Next. 

6 Confirm that you have backed up and click Next when the Upgrade complete message appears. 

7 The upgrade process copies the necessary system files to your i-Vu Pro v7.0 installation folder and performs 
the required database upgrade steps.  

Upgrading drivers 

○ When upgrading a v3.1 database, the drivers for the i-Vu Integrators are automatically updated to the 
latest drivers. v3.1 drivers do not function in v7.0. 

○ When upgrading a v4.2 or later database, a dialog lists all the current drivers and you can uncheck them 
if you do not want them to be upgraded. v4.2, v6.0, and v6.5 drivers will function in v7.0.  

8 Log in to your new i-Vu Pro v7.0 application using an Administrator account. 
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Upgrade from Access and i-Vu Pro v3.1 or v4.2 application to Derby, new 
computer, and 64-bit v7.0 

i-Vu Pro v3.1 and v4.2 only ran on a 32-bit platform and v7.0 is only 64-bit. since In the 32-bit v6.0, Access or 
MSDE is supported and they are not supported in the 64-bit version.  

Access®, MSDE, and SQL Server Express databases—As of v6.5, SiteBuilder no longer supports Access and MSDE 
database types. As of v7.0, SiteBuilder no longer supports SQL Server Express. If your system uses one of these, 
you need to migrate to a Derby database in your current i-Vu version before upgrading to v7.0 
NOTE  Derby became a supported database type in v6.0. If your current version is earlier, you will need to upgrade 
to v6.0 32-bit, migrate to Derby, and then upgrade to v7.0 64-bit.  
 

1 Install the 32-bit version of the i-Vu Pro v6.0 application on your current computer. 

NOTE  You will still have your i-Vu Pro v3.1 or v4.2 system there, also. 

2 Make a backup of your current i-Vu system by copying the system folder under the webroot folder. 

3 Upgrade database in SiteBuilder. Select File > Upgrade i-Vu System. 

4 In SiteBuilder, select File > Manage Database > Migrate/Replica > Migrate. Select Derby. 

5 Copy the migrated system folder from the i-Vu v7.0 webroot folder to your own USB drive. 

6 Install the i-Vu v7.0 application from the Installation USB drive. 

7 Copy the saved Derby database from your USB drive to the webroot folder of the new i-Vu Pro v7.0 
application. 

 

 

Upgrade from the i-Vu v3.1, v4.2, or v6.0 application that uses SQL 
Server 2000, 2005, 2008 to SQL Server 2012, 2014, or 2016 on a new 
computer 

Follow these procedures to successfully upgrade and migrate your system and computer: 

1 Copy system folder from your previous the i-Vu Pro application and back up the i-Vu databases in MS SQL 
(page 38).   

2 Install the i-Vu Pro v7.0 application and SQL Server on your new computer. (page 39) 

3 Restore previous i-Vu databases to upgraded SQL. (page 43) 

4 Upgrade system in SiteBuilder (page 44). 

 

 

Copy i-Vu v3.1, v4.2, or 6.0 system folder and backup in SQL to USB drive 

 CAUTION  You must have installed the i-Vu Pro v7.0 application on your existing computer and set up a 
database in SiteBuilder before following these steps.  

Use this procedure if you have been using SQL Server 2000, 2005, or 2008 and are upgrading to SQL Server 
2012, 2014, or 2016 on a new computer.   
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Copy data from computer used for i-Vu Pro v3.1 or v4.2 

1 Stop the i-Vu Pro Server and close any i-Vu applications. If the i-Vu Pro Server is installed as a service, stop it. 

2 Browse to your i-Vu Pro v3.1 or later webroot folder and copy the system folder to a USB drive. 

 

In SQL, back up the i-Vu databases to a USB drive  

NOTE  The i-Vu databases are named main, alarms, audit, and trends. 
 

1 Log in to SQL Studio Manager using your Windows Authentication login.  

2 Expand Databases on the left.  

3 Right-click any of the 4 databases and select New task > Backup. 

4 In the Backup > General tab, verify that the Backup Type is Full. 

5 Under Destination, click ADD. 

6 In the popup window, browse to the USB drive and enter a filename (i.e. main, alarms etc..) 

7 Click OK and then OK again to return to the original backup window. 

8 Under Options, check Overwrite all existing backup sets. 

9 Click OK to start the backup.  

10 Repeat the above steps for the 3 remaining i-Vu databases.  

 

 

Install the i-Vu Pro v7.0 application and SQL Server on new computer 

After installing the i-Vu Pro v7.0 application from the Installation USB drive on your new computer, use the 
following steps:.   

1 If you do not already have MS SQL installed, install the 2014, 2016, or 2017 version and any applicable SQL 
service packs. For instructions on how to install any version of SQL Server, go to 
http://msdn.microsoft.com/en-us/library/default.aspx and, in the Search window, type Install <your SQL 
Version >.  Select Authentication Mode - Mixed Mode during setup and enable TCP/IP on port 1433.  

NOTE  As you install MS SQL Server, you must select certain options to use with i-Vu. For all other options, you 
may keep the defaults or select your own values. Select the following: 

○ SQL Server Database Services 

○ Workstation components, Books Online, and development tools  

○ Authentication Mode - Mixed Mode (Windows Authentication and SQL Server Authentication)  

NOTE  The password you specify grants extensive privileges.  

○ Service Account for database engine – NT Authority\System 

○ Enable TCP/IP on port 1433 

2 If already installed, you must have selected Authentication Mode - Mixed Mode during setup and have TCP/IP 
enabled on port 1433. 
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If you are the database administrator and TCP/IP is not enabled on port 1433, or you are unsure of the port, 
follow the procedure below, 'To enable TCP/IP on port 1433' and then proceed to Step 1.  

 

Install the program and follow the instructions below. Record your SQL Administrator information here: 

   User name ___________________________ 

   Password ___________________________ 
 
 

To enable TCP/IP on port 1433 
a Click Start > All Programs > Microsoft SQL Server <your SQL version> > Configuration Tools > SQL 

Server Configuration Manager. 

b Expand the SQL Server Network Configuration. 

c Select Protocols for <server instance> where <server instance> is the SQL Server running the i-Vu 
application. 

d In the next window, under Protocol Name, double-click TCP/IP. 

e On the Protocol tab, under General, next to Enabled, select Yes. 

f On the IP Address tab, scroll down to the IPAll section. 

g Clear any values from the TCP Dynamics Port field. 

h In the TCP Port field, enter 1433, then click OK. 

i Close the SQL Server Configuration Manager. 

j Restart the SQL Server Service. 

Step 1:  Connect to the database engine for i-Vu SQL Server 
a Determine if Microsoft SQL is running on the i-Vu server: 

○ If Microsoft SQL is running on the i-Vu server, select Start > Programs > Microsoft SQL Server > SQL 
Server <your SQL version> > Management Studio.  

○ If Microsoft SQL is running on a different computer, download the SQL Management Studio and install it 
on the i-Vu server. 

b In the Connect to Server dialog box, select or enter the information using the table below. 

c Click Connect.  

 

To set up the databases for a new i-Vu system, complete steps 2, 3, and 4 below.   

Field Notes 

Server type Database engine. 

Server Name The address or name of the computer running the SQL Server service. Get from your 
database administrator. 

Authentication Get from your database administrator. 

User name Get from your database administrator. 

Password Get from your database administrator. 
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Step 2:  Create a database instance 
a In the Object Explorer pane, right-click Databases, then select New Database.  

b In the Database name field, type a name such as xxx_main; this will be your Main Database Connect 
String Instance in SiteBuilder. Record the name below. 

c Under Select a Page, select the Options page.  

d From the Recovery model drop-down list, select Simple.  

e Click OK. 

f Repeat steps a-e to create the Alarms, Trends, and Audit Log databases. 

NOTE  Database names are case-sensitive and must be 18 characters or less in length. 

 TIP  Record the database names here for future reference: 

Main ___________________________ 

Alarms ___________________________ 

Trends  ___________________________ 

Audit Log ___________________________ 

   

Step 3:  Create a database user 
a In the Object Explorer pane, click the plus sign to the left of Security.  

b Right-click Logins, then select New Login.  

c In the Login name field, type in a login name for i-Vu, such as XXX_User; this will be your Database User 
Login in SiteBuilder. 

 TIP  Record the role name here for future reference ___________________________. 

d Select SQL Server authentication.  

e In the Password and Confirm password fields, type a password; this will be your Database User 
Password in SiteBuilder. 

 TIP  Record the password here for future reference ___________________________. 

f Clear the following checkboxes:  

○ Enforce password policy  

○ Enforce password expiration  

○ User must change password at next login 

g  In the Default database drop-down list, select master.  

h In the Select a page pane, select the User Mapping.  

i Under Users mapped to this login, select the Map checkbox next to a database name you created in Step 2. 

j Under Database role membership for: section, select the following checkboxes:  

○ db_owner  

○ public 

k Click OK. 
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l Repeat steps i-k for each remaining database. 

m Close SQL Server Management Studio. 

Step 4:  Set up the SQL Server databases in SiteBuilder 
a In SiteBuilder, select File > New. 

b Type a name for the system. 

c Select SQL Server from the Database Type drop-down list. 

d Select Make this the default system for i-Vu if you want the i-Vu application to automatically run this 
system each time it starts. 

e Complete the remaining fields, then click Next. 

f Enter the Connect String information for each i-Vu database. See below. 

 
 

g Click Finish. 

NOTE  To change Database Connect Strings for an existing system, select Modify database connection 
parameters in the File > Open dialog box and then click Next. 
 
 

 

 

 

 

Database Connect Strings: 
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     Server Type one of the following:  

• localhost if the i-Vu application and the database are on the same machine 
• The name or IP address of the machine that the database is on if different than the i-Vu 

application 

     Port Do one of the following: 
• Type the default port of 1433. 
• Type the port number that the database uses for communication if different than the 

database default. 
     Instance The name that you gave the i-Vu database in step 2b. 

 

NOTE  If the 4 i-Vu databases do not reside under the default instance of SQL, then the 
instance name must be specified under the Instance column. The syntax for specifying the 
instance name of the SQL server is <Database>;instance=<instance name>. For 
example, if the SQL instance name is hvac, the syntax for the Instance field for the main 
database called i-Vu_Main would be i-Vu_Main;instance=hvac. 

  
Database User: 

     Login  The user name that you entered in step 3c. 

     Password The password that you entered in step 3e. 

   

 

Restore i-Vu Pro v3.1 or later databases to upgraded SQL 

1 Insert ihe USB drive that contains the database backups from your i-Vu Pro v3.1 or later system into your 
computer. 

2 Open SQL Studio Manager and expand Databases. 

3 Right-click the Main database and select Tasks > Restore > Database. 

4 Under Source for restore, select From device. 

5 Click on the browse icon on the right.  

6 Click the Add button in the Specify Backup window. 

7 Browse to the USB drive that contains the backed-up databases and select main.back (or whatever name you 
assigned to the main database). 

8 Click OK twice to return to the Restore database window. 

9 Check the box under the Restore column. 

10 Select Options at the top left of the Restore database window. 

11 Check Overwrite existing database and click OK. 

12 A popup message will appear showing the restore was successful. 

13 Repeat the above for the remain three databases. 

14  Close SLQ Studio Manager. 
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Upgrade in SiteBuilder v7.0 

1 Open SiteBuilder 7.0 and select File > Upgrade i-Vu System. 

2 Browse to your i-Vu Pro v3.1 or later system folder on the USB drive. 

3 Enter a new system name, if desired.  

4 Enter the name of the computer where the SQL server is installed.  

NOTE  This is usually the PC name itself. (See below) 

5 Leave the port field blank unless the IT department insists that a port number be entered.  

NOTE  Default port number for SQL Server is 1433. 

6 Enter the name of the four databases that were created in SQL Studio Manager on the new computer. 

7 Enter the username and password that was created in SQL Studio manager for the new i-Vu Pro v7.0 
installation.  

8 Click Next. 

 
 

9 Confirm that you have backed up and click Next when the Upgrade complete message appears. 
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10 The upgrade process copies the necessary system files to your i-Vu Pro v7.0 installation folder and performs 
the required database upgrade steps.  

Upgrading drivers 

○ When upgrading a v3.1 database, the drivers for the i-Vu Integrators are automatically updated to the 
latest drivers. v3.1 drivers do not function in v7.0. 

○ When upgrading a v4.2 database, a dialog lists all the current drivers and you can uncheck them if you 
do not want them to be upgraded. v4.2 drivers will function in v7.0.  

11 Enter a password and click Next to complete the database upgrade. 

NOTE   If the 4 i-Vu databases do not reside under the default instance of SQL, then the instance name must be 
specified under the Instance column. The syntax for specifying the instance name of the SQL server is 
<Database>;instance=<instance name>. For example, if the SQL instance name is hvac , the syntax for 
the Instance field for the main database called iVu_Main would be iVu_Main;instance=hvac. 

 

 

Update your routers and controllers for the i-Vu Pro v7.0 application 

IMPORTANT!  Update your routers and controllers only once. Use either the i-Vu or Field Assistant application. 

Router and controller configurations are maintained when they are updated using the procedure below. 

Step 1: Update the files for routers 

1 Select the router that you wish to update in the navigation tree. 

2 Right-click and select Driver Properties.  

3 Select Properties page > Update tab.  

4 If the database contains two or more routers, you must check Change for all controllers of this type? in the 
Controller section. 

5 Click Update. A message appears Changes the driver and screen file to use the current library version. 
Continue?  

NOTE  If more than one router exists, the additional routers are listed below the Update button. 

6 Click OK.  

7 Click Accept. 

 

Step 2: Update the files for controllers 

1 Double-click the controller in the navigation tree or right-click and select Configure.   

2 If you have multiple controllers of the same type, enable Change for all control programs of this type?. 

3 Click Update under Control Program. A message appears Changes the control program, view, driver, and 
screen file to use the current library version. Continue?  

4 Click OK. When the message Updated to the library version xx. appears, click Close. 

5 Repeat steps 1 - 4 for any additional types of controllers. 

6 Click Close again. 
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Step 3: Update the files for CCN controllers 

1 In the navigation tree, select the CCN device manager associated with the controllers that are to be updated. 

2 Select Devices > CCN Discovery and re-scan any controllers that need to be updated by checking Rescan 
Controllers Selected Below for Configuration Changes and clicking Start Scan. 

 

Step 4: Apply the update to routers and controllers 

1 Select the System  in the navigation tree and then select the Downloads page. 

2 If you wish to apply the new SAL file to your entire system, you can use this page to compare to your 
navigation tree and verify that you have selected all of your routers and controllers for download. 

NOTE  Only the CCN Gateway and device managers require download, so the CCN controllers/equipment will 
not be listed. 

3 A network's controllers download in the order shown. To change the order, select a controller(s), then drag 
and drop or click Move to Top or Move to Bottom. 
EXCEPTION  If a controller's router requires a download, it will download first regardless of its position on the 
Downloads page. Click the Start button. 

NOTES 

○ Use Ctrl+click, Shift+click, or the Select All checkbox to select multiple controllers.  

4 See To download from the Downloads page in Help for more details. 
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Upgrade v3.1 graphics 

i-Vu 3.1 graphics files (.view files) must be upgraded to be used in the i-Vu Pro v7.0 application.  

The graphics were copied to your v7.0 system when you upgraded the database in SiteBuilder v7.0. However, you 
must upgrade your graphics in ViewBuilder v7.0. 

Area graphics in the i-Vu CCN Pro v3.1 application may have been designed to use variable color expressions, 
which change zone color based on fixed temperature ranges. Colors in a zone on a floorplan graphic do not 
change dynamically in i-Vu Pro v7.0. The Equipment Color control oval  takes over this function and changes 
color based on the specific setpoints for the zone.   

The equipment’s color in the oval is based on the current zone temperature and the position of the colored bands 
in the setpoint control. 

 
Floorplan images used in the i-Vu v3.1 application often had random background colors assigned to each 
dynamically changing zone. These background colors will not be shown once the graphics have been upgraded.   
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When you open an i-Vu v3.1 .view file in ViewBuilder, you are prompted to upgrade the graphic and select a fill 
color for the zone. We recommend selecting a neutral color that is distinguishable from the wall color. 

 
 

You can convert one graphic at a time, or you can convert an entire folder at once by installing the plug-in before 
upgrading your graphics. 

1   Select Tools > Configure Tools > Upgrade 3.1 graphics and click Add. 

 
2 Select upgrade-3_1-graphics.viewbuilder-plugin and click Open. 

3 Once the plug-in is installed, all the graphics in a folder (views and symbols) may be upgraded at once by 
selecting Tools > Upgrade 3.1 Graphics. 

 

 

Upgrade v3.1 custom control programs 

Library 
The number of types of devices supported in the built-in equipment library has been greatly expanded since the i-
Vu Pro v3.1 application.   

• If the control program in the Integrator is only being used to access values in the CCN device, it is strongly 
recommended to use the control programs that are automatically generated when the devices are 
discovered.   

• If equipment is using control programs that were automatically generated during discovery in v3.1, you can 
select those equipment on the Devices page and re-scan them to update their control programs and graphics 
to the current versions. 

• If you wish to replace a control program that was made in the Snap application with a program that is 
automatically generated, you will have to delete the equipment from the Devices page and rediscover it. 
Deleting an equipment results in losing schedules, alarm actions, setpoints, or other parameters that are 
defined in that equipment. Schedules or alarm actions defined further up the hierarchy will not be affected. 
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Custom Control Programs 
• If you have custom logic created in the Snap application that is being used as a part of the control sequence, you 

cannot replace the custom control program with the automatically-generated one.   

• Your Snap-created control program will still run in an i-Vu Integrator that has been upgraded to run with the i-Vu 
Pro v7.0 application. 

• In order for a custom control program to support any of the new features available in the i-Vu Pro v7.0 
application, it is necessary to apply an update to the Snap application under the i-Vu Pro v3.1 application.  

 

To apply the Snap update: 

1 Download the update file called iv42_eikon.update from the Service Intranet. 

2 Open SiteBuilder v3.1. 

3 Select Actions > Apply Update. 

4 Browse to the location of the .update file and select it. 

5 The screen should appear as seen below. Click Apply to apply the Snap patch. 

 
 

• You will need to use the Snap application that was a part of your i-Vu Pro v3.1 system to edit any custom control 
programs.   

NOTE  Custom programs created with Snap will only run in an i-Vu Integrator. They are not supported in i-Vu 
CCN Routers. 

 

Local override  
• Local overrides were not allowed in the i-Vu Pro v3.1 application.   

• Control programs that are automatically generated during the discovery process in the i-Vu CCN Pro v4.2 
application will support local overrides.   
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• To support new features in an Snap-generated control program, you need to make some small changes.  

○ v3.1 control programs typically had a section like the one shown in Figure 1. This took the current 
schedule state and used a Carrier Schedule Write microblock to write it to a CCN device. This should be 
replaced with logic similar to that shown in Figure 2. 

  
Figure 1 

 

○ The logic shown in Figure 2 uses a new Carrier Schedule microblock and DOES NOT use either of the 
microblocks shown in Figure 1.  The bottom output from the new Carrier Schedule microblock indicates if 
the device is in override.  If you wish to use the Tenant Override Billing add-on, you must add a binary 
trend with a reference name of override (case sensitive) to this output, as shown in Figure 2. 

 
Figure 2 
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• Add-ons 

○ Some add-ons have been updated for compatibility with the i-Vu v7.0 application . Be sure that you have 
the latest version of the add-ons that were used in the previous i-Vu version.  
 

• In the i-Vu Plus application, if the add-on is signed and supported, go to the System Menu  > 
System Options > Add-ons tab, select the add-on, then click Remove Add-on and Keep Data. Install the 
latest version of the add-on. 
 

 In the i-Vu Pro application, System Menu  > System Options > System Settings > Add-ons tab, 
select the add-on, then click Remove Add-on and Keep Data. Install the latest version of the add-on. 
 

○ To increase security of a i-Vu system, by default, v7.0 allows only add-ons that are supported and signed 
by Carrier.  

 In the i-Vu Plus application, you cannot change this default.  

 In the i-Vu Pro application, you can run an unsigned add-on. You must open SiteBuilder and go to 
Configure > Preferences > Web Server, and check Allow unsigned add-ons.  

 

• Schedules—Descriptions are limited to 50 characters in a v6.0 or later system using v6-00a or later drivers. You 
must shorten any schedule descriptions over 50 characters or the schedules will not download. 
  

• Display settings—If i-Vu images appear fuzzy after upgrading and you have a Windows 7 computer, set the 
computer's Control Panel > Display setting to Smaller - 100%. 
  

• Alarm sounds—If an operator's My Settings page had an alarm sound file defined, copy the file from the old 
system to the new system. 
 

• Interface images and Graphics pages—On each client computer, clear the web browser's cache to avoid error 
messages, strange graphics, or images. 

○ In Internet Explorer®, search on "delete temporary Internet files". 
NOTE  If you had the i-Vu application saved as a Favorite, uncheck Preserve Favorites website data.  

○ In Safari®, search on "empty cache". 

○ In Mozilla® Firefox®, search on "clear cache". 

○ In GoogleTM ChromeTM, search on "delete cache".  
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i-Vu Pro application only: 

• SSL—If your old system used SSL, you will need to set up TLS again after upgrading. See "To set up i-Vu server 
communication" in SiteBuilder Help. If you use Internet Explorer®, you must check Use TLS 1.2 Internet 
Explorer's security options. 
  

• Windows® service—If you run i-Vu Pro Server as a Windows service, you must uninstall the service for your 
previous i-Vu Pro version, and then install the service for your new i-Vu Pro version. See "Running i-Vu Pro 
Server as a Windows® service" in i-Vu Pro Help for instructions on uninstalling and installing i-Vu Pro Server 
service. 

• MySQL 
If you use MySQL and your system is v4.2 or earlier, copy the MySQL driver from i-Vux.x\lib to the i-
Vux.x\database-drivers folder.  
If you use MySQL and your system is v3.1, copy the MySQL driver from i-Vux.x\bin\lib to the i-Vux.x\database-
drivers folder. 
If the driver is not named mysql-driver.jar, change its name to this. 
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Important changes to this document are listed below. Minor changes such as typographical or formatting errors are not 
listed. 
  

 Date Topic Change description Code* 

5/18/20 Cover Updated logo C-D 

Requirements Added Disk Mark column to table X-TS-RB-E 

10/8/19 Merging a mixed system to the i-Vu® 
Plus v7.0 application 

More detailed information added to description of clipping files C-TS-RD-E 

6/18/19 Upgrading to the i-Vu Pro v7.0 
application 
from: 
i-Vu Standard or Plus v6.0 and later 

Moved the step for "Exporting the clipping" to after restoring 
your system, instead of before.  

C-TS-CI-F 

6/6/19 

 
Install self-signed certificates for 
network security 

New topic. C-R-HRDC-O-BR 

Backup data from Management Tool http changed to https C-R-HRDC-O-BR 

1/31/19 Upgrading to the i-Vu Pro v7.0 
application  

Clarified upgrading i-Vu Standard or Plus v6.0 and later to i-Vu 
Pro v7.0 

C-TS-CP-O 

  
*  For internal use only 
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