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Test  

SiteBuilder creates the database that the i-Vu® Pro Server application uses to communicate with controllers in the 

field. 

SiteBuilder uses a tree interface to display the system hierarchy. The Geographic tree represents the areas, 

controlled zones, and mechanical equipment in a system. The Network tree represents the communication 

network of routers and controllers with the i-Vu® Pro Server application.  

  

After you create a database in SiteBuilder, you should use the i-Vu® Pro application to automatically discover Open 

controllers and/or a system with a single CCN Gateway.  However, you must use SiteBuilder to build a system with 

multiple CCN Gateways. 

  

Multiple CCN Gateways  

1 Create a database (page 3). 

2 Build a Network tree for a CCN system. (page 13)   

 

Building a complete system in SiteBuilder includes the following detailed steps: 

1 Creating a database (page 3) 

2 Building a Geographic tree (page 7) 

3 Building a Network tree (page 12) 

4 Assigning equipment to controllers (page 54) 

5 Testing a system (page 55) 

 

 

 

 
 

What is SiteBuilder? 
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Feature Improvement 

v7.0 cumulative patch #3  

HTTP redirect to HTTPS (page 

65) 

If you enable web server ports for Both HTTP and HTTPS, you can optionally elect 

to have HTTP requests automatically redirected to HTTPS.  

Improved security settings To increase security, the i-Vu® Pro application defaults to the following settings: 

 If your system is set to use TLS, the i-Vu® Pro application automatically uses 

TLS 1.2. 

 The i-Vu® Pro application requires SOAP applications to run over HTTPS. 

 The i-Vu® Pro application allows only add-ons that have been approved by 

Carrier. 

NOTE  If needed, you can override these defaults (page 65) in SiteBuilder; 

however, doing so will lessen the security of your system. 

  

 

 
 

What's new in SiteBuilder v7.0 
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PREREQUISITE  For any database type except Apache Derby, you must install and set up the database application 

before creating your system database. An Apache Derby database is installed with your i-Vu® Pro system.  

  

Follow the procedures below to create your system database. 

 

 
 

To create a new SiteBuilder database 

After you create a database in SiteBuilder, you should use the i-Vu® Pro application to automatically discover Open 

controllers and/or a system with a single CCN Gateway.  However, you must use SiteBuilder to build a system with 

multiple CCN Gateways. 

 

1 Click File > New. 

2 Enter appropriate values in each of the New Database fields. See table below. 

3 Click Next.  

4 Do one of the following: 

○ If you selected a MySQL, PostgreSQL, or SQL Server® Database Type, enter the Database Connect 

Strings, Login and Database User info. See table below. Then click Next. 

○ If you selected an Apache Derby, go to step 5. 

5 Make language selections. See table below. 

6 Click Next. 

7 Click File > Close. 

8 If you have multiple CCN Gateways, use use SiteBuilder to build a Network tree for them. See To build a 

Network tree for a CCN system (page 13).   

9 For BACnet, or single CCN Gateway systems, use the i-Vu® Pro interface to populate your database. You do 

not need to set up the information in SiteBuilder.  

a) Launch the i-Vu Pro Server. Wait for it to finish opening the database. 

b) Browse to http://localhost to open the i-Vu® Pro interface. 

c) Use the login and password you set up in SiteBuilder. 

d) Find your devices and networks and upload the files. See i-Vu® Pro Help for details. 

  

 

 

 

 

Creating a system database 
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 Field Notes 

System Name Enter the name for this system that will be displayed at the top of the i-Vu® Pro 

navigation tree. 

System Directory Name The name of the folder that contains all the system files:   

i-Vu_Pro_x.x\webroot\<system_directory_name> 

This name is automatically generated from the System Name, but it can be edited. 

The System Directory Name must have:  

•  less than 80 characters 

•  only alphanumeric characters, dashes, and underscores 

•  no spaces 

Administrator 

Login Name, Password, 

and 

Confirm Password 

Type a Login Name and Password (8-character minimum) for the Administrator 

operator. 

 CAUTION  To increase the security of your system, do not use "Administrator" as 

the Login Name. 

NOTE  You can change the password requirements in the i-Vu® Pro interface. See 

"Advanced password policy" in i-Vu® Pro Help. 

Database Type Select the type of database your system will use. 

NOTE  If you select Derby, SiteBuilder automatically creates the necessary files and 

folder structures under the i-Vu_Pro_x.x folder. Do not move or rename system files 

or folders. 

Make this the default 

system for iVu 

Select this box to open this system when you start the i-Vu® Pro application.  

Starting Base Network 

Number 

Starting Base Device 

Instance Number 

SiteBuilder automatically assigns sequential numbers to BACnet networks and 

devices as you add them to the database. Choose starting numbers that will generate 

unique network and device instance numbers across all systems that this system will 

communicate with. 

Server BACnet  

Device Instance 

Must be unique to the BACnet network. Unique Server Device IDs are important if you 

are running multiple copies of the i-Vu® Pro application on the same network. 

Languages Select all languages that you want your system to support. 

System Select the language that you want to use for: 

 The default language for new operators 

 Alarms sent to the database 

 State text and object names downloaded to the field 

 The default language for the i-Vu® Pro login page.  

NOTE  You can select a different language on the login page. 

All other information is displayed in the operator's language. 
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For MySQL, PostgreSQL, or SQL Server® Database Types 

Database Connect Strings: 

     Server Type one of the following:  

 localhost if the i-Vu® Pro application and the database are on the same 

machine 

 The name or IP address of the machine that the database is on if different than 

the i-Vu® Pro application 

     Port Do one of the following: 

 Type the appropriate default port number from the list below. 

 Type the port number that the database uses for communication if different than 

the database default.  

 
Default ports are: 

MySQL 

PostgreSQL 

SQL Server 

  

3306 

5432 

1433 

     Instance The name that you gave the i-Vu® Pro database in the database application. 

  

Database User: 

     Login  The user login that you set up in the database application. 

     Password The password that you set up in the database application. 

  

NOTE  To change Database Connect Strings for an existing system, select the Modify database connection 

parameters in the File > Open dialog box, then click Next.  

 

 
 

To assign system properties 

1 Double-click New System  on the Geographic tree. 

2 Enter values in the System dialog box. See table below. 

3 Optional:  Click Notes, then type in the notes field.  

4 Click OK. 

 

General tab 

Name The name displayed on the Geographic or Network tree. 

Reference Name A permanent name for a tree item that allows the item to be referenced from 

graphics, Properties pages, external spreadsheets, etc. A reference name 

consists of lowercase letters, numbers, hyphens, and underscores (no spaces), 

and it cannot begin with a number. In the system hierarchy, a reference name 

must be unique among its siblings, unless it is a global reference name that 

begins with a # sign. 
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General tab 

Base Network Number 

Base BACnet Device Instance 

SiteBuilder automatically assigns sequential numbers to BACnet networks and 

devices as you add them to the database. Choose starting numbers that will 

generate unique network and device instance numbers across all systems that 

this system will communicate with. 

Server BACnet 

Device Instance 

ID for the i-Vu® Pro server. Must be unique to the BACnet network. 

BACnet Alarm Recipient 

Instance 

ID for the server that receives alarms. Typically, the i-Vu® Pro server receives 

alarms, so enter the same ID as the Server BACnet Device Instance. 

Views You may attach a graphic file (page 9) now or later. 

  

Advanced tab 

Enable Network Address 

Translation (NAT) 

Check this field if either of the following statements is true for your system: 

 The server that receives alarms goes through a NAT router (firewall) to get 

to the Internet  

 One or more devices in the database are behind a NAT router. 

To enter the Network Number and IP Address, click the link that best describes 

your system in To build a Network tree (page 14). 

  

Notes tab These notes can also be seen on the i-Vu® Pro Properties page. 
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The Geographic tree represents the areas, controlled zones, and mechanical equipment in a system. 

You can copy, replicate, and move areas and equipment. See Productivity tools (page 56). 

 

 
 

To add an area 

An area is a logical group of areas or mechanical equipment. 

1 Right-click the system  or an area  on the Geographic tree that will be the parent of the new area. 

2 Select Add Area. 

3 Enter values in the Area dialog box. 

4 Attach graphic (.view) files now or later. 

5 Optional:  Click Notes, then type in the notes field.  

A notes icon ( ) on the tree indicates where you added notes. 

6 Click OK. 

 

 
 

To add BACnet equipment 

A piece of equipment represents a mechanical device that provides heating, ventilating, air conditioning, or other 

service to a building. 

1 Right-click the area  where you want to add the equipment. 

NOTE  You may add BACnet equipment at the system level . 

2 Select Add BACnet Equipment.  

3 Enter values in the BACnet Equipment dialog box. See table below. 

4 Optional:  Click Notes, then type in the notes field.  

A notes icon ( ) on the tree indicates where you added notes. 

NOTE  These notes can also be viewed and changed from the i-Vu® Pro Properties page and Equipment 

Checkout tool. 

5 Click OK. 

 

 

 

Building a Geographic tree 
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Field Notes 

Name The name displayed on the Geographic or Network tree. 

Reference Name A permanent name for a tree item that allows the item to be referenced from graphics, 

Properties pages, external spreadsheets, etc. A reference name consists of lowercase 

letters, numbers, hyphens, and underscores (no spaces), and it cannot begin with a 

number. In the system hierarchy, a reference name must be unique among its siblings, 

unless it is a global reference name that begins with a # sign. 

Object Instance SiteBuilder automatically assigns this unique number when you assign a piece of 

equipment to a controller. 

Control Program Select an existing control program from the list of control programs in the i-

Vu_Pro_x.x\webroot\<system_name>\programs folder. 

  

If the equipment's control program is not yet in the programs folder, type its name in 

this field. This equipment is called phantom equipment and has a grayed out icon . 

You can add points to this equipment. To convert phantom equipment to working 

equipment, put its control program in the programs folder, select the phantom 

equipment in SiteBuilder, then select Edit > Reload Control Program.  

Require operator to 

record any changes to 

equipment 

To provides support for 21 CFR 11, you can check this field to require a i-Vu® Pro 

operator to record a reason for changing an equipment property. You can also set this 

option in the i-Vu® Pro interface. See "Recording reasons for edits" in i-Vu® Pro Help. 

Views You may attach graphic files now or later. See the topic below for details. 

 

 
 

To add CCN equipment 

NOTE  You can use the i-Vu® Pro application to add a control program, in place of the following procedure.  

   

1 Right-click the area  where you want to add the equipment. 

NOTE  You may add CCN equipment at the system level . 

2 Select Add CCN Equipment.  

3 Enter values in the CCN Equipment dialog box. See table below. 

4 Optional:  Click Notes, then type in the notes field.  

A notes icon ( ) on the tree indicates where you added notes. 

NOTE  These notes can also be viewed and changed from the i-Vu® Pro Properties page and Equipment 

Checkout tool. 

5 Click OK. 

6 You must assign the equipment to the CCN Bridge that controls it. See Assigning equipment to controllers 

(page 54).   
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Field Notes 

Name The name displayed on the Geographic or Network tree. 

Reference Name A permanent name for a tree item that allows the item to be referenced from graphics, 

Properties pages, external spreadsheets, etc. A reference name consists of lowercase 

letters, numbers, hyphens, and underscores (no spaces), and it cannot begin with a 

number. In the system hierarchy, a reference name must be unique among its siblings, 

unless it is a global reference name that begins with a # sign. 

Associate with CCN 

Controller 

Select the correct Bus and Element number from the drop-down list 

Object Instance SiteBuilder automatically assigns this unique number when you assign a piece of 

equipment to a controller. 

Control Program Select an existing control program from the list of control programs in the i-

Vu_Pro_x.x\webroot\<system_name>\programs folder. 

  

If the equipment's control program is not yet in the programs folder, type its name in 

this field. This equipment is called phantom equipment and has a grayed out icon . 

You can add points to this equipment. To convert phantom equipment to working 

equipment, put its control program in the programs folder, select the phantom 

equipment in SiteBuilder, then select Edit > Reload Control Program. Reloading 

updates all instances of a control program throughout the system and marks the 

controller(s) for an All Content download. 

Require operator to 

record any changes to 

equipment 

To provides support for 21 CFR 11, you can check this field to require a i-Vu® Pro 

operator to record a reason for changing an equipment property. You can also set this 

option in the i-Vu® Pro interface. See "Recording reasons for edits" in i-Vu® Pro Help. 

Views You may attach graphic files now or later. See the topic below for details. 

 
 

To attach graphic files to an area or a piece of equipment 

You can attach one or more graphics to an area or piece of equipment in SiteBuilder. For example, you can assign 

a floorplan and a lighting plan to the same area. Or, you can attach an equipment graphic, an engineering shop 

drawing, and an as-built document to a single piece of equipment. 

See ViewBuilder Help to learn how to create graphics (.view files). All .view files must be stored in the i-

Vu_Pro_x.x\webroot\<system_name>\views\graphics folder. 

  

To attach a graphic: 

1 Double-click an area or piece of equipment on the Geographic tree. 

2 Select a file in the Available Views list. 

NOTE  A Graphics page is marked (lvl5); a custom WAP Properties page is marked (wap). 

3 Click the Attach button  . 

4 Optional:  To edit the graphic's properties that were defined in ViewBuilder, double-click the file in the 

Attached Views list or click . For a description of each field, see Managing attached views (page 10). 

5 Click OK. 
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NOTES   

 To assign graphics that have not yet been created, click the New View button . 

 You can also perform this task in the i-Vu® Pro interface. See "To attach a graphic in the i-Vu® Pro interface" 

in i-Vu® Pro Help. 

 

 
 

Managing attached views 

Double-click an area or a piece of equipment to open the properties dialog box. 

 

  

Click this 

button... 

To... 

 
Attach view 

Select a file in the Available list, then click the Attach button. 

 
Remove view 

Select a file in the Attached list, then click the Remove button. 

NOTE  If you remove a file, then decide to reattach it, SiteBuilder will not remember any 

property changes. 

 
Type a new view name 

Type a name for a graphic that will be added to the system later. 

 
Edit the attached view's properties 

You can edit the view's navigation properties that were defined in ViewBuilder. 

  Display Name If you attach more than one graphic to the tree item, change Default to the 

name you want to appear in the i-Vu® Pro Graphics button drop-down list. 

  Is the Default 

view 

If you attach more than one graphic to the tree item, check this field to 

display this graphic the first time you go to that item's Graphics page. 

NOTES   

 You can designate only one default graphic per tree item. If you check 

this field, SiteBuilder unchecks it for any other graphic assigned to 

that tree item.  

 The default graphic is bolded in the Attached Views list. 

  Action Indicates which i-Vu® Pro button will display the file. 

  Category Select None if you want to select the graphic from the Graphics button 

drop-down list. 

To add a new category to this list, see “Graphics pages” in i-Vu® Pro Help. 

  Instance The name that you enter in ViewBuilder when creating a link to the 

graphic. See “Adding links” in ViewBuilder Help. 

  Included in 

download 

Equipment graphics only. Select to have the .view file included in an All 

Content download so that it can be uploaded by Field Assistant. The 

graphic will have  beside it in the Attached Views list.  
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Refresh view files 

Click the Refresh button to have SiteBuilder refresh a graphic that was edited after it was 

attached. 

  

NOTE  You can attach and remove views and edit many of the above properties in the i-Vu® Pro interface.  See "To 

attach a graphic" in i-Vu® Pro Help. 
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The Network tree represents the communication network of routers and controllers with the i-Vu® Pro server. You 

can build a Network tree for a single building (one site) or for several facilities in different locations (multiple sites). 

  

Contact the network administrator 

Before you build a Network tree, obtain IP addresses for the following devices from the facility network 

administrator: 

 The i-Vu® Pro server 

 Each BACnet router/CCN device manager 

 IP and NAT routers that affect your BACnet or CCN network  

  

You must also ask the network administrator to open, or in the case of NAT routers port forward, the following 

ports: 

 TCP 80 between the i-Vu® Pro server and its clients 

 UDP 47808 between the i-Vu® Pro server and its BACnet routers 

 UDP 50005 between the i-Vu® Pro server and its CCN device managers  

  

NOTE  If you have to build your Network tree before you have the actual IP addresses, enter temporary addresses, 

then change them to the actual addresses later. 

  

Setting up geographically separate areas 

Areas in different geographical locations, such as different campuses, can be part of the same site if they are on 

the same wide area network (WAN) and are set up for the same time zone in SiteBuilder.  

If your system contains areas with different time zones, you must add at least one site on the Network tree for 

each time zone. 

NOTE  When using more than one site for a shared BACnet/IP network, the network numbers must be the same. 

SiteBuilder will automatically assign different network numbers, but you must manually change them to the same 

number. Each device's IP address must be unique. 

  

Setting up multiple CCN Gateways 

You must set up a separate site for each CCN Gateway that you have in your system. You can only have one 

Gateway per site. 

NOTE  When using more than one site for a shared BACnet/IP network, the network numbers must be the same. 

SiteBuilder will automatically assign different network numbers, but you must manually change them to the same 

number. Each device's IP address must be unique. 

 

 
 

Building a Network tree 
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To build a Network tree for a CCN system with a single or multiple 

Gateways 

  

If your CCN system has... You must... 

A single CCN Gateway Use the i-Vu® Pro application to find and download the Gateway and system 

An i-Vu® Integrator Add it in SiteBuilder, even if it is the only CCN Gateway. See "To add an i-Vu® 

Integrator (page 20)" in SiteBuilder Help. 

 

Multiple CCN Gateways without 

a NAT router 

1 In the SiteBuilder Network tree, add one site with one BACnet/IP network 

for each Gateway.  

2 In the i-Vu® Pro interface, discover all the Gateways, Bridges, and 

controllers.  

NOTES 

 You must have the Multi-CCN license for this feature to work. 

 Supports up to 50 CCN Gateways in one system 

 Every Gateway must be Bus 0. 

 Every BACnet/IP Network Number must be the same.  

  

Multiple CCN Gateways with a 

NAT router 

1 In SiteBuilder, configure the NAT information. 

2 In the Network tree, add one site with one BACnet/IP network per 

Gateway. 

3 Add one CCN Gateway and all its Bridges to each site you set up. 

4 In the i-Vu® Pro application, discover the rest of your controllers under the 

Bridges. 

NOTES 

 You must have the Multi-CCN license for this feature to work. 

 Supports up to 50 CCN Gateways in one system 

 Every Gateway must be Bus 0. 

 Every BACnet/IP Network Number must be the same. 

   

CCN Gateways and Bridges can be any of the following: 

 i-Vu® Link 

 i-Vu® CCN Router 

 i-Vu® Integrator 

 Carrier® ChillerVu™  

NOTE  For your i-Vu® Open system, use the i-Vu® Pro application to find your i-Vu® Open routers and controllers. 

You do not need to set up the information in SiteBuilder.  

  

See To Build a Network tree (page 14) for selecting the specific instructions that apply to your network 

architecture. 
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To build a Network tree 

Click the network below that resembles your system for instructions on how to build the SiteBuilder Network tree. If 

you are not sure which network to build, ask your network administrator.  

NOTE  If communications between the i-Vu® Pro server and any BACnet router pass through a NAT router (firewall) 

anywhere in the system, you must enable Network Address Translation (NAT) in SiteBuilder. Click the appropriate 

link below for instructions. 

  

 
Legend  

  

 

  

NOTE  The term "BACnet routers" includes Carrier Open routers and CCN Device Managers. 

1 Simple network (page 15) 

HUB

Cross-over
cable

or

 

 

2 Server and BACnet routers on the same IP network 

(page 21) R

 
  

3 BACnet routers separated by an IP router (page 

27) R

 
  

4 Server on an IP subnet without a BACnet router (no 

BBMD) (page 31) R
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5 Entire BACnet network behind a NAT router (page 

35) 
N
A
T

 

 

6 BACnet router behind a NAT router (page 39) N
A
T

 

 

7 Server behind a NAT router (page 44) N
A
T

 

 

8 Server and BACnet router behind different NAT 

routers (page 49) 
N
A
T

N
A
T

 

 

 

 
 

Simple network 

In this simple network, the server/client computer is connected to a BACnet router with a cross-over cable or hub. 

  

HUB

Cross-over
cable

Server/
Client

Server/
Client

Controller Controller

BACnet
Router

or

BACnet
Router
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To add a site 

1 On the Network tree, right-click the system . 

2 Select Add Site. 

3 Enter values in the Site dialog box. See table below. 

4 Optional:  Click Notes, then type in the notes field. These notes can also be seen on the i-Vu® Pro Properties 

page. 

5 Click OK. 

  

Field Notes 

Name The name displayed on the Network tree. 

Reference Name Global reference names begin with # and must be unique within the entire 

system. Non-global reference names (no #) must be unique among siblings.  

Site Number SiteBuilder automatically assigns a unique site number, but if needed, you can 

change it to some other unique number. 

Time Zone By default, the site is set to the same time zone as the i-Vu® Pro server. If the site 

is in a different time zone, select Specify Time Zone, and then select the zone 

from the drop-down list. 

Peer Caching Select Use Peer Caching, click the drop-down arrow, then choose the BACnet 

router closest to the i-Vu® Pro server to be the peer caching router. The peer 

caching router will poll other routers on the IP network for colors and prime 

variables. 

Peer caching also checks the communication status of the peer caching router 

and any routers for which it is caching. If any of the routers cannot communicate, 

a Dead Module Timeout alarm is issued. 

You can select Do Not Use Peer Caching to slightly reduce network bandwidth, 

but you will not receive Dead Module Timeout alarms for the BACnet routers. 

Optimize download for 

Open PIC controllers 

Check to increase download speed. The full source files are not downloaded into 

the PIC controllers when this is checked. 

Include graphics in Open 

programmable controller 

download 

Uncheck to increase download speed. If you are not changing the graphics, you 

may not want to include them in every download. 
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To add a BACnet/IP network 

1 On the Network tree, right-click the site . 

2 Select Add BACnet Network. 

3 Enter values in the Network dialog box. See table below. 

  Every site with a CCN Gateway must have the same Network Number if they are on the same IP network.  

4 Optional:  Click Notes, then type in the notes field. These notes can also be seen on the i-Vu® Pro Properties 

page. 

5 Click OK. 

  

Field Notes 

Name The name displayed on the Network tree. 

Reference Name Global reference names begin with # and must be unique within the entire system. Non-

global reference names (no #) must be unique among siblings.  

Network Number 
  Every site with a CCN Gateway must have the same Network Number. Click Yes in 

the dialog box stating This network number is already in use. Only in rare cases do you 

want to duplicate this. Are you sure you want a duplicate network number?. 

i-Vu® Open systems: Use the default number unless your BACnet administrator gives 

you a different number. 

Media Type Select BACnet/IP. 

 

 
 

To add a BACnet router 

1 Right-click the BACnet/IP network . 

2 Select Add BACnet Device Router. 

3 Enter values in the BACnet Device Router dialog box. See table below.  

4 Click OK. 

  

General tab  

Name The name displayed on the Network tree. 

Reference Name Global reference names begin with # and must be unique within the entire 

system. Non-global reference names (no #) must be unique among siblings.  

Controller Select the controller in the drop-down list.  

NOTE  If the controller you are adding is not listed, browse to the controller's 

driver.  
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General tab  

Device Instance This number must be unique throughout an entire BACnet system. Do one of the 

following: 

 Use the default number based on SiteBuilder's next sequential Device 

Instance number 

 Enter a specific number. 

  

i-Vu® XT or TruVu™ router only—Check Autogenerated only if you plan to let the 

controller autogenerate its Device instance. The number you enter in SiteBuilder 

must match the autogenerated number in the controller setup pages that you 

access through the Service Port. This number is equal to: 

(IP network number x 100) + the router's rotary switch address  

EXAMPLE  If the IP network number is 1600 and the rotary switch address is 15, 

the Device Instance is 160015. 

NOTE  To see the Autogenerated checkbox, you must click OK in the properties 

dialog box, then double-click the router to reopen the properties. 

Screen File If you have a file for a BACview® or touchscreen device, select a .bacview or 

.touch file from the drop-down list. 

  

Address tab Select Use Default IP Address, then type the Address (Dial Setting On Device). 

  

 CCN tab  

This device is a CCN 

Gateway 

Check if router is a CCN Gateway. Enter Element Number, and Baud Rate, if 

applicable. 

Leave unchecked if router is not a a CCN Gateway, enter Gateway IP Address, 

Element Number, and Baud Rate, if applicable. 

  

Networks tab i-Vu® XT or TruVu™ router only—Shows the network number, media type, and if 

applicable, lets you select the router port that each network will use. 

  

Notes tab These notes can also be seen on i-Vu® Pro Properties page. 

 

 
 

To add a BACnet/ARCNET or MS/TP network 

1 On the Network tree, right-click the device router . 

2 Select Add BACnet Network. 

3 Enter values in the Network dialog box. See table below. 

4 Optional:  Click Notes, then type in the notes field. These notes can also be seen on the i-Vu® Pro Properties 

page. 

5 Click OK.  
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6 If you are adding an MS/TP network to a i-Vu® XT or TruVu™ router, double click the router. On the Networks 

tab, select the physical port that the MS/TP network will use. 

7 Click OK. 

  

Field Notes 

Name The name displayed on the Network tree. 

Reference Name Global reference names begin with # and must be unique within the entire system. Non-

global reference names (no #) must be unique among siblings.  

Network Number Do one of the following: 

 Use the default number 

 Enter a specific number  

  

i-Vu® XT or TruVu™ router only—Check Autogenerated only if you plan to let the 

controller autogenerate this network number. The number you enter in SiteBuilder must 

match the autogenerated number in controller setup pages. 

The number is: 

1600 (the default IP network number) + the router's rotary switch address, and ending 

with the port identifier number (0 for Port S1 or 3 for the Port S2). 

EXAMPLE  If the IP network number is 1600 and the rotary switch address is 15 and 

this is an MS/TP network, the Network Number is 16153. 

Media Type Select ARCNET or MS/TP. 

  

NOTE  When wiring an MS/TP network to a router port, you must set the port's baud rate using one of the following 

methods: 

 Open router—Using the router's Local Access port and PuTTY. See "To set a port's baud rate using PuTTY" in 

the router's Installation and Start-up Guide. 

 i-Vu® XT or TruVu™ router—In the i-Vu® Pro interface on the driver's BACnet Router Properties page or in 

Local Access on the Ports tab.  

 

 
 

To add a controller 

1 Right-click the network  that the controller is attached to. 

2 Select Add BACnet Device. 

3 Enter values in the BACnet Device dialog box. See table below. 

4 Optional:  Click Notes, then type in the notes field.  

A notes icon ( ) on the tree indicates where you added notes. 

5 Click OK. 
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Field or Tab Notes 

Name The name displayed on the Network tree. 

Reference Name Global reference names begin with # and must be unique within the entire 

system. Non-global reference names (no #) must be unique among siblings.  

Address Type the rotary dial address of the controller. 

Controller Select the controller in the drop-down list. 

NOTE  If the controller you are adding is not listed, browse to the controller's 

driver. 

Device Instance Use the default number unless you use a naming convention for your devices. A 

device instance number must be unique throughout an entire BACnet system. 

Screen File If you have a file for a BACview® or touchscreen device, select a .bacview or 

.touch file from the drop-down list. 

 

 
 

To add an i-Vu® Integrator 

The i-Vu® Pro application cannot discover an i-Vu® Integrator, even if it is your only Gateway. You must manually 

add it using the following procedure. 

1 Right-click the BACnet/IP network . 

2 Select Add BACnet Device Router. 

3 Enter values in the BACnet Device Router dialog box. See table below.  

4 Enter a Name, which is displayed on the Network tree. 

5 Optional: Edit the Reference Name. 

NOTE  Global reference names begin with # and must be unique within the entire system. Non-global 

reference names (no #) must be unique among siblings.  

6 Do one of the following in the Controller field. If you have: 

○ A controller that is not listed in the droplist, browse to the controller's driver. 

○ An i-Vu® Integrator using a Modbus driver (drv_ivu_ccn2_x-xx-xxx), select i-Vu Integrator and then 

proceed to step 8. 

○ An  i-Vu® Integrator using a LonWorks (drv_ivu_ccn2lon_x-xx-xxx) or GE Lighting driver 

(drv_ivu_ccn2gel_x-xx-xxx), you must: 

a.  Browse to and select your driver.  

b.  In the Custom Driver dialog box, select i-Vu Integrator - Custom. 

c.  Click OK. 

7 Fill in the Device Instance, if you are not using the default. 

NOTE  Use the default number unless you use a naming convention for your devices. A Device Instance 

number must be unique throughout an entire BACnet system. 
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8 If you have a file for a BACview® or touchscreen device, do one of the following: 

○ Select a .bacview or .touch file from the drop-down list. 

○ Type the complete file name for a .KPD or .S37 file. Include the extension. This field is case sensitive. 

9 On the Address tab, select Use Default IP Address, then type the Address (Dial Setting On Device). 

10 On the CCN tab, check This device is a CCN Gateway, if applicable, and then enter Gateway IP Address, 

Element Number, and Baud Rate. 

11 Click OK. 

12 Entries on the Notes tab appear on the i-Vu® Pro Properties page. 

 

 

 
 

Troubleshooting a simple network 

 On the i-Vu® Pro Connections page, do not type the IP address unless the i-Vu® Pro server has dual NICs 

(Network Interface Cards). 

 Use this calculator to verify that the devices are on the same subnet. 

 

 

 
 

Server and BACnet routers on the same IP network 

In this example, the server and BACnet routers are on the same IP network. 
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To add a site 

1 On the Network tree, right-click the system . 

2 Select Add Site. 

3 Enter values in the Site dialog box. See table below. 

4 Optional:  Click Notes, then type in the notes field. These notes can also be seen on the i-Vu® Pro Properties 

page. 

5 Click OK. 

  

Field Notes 

Name The name displayed on the Network tree. 

Reference Name Global reference names begin with # and must be unique within the entire 

system. Non-global reference names (no #) must be unique among siblings.  

Site Number SiteBuilder automatically assigns a unique site number, but if needed, you can 

change it to some other unique number. 

Time Zone By default, the site is set to the same time zone as the i-Vu® Pro server. If the site 

is in a different time zone, select Specify Time Zone, and then select the zone 

from the drop-down list. 

Peer Caching Select Use Peer Caching, click the drop-down arrow, then choose the BACnet 

router closest to the i-Vu® Pro server to be the peer caching router. The peer 

caching router will poll other routers on the IP network for colors and prime 

variables. 

Peer caching also checks the communication status of the peer caching router 

and any routers for which it is caching. If any of the routers cannot communicate, 

a Dead Module Timeout alarm is issued. 

You can select Do Not Use Peer Caching to slightly reduce network bandwidth, 

but you will not receive Dead Module Timeout alarms for the BACnet routers. 

Optimize download for 

Open PIC controllers 

Check to increase download speed. The full source files are not downloaded into 

the PIC controllers when this is checked. 

Include graphics in Open 

programmable controller 

download 

Uncheck to increase download speed. If you are not changing the graphics, you 

may not want to include them in every download. 

 

 

 
 

To add a BACnet/IP network 

1 On the Network tree, right-click the site . 

2 Select Add BACnet Network. 

3 Enter values in the Network dialog box. See table below. 

  Every site with a CCN Gateway must have the same Network Number if they are on the same IP network.  
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4 Optional:  Click Notes, then type in the notes field. These notes can also be seen on the i-Vu® Pro Properties 

page. 

5 Click OK. 

  

Field Notes 

Name The name displayed on the Network tree. 

Reference Name Global reference names begin with # and must be unique within the entire system. Non-

global reference names (no #) must be unique among siblings.  

Network Number 
  Every site with a CCN Gateway must have the same Network Number. Click Yes in 

the dialog box stating This network number is already in use. Only in rare cases do you 

want to duplicate this. Are you sure you want a duplicate network number?. 

i-Vu® Open systems: Use the default number unless your BACnet administrator gives 

you a different number. 

Media Type Select BACnet/IP. 

 

 
 

To add a BACnet router 

1 Right-click the BACnet/IP network . 

2 Select Add BACnet Device Router. 

3 Enter values in the BACnet Device Router dialog box. See table below.  

4 Click OK. 

5 Repeat steps 1 through 4 for the second router. See tables below. 

6 Add networks and controllers as needed under each BACnet router. 

  

General tab  

Name The name displayed on the Network tree. 

Reference Name Global reference names begin with # and must be unique within the entire 

system. Non-global reference names (no #) must be unique among siblings.  

Controller Select the controller in the drop-down list.  

NOTE  If the controller you are adding is not listed, browse to the controller's 

driver.  
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General tab  

Device Instance This number must be unique throughout an entire BACnet system. Do one of the 

following: 

 Use the default number based on SiteBuilder's next sequential Device 

Instance number 

 Enter a specific number. 

  

i-Vu® XT or TruVu™ router only—Check Autogenerated only if you plan to let the 

controller autogenerate its Device instance. The number you enter in SiteBuilder 

must match the autogenerated number in the controller setup pages that you 

access through the Service Port. This number is equal to: 

(IP network number x 100) + the router's rotary switch address  

EXAMPLE  If the IP network number is 1600 and the rotary switch address is 15, 

the Device Instance is 160015. 

NOTE  To see the Autogenerated checkbox, you must click OK in the properties 

dialog box, then double-click the router to reopen the properties. 

Screen File If you have a file for a BACview® or touchscreen device, select a .bacview or 

.touch file from the drop-down list. 

  

Address tab See: 

Setting Open device IP addresses (page 68) or 

Setting i-Vu® XT or TruVu™ device IP addresses (page 75) 

Example 

Router  

Use Default IP Address Select if the i-Vu® Pro system is on a dedicated IP network, 

then type the Address (Dial Setting On Device). 

NOTE  The router's IP Address DIP switch must be set to 

Assigned. 

 

Specify a custom or 

DHCP IP Address  

Select if the i-Vu® Pro system is on a non-dedicated IP 

network, then enter values in the following fields. 

NOTE  Open router only—The router's IP Address DIP switch 

must be set to: 

Assigned if using a custom IP address 

DHCP if using a DHCP IP address 

 

        IP Address Type the BACnet router's IP address that you got from the 

network administrator.  

NOTE  If the i-Vu® Pro server will use a port other than 47808 

for BACnet communication, type :<port number> after 

the address.  

For example, 172.18.64.38:47901. 

172.18.64.38 

        Subnet Mask Type the BACnet router's subnet mask that you got from the 

network administrator. 

255.255.255.0 

        Default  

        Gateway 

        Address 

Type the BACnet router's default gateway address that you 

got from the network administrator. 

172.18.1.1 

        Automatically 

        Configure My 

        BBMDs 

Check this field for all BACnet routers in your system even 

though this kind of network cannot use BBMDs. 
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Address tab See: 

Setting Open device IP addresses (page 68) or 

Setting i-Vu® XT or TruVu™ device IP addresses (page 75) 

Example 

Router  

Local Access 

Connection 

Open router only—If your network administrator gave you a custom IP address (not 

DHCP), you must connect to the router locally and then Download Address before the 

i-Vu® Pro server can communicate with the router. See To set a controller's custom 

IP address in SiteBuilder (page 68).  

After the download is complete, click Module Status to verify the router's address. 

  

i-Vu® XT or TruVu™ router only—You cannot download the router's IP address from 

SiteBuilder. See Setting i-Vu® XT or TruVu™ device IP addresses (page 75). 

 

 CCN tab  

This device is a CCN 

Gateway 

Check if router is a CCN Gateway. Enter Element Number, and Baud Rate, if 

applicable. 

Leave unchecked if router is not a a CCN Gateway, enter Gateway IP Address, 

Element Number, and Baud Rate, if applicable. 

  

Networks tab i-Vu® XT or TruVu™ router only—Shows the network number, media type, and if 

applicable, lets you select the router port that each network will use. 

  

Notes tab These notes can also be seen on i-Vu® Pro Properties page. 

 

 
 

To add a BACnet/ARCNET or MS/TP network 

1 On the Network tree, right-click the device router . 

2 Select Add BACnet Network. 

3 Enter values in the Network dialog box. See table below. 

4 Optional:  Click Notes, then type in the notes field. These notes can also be seen on the i-Vu® Pro Properties 

page. 

5 Click OK.  

6 If you are adding an MS/TP network to a i-Vu® XT or TruVu™ router, double click the router. On the Networks 

tab, select the physical port that the MS/TP network will use. 

7 Click OK. 
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Field Notes 

Name The name displayed on the Network tree. 

Reference Name Global reference names begin with # and must be unique within the entire system. Non-

global reference names (no #) must be unique among siblings.  

Network Number Do one of the following: 

 Use the default number 

 Enter a specific number  

  

i-Vu® XT or TruVu™ router only—Check Autogenerated only if you plan to let the 

controller autogenerate this network number. The number you enter in SiteBuilder must 

match the autogenerated number in controller setup pages. 

The number is: 

1600 (the default IP network number) + the router's rotary switch address, and ending 

with the port identifier number (0 for Port S1 or 3 for the Port S2). 

EXAMPLE  If the IP network number is 1600 and the rotary switch address is 15 and 

this is an MS/TP network, the Network Number is 16153. 

Media Type Select ARCNET or MS/TP. 

  

NOTE  When wiring an MS/TP network to a router port, you must set the port's baud rate using one of the following 

methods: 

 Open router—Using the router's Local Access port and PuTTY. See "To set a port's baud rate using PuTTY" in 

the router's Installation and Start-up Guide. 

 i-Vu® XT or TruVu™ router—In the i-Vu® Pro interface on the driver's BACnet Router Properties page or in 

Local Access on the Ports tab.  

 

 
 

To add a controller 

1 Right-click the network  that the controller is attached to. 

2 Select Add BACnet Device. 

3 Enter values in the BACnet Device dialog box. See table below. 

4 Optional:  Click Notes, then type in the notes field.  

A notes icon ( ) on the tree indicates where you added notes. 

5 Click OK. 

  

Field or Tab Notes 

Name The name displayed on the Network tree. 

Reference Name Global reference names begin with # and must be unique within the entire 

system. Non-global reference names (no #) must be unique among siblings.  

Address Type the rotary dial address of the controller. 

Controller Select the controller in the drop-down list. 

NOTE  If the controller you are adding is not listed, browse to the controller's 

driver. 
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Field or Tab Notes 

Device Instance Use the default number unless you use a naming convention for your devices. A 

device instance number must be unique throughout an entire BACnet system. 

Screen File If you have a file for a BACview® or touchscreen device, select a .bacview or 

.touch file from the drop-down list. 

 

 
 

BACnet routers separated by an IP router 

To minimize network communications, IP routers do not pass on broadcasts that they receive. You can set up your 

BACnet network so that BACnet Broadcast Management Devices (BBMDs) can pass BACnet broadcasts across IP 

routers to other BBMDs. 

  

172.16.5.3
172.18.64.38

BBMD (2)
R

172.16.5.3
172.18.64.38

BBMD (1)

BACnet Router 1
IP address: 172.18.64.38
Subnet mask: 255.255.0.0
Default gateway: 172.18.1.1

172.18.1.1 172.16.1.1

BACnet Router 2
IP address: 172.16.5.3
Subnet mask: 255.255.0.0
Default gateway: 172.16.1.1

ControllerController

IP Router
(Default Gateway)

 

 

 
 

To add a site 

1 On the Network tree, right-click the system . 

2 Select Add Site. 

3 Enter values in the Site dialog box. See table below. 

4 Optional:  Click Notes, then type in the notes field. These notes can also be seen on the i-Vu® Pro Properties 

page. 

5 Click OK. 
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Field Notes 

Name The name displayed on the Network tree. 

Reference Name Global reference names begin with # and must be unique within the entire 

system. Non-global reference names (no #) must be unique among siblings.  

Site Number SiteBuilder automatically assigns a unique site number, but if needed, you can 

change it to some other unique number. 

Time Zone By default, the site is set to the same time zone as the i-Vu® Pro server. If the site 

is in a different time zone, select Specify Time Zone, and then select the zone 

from the drop-down list. 

Peer Caching Select Use Peer Caching, click the drop-down arrow, then choose the BACnet 

router closest to the i-Vu® Pro server to be the peer caching router. The peer 

caching router will poll other routers on the IP network for colors and prime 

variables. 

Peer caching also checks the communication status of the peer caching router 

and any routers for which it is caching. If any of the routers cannot communicate, 

a Dead Module Timeout alarm is issued. 

You can select Do Not Use Peer Caching to slightly reduce network bandwidth, 

but you will not receive Dead Module Timeout alarms for the BACnet routers. 

Optimize download for 

Open PIC controllers 

Check to increase download speed. The full source files are not downloaded into 

the PIC controllers when this is checked. 

Include graphics in Open 

programmable controller 

download 

Uncheck to increase download speed. If you are not changing the graphics, you 

may not want to include them in every download. 

 

 

 
 

To add a BACnet/IP network 

1 On the Network tree, right-click the site . 

2 Select Add BACnet Network. 

3 Enter values in the Network dialog box. See table below. 

  Every site with a CCN Gateway must have the same Network Number if they are on the same IP network.  

4 Optional:  Click Notes, then type in the notes field. These notes can also be seen on the i-Vu® Pro Properties 

page. 

5 Click OK. 
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Field Notes 

Name The name displayed on the Network tree. 

Reference Name Global reference names begin with # and must be unique within the entire system. Non-

global reference names (no #) must be unique among siblings.  

Network Number 
  Every site with a CCN Gateway must have the same Network Number. Click Yes in 

the dialog box stating This network number is already in use. Only in rare cases do you 

want to duplicate this. Are you sure you want a duplicate network number?. 

i-Vu® Open systems: Use the default number unless your BACnet administrator gives 

you a different number. 

Media Type Select BACnet/IP. 

 

 
 

To add BACnet routers 

1 Right-click the BACnet/IP network . 

2 Select Add BACnet Device Router. 

3 Enter values in the Device Properties dialog box. See table below. 

4 Click OK. 

5 Repeat steps 1 through 4 for the second router. See tables below. 

6 Add networks and controllers as needed under each BACnet router. 

  

General tab  

Name The name displayed on the Network tree. 

Reference Name Global reference names begin with # and must be unique within the entire 

system. Non-global reference names (no #) must be unique among siblings.  

Controller Select the controller in the drop-down list.  

NOTE  If the controller you are adding is not listed, browse to the controller's 

driver.  
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General tab  

Device Instance This number must be unique throughout an entire BACnet system. Do one of the 

following: 

 Use the default number based on SiteBuilder's next sequential Device 

Instance number 

 Enter a specific number. 

  

i-Vu® XT or TruVu™ router only—Check Autogenerated only if you plan to let the 

controller autogenerate its Device instance. The number you enter in SiteBuilder 

must match the autogenerated number in the controller setup pages that you 

access through the Service Port. This number is equal to: 

(IP network number x 100) + the router's rotary switch address  

EXAMPLE  If the IP network number is 1600 and the rotary switch address is 15, 

the Device Instance is 160015. 

NOTE  To see the Autogenerated checkbox, you must click OK in the properties 

dialog box, then double-click the router to reopen the properties. 

Screen File If you have a file for a BACview® or touchscreen device, select a .bacview or 

.touch file from the drop-down list. 

  

Address tab See: 

Setting Open device IP addresses (page 68) 

or 

Setting i-Vu® XT or TruVu™ device IP 

addresses (page 75) 

Example 

Router 1 

Example 

Router 2 

Specify a custom or 

DHCP IP Address 

Select this option, then enter values in the 

following fields. 

NOTE  Open router only—The router's IP 

Address DIP switch must be set to: 

Assigned if using a custom IP address 

DHCP if using a DHCP IP address 

 
 

        IP Address Type the BACnet router's IP address that you 

got from the network administrator.  

NOTE  If the i-Vu® Pro server will use a port 

other than 47808 for BACnet 

communication, type :<port number> 

after the address.  

For example, 172.18.64.38:47901. 

172.18.64.38 172.16.5.3 

        Subnet Mask Type the BACnet router's subnet mask that 

you got from the network administrator. 

255.255.0.0 255.255.0.0 

        Default 

        Gateway 

        Address 

Type the BACnet router's default gateway 

address that you got from the network 

administrator. 

172.18.1.1 172.16.1.1 

        Automatically 

        Configure My 

        BBMDs 

Check this field for all BACnet routers in your 

system. 

EXCEPTION  If your system has more than 50 

IP subnets, see Setting up BBMDs (page 79). 
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Address tab See: 

Setting Open device IP addresses (page 68) 

or 

Setting i-Vu® XT or TruVu™ device IP 

addresses (page 75) 

Example 

Router 1 

Example 

Router 2 

Local Access 

Connection 

Open router only—If your network administrator gave you a custom IP address (not 

DHCP), you must connect to the router locally and then Download Address before the 

i-Vu® Pro server can communicate with the router. See To set a controller's custom 

IP address in SiteBuilder (page 68).  

After the download is complete, click Module Status to verify the router's address. 

  

i-Vu® XT or TruVu™ router only—You cannot download the router's IP address from 

SiteBuilder. See Setting i-Vu® XT or TruVu™ device IP addresses (page 75). 

  CCN tab  

This device is a CCN 

Gateway 

Check if router is a CCN Gateway. Enter Element Number, and Baud Rate, if 

applicable. 

Leave unchecked if router is not a a CCN Gateway, enter Gateway IP Address, 

Element Number, and Baud Rate, if applicable. 

  

Networks tab i-Vu® XT or TruVu™ router only—Shows the network number, media type, and if 

applicable, lets you select the router port that each network will use. 

  

Notes tab These notes can also be seen on i-Vu® Pro Properties page. 

 

 
 

Server on an IP subnet without a BACnet router (no BBMD) 

To minimize network communications, IP routers do not pass on broadcasts that they receive. But, you can set up 

Carrier controllers as BACnet Broadcast Management Devices (BBMDs) to pass BACnet broadcasts across IP 

routers to other BBMDs.  

The i-Vu® Pro server is not a BBMD. If the server is on an IP subnet without a BBMD, you must register the server 

as a foreign device (page 83) to a BBMD in the system. That BBMD will then forward BACnet broadcasts to the 

server. Register the server with the BBMD that will have the fastest response time. Response time is affected by 

distance and network complexity. 
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NOTE  The BACnet device must be set up as a BBMD before you register the server as a foreign device. 

  

Controller

R

System Server
IP address: 172.18.64.37
Subnet mask: 255.255.0.0
Default gateway: 172.18.1.1

172.18.1.1

BACnet Router
IP address: 172.16.5.3
Subnet mask: 255.255.0.0
Default gateway: 172.16.1.1

R
172.16.1.1

IP Router
(Default Gateway)

 

 

 
 

To add a site 

1 On the Network tree, right-click the system . 

2 Select Add Site. 

3 Enter values in the Site dialog box. See table below. 

4 Optional:  Click Notes, then type in the notes field. These notes can also be seen on the i-Vu® Pro Properties 

page. 

5 Click OK. 

  

Field Notes 

Name The name displayed on the Network tree. 

Reference Name Global reference names begin with # and must be unique within the entire 

system. Non-global reference names (no #) must be unique among siblings.  

Site Number SiteBuilder automatically assigns a unique site number, but if needed, you can 

change it to some other unique number. 

Time Zone By default, the site is set to the same time zone as the i-Vu® Pro server. If the site 

is in a different time zone, select Specify Time Zone, and then select the zone 

from the drop-down list. 

Peer Caching Select Use Peer Caching, click the drop-down arrow, then choose the BACnet 

router closest to the i-Vu® Pro server to be the peer caching router. The peer 

caching router will poll other routers on the IP network for colors and prime 

variables. 

Peer caching also checks the communication status of the peer caching router 

and any routers for which it is caching. If any of the routers cannot communicate, 

a Dead Module Timeout alarm is issued. 

You can select Do Not Use Peer Caching to slightly reduce network bandwidth, 

but you will not receive Dead Module Timeout alarms for the BACnet routers. 
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Field Notes 

Optimize download for 

Open PIC controllers 

Check to increase download speed. The full source files are not downloaded into 

the PIC controllers when this is checked. 

Include graphics in Open 

programmable controller 

download 

Uncheck to increase download speed. If you are not changing the graphics, you 

may not want to include them in every download. 

 

 
 

To add a BACnet/IP network 

1 On the Network tree, right-click the site . 

2 Select Add BACnet Network. 

3 Enter values in the Network dialog box. See table below. 

  Every site with a CCN Gateway must have the same Network Number if they are on the same IP network.  

4 Optional:  Click Notes, then type in the notes field. These notes can also be seen on the i-Vu® Pro Properties 

page. 

5 Click OK. 

  

Field Notes 

Name The name displayed on the Network tree. 

Reference Name Global reference names begin with # and must be unique within the entire system. Non-

global reference names (no #) must be unique among siblings.  

Network Number 
  Every site with a CCN Gateway must have the same Network Number. Click Yes in 

the dialog box stating This network number is already in use. Only in rare cases do you 

want to duplicate this. Are you sure you want a duplicate network number?. 

i-Vu® Open systems: Use the default number unless your BACnet administrator gives 

you a different number. 

Media Type Select BACnet/IP. 

 

 
 

To add a BACnet router 

1 Right-click the BACnet/IP network . 

2 Select Add BACnet Device Router. 

3 Enter values in the BACnet Device Router dialog box. See table below.  

4 Click OK. 

5 Add a network and controllers as needed under the BACnet router. 
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General tab  

Name The name displayed on the Network tree. 

Reference Name Global reference names begin with # and must be unique within the entire 

system. Non-global reference names (no #) must be unique among siblings.  

Controller Select the controller in the drop-down list.  

NOTE  If the controller you are adding is not listed, browse to the controller's 

driver.  

Device Instance This number must be unique throughout an entire BACnet system. Do one of the 

following: 

 Use the default number based on SiteBuilder's next sequential Device 

Instance number 

 Enter a specific number. 

  

i-Vu® XT or TruVu™ router only—Check Autogenerated only if you plan to let the 

controller autogenerate its Device instance. The number you enter in SiteBuilder 

must match the autogenerated number in the controller setup pages that you 

access through the Service Port. This number is equal to: 

(IP network number x 100) + the router's rotary switch address  

EXAMPLE  If the IP network number is 1600 and the rotary switch address is 15, 

the Device Instance is 160015. 

NOTE  To see the Autogenerated checkbox, you must click OK in the properties 

dialog box, then double-click the router to reopen the properties. 

Screen File If you have a file for a BACview® or touchscreen device, select a .bacview or 

.touch file from the drop-down list. 

   

Address tab See: 

Setting Open device IP addresses (page 68) or 

Setting i-Vu® XT or TruVu™ device IP addresses 

(page 75) 

Example router 

Specify a custom or 

DHCP IP Address 

Select this option, then enter values in the following 

fields. 

NOTE  Open router only—The router's IP Address DIP 

switch must be set to: 

Assigned if using a custom IP address 

DHCP if using a DHCP IP address 

 

        IP Address Type the BACnet router's IP address that you got 

from the network administrator.  

NOTE  If the i-Vu® Pro server will use a port other 

than 47808 for BACnet communication, type 

:<port number> after the address.  

For example, 172.18.64.38:47901. 

172.16.5.3 

        Subnet Mask Type the BACnet router's subnet mask that you got 

from the network administrator. 

255.255.0.0 

        Default 

        Gateway 

        Address 

Type the BACnet router's default gateway address 

that you got from the network administrator. 

172.16.1.1 
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Address tab See: 

Setting Open device IP addresses (page 68) or 

Setting i-Vu® XT or TruVu™ device IP addresses 

(page 75) 

Example router 

        Automatically 

        Configure My 

        BBMDs 

Check this field for all BACnet routers in your 

system. 

EXCEPTION  If your system has more than 50 IP 

subnets, see Setting up BBMDs (page 79). 

 

Local Access 

Connection 

Open router only—If your network administrator gave you a custom IP address (not 

DHCP), you must connect to the router locally and then Download Address before the 

i-Vu® Pro server can communicate with the router. See To set a controller's custom 

IP address in SiteBuilder (page 68).  

After the download is complete, click Module Status to verify the router's address. 

  

i-Vu® XT or TruVu™ router only—You cannot download the router's IP address from 

SiteBuilder. See Setting i-Vu® XT or TruVu™ device IP addresses (page 75). 

  CCN tab  

This device is a CCN 

Gateway 

Check if router is a CCN Gateway. Enter Element Number, and Baud Rate, if 

applicable. 

Leave unchecked if router is not a a CCN Gateway, enter Gateway IP Address, 

Element Number, and Baud Rate, if applicable. 

  

Networks tab i-Vu® XT or TruVu™ router only—Shows the network number, media type, and if 

applicable, lets you select the router port that each network will use. 

  

Notes tab These notes can also be seen on i-Vu® Pro Properties page. 

 

 
 

Entire BACnet network behind a NAT router 

In this example, the entire BACnet system is behind a NAT router (firewall), but clients can access the network from 

the Internet. Small companies use this kind of network with a cable modem or DSL such as a Linksys® router. 

  

Private
System Server

192.168.0.3

Public
179.122.12.44

Private
192.168.0.1

Private
BACnet Router
192.169.0.5

Default Gateway

N
A
T

Controller

Internet

Browser
Client
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NOTES   

 The client will use the server NAT router's public IP address to access the i-Vu® Pro server.   

 The NAT router must be set up to port forward HTTP traffic to the i-Vu® Pro server. See Building a Network 

tree (page 12). 

  

 

 
 

To add a site 

1 On the Network tree, right-click the system . 

2 Select Add Site. 

3 Enter values in the Site dialog box. See table below. 

4 Optional:  Click Notes, then type in the notes field. These notes can also be seen on the i-Vu® Pro Properties 

page. 

5 Click OK. 

  

Field Notes 

Name The name displayed on the Network tree. 

Reference Name Global reference names begin with # and must be unique within the entire 

system. Non-global reference names (no #) must be unique among siblings.  

Site Number SiteBuilder automatically assigns a unique site number, but if needed, you can 

change it to some other unique number. 

Time Zone By default, the site is set to the same time zone as the i-Vu® Pro server. If the site 

is in a different time zone, select Specify Time Zone, and then select the zone 

from the drop-down list. 

Peer Caching Select Use Peer Caching, click the drop-down arrow, then choose the BACnet 

router closest to the i-Vu® Pro server to be the peer caching router. The peer 

caching router will poll other routers on the IP network for colors and prime 

variables. 

Peer caching also checks the communication status of the peer caching router 

and any routers for which it is caching. If any of the routers cannot communicate, 

a Dead Module Timeout alarm is issued. 

You can select Do Not Use Peer Caching to slightly reduce network bandwidth, 

but you will not receive Dead Module Timeout alarms for the BACnet routers. 

Optimize download for 

Open PIC controllers 

Check to increase download speed. The full source files are not downloaded into 

the PIC controllers when this is checked. 

Include graphics in Open 

programmable controller 

download 

Uncheck to increase download speed. If you are not changing the graphics, you 

may not want to include them in every download. 
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To add a BACnet/IP network 

1 On the Network tree, right-click the site . 

2 Select Add BACnet Network. 

3 Enter values in the Network dialog box. See table below. 

  Every site with a CCN Gateway must have the same Network Number if they are on the same IP network.  

4 Optional:  Click Notes, then type in the notes field. These notes can also be seen on the i-Vu® Pro Properties 

page. 

5 Click OK. 

  

Field Notes 

Name The name displayed on the Network tree. 

Reference Name Global reference names begin with # and must be unique within the entire system. Non-

global reference names (no #) must be unique among siblings.  

Network Number 
  Every site with a CCN Gateway must have the same Network Number. Click Yes in 

the dialog box stating This network number is already in use. Only in rare cases do you 

want to duplicate this. Are you sure you want a duplicate network number?. 

i-Vu® Open systems: Use the default number unless your BACnet administrator gives 

you a different number. 

Media Type Select BACnet/IP. 

 

 
 

To add a BACnet router 

1 Right-click the BACnet/IP network . 

2 Select Add BACnet Device Router. 

3 Enter values in the BACnet Device Router dialog box. See table below.  

4 Click OK. 

5 Add a network and controllers as needed under the BACnet router. 

     

General tab  

Name The name displayed on the Network tree. 

Reference Name Global reference names begin with # and must be unique within the entire 

system. Non-global reference names (no #) must be unique among siblings.  

Controller Select the controller in the drop-down list.  

NOTE  If the controller you are adding is not listed, browse to the controller's 

driver.  
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General tab  

Device Instance This number must be unique throughout an entire BACnet system. Do one of the 

following: 

 Use the default number based on SiteBuilder's next sequential Device 

Instance number 

 Enter a specific number. 

  

i-Vu® XT or TruVu™ router only—Check Autogenerated only if you plan to let the 

controller autogenerate its Device instance. The number you enter in SiteBuilder 

must match the autogenerated number in the controller setup pages that you 

access through the Service Port. This number is equal to: 

(IP network number x 100) + the router's rotary switch address  

EXAMPLE  If the IP network number is 1600 and the rotary switch address is 15, 

the Device Instance is 160015. 

NOTE  To see the Autogenerated checkbox, you must click OK in the properties 

dialog box, then double-click the router to reopen the properties. 

Screen File If you have a file for a BACview® or touchscreen device, select a .bacview or 

.touch file from the drop-down list. 

 

Address tab See: 

Setting Open device IP addresses (page 68) or 

Setting i-Vu® XT or TruVu™ device IP addresses 

(page 75) 

Example router 

Specify a custom or DHCP 

IP Address 

Select this option, then enter values in the 

following fields. 

NOTE  Open router only—The router's IP Address 

DIP switch must be set to: 

Assigned if using a custom IP address 

DHCP if using a DHCP IP address 

 

        IP Address Type the BACnet router's private IP address that 

you got from the network administrator. 

 CAUTION  SiteBuilder allows duplicate 

private IP addresses in the system, even on the 

same private network. So you must verify with 

your network administrator that the private 

network has no duplicate addresses. 

NOTE  If the i-Vu® Pro server will use a port 

other than 47808 for BACnet communication, 

type :<port number> after the address.  

For example, 172.18.64.38:47901. 

192.168.0.5 

        Subnet Mask Type the BACnet router's subnet mask that you 

got from the network administrator. 

255.255.255.0 

        Default 

        Gateway 

        Address 

Type the BACnet router's default gateway 

address that you got from the network 

administrator. 

192.168.0.1 
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        Automatically 

        Configure My 

        BBMDs 

Check this field for all BACnet routers in your 

system even though this kind of network cannot 

use BBMDs. 

 

Local Access Connection Open router only—If your network administrator gave you a custom IP address (not 

DHCP), you must connect to the router locally and then Download Address before 

the i-Vu® Pro server can communicate with the router. See To set a controller's 

custom IP address in SiteBuilder (page 68).  

After the download is complete, click Module Status to verify the router's address. 

  

i-Vu® XT or TruVu™ router only—You cannot download the router's IP address 

from SiteBuilder. See Setting i-Vu® XT or TruVu™ device IP addresses (page 75). 

  

 CCN tab  

This device is a CCN 

Gateway 

Check if router is a CCN Gateway. Enter Element Number, and Baud Rate, if 

applicable. 

Leave unchecked if router is not a a CCN Gateway, enter Gateway IP Address, 

Element Number, and Baud Rate, if applicable. 

  

Networks tab i-Vu® XT or TruVu™ router only—Shows the network number, media type, and if 

applicable, lets you select the router port that each network will use. 

  

Notes tab These notes can also be seen on i-Vu® Pro Properties page. 

 

 
 

BACnet router behind a NAT router 

This type of network layout is not recommended because the server is not protected by a NAT router (firewall), but 

it is commonly used with DSL or a cable modem. 

  

Public
System Server

130.130.130.130

Private
192.168.168.1

Public
127.127.127.127

Default Gateway

N
A
T Private

BACnet Router
192.169.168.2

Internet

Browser
Client

Controller
 

NOTES   

 When using NAT routers, the controllers on different sites cannot communicate with each other. 

 The BACnet router's NAT router must be set up to port forward BACnet traffic (typically UDP 47808) to the 

BACnet router. See Building a Network tree (page 12). 
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To edit System Properties 

1 In SiteBuilder, on the Network tree, double-click the system . 

2 In the System Properties dialog box, click the Advanced tab. 

3 Check Enable Network Address Translation (NAT). 

4 Type the NAT Alarm Recipient Address information. In most systems, the i-Vu® Pro server is the alarm 

recipient. 

○ Type the Network Number of the BACnet/IP network where the i-Vu® Pro server is located. You will add 

this network later. See "To add a BACnet/IP network". 

○ Type the i-Vu® Pro server's public IP address in the IP Address field. (130.130.130.130, in the example 

above.)  

5 Click OK. 

 

 
 

To add a site 

1 On the Network tree, right-click the system . 

2 Select Add Site. 

3 Enter values in the Site dialog box. See table below. 

4 Optional:  Click Notes, then type in the notes field. These notes can also be seen on the i-Vu® Pro Properties 

page. 

5 Click OK. 

  

Field Notes 

Name The name displayed on the Network tree. 

Reference Name Global reference names begin with # and must be unique within the entire 

system. Non-global reference names (no #) must be unique among siblings.  

Number SiteBuilder automatically assigns a unique site number, but if needed, you can 

change it to some other unique number. 

Devices under this site are 

behind a NAT 

Check this field. 

Deliver alarms from this 

site to the server through a 

NAT 

This field is automatically checked when you check Devices under this site are 

behind a NAT. This setting is required even though it may not make sense in this 

network layout. 

Time Zone By default, the site is set to the same time zone as the i-Vu® Pro server. If the site 

is in a different time zone, select Specify Time Zone, and then select the zone 

from the drop-down list. 
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Field Notes 

Peer Caching Select Use Peer Caching, click the drop-down arrow, then choose the BACnet 

router behind the NAT to be the peer caching router. The peer caching router will 

poll other routers behind the same NAT for colors and prime variables. 

Peer caching also checks the communication status of the peer caching router 

and any routers for which it is caching. If any of the routers cannot communicate, 

a Dead Module Timeout alarm is issued. 

NOTE  If a system has multiple BACnet routers behind different NAT routers, put 

each router in a different site in SiteBuilder, then set the BACnet router in each 

site as the peer caching device. 

  

Site 1

Site 2

Site 3

 
  

You can select Do Not Use Peer Caching to slightly reduce network bandwidth, 

but you will not receive Dead Module Timeout alarms for the BACnet routers. 

Optimize download for 

Open PIC controllers 

Check to increase download speed. The full source files are not downloaded into 

the PIC controllers when this is checked. 

Include graphics in Open 

programmable controller 

download 

Uncheck to increase download speed. If you are not changing the graphics, you 

may not want to include them in every download. 

  

 

 
 

To add a BACnet/IP network 

1 On the Network tree, right-click the site . 

2 Select Add BACnet Network. 

3 Enter values in the Network dialog box. See table below. 

  Every site with a CCN Gateway must have the same Network Number if they are on the same IP network.  

4 Optional:  Click Notes, then type in the notes field. These notes can also be seen on the i-Vu® Pro Properties 

page. 

5 Click OK. 
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Field Notes 

Name The name displayed on the Network tree. 

Reference Name Global reference names begin with # and must be unique within the entire system. Non-

global reference names (no #) must be unique among siblings.  

Network Number 
  Every site with a CCN Gateway must have the same Network Number. Click Yes in 

the dialog box stating This network number is already in use. Only in rare cases do you 

want to duplicate this. Are you sure you want a duplicate network number?. 

i-Vu® Open systems: Use the default number unless your BACnet administrator gives 

you a different number. 

Media Type Select BACnet/IP. 

 

 
 

To add a BACnet router 

1 Right-click the BACnet/IP network . 

2 Select Add BACnet Device Router. 

3 Enter values in the BACnet Device Router dialog box. See table below.  

4 Click OK. 

5 Add a network and controllers as needed under the BACnet router. 

   

General tab  

Name The name displayed on the Network tree. 

Reference Name Global reference names begin with # and must be unique within the entire 

system. Non-global reference names (no #) must be unique among siblings.  

Controller Select the controller in the drop-down list.  

NOTE  If the controller you are adding is not listed, browse to the controller's 

driver.  

Device Instance This number must be unique throughout an entire BACnet system. Do one of the 

following: 

 Use the default number based on SiteBuilder's next sequential Device 

Instance number 

 Enter a specific number. 

  

i-Vu® XT or TruVu™ router only—Check Autogenerated only if you plan to let the 

controller autogenerate its Device instance. The number you enter in SiteBuilder 

must match the autogenerated number in the controller setup pages that you 

access through the Service Port. This number is equal to: 

(IP network number x 100) + the router's rotary switch address  

EXAMPLE  If the IP network number is 1600 and the rotary switch address is 15, 

the Device Instance is 160015. 

NOTE  To see the Autogenerated checkbox, you must click OK in the properties 

dialog box, then double-click the router to reopen the properties. 
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General tab  

Screen File If you have a file for a BACview® or touchscreen device, select a .bacview or 

.touch file from the drop-down list. 

  

Address tab See: 

Setting Open device IP addresses (page 68) or 

Setting i-Vu® XT or TruVu™ device IP addresses 

(page 75) 

Example values 

Specify a custom or 

DHCP IP Address 

Select this option, then enter values in the 

following fields. 

NOTE  Open router only—The router's IP Address 

DIP switch must be set to: 

Assigned if using a custom IP address 

DHCP if using a DHCP IP address 

 

        IP Address Type the BACnet router's private IP address that 

you got from the network administrator. 

 CAUTION  SiteBuilder allows duplicate 

private IP addresses in the system, even on the 

same private network. So you must verify with 

your network administrator that the private 

network has no duplicate addresses. 

NOTE  If the i-Vu® Pro server will use a port 

other than 47808 for BACnet communication, 

type :<port number> after the address.  

For example, 172.18.64.38:47901. 

192.168.168.2 

        Subnet Mask Type the BACnet router's subnet mask that you 

got from the network administrator. 

255.255.255.0 

        Default 

        Gateway 

        Address 

Type the NAT router's private address that you 

got from the network administrator. 

192.168.168.1 

        NAT Address Type the NAT's public IP address that you got 

from the network administrator. 

127.127.127.127 

NAT CCN Port Type the NAT's public port for the NAT address 

that translates to the private CCN/IP port. 

 

        Automatically 

        Configure My 

        BBMDs 

Check this field for all BACnet routers in your 

system even though this kind of network cannot 

use BBMDs. 

 

Local access Connection Open router only—If your network administrator gave you a custom IP address (not 

DHCP), you must connect to the router locally and then Download Address before the 

i-Vu® Pro server can communicate with the router. See To set a controller's custom 

IP address in SiteBuilder (page 68).  

After the download is complete, click Module Status to verify the router's address. 

  

i-Vu® XT or TruVu™ router only—You cannot download the router's IP address from 

SiteBuilder. See Setting i-Vu® XT or TruVu™ device IP addresses (page 75). 
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 CCN tab  

This device is a CCN 

Gateway 

Check if router is a CCN Gateway. Enter Element Number, and Baud Rate, if 

applicable. 

Leave unchecked if router is not a a CCN Gateway, enter Gateway IP Address, 

Element Number, and Baud Rate, if applicable. 

  

Networks tab i-Vu® XT or TruVu™ router only—Shows the network number, media type, and if 

applicable, lets you select the router port that each network will use. 

  

Notes tab These notes can also be seen on i-Vu® Pro Properties page. 

 

 
 

Server behind a NAT router 

This network layout is usually used to add a new segment to an existing BACnet network. 

  

Private
System Server
192.168.168.3

Public
129.129.35.3

Private
192.168.168.1

Default Gateway

N
A
T Public

BACnet Router
190.180.155.45

Internet

Browser
Client Controller

 

 

  

NOTES   

 The client will use the server NAT router's public IP address to access the i-Vu® Pro server.  

 The NAT router must be set up to port forward HTTP traffic to the i-Vu® Pro server. This router also must be 

set up to port forward BACnet traffic (typically UDP 47808) to the server. See Building a Network tree (page 

12). 

  

 

 
 

To edit System Properties 

1 In SiteBuilder, on the Network tree, double-click the system . 

2 In the System Properties dialog box, click the Advanced tab. 

3 Check Enable Network Address Translation (NAT). 
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4 Type the NAT Alarm Recipient Address information. In most systems, the i-Vu® Pro server is the alarm 

recipient. 

 Type the Network Number of the BACnet/IP network where the i-Vu® Pro server is located. You will add 

this network later. See "To add a BACnet/IP network". 

 Type the NAT's public IP address in the IP Address field. (129.129.35.3, in the example above.)  

5 Click OK. 

 

 
 

To add a site 

1 On the Network tree, right-click the system . 

2 Select Add Site. 

3 Enter values in the Site dialog box. See table below. 

4 Optional:  Click Notes, then type in the notes field. These notes can also be seen on the i-Vu® Pro Properties 

page. 

5 Click OK. 

  

Field Notes 

Name The name displayed on the Network tree. 

Reference Name Global reference names begin with # and must be unique within the entire 

system. Non-global reference names (no #) must be unique among siblings.  

Number SiteBuilder automatically assigns a unique site number, but if needed, you can 

change it to some other unique number. 

Devices under this site are 

behind a NAT 

Uncheck this field. 

Deliver alarms from this 

site to the server through a 

NAT 

Check this field. 

Time Zones By default, the site is set to the same time zone as the i-Vu® Pro server. If the site 

is in a different time zone, select Specify Time Zone, and then select the zone 

from the drop-down list. 
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Field Notes 

Peer Caching Select Use Peer Caching, click the drop-down arrow, then choose the BACnet 

router behind the NAT to be the peer caching router. The peer caching router will 

poll other routers behind the same NAT for colors and prime variables. 

Peer caching also checks the communication status of the peer caching router 

and any routers for which it is caching. If any of the routers cannot communicate, 

a Dead Module Timeout alarm is issued. 

NOTE  If a system has multiple BACnet routers behind different NAT routers, put 

each router in a different site in SiteBuilder, then set the BACnet router in each 

site as the peer caching device. 

  

Site 1

Site 2

Site 3

 
  

You can select Do Not Use Peer Caching to slightly reduce network bandwidth, 

but you will not receive Dead Module Timeout alarms for the BACnet routers. 

Optimize download for 

Open PIC controllers 

Check to increase download speed. The full source files are not downloaded into 

the PIC controllers when this is checked. 

Include graphics in Open 

programmable controller 

download 

Uncheck to increase download speed. If you are not changing the graphics, you 

may not want to include them in every download. 

  

 

 
 

To add a BACnet/IP network 

1 On the Network tree, right-click the site . 

2 Select Add BACnet Network. 

3 Enter values in the Network dialog box. See table below. 

  Every site with a CCN Gateway must have the same Network Number if they are on the same IP network.  

4 Optional:  Click Notes, then type in the notes field. These notes can also be seen on the i-Vu® Pro Properties 

page. 

5 Click OK. 
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Field Notes 

Name The name displayed on the Network tree. 

Reference Name Global reference names begin with # and must be unique within the entire system. Non-

global reference names (no #) must be unique among siblings.  

Network Number 
  Every site with a CCN Gateway must have the same Network Number. Click Yes in 

the dialog box stating This network number is already in use. Only in rare cases do you 

want to duplicate this. Are you sure you want a duplicate network number?. 

i-Vu® Open systems: Use the default number unless your BACnet administrator gives 

you a different number. 

Media Type Select BACnet/IP. 

 

 
 

To add a BACnet router 

1 Right-click the BACnet/IP network . 

2 Select Add BACnet Device Router. 

3 Enter values in the BACnet Device Router dialog box. See table below.  

4 Click OK. 

5 Add a network and controllers as needed under the BACnet router. 

   General tab  

Name The name displayed on the Network tree. 

Reference Name Global reference names begin with # and must be unique within the entire 

system. Non-global reference names (no #) must be unique among siblings.  

Controller Select the controller in the drop-down list.  

NOTE  If the controller you are adding is not listed, browse to the controller's 

driver.  

Device Instance This number must be unique throughout an entire BACnet system. Do one of the 

following: 

 Use the default number based on SiteBuilder's next sequential Device 

Instance number 

 Enter a specific number. 

  

i-Vu® XT or TruVu™ router only—Check Autogenerated only if you plan to let the 

controller autogenerate its Device instance. The number you enter in SiteBuilder 

must match the autogenerated number in the controller setup pages that you 

access through the Service Port. This number is equal to: 

(IP network number x 100) + the router's rotary switch address  

EXAMPLE  If the IP network number is 1600 and the rotary switch address is 15, 

the Device Instance is 160015. 

NOTE  To see the Autogenerated checkbox, you must click OK in the properties 

dialog box, then double-click the router to reopen the properties. 
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   General tab  

Screen File If you have a file for a BACview® or touchscreen device, select a .bacview or 

.touch file from the drop-down list. 

 

Address tab See: 

Setting Open device IP addresses (page 68) or 

Setting i-Vu® XT or TruVu™ device IP 

addresses (page 75) 

Example router 

Specify a custom or DHCP 

IP Address 

Select this option, then enter values in the 

following fields. 

NOTE  Open router only—The router's IP 

Address DIP switch must be set to: 

Assigned if using a custom IP address 

DHCP if using a DHCP IP address 

 

        IP Address Type the BACnet router's IP address that you 

got from the network administrator.  

NOTE  If the i-Vu® Pro server will use a port 

other than 47808 for BACnet communication, 

type :<port number> after the address.  

For example, 172.18.64.38:47901. 

190.180.155.45 

        Subnet Mask Type the BACnet router's subnet mask that you 

got from the network administrator. 

255.255.255.0 

        Default 

        Gateway 

        Address 

Type the BACnet router's default gateway 

address that you got from the network 

administrator. 

129.129.35.3 

        Automatically 

        Configure My 

        BBMDs 

Check this field for all BACnet routers in your 

system even though this kind of network 

cannot use BBMDs. 

 

Local Access Connection Open router only—If your network administrator gave you a custom IP address (not 

DHCP), you must connect to the router locally and then Download Address before 

the i-Vu® Pro server can communicate with the router. See To set a controller's 

custom IP address in SiteBuilder (page 68).  

After the download is complete, click Module Status to verify the router's address. 

  

i-Vu® XT or TruVu™ router only—You cannot download the router's IP address 

from SiteBuilder. See Setting i-Vu® XT or TruVu™ device IP addresses (page 75). 

 

  

 CCN tab  

This device is a CCN 

Gateway 

Check if router is a CCN Gateway. Enter Element Number, and Baud Rate, if 

applicable. 

Leave unchecked if router is not a a CCN Gateway, enter Gateway IP Address, 

Element Number, and Baud Rate, if applicable. 
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Networks tab i-Vu® XT or TruVu™ router only—Shows the network number, media type, and if 

applicable, lets you select the router port that each network will use. 

  

Notes tab These notes can also be seen on i-Vu® Pro Properties page. 

NOTE  The client will use the public IP address to access the i-Vu® Pro server. 
 

Server and BACnet router behind different NAT routers 

This type of network layout using NAT routers (firewalls) is the most common. 

  

Public
129.129.35.3

Private
192.168.168.1

Public
129.15.200.12

Private
10.86.202.254

Default Gateway Default Gateway

Private
BACnet Router
10.86.202.36

N
A
T

N
A
TPrivate

System Server
192.168.168.3

Internet

Browser
Client Controller

 
  

NOTES  

 When using NAT routers, the controllers on different sites cannot communicate with each other. 

 The client will use the server NAT router's public IP address to access the i-Vu® Pro server.  

 The server NAT router must be set up to port forward HTTP traffic to the i-Vu® Pro server. This router also 

must be set up to port forward BACnet traffic (typically UDP 47808) to the server. See Building a Network tree 

(page 12). 

 The BACnet router's NAT router must be set up to port forward BACnet traffic (typically UDP 47808) to the 

BACnet router. See Building a Network tree (page 12). 

  

 

 
 

To edit System Properties 

1 In SiteBuilder, on the Network tree, double-click the system . 

2 In the System Properties dialog box, click the Advanced tab. 

3 Check Enable Network Address Translation (NAT). 

4 Type the NAT Alarm Recipient Address information. In most systems, the i-Vu® Pro server is the alarm 

recipient. 

 Type the Network Number of the BACnet/IP network where the i-Vu® Pro server is located. You will add 

this network later. See "To add a BACnet/IP network". 

 Type the NAT's public IP address in the IP Address field. (129.129.35.3, in the example above.)  

5 Click OK. 
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To add a site 

1 On the Network tree, right-click the system . 

2 Select Add Site. 

3 Enter values in the Site dialog box. See table below. 

4 Optional:  Click Notes, then type in the notes field. These notes can also be seen on the i-Vu® Pro Properties 

page. 

5 Click OK. 

  

Field Notes 

Name The name displayed on the Network tree. 

Reference Name Global reference names begin with # and must be unique within the entire 

system. Non-global reference names (no #) must be unique among siblings.  

Number SiteBuilder automatically assigns a unique site number, but if needed, you can 

change it to some other unique number. 

Devices under this site are 

behind a NAT 

Select this checkbox. 

Deliver alarms from this 

site to the server through a 

NAT 

This field is automatically checked when you check Devices under this site are 

behind a NAT.  

Time Zone By default, the site is set to the same time zone as the i-Vu® Pro server. If the site 

is in a different time zone, select Specify Time Zone, and then select the zone 

from the drop-down list. 

Peer Caching Select Use Peer Caching, click the drop-down arrow, then choose the BACnet 

router behind the NAT to be the peer caching router. The peer caching router will 

poll other routers behind the same NAT for colors and prime variables. 

Peer caching also checks the communication status of the peer caching router 

and any routers for which it is caching. If any of the routers cannot communicate, 

a Dead Module Timeout alarm is issued. 

NOTE  If a system has multiple BACnet routers behind different NAT routers, put 

each router in a different site in SiteBuilder, then set the BACnet router in each 

site as the peer caching device. 

  

Site 1

Site 2

Site 3

 
  

You can select Do Not Use Peer Caching to slightly reduce network bandwidth, 

but you will not receive Dead Module Timeout alarms for the BACnet routers. 
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Field Notes 

Optimize download for 

Open PIC controllers 

Check to increase download speed. The full source files are not downloaded into 

the PIC controllers when this is checked. 

Include graphics in Open 

programmable controller 

download 

Uncheck to increase download speed. If you are not changing the graphics, you 

may not want to include them in every download. 

 

 

 
 

To add a BACnet/IP network 

1 On the Network tree, right-click the site . 

2 Select Add BACnet Network. 

3 Enter values in the Network dialog box. See table below. 

  Every site with a CCN Gateway must have the same Network Number if they are on the same IP network.  

4 Optional:  Click Notes, then type in the notes field. These notes can also be seen on the i-Vu® Pro Properties 

page. 

5 Click OK. 

  

Field Notes 

Name The name displayed on the Network tree. 

Reference Name Global reference names begin with # and must be unique within the entire system. Non-

global reference names (no #) must be unique among siblings.  

Network Number 
  Every site with a CCN Gateway must have the same Network Number. Click Yes in 

the dialog box stating This network number is already in use. Only in rare cases do you 

want to duplicate this. Are you sure you want a duplicate network number?. 

i-Vu® Open systems: Use the default number unless your BACnet administrator gives 

you a different number. 

Media Type Select BACnet/IP. 

 

 
 

To add a BACnet router 

1 Right-click the BACnet/IP network . 

2 Select Add BACnet Device Router. 

3 Enter values in the BACnet Device Router dialog box. See table below.  

4 Click OK. 

5 Add a network and controllers as needed under the BACnet router. 
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General tab  

Name The name displayed on the Network tree. 

Reference Name Global reference names begin with # and must be unique within the entire 

system. Non-global reference names (no #) must be unique among siblings.  

Controller Select the controller in the drop-down list.  

NOTE  If the controller you are adding is not listed, browse to the controller's 

driver.  

Device Instance This number must be unique throughout an entire BACnet system. Do one of the 

following: 

 Use the default number based on SiteBuilder's next sequential Device 

Instance number 

 Enter a specific number. 

  

i-Vu® XT or TruVu™ router only—Check Autogenerated only if you plan to let the 

controller autogenerate its Device instance. The number you enter in SiteBuilder 

must match the autogenerated number in the controller setup pages that you 

access through the Service Port. This number is equal to: 

(IP network number x 100) + the router's rotary switch address  

EXAMPLE  If the IP network number is 1600 and the rotary switch address is 15, 

the Device Instance is 160015. 

NOTE  To see the Autogenerated checkbox, you must click OK in the properties 

dialog box, then double-click the router to reopen the properties. 

Screen File If you have a file for a BACview® or touchscreen device, select a .bacview or 

.touch file from the drop-down list. 

  

Address tab See: 

Setting Open device IP addresses (page 68) or 

Setting i-Vu® XT or TruVu™ device IP addresses 

(page 75) 

Example router 

Specify a custom or 

DHCP IP Address 

Select this option, then enter values in the 

following fields. 

NOTE  Open router only—The router's IP Address 

DIP switch must be set to: 

Assigned if using a custom IP address 

DHCP if using a DHCP IP address 

 

        IP Address Type the BACnet router's private IP address that 

you got from the network administrator. 

 CAUTION  SiteBuilder allows duplicate private 

IP addresses in the system, even on the same 

private network. So you must verify with your 

network administrator that the private network has 

no duplicate addresses. 

NOTE  If the i-Vu® Pro server will use a port other 

than 47808 for BACnet communication, type 

:<port number> after the address.  

For example, 172.18.64.38:47901. 

10.86.202.36 
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Address tab See: 

Setting Open device IP addresses (page 68) or 

Setting i-Vu® XT or TruVu™ device IP addresses 

(page 75) 

Example router 

        Subnet Mask Type the BACnet router's subnet mask that you got 

from the network administrator. 

255.255.255.0 

        Default 

        Gateway 

        Address 

Type the private IP address of the router's NAT that 

you got from the network administrator.  

10.86.202.254 

        NAT Address Type the public IP address of the router's NAT that 

you got from the network administrator. 

129.15.200.12 

NAT CCN Port Type the NAT's public port for the NAT address that 

translates to the private CCN/IP port. 

 

        Automatically 

        Configure My 

        BBMDs 

Check this field for all BACnet routers in your 

system even though this kind of network cannot 

use BBMDs. 

 

Local Access 

Connection 

Open router only—If your network administrator gave you a custom IP address (not 

DHCP), you must connect to the router locally and then Download Address before the 

i-Vu® Pro server can communicate with the router. See To set a controller's custom 

IP address in SiteBuilder (page 68).  

After the download is complete, click Module Status to verify the router's address. 

  

i-Vu® XT or TruVu™ router only—You cannot download the router's IP address from 

SiteBuilder. See Setting i-Vu® XT or TruVu™ device IP addresses (page 75). 

  

 CCN tab  

This device is a CCN 

Gateway 

Check if router is a CCN Gateway. Enter Element Number, and Baud Rate, if 

applicable. 

Leave unchecked if router is not a a CCN Gateway, enter Gateway IP Address, 

Element Number, and Baud Rate, if applicable. 

  

Networks tab i-Vu® XT or TruVu™ router only—Shows the network number, media type, and if 

applicable, lets you select the router port that each network will use. 

  

Notes tab These notes can also be seen on i-Vu® Pro Properties page. 
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Each controller on the Network tree may operate one or more pieces of equipment on the Geographic tree. Assign 

the equipment to the controller where you will wire its physical inputs and outputs. 

 

 
 

To assign equipment to controllers 

1 On the Geographic tree, select or multiple-select equipment . 

2 Right-click a controller on the Network tree. 

3 Select Assign Equipment. 

Or, you can drag the selected equipment, then drop it onto a controller. 

 TIP  Click View > Highlight > Not Assigned to show unassigned equipment and phantom equipment as red 

text.  

 

 
 

To unassign equipment 

You cannot delete a piece of equipment from the Network tree; you must unassign it. 

1 On the Network tree, right-click a piece of equipment. 

2 Select Unassign Equipment. 

 

 
 

Assigning equipment to controllers 
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After creating a database, you can check your work by running the system without connecting to the controllers. 

See "Running i-Vu_Pro_ Server" in i-Vu® Pro Help. 

 
 

To run SiteBuilder concurrently with the i-Vu® Pro Server application 

You can start SiteBuilder from the i-Vu® Pro Server application if they are both running on the same computer. 

1 In the i-Vu_Pro_ Server application, click Launch Concurrent SiteBuilder. 

2 Type your Name and Password. 

3 Click the mode icon to change from view only mode (red) to edit mode (green). 

 

 
  

4 Close SiteBuilder after you make your changes. 

  

NOTES 

 Any changes you make while SiteBuilder is in edit mode are saved immediately. You cannot "close" SiteBuilder 

without saving changes.  

 In view only mode, i-Vu_Pro_ Server and field communications run normally. In edit mode, the i-Vu_Pro_ Server 

is not affected, but field communications are disabled and operators will see question marks on i-Vu® Pro 

pages instead of live data. After you switch to view mode or close SiteBuilder, field communications resume 

automatically.  

 
 

Using the Error Log 

When an error occurs in the SiteBuilder database, a red triangle appears in the lower right corner of the screen 

indicating that a message has been written to the Error Log. The Error Log displays database errors for the current 

SiteBuilder session and erases the messages when you close SiteBuilder. 

Click File > Error Log to view the errors or click the red triangle in the lower right corner. 

 
 

Testing a system 
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Use the following features to work efficiently in SiteBuilder. 

 

 
 

To copy tree items 

1 Right-click the item you want to copy. 

NOTE  Its children will be copied as well. 

2 Select Copy. 

3 Right-click the item that will be the new parent of the copied item. 

4 Select Paste. 

5 Double-click each pasted item to change its properties if necessary. 

  

NOTE  Use the Library or Export/Import Clipping (page 61) feature to copy and paste between two databases. 

 

 
 

To replicate a tree item 

The Replicate command makes copies of a tree item and all of its children. For example, if you have a building with 

6 identical floors, you can build one floor, then replicate it 5 times. The Replicate command can generate the 

following for the item that you replicate: 

 A unique name for each area or device 

 A unique name and object instance number for each piece of equipment 

 A unique IP address for each BACnet device router 

 A unique address for each BACnet device 

  

 TIP  Define all the properties of an item before you replicate it. 

NOTES   

 Plan carefully when replicating an item with children. When you replicate an item with children, copy_of_ is 

added at the beginning of the children's reference names. The cleanup required may outweigh the benefits of 

the replication. 

 The Replicate command does not copy phantom equipment. 

  

To replicate an item: 

1 Right-click an area, a piece of equipment, or a device that you want to replicate. 

2 Select Replicate. 

SiteBuilder productivity tools 
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3 Enter values in the Replicate dialog box. See table below. 

4 Click OK. 

  

Field Notes 

Number of Times To Replicate The number of copies you want 

Name Template,  

Reference Name Template, 

and  

Starting Character to replace * in 

names 

SiteBuilder gives the first copy a unique name and reference name by 

replacing the * in the Templates with the Starting Character. For each 

additional copy, SiteBuilder increases or decreases the character.  

NOTES 

 The asterisk appears at the end of the name in the Template fields, 

but you may move it if needed. 

 Use additional asterisks to insert zeros in the numbers. 

For example, to replicate 15 times with a Starting Number of 1: 

If Name  

Template is... 

First copy's  

name is... 

Last copy's name 

is... 

Building 1* Building 11 Building 115 

Building ** Building 101 Building 115 

  

 TIP  See the results of your settings in the Preview box. 

Increase characters or Decrease 

characters 

Increase:   1, 2, 3 or a, b, c 

Decrease:   9, 8, 7 or i, h, g 

Specify Object Instance 

and  

Starting Object Instance Number 

Equipment only. 

Check Specify Object Instance and enter a starting number to set 

sequential numbers for each copy. 

Uncheck Specify Object Instance to have SiteBuilder assign the numbers. 

IP Address Template  

and  

Starting Number 

BACnet device routers only. 

Enter an IP address and starting number to set a sequential IP address 

for each copy. 

Starting Address Number BACnet devices only. 

Enter a starting address number to set a sequential address for each 

copy. 
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To rearrange sibling items 

1 Select the item that you want to move. 

NOTE  Its children will move as well. 

2 Move the item using one of the following methods: 

○ Click  or  on the toolbar. 

○ Hold down the Alt key, then press the up or down arrow key. 

  

NOTE  To move an item to different parent, use the Cut and Paste commands. 

 
 

To delete tree items 

 CAUTION  You cannot undo the Delete command. Save the database before you delete items. 

  

1 Right-click the item you want to delete. 

2 Select Delete. 

  

NOTE  When you delete a control device from the Network tree, its corresponding equipment on the Geographic 

tree becomes unassigned. 

 
 

To find items in SiteBuilder 

1 Click Edit > Find. 

2 Type the text you are looking for in the Find What field.  

3 To narrow the search, check: 

 Case Sensitive to find exact case. For example, Heat finds only Heat and Heating, but not heat or heating. 

 Match Full Text to find exact words. For example, Heat finds Heat, but not Heating. 

4 Tell SiteBuilder where to search: 

 Active Tree Only—Check to search only the tree that is currently active. Uncheck to search all trees.  

 From Current Location—Check to search the selected item and its children. Uncheck to search from the 

top of the tree. 

5 Check the types of information that you want SiteBuilder to search for in the properties dialog boxes. 

NOTE  Check Type to search Control Program, Controller, or Driver names. Check Other to search any other 

properties not specifically listed.  

6 Click Find. The Found items are listed. 

7 Double-click a Found Item to highlight the item on the tree and to open its properties dialog box. 
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To find assigned tree items 

Use the Find in Tree command to show an item’s assigned counterpart on the opposite tree. 

1 Right-click a tree item. 

2 Select Find In Network (or Geographic) Tree. 

 

 
 

To locate a tree item 

1 Type or paste the item's path in the Location field. 

 

NOTE  Type the global reference name (for example, #oa_conditions) or the relative path (for example, 

geographic/world_corporation/first_floor/vav_101). 

2 Press Enter or click Go. 

  

NOTE  If the path does not match any item in the database, the text in the Location field turns red. 

 

 
 

To show tree item details 

To show details for the items on the Geographic and Network trees: 

1 Select View > Display. 

2 Check the options that you want to see. 

  

NOTE  Hold down the Alt key to see an underlined letter for each option in the Display Options dialog box. That 

letter identifies each option in the tree. 
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To copy a tree item's path 

1 Select a tree item to view its path in the Location field. 

2 Highlight the text in the field or triple-click it. 

 

3 Press Ctrl+C to copy the path to the clipboard. 

4 Paste this information into another application if desired. 

 

 
 

Mouse and keyboard shortcuts 

You can use typical mouse and keyboard shortcuts in SiteBuilder such as double-click, right-click, multiple-select, 

and the arrow keys. 

Ctrl+drag  Hold down the Ctrl key to drag and drop a copy of a selected item. 

F6  Activates the opposite tree. 
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SiteBuilder exports and imports items from one system to another, even if the database types are different. For 

example, you can export a library item or clipping from a Derby database and import it into a MySQL database. 

 

Export/Import... To...       Exported items 

Library item (see "To 

export and import 

library items" page 

61) 

Create generic Geographic tree 

items that can be reused as 

building blocks for new or 

existing systems. 

 A selected Geographic tree item  

 Reports 

 Alarm categories 

Clipping (see "To 

export and import a 

clipping" page 62) 

Move part or all of a system into 

another system for one-time 

integration of additions into a 

master system. 

 One or more selected Geographic and Network 

tree items including attached control programs, 

graphics, and drivers 

 Trend data (optional) 

 Reports 

 Alarm categories 

 Location-dependent security information 

 Schedules and schedule group membership 

(including the entire schedule group and 

schedules, if it does not exist in the target 

system) 

 Alarm actions 

  
 

To export and import library items 

You can export and import items from one database type to another. For example, you can export a library item 

from a Derby database and import it into a MySQL database. 

 

 
 

To export library items 

1 Right-click a Geographic tree item that you want to export to the library. 

NOTE  All children of the item will be exported as well. 

2 Click Export To Library. 

3 Click Browse. 

4 Browse to an existing folder or create a new folder for the library you want to export. 

5 Name the .library file. 

6 Click Select. 

7 Type the Entry Name. 

8 Click Next. 

9 Click Finish. 
 

Using library items and clippings 



 

 

 
SiteBuilder v7.0 Carrier Proprietary and Confidential CARRIER CORPORATION ©2020   

Help  All rights reserved 

 62 

 

To import library items 

 CAUTIONS   

 Do not save a database if you cancel an import command before the process is complete because items will 

be partially imported. 

 Do not cancel an import command while running SiteBuilder concurrently with i-Vu_Pro_ Server because items 

will be partially imported. 

 

1 Right-click the Geographic tree item that will be the parent of the imported library item. 

2 Select Import From Library. 

3 Do one of the following: 

○ Select a library item from the list. 

○ Browse to the desired .library file, then click Select, then Next. 

NOTE  SiteBuilder generates a list of naming and numbering conflicts that were found during the import 

process. The Original Value and the New Value that SiteBuilder created to fix the conflict are listed beside the 

affected tree location name. 

4 Select a Severity Level to filter the list of issues. 

5 Select an issue from the list. 

6 Click Edit to change the properties of that item. 

7 Repeat steps 4 through 6 for each error. 

NOTE  Click Save Messages if you want to save the issues to a text file. 

8 Click Next. 

9 Click Finish. 

 

 
 

To export and import a clipping 

Clippings must be exported and imported into the same version of SiteBuilder, but they can be exported from one 

database type and imported into another database type. For example, you can export a clipping from a Derby 

database and import it into a MySQL database. 

NOTE  A site can have only one BACnet/IP network. The import process will automatically merge a clipping of a 

BACnet/IP network into the target system's BACnet/IP network if the networks have identical reference names. If 

the names are different, the import will create a second BACnet/IP network under the site, and you will have to 

manually correct this. See step 13 of To import a clipping (page 63). 
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To export a clipping 

1 Select File > Clipping > Export.  

2 On the Geographic or Network tree, select the tree items you want to include in the clipping. Use Ctrl+click, 

Shift+click, or both to select multiple items. 

3 Click Add in the Export Clipping dialog box. Repeat steps 2 and 3 if necessary. 

NOTE  Red text in this list indicates that a corresponding device or assigned equipment is missing. Hover over 

the text for details. 

4 Optional:  Check Include trend data if you want historical trend data in the clipping. 

NOTE  The import and export can take a long time if trend data is included. 

5 Click Export. 

6 Name and save the exported file. 

7 Click Export. 

8 Close the Export Clipping Progress dialog box. 

 

 
 

To import a clipping 

NOTE  You can also perform this task in the i-Vu® Pro interface if the clipping does not include trend data. A 

clipping with trend data can be imported only in SiteBuilder running in non-concurrent mode. 

   

1 Save your SiteBuilder database. 

2 Select File > Clipping > Import. 

3 Browse to and select the clipping you want to import, then click Next. 

4 Optional:  If necessary, change the location path where the clipping will be imported, then click Next. 

5 If asked if you want to replace event templates, follow the on-screen instructions. 

6 If asked if you want to overwrite components, follow the on-screen instructions. 

NOTES 

○ SiteBuilder lists any conflicts and problems that were found during the import. The Original Value and the 

New Value, if any, that SiteBuilder created to fix the conflict are listed beside the affected tree location 

name. 

○ You cannot cancel the import process. If the import produces unwanted results, close SiteBuilder without 

saving your database. Any program or graphics files that were included in the clipping will still be 

imported.  

7 Select a Severity Level to filter the list of issues. 

8 Select an issue from the list. 

9 Click Edit to change the properties of that item. 

10 Repeat steps 7 through 9 for each error. 

NOTE  Click Save Messages if you want to save the issues to a text file. 

11 Click Next. 
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12 Click Finish. 

13 Do any of the following that apply. 

  

If you imported... Do the following in the SiteBuilder 

application... 

Do the following in the i-Vu® Pro 

application... 

Another site into the system Change the new site's BACnet/IP 

network number to be the same as the 

other BACnet/IP network(s).  

 

Download All Content to all Carrier IP 

routers in the system. 

A second BACnet/IP network 

into a site 

Move the items under the new network 

to the original BACnet/IP network, then 

delete the new network.  

 

Download Parameters to any 

controllers that you moved. 

Any controllers that use the 

SiteBuilder option Automatically 

Configure My BBMDs 

N/A Download BBMDs to the routers. 

Any controllers that use 

manually configured BBMD 

tables 

N/A Update the routers' BBMD tables.  

See "To set up BBMDs through the i-

Vu® Pro interface (page 79)"  

or  

"To set up BBMDs using the BBMD 

Configuration Tool (page 81)"  

in i-Vu® Pro Help. 
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To set up i-Vu® Pro server communication 

By default, the i-Vu® Pro server uses the following TCP and UDP ports. 

  

Port Traffic 

TCP/IP 80 HTTP server 

TCP/IP 443 Secure HTTP server (HTTPS) 

TCP/IP 47806 Alarm Popup alarm action 

UDP/IP 47808 BACnet (used by all BACnet vendors) 

   

Under some circumstances, a facility may require the i-Vu_Pro_ server to use a different port for HTTP traffic. Or, 

you may need to set up secure i-Vu_Pro_ communication using TLS. 

To change server communication settings: 

1 In SiteBuilder, select Configure > Preferences > Web Server. 

2 Enter appropriate values. See table below.  

  

Field Notes 

Restrict to IP Address If your i-Vu_Pro_ server has multiple IP addresses and you don’t want i-Vu_Pro_ 

pages served to all the IP addresses, type the IP address that you want to serve 

pages on. Use this field only under the direction of Carrier Technical Support. 

Enabled Web Server Ports For systems with clients both on an internal network and that connect through the 

Internet, select Both HTTP and HTTPS.  This allows you to configure your firewall 

so internal clients can use HTTP and external clients are required to use TLS. 

Redirect HTTP requests to 

HTTPS 

Check this field to have all HTTP requests automatically redirected to the more 

secure HTTPS. Checking this field automatically disables the field Allow SOAP 

applications over HTTP (described below). 

HTTP Port To use an HTTP port other than 80, the URL used on a client to access the i-

Vu_Pro_ system must include the port. For example, for an HTTP port of 90, each 

client must use the URL http://<servername>:90 

HTTPS Port To use a secure port other than 443, the URL used on a client to access the i-

Vu_Pro_ system must include the port. For example, to sue port 444, each client 

must use the URL https://<servername>:444 

To use https, you must set up TLS in your browser. See "What is TLS?" in i-Vu_Pro_ 

Help. 

Keystore Password See "What is TLS?" in i-Vu_Pro_ Help. 

Allow TLS 1.1 If your system is set up to use TLS, i-Vu® Pro automatically uses TLS 1.2. If a i-

Vu_Pro_ client computer cannot use TLS 1.2, you can check this box to allow the 

less secure TLS 1.1. 

Advanced topics 
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Field Notes 

Allow SOAP applications 

over HTTP 

By default, i-Vu® Pro requires that SOAP applications run over HTTPS. If you have 

an external SOAP application that must run over HTTP, you can either change the 

application or check this box. 

NOTES   

 User names and passwords are vulnerable over HTTP connections. 

 This field is disabled if the field Redirect HTTP requests to HTTPS is checked. 

Allow unsigned add-ons By default, i-Vu® Pro allows only add-ons that have been approved by Carrier. 

Check this box if you want to allow other unapproved add-ons in your system. 

Authentication Provider If your system has one or more i-Vu_Pro_ add-ons that provide a different user 

authentication mechanism such as LDAP or Active Directory, the add-on name(s) 

will appear in this list. Select the one you want to use from the list or leave it set 

on Default to use i-Vu_Pro_'s built-in mechanism.  

Depending on the add-on's capability, selecting a provider other than Default may 

affect any of the following: 

 Change the User Name and Password requirements in i-Vu_Pro_ 

 Remove operators or operator groups from the i-Vu_Pro_ interface 

 Display a different login page than i-Vu_Pro_'s standard login page 

  

 

 
 

To disable default global reference names 

SiteBuilder can create global and non-global reference names. SiteBuilder creates global reference names by 

default because they are easier to work with than non-global reference names. However, using non-global 

reference names can be more efficient for jobs with many identical areas. You can use both kinds of reference 

names in the same database. 

Both types of reference names consist of lowercase letters, numbers, hyphens, and underscores (no spaces). 

A global reference name begins with the pound sign (#) and must be unique within the entire system. A global 

reference name is a complete i-Vu® Pro path. 

A non-global reference name must be unique only among its sibling tree items. You must specify absolute or 

relative paths when using non-global reference names. See “Defining i-Vu® Pro paths” in ViewBuilder Help for 

more information. 

Follow the steps below to disable the global reference name default. 

1 Select Configure > Preferences. 

2 Uncheck Make default reference names global (#refname) on the General tab. 

NOTE  Changing this default will not affect existing reference names. 
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Changing a control program 

      

If you change... Then... Notes 

A control program's logic in 

the Snap application 

Do one of the following in SiteBuilder to have 

the changes take effect: 

 Right-click the equipment on the 

Geographic tree, then select Reload 

Control Program.  

 Select Action > Reload Selected, select 

the control program(s) you want to reload, 

then click OK. 

Reloading updates all instances of 

a control program throughout the 

system and marks the 

controller(s) for an All Content 

download in the i-Vu® Pro 

interface.  

Only a control program's 

parameters in the Snap 

application 

Same as above. Reloading marks the controller(s) 

for an Only Parameters download 

in the i-Vu® Pro interface. 

Something in the control 

program that does not affect 

logic, such as Properties 

page text 

Right-click the equipment on SiteBuilder's 

Geographic tree, then select Rebuild 

Equipment Pages.  

No download required. 

A control program in the i-

Vu® Pro interface but then 

need to restore the original 

values set in the Snap 

application 

Right-click the equipment on SiteBuilder's 

Geographic tree, then select Reset to Control 

Program Defaults.  

This marks the controller(s) for an 

Only Parameters download in the 

i-Vu® Pro interface. 

 

NOTES   

 You can reload a control program or select a different control program in the i-Vu® Pro interface. 

 If you change a control program in the Snap application and it does not display correctly in the i-Vu® Pro 

interface, Ctrl+right-click the i-Vu® Pro action pane, and then select Refresh. 

 

 
 

To change or upgrade a driver 

 CAUTIONS 

 Upgrading drivers requires an All Content download to all affected controllers. Downloading to all controllers at 

the same time can take several hours for a large system. Communication with the controllers is suspended 

during an All Content download. 

 An All Content download clears trend, history, and alarm data from the affected controllers. At the beginning of 

the download process, trends that have the Trend Historian enabled are saved to the system database. 
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To change or upgrade a driver: 

1 Copy the new driver to webroot\<system_name>\drivers folder. 

2 In SiteBuilder, do one of the following: 

○ Upgrade multiple drivers. Select Action > Scan For New Device Drivers, then follow the on-screen 

instructions. 

-or- 

○ Upgrade a single driver: 

a.  Double-click the driver on the Network tree. 

b.  Select the new driver from the Driver Definition drop-down list. 

c.  Click OK. 

d.  Select the device(s) to change in the Change Which Devices dialog box. 

e.  Click OK. 

  

NOTES 

 If a driver becomes corrupt (for example, a driver page is missing in the i-Vu® Pro interface), right-click the 

driver on the Network tree, then select Reload Driver. Reloading updates all instances of the driver 

throughout the system and marks the controller(s) for an All Content download. Changes you made on the i-

Vu® Pro driver pages remain in effect. 

 You can also change, upgrade, or reload a driver in the i-Vu® Pro interface. 

 

 
 

Setting Open device IP addresses 

For the i-Vu® Pro server to communicate with Carrier controllers on the IP network, the i-Vu® Pro server and each 

controller must have the following: 

 IP address (unique and static) 

 Subnet mask 

 Default gateway address, if your system has a default gateway (IP router) 

 

You can use one of the following IP addressing methods for the i-Vu® Pro system. 

  

Use... If... 

DHCP addressing (page 

69) 

(requires v6.0 or later 

controller drivers) 

The IP network uses a DHCP server for IP addressing 
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Use... If... 

Custom addressing 

(page 70) 

The answer to any of the following questions is yes and you do not have a DHCP 

server. 

 Will the system share a facility's existing IP data network? 

 Will it have 199 or more Carrier IP devices, or 254 or more devices with static IP 

addresses? 

 Will it be connected to the Internet? 

 Will it have at least one device located on the other side of an IP router? 

 Will it have any third-party controllers? 

Default addressing 

(page 74) 

The answer to all of the above questions is no. 

  

 

 
 

To set an Open device's DHCP IP address 

PREREQUISITES 

 A computer with a USB port 

 A USB Link cable   

NOTE  The USB Link driver is installed with i-Vu® Pro v5.1 or later systems. But if needed, you can get the 

latest driver from http://www.silabs.com/products/mcu/Pages/USBtoUARTBridgeVCPDrivers.aspx. Install the 

driver before you connect the USB Link to your computer 

 

 CAUTION   If multiple controllers share power but polarity was not maintained when they were wired, the 

difference between the controller's ground and the computer's AC power ground could damage the USB Link and 

the controller. If you are not sure of the wiring polarity, use a USB isolator between the computer and the USB Link. 

Purchase a USB isolator online from a third-party manufacturer. 

  

1 Connect the laptop to the controller or sensor using the appropriate USB Link cable(s). 

 

USB Link

Connect to

Local Access port

12 ft

Connect to

USB port

7 3/4 in.

 

NOTE  If using a USB isolator, plug the isolator into your computer's USB port, and then plug the USB Link 

cable into the isolator. 
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2 i-Vu® Open Router or i-Vu® Open Link only: Turn off the router's power, set its Router Config Mode DIP switch 

to ON, then turn its power on again.   

3 In SiteBuilder, set your Configure > Preferences > Connections tab settings. 

  

Field Value 

Port The laptop's Com port number that the USB Link is connected to. 

Baud Rate 115200 

Data Bits 8 

Parity None 

Stop Bits 1 

 

4 On the Network tree, double-click the controller. 

5 On the Address tab, click Module Status. 

6 Note the controller’s Ethernet MAC address.  

7 i-Vu® Open Router or i-Vu® Open Link only: When finished, turn off the controller's power, set its Router 

Config Mode DIP switch to OFF to restore normal functionality to the Local Access port, then turn the power on 

again. 

8 Give the Ethernet MAC address to your DHCP network administrator and request that he reserve a static IP 

address for that MAC address.   

9 Get from him the reserved IP address, subnet mask, and default gateway address for your router. 

10 Repeat steps 1 and 2. 

11 i-Vu® Open Router or i-Vu® Open Link only: Set the DHCP/Assigned DIP switch to DHCP. 

12 Repeat steps 3 and 4. 

13 On the Address tab, select Specify a custom or DHCP IP Address. 

14 Type the IP Address, Subnet Mask, and Default Gateway Address that the DHCP network administrator gave 

you. 

15 Click Download Address. 

16 i-Vu® Open Router or i-Vu® Open Link only: Turn off the router's power, set its Router Config Mode DIP switch 

to ON, then turn its power on again. 

 

 
 

To set the Open device's custom IP address 

If your system's IP addresses are assigned by the network administrator, you can connect a laptop to a controller's 

Local Access Port and then use either of the following methods to set the controller's custom IP address so that the 

i-Vu® Pro server can communicate with it. 

 Set the custom IP address in SiteBuilder (page 71) 

 Set the custom IP address using PuTTY (page 72) 
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To set a controller's custom IP address in SiteBuilder 

PREREQUISITES 

 A computer with a USB port 

 A USB Link cable   

NOTE  The USB Link driver is installed with i-Vu® Pro v5 or later systems. But if needed, you can get the latest 

driver from http://www.silabs.com/products/mcu/Pages/USBtoUARTBridgeVCPDrivers.aspx. Install the driver 

before you connect the USB Link to your computer. 

   

 CAUTION   If multiple controllers share power but polarity was not maintained when they were wired, the 

difference between the controller's ground and the computer's AC power ground could damage the USB Link and 

the controller. If you are not sure of the wiring polarity, use a USB isolator between the computer and the USB Link. 

Purchase a USB isolator online from a third-party manufacturer. 

  

1 Connect the computer to the controller using the USB Link cable(s). 

  

USB Link

Connect to

Local Access port

12 ft

Connect to

USB port

7 3/4 in.

 

  

NOTE  If using a USB isolator, plug the isolator into your computer's USB port, and then plug the USB Link 

cable into the isolator. 

2 i-Vu® Open Router or i-Vu® Open Link only: Turn off the router's power, set its Router Config Mode DIP switch 

to ON, then turn its power on again. Set the router's IP Address DIP switch to Assigned. 

3 In SiteBuilder, set your Configure > Preferences, Connections tab settings. 

  

Field Value 

Port The laptop's Com port number that the USB Link is connected to. 

Baud Rate 115200 

Data Bits 8 

Parity None 

Stop Bits 1 

 

4 Click OK. 

5 In the Network tree, double-click the controller. 

6 On the Address tab, select Specify a custom or DHCP IP Address. 
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7 Type the IP Address, Subnet Mask, and Default Gateway Address. 

8 Click Download Address. 

9 When the download is complete, click Module Status in the same dialog box to verify the controller's address. 

10 i-Vu® Open Router or i-Vu® Open Link only: Turn off the router's power, set its Router Config Mode DIP switch 

to ON, then turn its power on again. 

 

 
 

To set a controller's custom IP address using PuTTY 

PREREQUISITES 

 A computer with a USB port 

 A USB Link cable   

NOTE  The USB Link driver is installed with i-Vu® Pro v5 or later systems. But if needed, you can get the latest 

driver from http://www.silabs.com/products/mcu/Pages/USBtoUARTBridgeVCPDrivers.aspx. Install the driver 

before you connect the USB Link to your computer. 

   

 CAUTION   If multiple controllers share power but polarity was not maintained when they were wired, the 

difference between the controller's ground and the computer's AC power ground could damage the USB Link and 

the controller. If you are not sure of the wiring polarity, use a USB isolator between the computer and the USB Link. 

Purchase a USB isolator online from a third-party manufacturer. 

  

1 Download and install PuTTY from the PuTTY website 

(http://www.chiark.greenend.org.uk/~sgtatham/putty/download.html). 

2 Connect the laptop to the local access port of the controller, ZS sensor, or an SPT sensor using the USB Link 

cable(s). 

  

 

  

NOTE  If using a USB isolator, plug the isolator into your computer's USB port, and then plug the USB Link 

cable into the isolator. 

 

3 i-Vu® Open Router or i-Vu® Open Link only: Turn off the router's power, set its Router Config Mode DIP switch 

to ON, then turn its power on again. Set the router's IP Address DIP switch to Assigned. 

4 Start PuTTY. 

5 Under Category > Connection, select Serial. 

 

http://www.chiark.greenend.org.uk/~sgtatham/putty/download.html
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6 Under Options controlling local serial lines, enter the following settings: 

  

Field Value 

Serial line to connect to Replace X with the computer's port number that the USB Link cable is 

connected to.  

NOTE  To find the port number, select Start > Control Panel > System > 

Device Manager > Ports (Com & LPT). The COM port number is beside 

Silicon Labs CP210x USB to UART Bridge.  

 

 

Speed (baud) 115200 

Data Bits 8 

Stop Bits 1 

Parity None 

Flow Control None 

    

7 Click Open. A window similar to the one below appears. 

 

 

8 If you changed a value, type 1, then press Enter to restart the controller. 

9 Type the number of the address field, then press Enter. 

10 Type the new address, then press Enter. 

11 Type 1, then press Enter to restart the controller. 

12 Close PuTTY. 

13 i-Vu® Open Router or i-Vu® Open Link only: Turn off the router's power, set its Router Config Mode DIP switch 

to ON, then turn its power on again. 
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To remotely change a controller's custom IP address 

Steps 1 through 5 below change the IP address in the controller. Steps 6 through 10 change it in the system 

database. Communication with the controller will be disrupted until all steps are performed. 

   

1 On the i-Vu® Pro Installer navigation tree, right-click a router and select Driver Properties > BACnet Router 

Properties page. 

2 Under IP Configuration, check Enable IP configuration changeover. 

NOTE  The field Allow remote management of IP configuration is for future use. 

3 In the Next column, type the new IP Address, Subnet Mask, and Default Gateway Address. Type the UDP Port 

that your server is using to communicate to all controllers. 

NOTE  You must enter values in all 4 fields, even if the values will not change. 

4 Do one of the following. 

  

Set the Changeover timeout 

field to... 

The router will use the Next settings... 

0:00 As soon as the router can communicate with the Next Default 

Gateway Address. 

A specific length of time As soon as the router can communicate with the Next Default 

Gateway Address, or when the timeout expires, whichever 

occurs first. 

 

5 Click Accept. 

6 On the System Options tree, select Connections. 

7 On the Configure tab, select the BACnet/IP Connection, then click Disconnect. 

8 On the navigation tree, go to the controller's Properties page. 

9 Make the necessary changes in the Address and Subnet mask fields. 

10 Click Accept. 

11 On the System Options tree, select Connections. 

12 On the Configure tab, select the BACnet/IP Connection, then click Start. 

13 On the navigation tree, go to the router's Properties page, then click Module Status to verify communication. 

 

 
 

To set the Open device's default IP address 

NOTES   

 If you want to use the default IP addressing but a DHCP server exists, follow the instructions in To set a 

controller's custom IP address (page 70), and enter the default addresses listed in step 2 below. 

 A network using default addressing does not have a default gateway (IP router). 
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1 If wired for power, turn off the controller's power.  

NOTE  The controller only reads the rotary switch positions during power up or upon reset. 

2 i-Vu® Open Router or i-Vu® Open Link only: Set the DHCP/Assigned DIP switch to the Assigned position to 

use the following IP networking parameters. 

IP address = 192.168.168.x 

where x is the controller address you will set in steps 3 and 4. 

Subnet mask = 255.255.255.0 

Default gateway address = 192.168.168.254 

3 Using the rotary switches, set the controller's address to match the Address in the controller's properties 

dialog box in SiteBuilder. Set the Tens (10's) switch to the tens digit of the address, and set the Ones (1's) 

switch to the ones digit. 

EXAMPLE  Setting the switches as shown in the figures below produces an IP address of 192.168.168.25.  

10's 1's
1

3

45

2

7
8

9

6

01

3

45

2

7
8

9

6

0

 

4 On SiteBuilder's Network tree, double-click the controller. 

5 On the Address tab, select Use Default IP Address. 

6 In the Address (Dial Setting on Device) field, type the value of x. 

7 Click OK. 

  

NOTE  The default address is an intranet address. Data packets from this address are not routable to the Internet. 

 

 
 

Setting i-Vu® XT or TruVu™ device IP addresses 

For the i-Vu® Pro server to communicate with Carrier controllers on the IP network, the i-Vu® Pro server and each 

controller must have the following: 

 IP address (unique on the IP network) 

 Subnet mask 

 Default gateway address, if your system has a default gateway (IP router) 
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Use one of the IP addressing schemes described below with the associated instructions that follow.  

  

Use a... If... 

DHCP IP Address  

generated by a DHCP server 

The IP network uses a DHCP server for IP addressing 

Custom Static IP Address  

from your network administrator  

You do not use a DHCP server and the answer to any of the 

following questions is yes. Will the i-Vu® Pro system: 

 Share a facility's existing IP data network? 

 Have 254 or more devices with static IP addresses? 

 Be connected to the Internet? 

 Have at least one device located on the other side of an IP 

router? 

 Have any third-party IP devices? 

Default IP Address  

that your system creates 

The answer to all of the above questions is no. 

  

NOTE  Carefully plan your addressing scheme to avoid duplicating addresses. If third-party devices are integrated 

into the system, make sure your addresses do not conflict with their addresses. 

 
 

To set the IP address in the controller setup pages 

You must define the i-Vu® XT or TruVu™ device's IP address in 2 places, in SiteBuilder and in the controller setup 

pages. Defining it in the controller setup pages sets the IP address in the controller. To open the controller setup 

pages: 

1 Connect an Ethernet cable from a computer to the controller as shown below. 

 

 
  

2 Turn off the computer's Wi-Fi if it is on. 

3 If your computer uses a static IP address, use the following settings: 

○ Address: 169.254.1.x, where x is 2 to 7 

○ Subnet Mask: 255.255.255.248 

○ Default Gateway: 169.254.1.1  

4  If it uses a DHCP address, leave the address as it is. 

5 Open a web browser on the computer.  

6 Navigate to http://local.access or http://169.254.1.1 to see the Service Port controller setup pages.  
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To set a DHCP IP address 

1 On the controller setup pages Modstat tab, find the controller’s Ethernet MAC address and write it down. 

2 On the Ports tab under IP Port, select DHCP. 

3 Click Save. 

4 Write down the IP Address. 

5 Give the DHCP network administrator the IP address and Ethernet MAC address and ask him to reserve that IP 

address for the controller so that it always receives the same IP address from the DHCP server. 

  

  

To set a custom IP address 

1 Obtain the IP address, subnet mask, and default gateway address for the controller from the facility network 

administrator. 

2 On the controller setup pages Ports tab under IP Port, select Custom Static. 

3 Enter the IP Address, Subnet Mask, and Default Gateway addresses that the network administrator gave you. 

4 Click Save. 

  

  

To set a default IP address 

Default IP addressing assigns the following to the controller: 

 IP address = 192.168.168.x 

where x is the setting on the rotary switches in the range from 1 to 253 

 Subnet mask = 255.255.255.0 

 Default Gateway = 192.168.168.254 

  

1 Set the controller's three rotary switches to a unique address on the network. Set the left rotary switch to the 

hundreds digit, the middle switch to the tens digit, and the right switch to the ones digit.  

EXAMPLE  The switches below are set to 125. 

  

 
  

2 On the controller setup pages Ports tab under IP Port, select Default IP Address. 

3 Click Save. 

  

NOTE  The default address is an intranet address. Data packets from this address are not routable to the Internet. 
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To remotely change an i-Vu® XT or TruVu™ device's custom IP address 

Steps 1 through 5 below change the IP address in the controller. Steps 6 through 10 change it in the system 

database. Communication with the controller will be disrupted until all steps are performed. 

   

1 On the i-Vu® Pro navigation tree, right-click a router and select Driver Properties > BACnet Router Properties 

page. 

2 Under IP Configuration, select Enable IP configuration changeover. 

3 In the Next column, type the new IP Address, Subnet Mask, and Default Gateway Address. Type the UDP Port 

that your server is using to communicate to all controllers. 

NOTE  You must enter values in all 4 fields, even if the values will not change. 

4 Do one of the following. 

  

Set the Changeover timeout 

field to... 

To have the controller use the Next settings... 

0:00 As soon as the controller can communicate with the Next Default Gateway 

Address. 

A specific length of time As soon as the controller can communicate with the Next Default Gateway 

Address, or when the timeout expires, whichever occurs first. 

 

5 Click Accept. 

6 On the System Options tree, select Connections. 

7 On the Configure tab, select the BACnet/IP Connection, then click Stop. 

8 On the navigation tree, go to the controller's Properties page. 

9 Make the necessary changes in the Address, Subnet mask, and Default Gateway fields. 

10 Click Accept. 

11 On the  System Options tree, select Connections. 

12 On the Configure tab, select the BACnet/IP Connection, then click Start. 

13 On the navigation tree, go to the controller's Properties page, then click Module Status to verify 

communication with the controller. 
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Setting up BACnet Broadcast Management Devices (BBMDs) 

To minimize network communications, IP routers do not pass on broadcasts that they receive. If your system has 

<control-module>s on different IP subnets separated by an IP router, you must set up a BACnet router on each IP 

subnet as a BACnet Broadcast Management Device (BBMD). A BBMD passes BACnet/IP broadcasts across the IP 

router to other BBMDs.  

  

IP subnet
R

BBMD

172.18.1.1 172.16.1.1

IP Router

Controller Controller

IP subnet

BBMD

 

  

The following Carrier BACnet routers can function as a BBMD on an IP subnet: 

Open routers: i-Vu® XT routers: 

i-Vu® Open Link 

i-Vu® Open Router 

 

i-Vu® XT Router 

i-Vu® XT BACnet Link  

 

  

To set up BBMDs, use the appropriate method in the table below. 

  

If your i-Vu® Pro system has... Use this method 

Fewer than 100 IP subnets with no third-party BACnet routers* Let SiteBuilder automatically configure 

your BBMDs. 

Any of the following: 

 More than 100 IP subnets* 

 Carrier controllers on an IP subnet that has a third-party 

BBMD 

 Carrier controllers that need to communicate with third-

party devices on a different IP subnet 

Set up custom BBMDs in the i-Vu® Pro 

interface or in the BBMD Configuration 

Tool. 

 * If your system has only i-Vu® XT or TruVu™ routers, this number changes from 100 to 500. 

  

NOTE  If the i-Vu® Pro server is on an IP subnet without the Carrier BACnet router, register the server as a foreign 

device. See To set up the i-Vu® Pro server as a foreign device (page 83). 
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To set up BBMDs in SiteBuilder 

As you add each Carrier BACnet router to an IP network on the Network tree, check Automatically Configure My 

BBMDs on the Address tab. SiteBuilder automatically selects a router in each IP subnet as the BBMD and sets up 

BBMD tables appropriately. 

To see which BACnet routers SiteBuilder assigned as BBMDs, select View > Display > BBMD. BBMDs show 

B=assigned on the Network tree. 

To override SiteBuilder's BBMD selection, right-click a different BACnet router on the same IP subnet, then select 

Force to BBMD.  

  

NOTE  If you are managing 3rd party BBMDs, you must add every 3rd party device that could be a BBMD as a 3rd 

party device router in SiteBuilder. 

 

 
 

To set up BBMDs through the i-Vu® Pro interface 

1 Make a list of the IP addresses for every controller that will function as a BBMD in your system. 

 CAUTION  Multiple BBMDs on an IP subnet disrupt BACnet communications. Define only one BBMD on 

either side of each IP router in your system. 

2 In Notepad, type the list putting each IP address on a separate line. (Open routers support up to 100 IP 

addresses per .bdt file; i-Vu® XT or TruVu™ routers support up to 500.) 

NOTE  If you must communicate with a third-party router that does not use the BACnet/IP port 47808 

(0xbac0), you must include the hexadecimal port number in the IP address. For example, 

172.168.23.67:0xe78a 

 

3 Save the file in the webroot\<system_name> folder with a .bdt extension instead of .txt. 

4 On the i-Vu® Pro navigation tree, select one of the Carrier controllers that will function as a BBMD. 

5 To check if the controller has an existing BBMD table, click  and select Manual Command. 

6 In the manual command field, type:  bbmd read x.x.x.x 

where x.x.x.x is the IP address of the controller you are on. 

7 Click OK. 
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8 If the Broadcast Distribution Table contains IP addresses that are not in your .bdt file, add them to your .bdt 

file. 

9  Click  and select Manual Command. 

10 In the manual command field, type:  bbmd write filename.bdt x.x.x.x 

where filename.bdt is the .bdt file in the webroot\<system_name> folder 

and x.x.x.x is the IP address of the controller you are on. 

11 Click OK. 

12 Issue another bbmd read command to verify that the .bdt file was written correctly. 

 

 

 
 

To set up BBMDs using the BBMD Configuration Tool 

Before you begin, do the following: 

○ Set up the IP address, subnet mask, default gateway, and network numbers for the i-Vu® Pro server and 

each Carrier controller on the IP network.  

○ The BBMD Configuration Tool is available on the i-Vu® Tech Tools USB drive or go to 

http://www.hvacpartners.com. 

 

1 Make a list of the IP addresses for every controller that will function as a BBMD in your system. 

 CAUTION  Multiple BBMDs on an IP subnet disrupt BACnet communications. Define only one BBMD on 

either side of each IP router in your system. 

2 In Notepad, type the list putting each IP address on a separate line. (Open routers support up to 100 IP 

addresses per .bdt file; i-Vu® XT or TruVu™ routers support up to 500.) 
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NOTE  If you must communicate with a third-party router that does not use the BACnet/IP port 47808 

(0xbac0), you must include the hexadecimal port number in the IP address. For example, 

172.168.23.67:0xe78a 

 

3 Save the file in the webroot\<system_name> folder with a .bdt extension instead of .txt. 

4 Open the BBMD Configuration Tool. 

5 In the IP Address or Host Name field, type the IP address of an Carrier controller that functions as the BBMD 

(BACnet Broadcast Management Device) for its subnet. 

6 Click the Broadcast Distribution Table Read button to see if the controller has an existing BBMD table. The 

information found is displayed in the bottom half of the window. 

7 If the Broadcast Distribution Table contains IP addresses that are not in the .bdt file you created in steps 2 

and 3, add them to your .bdt file. 

8 Verify that the same controller IP address is still in the IP Address or Host Name field. 

9 Click the Broadcast Distribution Table Browse button, then select the .bdt file that you created in steps 2 and 

3. 

10 Click the Broadcast Distribution Table Write button to send the information to the controller. 

11 Click Read again to verify that the new .bdt file was written to the Carrier controller. 

12 Repeat steps 5 through 11 for each Carrier controller that will function as a BBMD in your system. 
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To set up the i-Vu® Pro server as a foreign device 

If the i-Vu® Pro server is on an IP subnet without an Carrier BACnet router, register the server as a foreign device to 

a BBMD in the system. That BBMD will then forward BACnet broadcasts to the server. Register the server with the 

BBMD that will have the fastest response time. Response time is affected by distance and network complexity. 

  

1 Click  > System Options > Connections. 

2 On the Configure tab, select BACnet/IP Connection. 

3 If the Status column shows: 

○ Connected, click Disconnect. 

○ Stopped or Design Mode, go to step 4.  

4 Type the i-Vu® Pro server's IP address in the IP Address field. (172.18.64.37, in the example above.) 

NOTE  If you have more than one network interface card, type the address that connects to the controller 

network. 

5 Type the i-Vu® Pro server's subnet mask in the IP Subnet Mask field. (255.255.0.0, in the example above.) 

6 Select Force Registration from the Foreign Device drop-down list. 

7 Select the BBMD in the Primary BBMD field. 

8 To have a backup in case the first BBMD fails, select another BBMD in the Backup BBMD if primary fails field. 

9 Click  next to Tuning Parameters. 

10 Keep the 600-second default value in the Register FD Interval field.  

NOTE  If the re-registration does not occur within this time, the BBMD will delete the i-Vu® Pro server from its 

list. 

11 Click OK. 

12 If running i-Vu® Pro Server (not i-Vu® Pro Design Server), select the BACnet/IP Connection, then click Start.  

  

If your system does not have any BBMDs 

Follow the steps below to create pseudo BBMDs so that you can register the server. 

1 In the SiteBuilder application, double-click each BACnet router and check Automatically Configure My BBMDs 

on the Address tab. 

2 In the i-Vu® Pro application, select any location on the navigation tree. 

3 Run the manual command bbmd update to create a blank .bdt table in every router and mark them for 

download.  

4 Download parameters to the routers. 

5 Follow the steps above to register the i-Vu® Pro server as a foreign device to one of the routers. 
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Upgrading the i-Vu® Pro system 

To upgrade to the i-Vu® Pro v7.0 system, see the i-Vu® Application Upgrade Guide to v7.0. 

 

 

 
 

Working with databases 

A i-Vu® Pro system has 4 databases:  Main, Alarms, Trends, Audit Log. 

An Apache Derby database is in the \webroot\<system>\databases folder. 

An SQL Server® Express database is in the \webroot\<system> folder. You can get a copy of your system by 

copying the system folder. 

A MySQL, Oracle, PostGreSQL, or SQL Server® database is in the database management system's file structure, 

not in your i-Vu® Pro system folder.  

Use the following SiteBuilder features to work with your databases. 

  

Relocate Lets you define the new location of one or more system databases. 

EXAMPLES   

 If you move the trends database to a new server, use Relocate to tell the i-Vu® Pro 

application the database's new location. 

 Use Relocate to move data from My SQL databases on an old database server to 

MySQL databases on a new server.  

NOTE  Does not apply to Apache Derby or SQL Serve®r Express databases.  

Migrate Moves the 4 i-Vu® Pro databases to a new database type.  

EXAMPLE  Create an Apache Derby system, move the system to the customer's server, then 

migrate the databases to the final database type such as MySQL. 

Replicate Makes a copy of selected databases and/or system files in a new folder under \webroot.  

EXAMPLE  Use Replicate to create a backup of your PostgreSQL system. See System 

maintenance (page 87) for another way to back up your system. 

Clippings Lets you export navigation tree portions of a system, then import them into a different 

system.  See Using library items and clippings (page 61). 

 

 
 

To relocate a database 

1 Open your system in SiteBuilder. 

2 Click File > Manage Database > Migrate/Replicate. 

3 Select Relocate, then click Next.  

4 Choose the database you want to relocate. 
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5 Type the connect string(s). See Database Connect Strings (page 86).  

6 Change the Login and Password if you are using a different user name and password, then click Next. 

7 Verify your selection(s). If correct, click Next. If you want to change your selection, click Previous. 

8 Click Finish.  

 

 
 

To migrate the databases 

1 Open your system in SiteBuilder. 

2 Click File > Manage Database > Migrate/Replicate. 

3 Select Migrate, then click Next.  

4 Select the Database Type from the drop-down list, then click Next. If migrating to Apache Derby or SQLServer 

Express, go to step 8. 

5 Type the connect string(s). See Database Connect Strings (page 86). 

6 Type in the Login and Password, then click Next. 

7 Verify your selection. If correct, click Next. If you want to change your selection, click Previous. 

8 Click Finish.  

 

 
 

To replicate a database 

1 Open your system in SiteBuilder. 

2 Click File > Manage Database > Migrate/Replicate. 

3 Select Replicate database, then click Next.  

4 In the New System Name field, type the name of the copy. 

5 Select the Database Type from the drop-down list, then click Next. 

6 Choose the databases or files that you want to replicate.  

7 Click Next. If replicating an Apache Derby or SQLServer Express database, go to step 10. 

8 Type the connect string(s). See Database Connect Strings (page 86). 

 WARNING  The Main Database Connect String must be different than the original system's. Using the 

same string will destroy the original database. 

9 Type the Login and Password, then click Next. 

10 Verify your selection(s). If correct, click Next. If you want to change your selection, click Previous. 

11 Click Finish.  
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Database Connect Strings 

For MySQL, Oracle, PostgreSQL, or SQL Server databases, you must enter the Database Connect Strings. 

 

Database Connect Strings: 

     Server Type one of the following:  

 localhost if the i-Vu® Pro application and the database are on the same 

machine 

 The name or IP address of the machine that the database is on if different than 

the i-Vu® Pro application 

     Port Do one of the following: 

 Type the appropriate default port number from the list below. 

 Type the port number that the database uses for communication if different than 

the database default.  

 
Default ports are: 

MySQL 

Oracle 

PostgreSQL 

SQLServer 

  

3306 

1521 

5432 

1433 

     Instance The name that you gave the i-Vu® Pro database in the database application. 

NOTE   If the 4 i-Vu® databases do not reside under the default instance of SQL, then 

the instance name must be specified under the Instance column. The syntax for 

specifying the instance name of the SQL server is 

<Database>;instance=<instance name>. For example, if the SQL instance 

name is hvac , the syntax for the Instance field for the main database called 

iVu_Main would be iVu_Main;instance=hvac. 

  

Database User: 

     Login  The user login that you set up in the database application. 

     Password The password that you set up in the database application. 

  

NOTE  To change Database Connect Strings for an existing system, select the Modify database connection 

parameters in the File > Open dialog box, then click Next.   

  

 

Database Connect Strings: 

     Server Type one of the following:  

 localhost if the i-Vu® Pro application and the database are on the same 

machine 

 The name or IP address of the machine that the database is on if different than 

the i-Vu® Pro application 
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     Port Do one of the following: 

 Type the appropriate default port number from the list below. 

 Type the port number that the database uses for communication if different than 

the database default.  

 
Default ports are: 

MySQL 

Oracle 

PostgreSQL 

SQL Server 

  

3306 

1521 

5432 

1433 

     Instance The name that you gave the i-Vu® Pro database in the database application. 

  

Database User: 

     Login  The user login that you set up in the database application. 

     Password The password that you set up in the database application. 

  

NOTE  To change Database Connect Strings for an existing system, select the Modify database connection 

parameters in the File > Open dialog box, then click Next.  

 

 
 

System database maintenance 

You should perform the following system maintenance on a regular basis. See To safely shut down the i-Vu® Pro 

application for database server maintenance (page 89) before doing any maintenance on your database server. 

 

 
 

To back up a system 

The type of database your system uses determines the method you use to back up the system. 

 CAUTION  Do Not use SiteBuilder's Replicate feature to back up your database. 

  

For Apache Derby or SQL Server Express 

1 Shut down the SiteBuilder and i-Vu_Pro_ Server applications. 

2 In the i-Vu_Pro_x.x\webroot folder, copy your system folder. 

3 Paste the copy to a new location. 

 TIP  Zip the copy before transporting it over a network or to a USB drive.  
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For MySQL, MS SQL Server, or PostGreSQL 

1 Follow the instructions above to copy your system folder in  i-Vu_Pro_x.x\webroot. 

2 Use the database management system's backup method. See To safely shut down the i-Vu® Pro application 

for database server (page 89) maintenance before doing any maintenance on your database server. 

 
 

To compact and defragment 

In a new i-Vu® Pro system, the records in a database are contiguous. As records are added, deleted, and modified, 

the records become scattered in the database. This condition, called fragmentation, can slow down system 

performance and increase the database size. Compact the database to correct this situation.  

The files on the server's hard drive can also become fragmented. Defragment the hard drive to correct this 

situation. 

You should compact and defragment on a regular schedule such as once a month. But, you may need to do these 

more often, depending on how often the data or files change.  

NOTE Compacting a database may take several minutes to several hours, depending on its size. 

 TIP  To minimize the effects of fragmentation, you should maintain at least 20% free disk space on the server. 

  

Compacting the database 

The following databases are compacted dynamically—compacting occurs in the background when a database is 

open.  

 MySQL 

 MS SQL Server 

 MS SQL Server Express 

 PostGreSQL  

  

To compact a Derby database: 

1 Shut down the SiteBuilder and i-Vu® Pro Server applications. 

2 Open a Windows command prompt application and type cd c:\i-Vu_Pro_x.x, replacing x.x with your 

system version number. 

3 Click Enter. 

4 Type "Derby Compression Tool.exe" <system name>. 

5 Click Enter. 

6 When compacting finishes, close the command window. 

   

Defragmenting the server's hard drive 

For all database types, use a defragmentation utility such as Windows Disk Defragmenter or Norton SystemWorks. 

NOTE  If you are using a single computer as both the i-Vu® Pro server and the client, you must defragment the disk 

more often than the disk of a dedicated server—especially if people access the Internet from this computer. 
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To minimize the database size 

The larger a database is, the less responsive it may become. Deleting closed alarm incident groups, expired 

schedules, and expired historical trends on a regular basis will reduce the database size. You can set up your i-Vu® 

Pro application to automatically delete these. See "System Settings > Scheduled Tasks tab" in i-Vu® Pro Help. 

 

 
 

To safely shut down the i-Vu® Pro application for database server maintenance 

Occasionally, the database server is shut down for maintenance or backups. If this is done without shutting down 

the i-Vu® Pro Server first, the database may get locked and the i-Vu® Pro application may not be able to 

reconnect. 

1 Shut down the i-Vu® Pro application.   

2 Shut down the database server. 

3 Perform the maintenance or repair needed on the server. 

4 Restart the database server. 

5 Restart the i-Vu® Pro application.  

 

To unlock a database 

1 In SiteBuilder, click File > Open and Select Database to open your site. The following message appears The 

database appears to be in use by another application …..  Do you want to override the lock?”   

2 Click Yes to override the lock. 

3 Log in to the site. 

4 Exit SiteBuilder. 

5 Start the i-Vu Pro Service.  
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Miscellaneous SiteBuilder menu commands 

  

Menu command Notes 

File > Open System Folder When you have a database open in SiteBuilder, this command opens 

the system folder in Windows® Explorer. 

File > All Source Files > 

Import/Export 

Use to export source files to a .zip file that can be imported into another 

i-Vu® Pro or Field Assistant system. Source files include: 

 Control programs (.equipment files only) 

 Drivers 

 Graphics (.view files only) 

 Touchscreen files 

 BACview® files 

 Report design files for Equipment Values or Trend Sample reports 

NOTE  If import detects a difference between a database file and an 

import file with the same name, import does not overwrite the database 

file. A message lists any file differences so that you can resolve them. 

Edit > Run Global Point Count 

 

Select the system level on the Geographic tree, then select this menu 

command to display the number of: 

Allowed points Points allowed by your system 

System points These include: 

 Network inputs/outputs with an address whose 

device does not exist in the database 

 All microblocks that have an input/output 

number assigned 

 The following display microblocks: AI, AO, AV, BI, 

BO, BV, MSI, MSO, MSV 

NOTES 

 RS or Airflow microblocks count as 1 point. 

 Does not count expander numbers greater than 

89. 

Edit > Run Local Point Count This command is like Run Global Point Count except that it counts 

points at and below the selected item. 

Edit > Run Point Count Select an item on the Network tree, then select this menu command to 

display the number of non-BACnet third-party points allowed by a 

controller and an estimate of the number of third-party points used.   

Edit > Rebuild Graphic Resources See “Setting up your system for non-English languages” in i-Vu® Pro 

Help. 

Edit > Export (or Import) Checkout 

Information 

See "Commissioning Equipment" in i-Vu® Pro Help. 

Configure > Preferences > Language  See “Setting up your system for non-English languages” in i-Vu® Pro 

Help. 

Current Session affects only what you see in SiteBuilder, and is not part 

of the system you create. 

Configure > Preferences > Font Click the name in the Font column to see a different font in SiteBuilder. 
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Menu command Notes 

Action > Reload Selected Use this command to select which control programs and drivers you 

want to reload. All occurrences of the selected items are reloaded. 

Action > Compile JSP Cache If the i-Vu® Pro server has a Pentium III ® processor, you may want to 

compile jsp cache as part of commissioning a system. Compile JSP 

Cache prepares and stores every i-Vu® Pro page on the server so that it 

can quickly serve pages to client browsers. 

Action > Check Database Integrity Use as Technical Support directs. 

Tools > Configure Tools Use this command if directed by Technical Support to install an added 

SiteBuilder feature. 

Help > Apply Update Use this command as directed by installation instructions for i-Vu® Pro 

service packs or patches. 

Help > About > Java VM tab If the system runs slowly when performing memory-intensive tasks or 

produces "Out of memory" errors in the i-Vu® Pro Server application or 

in log files, you can increase the amount of memory that the i-Vu® Pro 

application is permitted to use. On the Java VM tab, click Memory 

Settings. If your i-Vu® Pro server is a 64-bit machine with at least  

6 GB RAM, change Maximum memory to 3000 MB. 

NOTES   

 The memory setting for the 64-bit machine depends on the size of 

the i-Vu® Pro system and what other services are running on the 

machine. For example, you could change the memory to 4000 MB if 

the database server is on a different machine.  

 You can also change this setting from i-Vu® Pro Server's Help > 

About menu command. 
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Important changes to this document are listed below. Minor changes such as typographical or formatting errors are not 

listed. 

  

Date Topic Change description Code* 

4/24/20 To safely shut down the i-Vu® Pro 

application for database server  

maintenance 

Added section on how to unlock a database X-TS-RD-E_CI 

10/18/18 What's new in SiteBuilder 

To set up WebCTRL server 

communication 

Added description of the new field Redirect HTTP requests to 

HTTPS. 

A-O-CY-BR 

9/25/18 Setting up BACnet Broadcast 

Management Devices (BBMDs) 

Changed 50 IP subnets to 100 IP subnets. X-D 

8/6/18 Upgrading the i-Vu Pro system Changed v6.5 to v7.0 C-D 

  

*  For internal use only 
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