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Follow these upgrade procedures: 

To upgrade a single system to the i-Vu Standard/Plus v6.0 application (page 2) 

To upgrade a mixed system to the i-Vu Plus v6.0 application (page 12)  

To upgrade to the i-Vu Pro v6.0 application (page 22) 

To upgrade Field Assistant (page 37) 
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To upgrade a single system to the i-Vu Standard/Plus v6.0 application  
  

 

Use the following instructions to upgrade a single i-Vu CCN or i-Vu Open system.  

NOTES 

• If you are running a mixed CCN and Open system, see To merge a mixed system to the i-Vu Plus v6.0 
application. (page 12)  

• You cannot downgrade an i-Vu CCN Pro database to the i-Vu Standard/Plus v6.0 application. 

• The i-Vu CCN v4.2 application must be upgraded to v4.2 before you can install v6.0. 

 

i-Vu web server models  
You MUST check your model to ascertain if you need to upgrade and purchase a new one. The model number is 
on the bottom of your web server.  

 

i-Vu web server model number  Memory System limits 

MP945-D 512 MB You must purchase a new web server to 
accommodate v6.0 

MP965-D 1 GB USB CCN Router - 140 CCN controllers 

External routers - 750 CCN controllers 

  CAUTION  This web server was 
previously available only for CCN. If you want 
to add i-Vu Open controllers to your network, 
we highly recommend you upgrade the 
memory in the MP965-D to 2 GB.  

MP45-DU or MP65-D 2 GB USB Router -  

• 140 CCN controllers 

or  

• 60  i-Vu Open controllers 

 
External routers - 750 controllers 

Total combined - 750 controllers 
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 To upgrade a single system to the i-Vu Standard/Plus v6.0 application
  

 

The table below is a quick outline of steps. Each step is explained in detail in the sections that follow. 

Existing system Procedure 

i-Vu CCN Standard v4.0 
application 

You MUST upgrade to i-Vu CCN v4.2 application before you can 
install v6.0. Also, you must replace web server model MP945-D. 
See table above for details. 

Upgrade to v4.2: 

1 Backup system to PC or USB from Management Tool. 

1 Connect upgraded web server to your network. 

2 Install i-Vu v4.2 application from the DVD or USB drive on 
your web server.  

3 Restore system to upgraded web server from the 
Management Tool. 

4 Follow instructions to upgrade v4.2 to v6.0. 

i-Vu CCN Standard v4.2 
application with USB CCN  
Adapter 

If using your current web server: 

1 Backup system to PC or USB from Management Tool. 

2 Install i-Vu v6.0 application from the DVD or USB drive on 
your web server.  

3 Restore system to upgraded web server from the 
Management Tool. 

NOTE  If you purchase a new MP65-D web server, follow steps 1 
and 3 above. 

i-Vu CCN Plus v4.2 application 
with 
i-Vu CCN Router or i-Vu Link 

1 Backup system to PC or USB from Management Tool. 

2 Install i-Vu v6.0 application from the DVD or USB drive on 
your web server.  

3 Restore system to upgraded web server from the 
Management Tool. 

i-Vu Open Standard v5.0 or v5.1 
application with USB Open 
Adapter  

1 Backup system to PC or USB from Management Tool. 

2 Install i-Vu v6.0 application from the DVD or USB drive on 
your web server.  

3 Restore system to upgraded web server from the 
Management Tool. 

NOTE  If you purchase a new MP65-D web server, follow steps 1 
and 3 above. 

i-Vu Open Plus v5.0 or v5.1 
application with an i-Vu Open 
Router or i-Vu Open Link 

1 Backup system to PC or USB from Management Tool. 

2 Install i-Vu v6.0 application from the DVD or USB drive on 
your web server.  

3 Restore system to upgraded web server from the 
Management Tool. 
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To upgrade a single system to the i-Vu Standard/Plus v6.0 application  
  

 

Capture current i-Vu® web server settings 

Access the Management Tool using one of the following methods: 

• Click Main Menu   in the i-Vu® interface, then select System Options > General tab > Management Tool.  

• Launch your browser and type your system name followed by :8080. For ex.: http://ivu:8080/. 

 

Print the Management Tool screen or record all of the information under Addressing and i-Vu Port Configuration. 

•  i-Vu Standard v4.2 addresses 

 
 

• i-Vu Standard v5.1 addresses 
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 To upgrade a single system to the i-Vu Standard/Plus v6.0 application
  

 

• i-Vu Plus v4.2 or v5.1 addresses 

 
 

 
 

Backup data from Management Tool 

Access the Management Tool using one of the following methods: 

• Click Main Menu   in the i-Vu® interface, then select System Options > General tab > Management Tool.  

• Launch your browser and type your system name followed by :8080. For ex.: http://ivu:8080/. 

 

Use either of the following methods to backup your data from the Management Tool: 

Backup data to your PC 

1 Click PC Backup under Manage Server Data to save the entire i-Vu database zipped into one file to your PC. 

2 Click OK when you see the message The system will be stopped and restarted. Do you wish to proceed? 
Watch Operation Status to see the progress. 

3 Click the message Save/Download Backup File to Your Local Hard drive when it appears.  

4 Click Save when asked Do you want to open or save this file? 

5 Save the file (system.backup.tgz) to a convenient location on your computer.  

CAUTION! Do not alter the name of this file! 

6 Exit from Management Tool. 

 

Backup data to a USB drive 

1 Plug your USB drive into any available USB port on your i-Vu web server. 

2 Click USB Backup under Manage Server Data to save the entire i-Vu database zipped into one file to your 
USB drive. 

3 Click OK when you see the message The system will be stopped and restarted. Do you wish to proceed? The 
Operation Status message updates as the i-Vu application prepares and creates the backup. Wait for 
Operation Status to state No Background Operations Currently Active.,  
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To upgrade a single system to the i-Vu Standard/Plus v6.0 application  
  

 

4 Remove USB drive from the web server. 

NOTES 

○ A check of the USB drive will show a backup file named system.backup 

○ An error may be displayed under the Management Tool title stating The USB device failed to mount and 
initialize. Connect the USB drive to the first USB port. In this case, try a different USB drive or try 
rebooting the i-Vu Open web server, as there was an issue accessing the USB drive. 

5 Exit from Management Tool. 

 

 
 

Install new i-Vu® 6.0 software 

  CAUTION  If you are using a USB CCN or Open Adapter with an upgraded web server, you must connect the 
cable to your network and the web server before you start the i-Vu 6.0 application.  

 

1 Remove the i-Vu® web server from the network by disconnecting the LAN cable. 

2 Insert the i-Vu® v6.0 Installation DVD into the i-Vu® web server DVD drive or USB Installation drive into the 
USB port on the front of the web server. 

3 Shut down the i-Vu® web server by pushing the On/Off button once. Wait for the blue light to turn off (could 
take as long as 2 minutes). 

4 Press the On/Off button again to restart the web server. The installation begins automatically. 

5 The Installation DVD ejects or the USB drive's light goes off when the installation is complete. This process 
takes several minutes. 

NOTE  Do not power off during the installation. 

  

 
 

Access updated system 

  CAUTION  If you are using a USB CCN or Open Adapter with an upgraded web server, you must connect the 
cable to your network and the web server before you start the i-Vu 6.0 application.  

 

1 Connect a LAN cable between the computer and the i-Vu® web server. 

2 Make sure that the computer is set up for DHCP. 

3 Allow about a minute after connecting the LAN cable for the IP addressing to complete. 

4 Launch Internet Explorer to access your system. Type http://ivu.   

NOTES 

○ Use only the i-Vu® interface to navigate through the i-Vu® interface; do not use the browser’s navigation 
buttons. 

○ Disable all popup blockers. IE > Tools > Turn Off Popup Blocker.   

5 Accept License Agreement. 
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On the Startup page:  

1 You must carefully select the USB Network Type. If you change from using a router to a cable at a later time, 
you will lose all your settings and have to restore to factory defaults. 

NOTE  Do not fill in any other blank fields on the Startup page. Restoring your system in Step 2 will 
automatically fill in the other information. 

 
2 Click Link to Management Tool at the bottom of the screen.   

 
 

 

 

 
 

Restore data from backup 

1 Click PC Restore or USB Restore under Manage Server Data in the Management Tool. 

○ PC Restore - Browse to your backup file and click Upload File, then click Perform Restore. 

○ USB Restore - Place your backup USB drive in any port on the i-Vu web server. Select the backup file and 
click Perform Restore. 

2 Restore is complete when Operation Status displays No Background Operations Currently Active. 

 

 
 

Restore Addressing and set NTP (Network Time Protocol) 

1 Refer to the data recorded from your original i-Vu web server. See Capture current i-Vu® web server settings. 
(page 5) 

2 Enter your previous Name. 

3 If your original setup did not have Obtain an IP address automatically checked, then enter ALL of the IP 
address information from the original configuration. 

4 Enter your original settings in i-Vu Port Configuraton. 
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To upgrade a single system to the i-Vu Standard/Plus v6.0 application  
  

 

Configuring NTP 

Network Time Protocol (NTP) is a networking protocol for clock synchronization. You can designate an NTP source 
that sends the correct time to the i-Vu® web server, ensuring constant accurate time. You can enter 2 static 
addresses (DNS name or IP) of NTP servers or use the default addresses provided by the i-Vu® application. If you 
do not enable NTP, the i-Vu® system clock must be monitored and updated regularly in the System Options menu 
> General tab.  

You can configure DHCP servers to supply IP addresses of NTP servers to the i-Vu® web server. If you have 
checked Obtain an IP address automatically and Enable Time Synchronization, the i-Vu® web server tries to 
obtain an NTP server address from the DHCP server on site. If it cannot find one, the i-Vu® web server uses the 
User Assigned NTP addresses, if any, in the User Assigned fields. 

 CAUTION Contact your Network Administrator for guidance in entering these settings.  

You can access NTP from a local server, a remote server, or a website. To set up NTP: 

1 Verify that Enable time synchronization from an NTP server is checked. 

2 System Assigned NTP Server Address - To use this read-only field, make sure you have checked Obtain an IP 
address automatically to allow your system to search for an address for the NTP server and display a primary 
and alternate address. 

3 User Assigned NTP Server Address - You can use the default website addresses if your system allows it. 
Firewalls may prevent successful access to the default websites. Your Network Administrator can provide 
alternate addresses for a local server, a remote server, or a website. 

 

After entering address and/or NTP settings 

1 Click Apply Changes to save your updated settings. The web server automatically reboots. 

2 Close the Management Tool. 

3 Disconnect the LAN cable between the computer and the i-Vu® web server and reconnect the web server to 
the customer’s LAN. 

 

 
 

Start the i-Vu® application 

1 If necessary, reconfigure the computer to access the i-Vu web server over the customer’s network. 

2 Launch Internet Explorer, access the i-Vu® interface, and login.  

3 Since the database was restored, the you must adjust the following: 

○ Timezone, Date  - select appropriate options 

○ Time - enter the correct time! The i-Vu® web server will not automatically read the time from your 
computer. 

 
4 Click Next. 

5 Review entries. Click Submit. Wait for your system to launch. It will take a minute. If you get an error, type 
http://<your system name> in your browser and hit return. 
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 To upgrade a single system to the i-Vu Standard/Plus v6.0 application
  

 

Update the equipment library 

The i-Vu® SAL files update your i-Vu® controllers. The SAL libraries contain control programs, graphics, drivers, 
screen files, and other important controller data.  

Carrier periodically provides updates, which include enhancements and bug fixes. 

NOTES 

• The library update only changes default graphics. If you have edited your graphic in ViewBuilder, it is not 
updated. 

• The last digits in the SAL library name are the release date of the library. 

• All of the SAL files will not necessarily have the same <date> revision. 

• To ensure that your installation is running the latest software, we recommend that you check Control Systems 
Support  http://www.hvacpartners.com/ for updates. Download the latest SAL files and apply them to all new 
installations. 

• If you are changing to an older SAL file than the current one being used, a warning asks you if you are sure 
you want to apply an older version. 

 

There are currently 6 SAL files used by the i-Vu® v6.0 application:  

• ivu-6.0-factory-<date>.sal (for PIC-based controllers)  

• ivu-6.0-upc-open-<date>.sal (for Universal Protocol Converter-based equipment)  

• ahub-6.0-<date>.sal (for 39m AHU applications)  

• ivu-6.0-universal-controller-<date>.sal (for UC Open and AppController-based applications) 

• ivu-6.0-applicationbuilder-<date>.sal (for CCN applications) 

• ivu-6.0-discovery-<date>.sal (for CCN PIC applications) 

NOTE  Keep copies of the latest libraries in a safe place. In the event of a system restore, the updated .sal file 
must be reapplied. 

 

Check current SAL library version 

1 Login to the i-Vu® application using the Installer role. 

2 Click Main Menu , then select System Options > Update tab. 

3 Click Current Libraries (.sal) to view the current SAL libraries and their revision date. 

  

Step 1: Update library  

1 Save the updated library (.sal file) to your computer. 

2 Click Main Menu , then select System Options > Update tab. 

NOTE  Expand Current Libraries (.sal) to see the current SAL libraries and their revision. Compare them to 
what you downloaded from the Carrier support website http://www.hvacpartners.com to determine if any of 
them have been updated. 

3 Click  and browse to the updated .sal file that you have saved on your computer, select the 
file, and click Open. 

4 Click Continue. 
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To upgrade a single system to the i-Vu Standard/Plus v6.0 application  
  

 

5 When process is complete, the message appears File added successfully. 

6 Click Close. 

NOTE  These changes are not applied to the controllers until you have updated routers and controllers. 

 
 

Update your routers and controllers 

IMPORTANT!  Update your routers and controllers only once. Use either the i-Vu application or Field Assistant. 

Router and controller configurations are maintained when you update them using the procedure below. 

Step 1: Update the files for routers 

1 Select the router that you wish to update in the navigation tree. 

2 Right-click and select Driver Properties.  

3 Select Properties page > Update tab.  

4 If the database contains 2 or more routers, you must check Change for all control programs of this type in 
the Controller section. 

5 Click Update. A message appears Changes the driver and screen file to use the current library version. 
Continue?  

NOTE  If more than one router exists, the additional routers are listed below the Update button. 

6 Click OK.  

7 Click Accept. 

 

Step 2: Update the files for controllers 

1 Double-click the controller in the navigation tree or right-click and select Configure .   

2 If you have multiple controllers of the same type, enable Change for all control programs of this type?. 

3 Click Update under Controller. A message appears Changes the control program, view, driver and screen 
files to use the current library version. Continue?  

4 Click OK. When the message Updated to the library version xx. appears, click Close. 

5 Repeat steps 1 - 4 for any additional types of controllers. 

6 Click Close again. 

 

Step 3: Update the files for CCN controllers 

1 In the navigation tree, select the CCN device manager associated with the controllers that are to be updated. 

2 Select the Devices tab and re-scan any controllers that need to be updated by checking Rescan Controllers 
Selected Below for Configuration Changes and clicking Start Scan. 

 

Step 4: Apply the update to routers and controllers 

1 Select the site level in the navigation tree and then select the Downloads page. 

2 If you wish to apply the new SAL file to your entire system, you can use this page to compare to your 
navigation tree and verify that you have selected all of your routers and controllers for download. 

NOTE  Only the CCN Gateway and device managers require download, so the CCN controllers/equipment will 
not be listed. 
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3 A network's controllers download in the order shown. To change the order, select a controller(s), then drag 
and drop or click Move to Top or Move to Bottom. 
EXCEPTION  If a controller's router requires a download, it will download first regardless of its position on the 
Download page.Click the Start button. 

NOTES 

○ Use Ctrl+click, Shift+click, or the Select All checkbox to select multiple controllers.  

○ Up to 5 routers can download simultaneously. 

4 See To download from the Downloads page in Help for more details. 
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Terms to know: 

• Restore files – restores all settings, including database, operators, alarms, and trends  

• Source files – includes drivers, .equipment, .view, .bacview files, and .touch files 

• Clipping file – Includes source files, database, and trends (does not include operators or alarms) 

NOTE  A system clipping file takes time to import. You can see the estimated time for each database in 
System Options > General tab > System Statistics. 

• Primary database - This is the database that is restored and not added using a clipping. Primary includes 
database, operators, alarms, and trends. See Before you start the upgrade process below to determine if the 
CCN or Open system should be your primary database.  

• Target web server - the web server you decide to use for the i-Vu® v6.0 application 

NOTE  Web server model numbers and memory - see To upgrade to the i-Vu v6.0 application (page 1). 

i-Vu web server models  
You MUST check your model to ascertain if you need to upgrade and purchase a new one. The model number is 
on the bottom of your web server.  

i-Vu web server model number  Memory System limits 

MP945-D 512 MB You must purchase a new web server to 
accommodate v6.0 

MP965-D 1 GB USB CCN Router - 140 CCN controllers 

External routers - 750 CCN controllers 

  CAUTION  This web server was 
previously available only for CCN. If you want 
to add i-Vu Open controllers to your network, 
we highly recommend you upgrade the 
memory in the MP965-D to 2 GB.  

MP45-DU or MP65-D 2 GB USB Router -  

• 140 CCN controllers 

or  

• 60  i-Vu Open controllers 

 
External routers - 750 controllers 

Total combined - 750 controllers 

Before you start the upgrade process    

• The limit for the i-Vu Standard or Plus v6.0 application is 750 devices. The amount of memory in your web 
server determines your system's actual capacity. If your combined system devices are going to exceed 750, 
you must upgrade to the i-Vu Pro v6.0 application. See To upgrade to the i-Vu Pro v6.0 application (page 22). 
Even if you upgrade to a Pro system, you must first upgrade both of your web servers and systems to the i-Vu 
Plus v6.0 application. After installing the v6.0 application and restoring your databases to both web servers, 
verify the number of devices in both of your systems. Select System Options > General tab > Statistics to see 
the actual number of your devices. Check both systems for a sum.  

To merge a mixed system to the i-Vu Plus v6.0 application 
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• If you use one of your current web servers and are not purchasing a new one, you must select the web server 
with the most memory for running the i-Vu v6.0 application. This is referred to as your target web server in 
these instructions. See table above. 

• If you are currently using both a USB CCN and an Open Adapter, you must replace one of them with an 
external router. i-Vu v6.0 application does not support 2 USB cables on the single web server.  

NOTE  Replace a USB CCN Adapter with an i-Vu Link or an i-Vu CCN Router. Replace a USB Open Adapter with 
an i-Vu Open Link or an i-Vu Open Router. During the upgrade process, the i-Vu application will automatically 
find the new router and connect it to the network.  

• Decide which database will be primary. A  system that is connected with a USB Adapter (CCN or Open), must 
be primary. If you are not using a USB Adapter, select the larger database. The primary system is the first one 
you restore on the target web server with the v6.0 application. All settings are restored in your primary 
database, including, alarms, trends, and operators. The secondary system is installed using a clipping, which 
does not include operators or alarms. 

 
 

 
 

Example of merging i-Vu databases to v6.0 

The following example is an overview of the steps to upgrade and merge systems. Review this process to become 
familiar with the concepts. See proceeding topics for specific details on how to execute these steps. 

Assumptions in this example 

• An i-Vu CCN Plus v4.2 web server system is connected to the network using a USB CCN Adapter 

• i-Vu Open v5.0 or 5.1 system is connected to an i-Vu Open Link or an i-Vu Open Router 

• You are using one of the web servers you already own and not purchasing a new one 

• The i-Vu Open v5.1 web server is more powerful 

• See the illustration below for explanations of the terms used in the steps. 
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1 Capture current web server settings (page 15). 

2 Backup DB1 and DB2 from Management Tool to PC or USB (page 17).  

3 Install v6.0 on both boxes from the USB drive or CD. (page 18) 

4 Connect and power up your target web server (page 18).  

5 Restore DB1 to WS2 from Management Tool (page 19).  

6 Restore DB2 to WS1 from Management Tool. (page 19) 

7 Check number of devices on both systems in System Options > General tab > Statistics to ensure your 
merged system will not have more than 750 devices. 

8 Fix potential conflicts between both databases. (page 19) 

1. Export DB2 Source files from WS1. 
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2. Import DB2 Source file into WS2. 

3. Resolve conflicts.  

9 Export DB2 Clippings from WS1. 

10 Import DB2 Clippings into DB1 in the target web server WS2. 

11 Verify that the imported devices are communicating.  

12 Back up the merged database 

 

To merge a mixed system onto a new i-Vu® v6.0 web server 

1 Capture current web server settings (page 15). 

2 Backup DB1 and DB2 from Management Tool to PC or USB (page 17).  

3 Connect and power up your target web server (page 18).  

4 Restore primary database to the new web server from the Management Tool. 

5 Check number of devices on both systems in System Options > General tab > Statistics to ensure your 
merged system will not have more than 750 devices. 

6 Fix potential conflicts between both databases. (page 19) 

1. Export DB2 Source files from WS1. 

2. Import DB2 Source file into WS2. 

3. Resolve conflicts.  

7 Export DB2 clipping from secondary database. 

8 Import DB2 clipping into new web server. 

9 Verify that the imported devices are communicating by obtaining a Module Status (Modstat).  

10 Back up the merged database 

 

 

 
 

Capture current i-Vu® web server settings 

You need to record the Addressing information from the  i-Vu web server Management Tool that is physically 
residing where you are going to place your i-Vu v6.0 web server. (whether it is the same web server, a new one, or 
the one currently located elsewhere.) 

• If you will be using a USB Adapter (CCN or Open), your v6.0 web server needs to be where the cable is 
located.  

• If you have external routers, you probably want to use the location of the web server that connects to the 
system you choose for your primary database. 

• If you enable Obtain an IP address automatically, the only setting you need to record is the i-Vu Port 
Configuration. 
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Access the Management Tool using one of the following methods: 

• Click Main Menu   in the i-Vu® interface, then select System Options > General tab > Management Tool.  

• Launch your browser and type your system name followed by :8080. For ex.: http://ivu:8080/. 

 

Print the Management Tool screen or record all of the information under Addressing and i-Vu Port Configuration. 

•  i-Vu Standard v4.2 addresses 

 
 

• i-Vu Standard v5.1 addresses 
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• i-Vu Plus v4.2 or v5.1 addresses 

 
 

 

 
 

Backup data from Management Tool 

Access the Management Tool using one of the following methods: 

• Click Main Menu   in the i-Vu® interface, then select System Options > General tab > Management Tool.  

• Launch your browser and type your system name followed by :8080. For ex.: http://ivu:8080/. 

 

Use either of the following methods to backup your data from both databases.  

Backup data to your PC 

1 Click PC Backup under Manage Server Data to save the entire i-Vu database zipped into one file to your PC. 

2 Click OK when you see the message The system will be stopped and restarted. Do you wish to proceed? 
Watch Operation Status to see the progress. 

3 Click the message Save/Download Backup File to Your Local Hard drive when it appears.  

4 Click Save when asked Do you want to open or save this file? 

5 Save the file (system.backup.tgz) to a convenient location on your computer.  

CAUTION! Do not alter the name of this file! 

6 Exit from Management Tool. 

7 You must reboot the web server before proceeding. 

 

Backup data to a USB drive 

1 Plug your USB drive into any available USB port on your i-Vu web server. 

2 Click USB Backup under Manage Server Data to save the entire i-Vu database zipped into one file to your 
USB drive. 
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3 Click OK when you see the message The system will be stopped and restarted. Do you wish to proceed? The 
Operation Status message updates as the i-Vu application prepares and creates the backup. Wait for 
Operation Status to state No Background Operations Currently Active.,  

4 Remove USB drive from the web server. 

NOTES 

○ A check of the USB drive will show a backup file named system.backup 

○ An error may be displayed under the Management Tool title stating The USB device failed to mount and 
initialize. Connect the USB drive to the first USB port. In this case, try a different USB drive or try 
rebooting the i-Vu web server, as there was an issue accessing the USB drive. 

5 Exit from Management Tool. 

6 You must reboot the web server before proceeding. 

 

 
 

Install i-Vu® v6.0 software 

Use the following steps to install the i-Vu® v6.0 application on both of your web servers, even the one you will no 
longer use. 

 

1 Remove the i-Vu® web server from the network by disconnecting the LAN cable. 

2 Insert the i-Vu® v6.0 Installation DVD into the i-Vu® web server DVD drive or USB Installation drive into the 
USB port on the front of the web server. 

3 Shut down the i-Vu® web server by pushing the On/Off button once. Wait for the blue light to turn off (could 
take as long as 2 minutes). 

4 Press the On/Off button again to restart the web server. The installation begins automatically. 

5 The Installation DVD ejects or the USB drive's light goes off when the installation is complete. This process 
takes several minutes. 

NOTE  Do not power off during the installation. 

   

 
 

Connect and power up target i-Vu® web server 

If you are currently using both a USB CCN and an Open Adapter, you must replace one of them with an external 
router. i-Vu v6.0 application does not support 2 USB cables on the single web server.  

 

1 If necessary, re-locate the i-Vu web server that you have chosen as the web server for i-Vu v6.0. For instance, 
if you are using a USB Adapter cable, you most likely need to move the target web server with the largest 
memory to the physical location of the cable.    

2 Plug the power cable into the back of the i-Vu® web server and into an electrical outlet. 

NOTE  We highly recommended using a UL Certified power surge/RFI suppression device. 

3 Connect an Ethernet cable from the laptop computer’s network port, or the customer's LAN, to the Ethernet 
jack on the back of the i-Vu® web server.  
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4 Connect your the selected i-Vu web server to your CCN and Open networks using routers and/or a USB 
Adapter cable (CCN or Open). If you are using a USB Adapter cable, plug the adapter into the USB port and 
connect to your network.  

  

 

 
 

Restore data from backups 

When merging an existing CCN and Open system, the database that you restore on the target web server becomes 
the primary database. Restoring includes all settings, including database, operators, alarms, and trends. You 
merge the second database using a clipping, which does not include operators or trends. 

On your target web server: 

1 Click PC Restore or USB Restore under Manage Server Data in the Management Tool. 

○ PC Restore - Browse to your backup file and click Perform Restore. 

○ USB Restore - Place your backup USB drive in any port on the i-Vu web server. Select the backup file and 
click Perform Restore. 

2 Restore is complete when Operation Status displays No Background Operations Currently Active. 

 

 

 
 

Troubleshoot, import secondary database, and resolve conflicts 

Export source files (drivers, .equipment, .view, and .bacview files) from the secondary database and import them 
into the primary database to identify and fix any equipment file names that may be duplicated in both databases. 
After you fix the conflicts, you export a clipping file (Source Files, database, and trends) from the secondary 
database and import it into the primary database on the target web server.   

If you skip using source files for removing conflicts and proceed directly to exporting and importing the clipping 
file, when duplicate file names are encountered during the clipping process, your must delete one of the files 
completely or stop the entire import process, fix the conflict, and start importing all over again. 

NOTE  A system clipping file takes time to import. You can see the estimated time for each database in System 
Options > General tab > System Statistics. 

Fixing potential conflicts 

1 Export source files from your secondary database, which is residing in the web server that you are not using 
for your target system. Select System Options > General tab > Source Files > Export button. 

2 Close System Options.  

3 Access the target web server. 

4 Import the source files into the primary database. Select System Options > General tab > Source Files > 
Import button. 

5 Browse to the source files you just exported and click Open. 

6 Click Continue. You can copy the list of any conflicts that appear to use for a troubleshooting reference.  
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7 Resolve conflicts before proceeding. To change the name of a custom equipment file: 

○ If the control program was made in Snap, open it in Snap and save with a different name. 

○ If the control program was produced in ApplicationBuilder, open the equipment file in EquipmentBuilder 
and save the file with another name.    

 

Import the secondary database into the target web server 

Clippings include source files, database, and trends. They do not include operators or alarms.  

1 Export a clipping file from the secondary database, which is residing in the web server that you are not using 
for your target system. Select System Options > General tab > Clippings > Export button.  

2 Click Save.  

3 Import the clipping file into the primary database on the target web server. Select System Options > General 
tab > Clippings > Import button.  

4 Browse to the exported clipping. 

5 Click Next. 

NOTE  You must resolve conflicts or problem that are displayed during the clipping import. In the case of 
duplicate file names, your only options are to delete one of the files completely or stop the entire import 
process, fix the conflict, and start the entire clipping import again. 

6 Verify that in the i-Vu® v6.0 interface the imported devices are communicating by selecting one router at a 
time in the navigation tree and clicking the Devices tab. 

7 Back up the merged target system from the Management Tool (page 17).  

 

 
 

Update your routers and controllers 

IMPORTANT!  Update your routers and controllers only once. Use either the i-Vu application or Field Assistant. 

Router and controller configurations are maintained when you update them using the procedure below. 

Step 1: Update the files for routers 

1 Select the router that you wish to update in the navigation tree. 

2 Right-click and select Driver Properties.  

3 Select Properties page > Update tab.  

4 If the database contains 2 or more routers, you must check Change for all control programs of this type in 
the Controller section. 

5 Click Update. A message appears Changes the driver and screen file to use the current library version. 
Continue?  

NOTE  If more than one router exists, the additional routers are listed below the Update button. 

6 Click OK.  

7 Click Accept. 
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Step 2: Update the files for controllers 

1 Double-click the controller in the navigation tree or right-click and select Configure .   

2 If you have multiple controllers of the same type, enable Change for all control programs of this type?. 

3 Click Update under Controller. A message appears Changes the control program, view, driver and screen 
files to use the current library version. Continue?  

4 Click OK. When the message Updated to the library version xx. appears, click Close. 

5 Repeat steps 1 - 4 for any additional types of controllers. 

6 Click Close again. 

 

Step 3: Update the files for CCN controllers 

1 In the navigation tree, select the CCN device manager associated with the controllers that are to be updated. 

2 Select the Devices tab and re-scan any controllers that need to be updated by checking Rescan Controllers 
Selected Below for Configuration Changes and clicking Start Scan. 

 

Step 4: Apply the update to routers and controllers 

1 Select the site level in the navigation tree and then select the Downloads page. 

2 If you wish to apply the new SAL file to your entire system, you can use this page to compare to your 
navigation tree and verify that you have selected all of your routers and controllers for download. 

NOTE  Only the CCN Gateway and device managers require download, so the CCN controllers/equipment will 
not be listed. 

3 A network's controllers download in the order shown. To change the order, select a controller(s), then drag 
and drop or click Move to Top or Move to Bottom. 
EXCEPTION  If a controller's router requires a download, it will download first regardless of its position on the 
Download page.Click the Start button. 

NOTES 

○ Use Ctrl+click, Shift+click, or the Select All checkbox to select multiple controllers.  

○ Up to 5 routers can download simultaneously. 

4 See To download from the Downloads page in Help for more details. 
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To begin, see Order software and obtain license. 

If you are upgrading from an i-Vu Standard or Plus system that uses a USB Adapter cable (CCN or Open), you must 
replace the cable with a router. Use an i-Vu CCN Router or i-Vu Link for a CCN network and an i-Vu Open Router or 
i-Vu Open Link for an MS/TP network.  

If your web server is model MP 945-D, you have to replace it in order to convert your system to an i-Vu v6.0 
application. Your model number is on the bottom of your web server. 

 

The table below is a quick outline of steps. Each step is explained in detail in the sections that follow. 

 Existing system Notes Procedure 

i-Vu CCN Standard v4.2 
or i-Vu Open Standard 
v5.1   

You must first upgrade to i-Vu 
Standard v6.0 application and 
then convert that to the i-Vu Pro v6 
application.  

 

 

1 Backup system to PC or USB from 
Management Tool. 

2 Install i-Vu Standard v6.0 application from 
the DVD or USB drive on your web server.  

3 Restore system to upgraded web server 
from the Management Tool. 

4 Export clipping file. Go to System Options 
> General tab > Clippings > and click the 
Export button. 

5 On your new computer, install the 32 or 
64-bit i-Vu Pro v6.0 application from the 
DVD. 

6 Open SiteBuilder v6.0 and import 
clipping. File > Clipping > Import. 

i-Vu CCN Plus v4.2 or i-
Vu Open Plus v5.1  

You must first upgrade to i-Vu  
Plus v6.0 application and then 
convert that to i-Vu Pro v6.0 
application 

1 Backup system to PC or USB from 
Management Tool. 

2 Install i-Vu Plus v6.0 application on your 
web server. 

3 Restore system to upgraded web server 
from the Management Tool. 

4 Export clipping file. Go to System Options 
> General tab > Clippings > and click the 
Export button. 

5 On your new computer, install the 32 or 
64-bit i-Vu Pro v6.0 application from the 
DVD. 

6 Open SiteBuilder v6.0 and import 
clipping. File > Clipping > Import. 

To upgrade to the i-Vu Pro v6.0 application 
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 Existing system Notes Procedure 

Mixed i-Vu CCN Plus 
v.4.2 and i-Vu Open 
Plus v5.1 

 Follow instructions in To merge a mixed 
system to the i-Vu Plus v6.0 application (page 
12). Once you have both databases merged in 
a single web server that is running the i-Vu 
v6.0 application, do the following: 

1 Backup system to PC or USB from 
Management Tool. 

2 Export clipping file. Go to System Options 
> General tab > Clippings > and click the 
Export button. 

3 On your new computer, install the 32 or 
64-bit i-Vu Pro v6.0 application from the 
DVD. 

4 Open SiteBuilder v6.0 and import 
clipping. File > Clipping > Import. 

i-Vu CCN Pro 3.1 You must install the latest driver 
in all i-Vu Integrators. They 
download automatically with the 
installation. 

If you install the 64-bit version, 
see Upgrade v3.1 or v4.2 
database in SiteBuilder (page 27).   

1 On your new computer, install the 32 or 
64-bit i-Vu Pro v6.0 application from the 
DVD. 

2 Upgrade database in SiteBuilder v6.0. 
Select File > Upgrade i-Vu System. 

3 Upgrade graphics in ViewBuilder, using 
the plug-in (page 32).  

i-Vu CCN Pro 4.2 If you install the 64-bit version, 
see Upgrade v3.1 or v4.2 
database in SiteBuilder (page 27).   

 

1 On your new computer, install the 32 or 
64-bit i-Vu Pro v6.0 application from the 
DVD. 

2 Upgrade database in SiteBuilder v6.0. 
Select File > Upgrade i-Vu System. 

 

For more details on upgrading to the i-Vu Pro v6.0 application and migrating to different databases, see Options 
for migrating and upgrading the database (page 24). 

 

 
 

To register and download your i-Vu® license 

To register your software, you must obtain a license from Carrier and then apply it in the i-Vu® interface.  

1 Login to ivusystems.com http://www.ivusystems.com, using your email and password. 

 NOTE  If you need a password, email mary.fleiger@carrier.utc.com to request one.  

2 Select Request/Download i-Vu Software Licenses. All your Sites Names/Project Names are listed. 

3 Select the site/project to register it. 

4 In the License Registration Area., fill in the Owner Information and the Site Information.  
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5 Click Register License. 

6 Check I agree to the terms of use. 

7 Click Download License, then save the license.properties file to a convenient location. 

 

To apply the license to the i-Vu® Pro application 

1 During the i-Vu® installation, in the Setup Wizard, on the Product License screen, check Browse to a 
different license, and select the site license you obtained.  

NOTES   

○ Selecting the default license results in a prompt appearing every few minutes in the i-Vu® interface to 
remind you to apply your site license. 

○ Do not edit any part of this registered license file. Editing a license file invalidates the license. 

○ Store the license in a safe location. 

 

To apply the site license after the installation: 

1 In the i-Vu® Pro v6.0 interface, select the System Options tree > License Administration. 

2 Browse to the license file. 

3 Click Apply. 

4 Restart i-Vu® Server using the rebootserver manual command. 
 

 

 
 

Options for migrating and upgrading the database 

NOTE  The "system folder" refers to the folder with the name of your site in the webroot folder, as in the following 
example, i-Vu Pro x.x > webroot > acme_corp. 

 

 From  To  Steps to migrate to the 32-bit i-Vu Pro v6.0 application on your same 
computer.  

Access Access 1 Copy existing i-Vu system folder for safekeeping. 

2 Install the 32-bit i-Vu Pro v6.0 application from the DVD.  

3 Upgrade database in SiteBuilder v6.0. Select File > Upgrade i-Vu 
System. 

Access Derby 1 Copy existing i-Vu system folder for safekeeping. 

2 Install the 32-bit i-Vu Pro v6.0 application from the DVD. 

3 Upgrade database in SiteBuilder v6.0. Select File > Upgrade i-Vu 
System. 

4 In SiteBuilder, select File > Manage Database > Migrate/Replica > 
Migrate. Select Derby. 
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 From  To  Steps to migrate to the 32-bit i-Vu Pro v6.0 application on your same 
computer.  

Access MS SQL 1 Copy existing i-Vu system folder. You cannot retrieve the files once they 
are upgraded.  

2 Install 2005/8/12 MS SQL. See Upgrade to MS SQL Server 2005-8-12 
on a new computer (page 28). 

3 Install the 32-bit i-Vu Pro v6.0 application from the DVD. 

4 Upgrade database in SiteBuilder v6.0. Select File > Upgrade i-Vu 
System. 

5 In SiteBuilder, select File > Manage Database > Migrate/Replica > 
Migrate. Select MS SQL. 

MSDE Access 1 Copy existing i-Vu system folder for safekeeping. 

2 Install the 32-bit i-Vu Pro v6.0 application from the DVD. 

3 Upgrade database in SiteBuilder v6.0. Select File > Upgrade i-Vu 
System. 

4 In SiteBuilder, select File > Manage Database > Migrate/Replica > 
Migrate. Select Access. 

MSDE MS SQL 1 Copy existing i-Vu system folder. You cannot retrieve the files once they 
are upgraded.  

2 Install 2005/8/12 MS SQL. See Upgrade to MS SQL Server 2005-8-12 
on a new computer (page 28). 

3 Install the 32-bit i-Vu Pro v6.0 application from the DVD. 

4 Upgrade database in SiteBuilder v6.0. Select File > Upgrade i-Vu 
System. 

5 In SiteBuilder, select File > Manage Database > Migrate/Replica > 
Migrate. Select MS SQL. 

MS SQL MS SQL 1 Copy existing i-Vu system folder. You cannot retrieve the files once they 
are upgraded.  

2 Backup 4 databases in MS SQL. 

3 Upgrade database in SiteBuilder v6.0. Select File > Upgrade i-Vu 
System. 

See Upgrade from the i-Vu v3.1 or v4.2 application that uses MS SQL 
Server 2000-5-8 to MS SQL Server 2005-8-12 on a new computer (page 
28). 
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 From  To Steps to migrate to the 64-bit i-Vu Pro v6.0 application on a new computer 

Access Access N/A  64-bit does not support Access. 

Access Derby 1 Install the 32-bit i-Vu Pro v6.0 application from the DVD on your existing 
computer. 

2 Upgrade database in SiteBuilder v6.0. Select File > Upgrade i-Vu 
System. 

3 In SiteBuilder, select File > Manage Database > Migrate/Replica > 
Migrate. Select Derby. 

4 Copy upgraded i-Vu system folder to USB drive. 

5 On your new computer, install the 32 or 64-bit i-Vu Pro v6.0 application 
from the DVD. 

6 Copy the system folder from your USB drive into the webroot folder. 

Access MS SQL 1 On your existing computer, install the 32-bit i-Vu Pro v6.0 application 
from the DVD. 

2 Upgrade database in SiteBuilder v6.0. Select File > Upgrade i-Vu 
System. 

3 In SiteBuilder, select File > Manage Database > Migrate/Replica > 
Migrate. Select Derby. 

4 Copy upgraded i-Vu system folder to USB drive. 

5 On your new computer, install the 64-bit i-Vu Pro v6.0 application from 
the DVD. 

6 Install 2005/8/12 MS SQL. See Upgrade to MS SQL Server 2005-8-12 
on a new computer (page 28). 

7 Copy the system folder from your USB drive into the webroot folder. 

8 In SiteBuilder, select File > Manage Database > Migrate/Replica > 
Migrate. Select MS SQL. 

MSDE Access N/A  64-bit does not support Access. 

MSDE MS SQL 1 On your existing computer, install the 32-bit i-Vu Pro v6.0 application 
from the DVD. 

2 Upgrade database in SiteBuilder v6.0. Select File > Upgrade i-Vu 
System. 

3 In SiteBuilder, select File > Manage Database > Migrate/Replica > 
Migrate.  

4 Copy upgraded i-Vu system folder to USB drive. 

5 On your new computer, install the 32 or 64-bit i-Vu Pro v6.0 application 
from the DVD. 

6 Install 2005/8/12 MS SQL. See Upgrade to MS SQL Server 2005-8-12 
on a new computer (page 28). 

7 Copy the system folder from your USB drive into the webroot folder. 

8 In SiteBuilder, select File > Manage Database > Migrate/Replica > 
Migrate. 
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 From  To Steps to migrate to the 64-bit i-Vu Pro v6.0 application on a new computer 

MS SQL MS SQL 1 Copy existing i-Vu system folder on USB drive. 

2 Backup 4 databases in MS SQL on USB drive. 

3 On your new computer, install the 32 or 64-bit i-Vu Pro v6.0 application 
from the DVD. 

4 Install 2005/8/12 MS SQL. See Upgrade to MS SQL Server 2005-8-12 
on a new computer (page 28).  

5 Restore above databases to upgraded MS SQL (page 30).  

6 Upgrade database in SiteBuilder v6.0. Select File > Upgrade i-Vu 
System. 

 

 

 
 

Install v6.0 and use SiteBuilder to upgrade database 

  The i-Vu CCN Pro v3.1 or v4.2 database must be upgraded using SiteBuilder v6.0.  

 CAUTION  Back up your system before upgrading. Once a system is upgraded, you cannot retrieve or access 
the database with your previous i-Vu installation.   

Typically, the file path for your i-Vu Pro v3.1 or v4.2 system are the default paths: C:\i-Vu3.1 or C:i-Vu4.2.  

1 Insert the Installation DVD into your computer. 

2 Click Install i-Vu Pro.and the Setup Wizard starts, unless you have a 64-bit computer. 

If you are using a 64-bit computer. a prompt asks if you want to install the 64-bit version of i-Vu® Pro. Click 
OK to begin the 64-bit installation. Click Cancel to install the 32-bit version. 

NOTE  MS Access is not available on a 64-bit installation. If your system uses an Access database and you 
want to upgrade to the 64-bit version of the i-Vu Pro v6.0 application, you must migrate your Access database 
to a different type of database before upgrading. Use the following steps: 

1. Open database in your v3.1 or v4.2 SiteBuilder. 

2. Select File > Manage Database > Migrate/Replicate > Migrate to a different database type and click 
Next. 

3. Select database type from drop-down list and click Next. 

4. Click Finish. Continue to upgrade your system in SiteBuilder v6.0. You can migrate again in v6.0 if you 
want to change your database to Derby, which was not previously available.   

3 Open SiteBuilder 6.0. and select File > Upgrade i-Vu System from the drop-down menu. 

4 Click Browse and select the system folder for your i-Vu Pro v3.1 or v4.2 system: C:\i-Vu3.1\webroot or C:\i-
Vu4.2\webroot. 

5 Select Make this the default system for iVu and click Next. 

6 Confirm that you have backed up and click Next when the Upgrade complete message appears. 

7 The upgrade process copies the necessary system files to your i-Vu Pro v6.0 installation directory and 
performs the required database upgrade steps.  
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Upgrading drivers 

○ When upgrading a v3.1 database, the drivers for the i-Vu Integrators are automatically updated to the 
latest drivers. v3.1 drivers do not function in v6.0. 

○ When upgrading a v4.2 database, a dialog lists all the current drivers and you can uncheck them if you 
do not want them to be upgraded. v4.2 drivers will function in v6.0.  

8 Log in using an administrator account. 

 

 

 
 

Upgrade from the i-Vu v3.1 or v4.2 application that uses MS SQL Server 
2000-5-8 to MS SQL Server 2005-8-12 on a new computer 

Follow these procedures to successfully upgrade and migrate your system and computer: 

1 Install the i-Vu Pro v6.0 application from the DVD on your existing i-Vu Pro v3.1 or v4.2 computer and set up a 
database in SiteBuilder. 

2 Copy data from the i-Vu Pro v3.1 or 4.2 application and back up the i-Vu databases in SQL (page 28). 

3 Install the i-Vu Pro v6.0 application and SQL Server on your new computer. (page 29) 

4 Restore i-Vu v3.1 or v4.2 databases to upgraded SQL. (page 30) 

5 Upgrade system in SiteBuilder (page 30). 

 

 

 
 

Copy i-Vu v3.1 or v4.2 data and back up in MS SQL to USB drive 

You must have installed the i-Vu Pro v6.0 application on your existing computer and set up a database in 
SiteBuilder before following these steps. Use this procedure if you have been using MS SQL Server 
2000/2005/2008 and are upgrading to MS SQL Server 2005/2008/2012 on a new computer.   

Copy data from computer used for i-Vu Pro v3.1 or v4.2 

1 Stop the i-Vu Server and close any i-Vu applications. If the i-Vu Server is installed as a service, stop it. 

2 Browse to your i-Vu Pro v3.1 or v4.2 webroot folder and copy the system folder to a USB drive. 

 

In SQL, back up the i-Vu databases to a USB drive  

NOTE  The i-Vu databases are named main, alarms, audit, and trends. 
 

1 Log in to SQL Studio Manager using your Windows Authentication login.  

2 Expand Databases on the left.  

3 Right-click any of the 4 databases and select New task > Backup. 

4 In the Backup > General tab, verify that the Backup Type is Full. 

5 Under Destination, click ADD. 

6 In the popup window, browse to the USB drive and enter a filename (i.e. Main, Alarms etc..) 
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7 Click OK and then OK again to return to the original backup window. 

8 Under Options, check Overwrite all existing backup sets. 

9 Click OK to start the backup.  

10 Repeat the above steps for the 3 remaining i-Vu databases.  

 

 

 
 

Install the i-Vu Pro 6.0 application and MS SQL Server on new computer 

1 Install i-Vu Pro v6.0 from the Installation DVD on your new computer. If you are changing to a 64-bit install, 
select i-Vu Pro server for 64-bit O/S Server.         

NOTE  The 32-bit version of i-Vu can be installed on either a 32 or 64-bit operating system. However, the 64-
bit can only be installed on a 64-bit operating system. 

2 Install SQL 2005/2008/2012 and any applicable SQL service packs. For instructions on how to install any 
version of MS SQL Server go to http://msdn.microsoft.com/en-us/library/default.aspx and, in the Search 
window, type Install <your SQL Version >. 

3 As you install MS SQL Server 2005, 2008 or 2012, you must select certain options to use with i-Vu Pro. For 
all other options, you may keep the defaults or select your own values. Select the following: 

○ MS SQL Server Database Services 

○ Workstation components, Books Online, and development tools  

○ Authentication Mode - Mixed Mode (Windows Authentication and SQL Server Authentication)  

○ NOTE the password you specify grants extensive privileges.  

○ Service Account for database engine – NT Authority\System 

4 Select Start > Programs > Microsoft SQL Server 2005 (2008 or 2012) > SQL Server Management Studio. In 
the opening dialog box, select the following options:  

○ Server type: Database engine  

○ Server name: [Address of machine where the database is located]  

○ Authentication: Windows Authentication  

○ User name: [A valid Windows user name]  

○ Password: [Password associated with the above user name]  

5 Click Connect. 

6 In the Object Explorer pane, click the plus sign to the left of Security and then  
right-click Logins and select New Login.  

7 Check SQL Server authentication. 

8 Clear the following checkboxes:  

○ Enforce password policy  

○ Enforce password expiration  

○ User must change password at next login  

9 Enter and confirm a username and password in Login. Record them. 

10 Select Master from the Default database drop-down list and click OK. 

11 In the Object Explorer pane, right-click Databases, then select New Database.  
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12  Enter main for the name.  

13  In the Owner field, type the user name created in step 9.  

14  Do not change the default values for the other fields.  

15  Select Options at the top of Database Properties.  

16  Select Simple from the Recovery model drop-down list. 

17  Click OK. 

18  Repeat steps 11 through 17 for the alarms, audit, and trends databases. 

 

 

 
 

Restore i-Vu v3.1 or v4.2 databases to upgraded MS SQL 

1 Insert ihe USB drive that contains the database backups from your i-Vu v3.1 or v4.2 system, into your 
computer. 

2 Open SQL Studio Manager and expand Databases. 

3 Right-click the Main database and select Tasks > Restore > Database. 

4 Under Source for restore select From device. 

5 Click on the browse icon on the right.  

6 Click the Add button in the Specify Backup window. 

7 Browse to the USB drive that contains the backed-up databases and select main.bak (or whatever name you 
assigned to the main database). 

8 Click OK twice to return to the Restore database window. 

9 Check the box under the Restore column. 

10 Select Options at the top left of the Restore database window. 

11 Check Overwrite existing database and click OK. 

12 A popup message will appear showing the restore was successful. 

13 Repeat the above for the remain three databases. 

14  Close SLQ Studio Manager. 

 

 
 

Upgrade in SiteBuilder v6.0 

1 Open SiteBuilder 6.0. and select File > Upgrade i-Vu System. 

2 Browse to your i-Vu v3.1 or v4.2 system folder on the USB drive. 

3 Enter a new system name, if desired.  

4 Enter the name of the computer where the SQL server is installed.  

NOTE  This is usually the PC name itself. (See below) 

5 Leave the port field blank unless the IT department insists that a port number be entered.  

NOTE  Default port number for SQL Server is 1433. 

 
 
i-Vu® Application Carrier Proprietary and Confidential CARRIER CORPORATION ©2014   
Rev. 3/21/2014  All rights reserved 
 30 

 



 To upgrade to the i-Vu Pro v6.0 application
  

 

6 Enter the name of the four databases that were created in SQL Studio Manager on the new computer. 

7 Enter the username and password that was created in SQL Studio manager for the new i-Vu v6.0 installation.  

8 Click Next. 

 
9 Confirm that you have backed up and click Next when the Upgrade complete message appears. 

10 The upgrade process copies the necessary system files to your i-Vu Pro v6.0 installation directory and 
performs the required database upgrade steps.  

Upgrading drivers 

○ When upgrading a v3.1 database, the drivers for the i-Vu Integrators are automatically updated to the 
latest drivers. v3.1 drivers do not function in v6.0. 

○ When upgrading a v4.2 database, a dialog lists all the current drivers and you can uncheck them if you 
do not want them to be upgraded. v4.2 drivers will function in v6.0.  

11 Enter a password and click Next to complete the database upgrade. 

 

NOTE   If the 4 i-Vu® databases do not reside under the default instance of SQL, then the instance name must be 
specified under the Instance column. The syntax for specifying the instance name of the SQL server is 
<Database>;instance=<instance name>. For example, if the SQL instance name is hvac , the syntax for 
the Instance field for the main database called iVu_Main would be iVu_Main;instance=hvac. 
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Upgrade from Access and i-Vu Pro v3.1 or v4.2 application to Derby, new 
computer, and 64-bit v6.0 

If you are continuing to use your current computer for the i-Vu Pro v6.0 application, the operating system is 32-bit, 
since v3.1 and v4.2 only ran on a 32-bit platform. The 32-bit v6.0 does support Access, however the 64-bit does 
not.   

 

1 Install the 32-bit version of the i-Vu Pro v6.0 application on your current computer. 

NOTE  You will still have your i-Vu Pro v3.1 or v4.2 system there, also. 

2 Make a backup of the current i-Vu system by copying your system folder under the webroot folder. 

3 Upgrade database in SiteBuilder v6.0. Select File > Upgrade i-Vu System. 

4 In SiteBuilder, select File > Manage Database > Migrate/Replica > Migrate. Select Derby. 

5 Copy the migrated system folder from the i-Vu v6.0 webroot folder to a USB drive. 

6 Install the 64-bit version of the i-Vu v6.0 application on the new computer. 

7 Copy the saved Derby database from the USB drive to the webroot folder of the new i-Vu Pro v6.0 64-bit 
application. 

 

 

 
 

Upgrade v3.1 graphics 

i-Vu 3.1 graphics files (.view files) must be upgraded to be used in i-Vu® v6.0.  

The graphics were copied to your v6.0 system when you upgraded the database in SiteBuilder 6.0. However, you 
must upgrade your graphics in ViewBuilder v6.0 

Area graphics in i-Vu CCN Pro v3.1 may have been designed to use variable color expressions, which change zone 
color based on fixed temperature ranges. Colors in a zone on a floorplan graphic do not change dynamically in i-
Vu® v6.0. The Equipment Color control oval  takes over this function and changes color based on the 
specific setpoints for the zone.   

The equipment’s color in the oval is based on the current zone temperature and the position of the colored bands 
in the setpoint control. 

 
Floorplan images used in i-Vu v3.1 often had random background colors assigned to each dynamically changing 
zone. These background colors will not be shown once the graphics have been upgraded.   
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When you open an i-Vu v3.1 .view file in ViewBuilder, you are prompted to upgrade the graphic and select a fill 
color for the zone. We recommend selecting a neutral color that is distinguishable from the wall color. 

 
 

You can convert one graphic at a time, or you can convert an entire directory at once by installing the plug-in 
before upgrading your graphics. 

1   Select Tools > Configure Tools > Upgrade 3.1 graphics and click Add. 

 
2 Select upgrade-3_1-graphics.viewbuilder-plugin and click Open. 

3 Once the plug-in is installed, all the graphics in a directory (views and symbols) may be upgraded at once by 
selecting Tools > Upgrade 3.1 Graphics. 

 

 

 
 

Upgrade v3.1 custom control programs 

Library 
The number of types of devices supported in the built-in equipment library has been greatly expanded since the i-
Vu Pro v3.1 application.   

• If the control program in the Integrator is only being used to access values in the CCN device, it is strongly 
recommended to use the control programs that are automatically generated when the devices are 
discovered.   

• If equipment is using control programs that were automatically generated during discovery in 3.1, you can 
select those equipment on the Devices page and re-scan them to update their control programs and graphics 
to the current versions. 

• If you wish to replace a control program that was made with EIKON® with one that is automatically 
generated, you will have to delete the equipment from the Devices page and rediscover it. Deleting an 
equipment results in losing schedules, alarm actions, setpoints, or other parameters that are defined in that 
equipment.  Schedules or alarm actions defined further up the hierarchy will not be affected. 
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Custom Control Programs 
• If you have custom logic created in EIKON that is being used as a part of the control sequence, you cannot 

replace the custom control program with the automatically-generated one.   

• Your EIKON-created control program will still run in an i-Vu Integrator that has been upgraded to run with the 
i-Vu Pro v6.0 application. 

• In order for a custom control program to support any of the new features available in  the i-Vu Pro v6.0 
application, it is necessary to apply an update to EIKON under the i-Vu Pro v3.1 application.  

 

To apply the EIKON update: 

1 Download the update file called iv42_eikon.update from the Service Intranet. 

2 Open SiteBuilder v3.1. 

3 Select Actions > Apply Update. 

4 Browse to the location of the .update file and select it. 

5 The screen should appear as seen below. Click Apply to apply the EIKON patch. 

 
 

• You will need to use the EIKON program that was a part of your i-Vu Pro v3.1 system to edit any custom 
control programs.   

NOTE  Custom programs created with EIKON will only run in an i-Vu Integrator.  They are not supported in i-Vu 
CCN Routers. 

 

Local override  
• Local overrides were not allowed in the i-Vu Pro v3.1 application.   

• Control programs that are automatically generated during the discovery process in the i-Vu CCN Pro v4.2 
application will support local overrides.   

• To support new features in an EIKON-generated control program, you need to make some small changes.  

○ v3.1 control programs typically had a section like the one shown in Figure 1. This took the current 
schedule state and used a Carrier Schedule Write microblock to write it to a CCN device.  This should be 
replaced with logic similar to that shown in Figure 2. 

 
 
i-Vu® Application Carrier Proprietary and Confidential CARRIER CORPORATION ©2014   
Rev. 3/21/2014  All rights reserved 
 34 

 



 To upgrade to the i-Vu Pro v6.0 application
  

 

  
Figure 1 

 

○ The logic shown in Figure 2 uses a new Carrier Schedule microblock and DOES NOT use either of the 
microblocks shown in Figure 1.  The bottom output from the new Carrier Schedule microblock indicates if 
the device is in override.  If you wish to use the new Tenant Billing plug-in, you must add a binary trend 
with a reference name of override (case sensitive) to this output, as shown in Figure 2. 

 
Figure 2 

 

 
 

Update your routers and controllers for the i-Vu Pro v6.0 application 

IMPORTANT!  Update your routers and controllers only once. Use either the i-Vu or Field Assistant application. 

Router and controller configurations are maintained when they are updated using the procedure below. 

Step 1: Update the files for routers 

1 Select the router that you wish to update in the navigation tree. 

2 Right-click and select Driver Properties in the drop-down list. A dialog window appears.  

3 If the database contains 2 or more routers, you must check Change for all control programs of this type in 
the Control Program section. 

4 Click Update. A message appears Changes the driver and bacview to use the current library version. 
Continue?  

NOTE  If more than one router exists, the additional routers are listed below the Update button. 

5 Click OK.  

6 Click Close. 

 

Step 2: Update the files for controllers 

1 Double-click the controller in the navigation tree or right-click and select Configure .   

2 If you have multiple controllers of the same type, enable Change for all control programs of this type?. 

3 Click Update under Controller. A message appears Changes the control program, view, driver and screen 
files to use the current library version. Continue?  

4 Click OK. When the message Updated to the library version xx. appears, click Close. 

5 Repeat steps 1 - 4 for any additional types of controllers. 

6 Click Close again. 
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Step 4: Update the files for CCN controllers 

1 In the navigation tree, select the CCN device manager associated with the controllers that are to be updated. 

2 Select the Devices tab and re-scan any controllers that need to be updated by checking Rescan Controllers 
Selected Below for Configuration Changes and clicking Start Scan. 

 

Step 3: Apply the update to routers and controllers 

1 Select the site level in the navigation tree and then select the Downloads page. 

2 If you wish to apply the new SAL file to your entire system, you can use this page to compare to your 
navigation tree and verify that you have selected all of your routers and controllers for download. 

NOTE  Only the CCN Gateway and device managers require download, so the CCN controllers/equipment will 
not be listed. 

3 A network's controllers download in the order shown. To change the order, select a controller(s), then drag 
and drop or click Move to Top or Move to Bottom. 
EXCEPTION  If a controller's router requires a download, it will download first regardless of its position on the 
Download page.Click the Start button. 

NOTES 

○ Use Ctrl+click, Shift+click, or the Select All checkbox to select multiple controllers.  

○ Up to 5 routers can download simultaneously. 

4 See To download from the Downloads page in Help for more details. 
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Follow these steps to upgrade your Field Assistant systems:  

1 Install new software. (page 37) 

2 Transfer existing databases. (page 37)  

3 Update your equipment SAL libraries. (page 38) 

 

 
 

Install Field Assistant v6.0 software 

1 Insert your Tech Tools v6.0 DVD in your computer and click Install Field Assistant Tool, which opens the i-Vu 
Tools menu. 

2 Click on Install Field Assistant Tool. 

3 Accept the license agreement. 

4 Select directory where you wish to install Field Assistant (default is C:\Field Assistant Tool6.0). 

NOTE  Field Assistant v6.0 must be installed in a new directory; it cannot be installed in an existing Field 
Assistant installation folder. 

5 Select the Start Menu folder and locate Field Assistant (default is Field Assistant Tool). 

NOTE  We recommend that you add 6.0 to the default folder name in order to identify this version of Field 
Assistant, in case you decide to retain the previous version. 

6 Review and accept the Installation Summary. 

7 When installation is complete, select Exit Installer to close i-Vu Tools menu. 

 

 
 

Transfer existing databases 

Field Assistant 6.0 is compatible with systems created with previous versions of Field Assistant. You must copy 
them so they reside in the Field Assistant 6.0 installation folder. 

1 Navigate to your Field Assistant 5.0 or 5.1 folder (default is C:\Field Assistant Tool5.0 / 5.1) and open the 
webroot folder. 

NOTE  Each system created in Field Assistant has a separate folder. By default, the following 2 folders are 
under webroot: 

○ _common 

○ WEB-INF 

2 Select and copy the other folders, which are system databases. Use Shift+click or Ctrl+click to select multiple 
folders. 

3 Paste these folders into the new Field Assistant 6.0 > webroot folder C:\Field Assistant Tool6.0\webroot). 

NOTE  Do not copy any folders other than your systems. 

To upgrade Field Assistant 
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4 Start Field Assistant 6.0 to access the Field Assistant Launcher screen.   

5 Select the appropriate Communications option, based on your connection to the system: 

• If you are connecting over the IP network, click BACnet/IP and select your IP. (This requires that the i-Vu 
Control System has one or more routers.). 

• If you are connecting to the system using the USB Link cable, click Local Access, and select the Comm port 
that the USB Link (USB-L) cable is attached to.  

1 Select an existing system from the drop-down menu, or, to set up a new one, click  and type your System 
Name.  

NOTES   

○ Do not begin your System Name with a number or use capital letters or special characters, other than a 
dash or an underscore.  

○ If you elect to use an existing system, the database is updated automatically for 6.0 compatibility when 
you launch Field Assistant. 

2 Click the Start    button. Your browser automatically launches the interface.  

NOTE  This could take a few moments. However, if  Field Assistant does not start automatically, type 
http://localhost/ in your browser. 

 
 

Update equipment SAL libraries 

The i-Vu® SAL files update your i-Vu® controllers. The SAL libraries contain control programs, graphics, drivers, 
screen files, and other important controller data.  

Carrier periodically provides updates, which include enhancements and bug fixes. 

NOTES 

• The library update only changes default graphics. If you have edited your graphic in ViewBuilder, it is not 
updated. 

• The last digits in the SAL library name are the release date of the library. 

• All of the SAL files will not necessarily have the same <date> revision. 

• To ensure that your installation is running the latest software, we recommend that you check Control Systems 
Support  http://www.hvacpartners.com/ for updates. Download the latest SAL files and apply them to all new 
installations. 

• If you are changing to an older SAL file than the current one being used, a warning asks you if you are sure 
you want to apply an older version. 

 

There are currently 6 SAL files used by the i-Vu® v6.0 application:  

• ivu-6.0-factory-<date>.sal (for PIC-based controllers)  

• ivu-6.0-upc-open-<date>.sal (for Universal Protocol Converter-based equipment)  

• ahub-6.0-<date>.sal (for 39m AHU applications)  

• ivu-6.0-universal-controller-<date>.sal (for UC Open and AppController-based applications) 

• ivu-6.0-applicationbuilder-<date>.sal (for CCN applications) 

• ivu-6.0-discovery-<date>.sal (for CCN PIC applications) 
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NOTE  Keep copies of the latest libraries in a safe place. In the event of a system restore, the updated .sal file 
must be reapplied. 

 

Field Assistant 

1 Stop the Field Assistant Server, if it is running.  

2 Copy the updated SAL file(s) to your Field Assistant Tool Installation path (Default: C:\Field Assistant Tool6.0) 
> equipmentbuilder folder.  

NOTE  Do not delete the older SAL file(s) to retain compatibility with older installations.  

3 Start your system in Field Assistant.  

 

Refer to Update your routers and controllers (page 10) to complete upgrading your system. 
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