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What is an i-Vu® Pro system?

An i-Vu® Pro system is a web-based building automation system that can be accessed from anywhere in the world
through a web browser, without the need for special software on the workstation. Through the web browser, you
can perform building management functions such as:

e adjust setpoints and other control parameters
e setand change schedules

e graphically trend important building conditions
e view and acknowledge alarms

e run preconfigured and custom reports on energy usage, occupant overrides, and much more

NOTE If you are upgrading your i-Vu® Pro application from v6.0 or earlier, see the i-Vu® Application Upgrade
Guide. You must convert your trends, which is not described in this document.

A typical i-Vu® Pro system

An i-Vu® Pro system uses a network of microprocessor-based controllers to control heating and air conditioning. A
web-based server communicates with these controllers and generates the i-Vu® Pro interface that the user can
access through a web browser. Through the interface, you can gather information, change operating properties,
run reports, and perform other building management functions on a single building or an entire campus.

The i-Vu® Pro client uses a supported web browser to access i-Vu® Pro Server as a website.
i-Vu® Pro supports:

e  Unlimited simultaneous users

. Multiple operating systems and databases

e CCN, Open, and third-party devices

e  Built-in alarming, trending, and reporting

e  Third-party integration

e  Secure server access using TLS

-Vu® Pro v8.5 ©2023 Carrier.
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What is an i-Vu® Pro system?

i-Vu® Pro tools

Develop and configure graphics and a system database for your i-Vu® Pro system using the following i-Vu® Pro

tools.

NOTE The i-Vu® Pro v8.5 Tech Tools and Customer Tools USB drives have a built-in license that expires 2 years
after the software is released. When prompted during installation, browse to the i-Vu® Pro v8.5 non-expiring
license that you obtained from Carrier.

Use...
ViewBuilder

SiteBuilder

Tech tools for the Installer only:

Use...

EquipmentBuilder

Alarm Notification

Virtual BACview®

BBMD Configuration Tool

MSTP Capture Utility

Test & Balance

Snap

LonWorks Integration Tool

AppLoader

Field Assistant

-Vu® Pro v8.5
Installation Guide

To...
Create or edit graphics
Create and modify the system database

Build a system for multiple CCN Gateways

To...

Build or edit control programs (.equipment files) for programmable
controllers. Can also produce graphics, sequence of operation, and
screen files

Receive a message on any networked computer that is running the i-
Vu® Pro Alarm Notification Client application

View and change property values and the controller's real time clock
Configure BACnet/IP Broadcast Management Devices (BBMDs)

NOTE If your system has multiple routers that reside on different IP
subnets, you must set up one router on each IP subnet as a BACnet/IP
Broadcast Management Device (BBMD).

Capture BACnet traffic on MS/TP. It is intended for situations where
Carrier Control Systems Support needs a network capture to
troubleshoot communications.

Calibrate airflow in a VAV or VVT Zone controller

Calibrate the static pressure in a VVT Bypass controller
Commission air terminals

Override reheat and terminal fans

NOTE Use Test & Balance to manipulate the controllers associated with
an air source, but not the air source itself, or heating and cooling
equipment, such as chillers and boilers.

Build custom control programs using individual blocks of programming
code called microblocks

Generate the microblock addresses automatically for third-party
LonWorks points

Use to download .clipping files to restore factory defaults and check
Module Status (Modstat) through the Rnet port

Service or start up and commission a piece of equipment or a network of
controllers.

©2023 Carrier.
All rights reserved.



What's new in v8.5

What's new in v8.5

What's new in the i-Vu® Pro v8.5 application

Feature Improvement

Interactive Zone Widget Also available in v8.0 with Cumulative Patch #5

Remote System Full featured system configuration in the i-Vu Set Up Tree
Engineering

Staged firmware downloads e  Keep the controller online while transferring a driver from the server
to the controller, then only take the controller offline when installing
those files

e  Reduce downtime of controllers by at least 75%

Network Tree Organization Easier network organization for large IP controller networks
for IP Networks

Report options e  System-wide report formatting options available to all i-Vu report
users

e  New Operator Information Report
e  Numerous improvements to Custom Reports
e Quarantine Data reports for Life Science Systems

e  Custom logo feature moved to System Options > System Settings >
Reports

New "programdata" e Enables quarterly releases
directory structure

. Increases security

e Simplifies installation

e  Place your system folder anywhere you like
Additional Features e License expiration shown on About page

e  Personal Information fields removed from Operator page

-Vu® Pro v8.5 ©2023 Carrier.
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What's new in v8.5

What's new in the SiteBuilder v8.5 application

Feature Improvement

Network Tree Organization for  Easier network organization for large IP controller networks
IP Networks

What's new in the ViewBuilder v8.5 application

Feature Improvement

Interactive Zone Widget e New zone control widget that is sensor agnostic.
e Allows setpoint, timed local override, and fan adjustment
e  Optionally shows zone color as border color

e Also available in v8 with Cumulative 5

-Vu® Pro v8.5 ©2023 Carrier.
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Before starting the i-Vu® Pro application and your system

Before starting the i-Vu® Pro application and your system

You must complete the following steps BEFORE installing i-Vu® Pro.

Step 1. Install Tools and have documentation ready

1  Follow the rest of this document to set up your entire system.

2 Insert the Tech Tools USB drive into your computer and wait until the Installation screen appears. If this
screen does not appear, open My Computer and double-click Tech Tools.

3 Click the utilities you wish to install. Depending on how security and permissions are configured on your
Windows computer, you may need to right-click the executable file and select Run as Administrator. For
example, to install Tech Tools, right-click i-Vu_Tools_v8.5_windows_setup.exe and select Run as

Administrator.

NOTE Some utilities are not copied to the hard drive. We recommend that you copy the Tech Tools USB
contents to a folder on your hard drive. This ensures that you have the utilities when you need them.

Step 2: Install device managers and routers

If you haven't already, download the Installation and Start-up Guides from the Carrier support website.
o Mount and wire your CCN device manager(s)*, Open, XT, or TruVu™ routers.

o  Wire the ports for communication and set DIP switches.

o  Setup IP addressing, including BACnet/IP Broadcast Management Devices (BBMDs).

NOTE If your system has multiple routers that reside on different IP subnets, you must set up 1 router on
each IP subnet as a BACnet/IP Broadcast Management Device (BBMD's). See the BBMD Utility User
Guide for details.
Configure BACnet device instance and network number using PuTTY or Hyperterminal connected to the
Rnet or S2 port. See Communicating using PuTTY (page 42) or Communicating using Hyperterminal
(page 44).

*If you have multiple CCN Gateways, you must obtain the required license and then use SiteBuilder to set up a
site and BACnet/IP network per Gateway. See i-Vu®-Pro and SiteBuilder Help.

-Vu® Pro v8.5 ©2023 Carrier.
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Before starting the i-Vu® Pro application and your system

Step 3: Use Network Service Tool V to ensure hardware is
communicating on the CCN network

1 Connect the 3-terminal connector of the Network Service Tool's USB to CCN Converter to Port S1 on the i-Vu®
device manager.

Carrier USB to CCN converter i-Vu® device manager
(top CCN Port) (Port S1)

+ Net+ (Pin 1)

G Signal Ground (Pin 5)
- Net- (Pin 2)

2 Launch Network Service Tool and connect to the i-Vu® device manager. Each i-Vu® device manager defaults
to Gateway functionality and has a CCN address of 0, 1.

& CAUTION Every CCN device must have a unique CCN address on the CCN network! Do not use Bus O,
Element 238, as it is automatically assigned to the i-Vu® Pro web server.

3 Find the device manager at 0,1 using Address Search and change the device manager’s CCN address as
desired.

NOTE We do not recommend leaving a device manager’s CCN address at 0,1, because this is the address
that it defaults to when formatted.

4 Upload the i-Vu® device manager.
5 Access the Service Configuration Table IP_CONF to enter the following configuration options:
NOTE A static IP address is required, as DHCP is not supported.

o Host IP Address - enter the device manager's IP address, provided by the LAN administrator (allowable
entries for XxXx.XxXx.xxx.xxx: Xxx is a decimal number between O - 255)

o  Subnet Mask - enter the device manager's IP address, provided by the LAN administrator (allowable
entries for XxXx.Xxx.xXxx.xxx: Xxx is a decimal number between O - 255)

o Default Gateway - enter the IP Gateway's IP address, provided by the LAN administrator (typically a
router on the Ethernet LAN).

CCN ENET Configuration

Device Type

o  Select 0 if this device manager is the Gateway. (NOTE Only 1 Gateway is permitted per system.)
o  Select 1 if this device manager is the Bridge.

If using the router as a Bridge, enter CCN/Ethernet Gateway IP (the IP address of the i-Vu® device manager
that is configured as the Gateway). This is the same address that was entered in the Host IP address for the
CCN Gateway.

NOTE Record the IP address of the Gateway, because you need it to install your i-Vu® Pro system.

6 Repeat the above steps for every i-Vu® device manager used in the CCN system.

-Vu® Pro v8.5 ©2023 Carrier.
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Before starting the i-Vu® Pro application and your system

Step 4: Get your systems ready

CCN

1 Have the IP address of the external Gateway.

2 Have a list of all of the devices at your job site, along with the name of each device, the bus and element
numbers, and their respective locations.

3 For a retrofit project, which is already using CCN global and network schedules, you must have a list of all
existing CCN schedule numbers, systems using global and network schedules, and all global schedule
masters.

4 Verify that each device has a unique element number because duplicates will not install correctly.

& CAUTION Do not use Bus O, Element 238. It is automatically assigned to the i-Vu® Pro web server.

BACnet

1 Create a list of all of the i-Vu® Open, XT, or TruVu™ routers and controllers at your job site, with their BACnet
Device ID's, IP addresses (where applicable), BACnet network numbers, and the physical location of all
devices.

2  Verify that every router has a unique address because duplicates will not install correctly.

See i-Vu® Pro Help for more information about setting schedules in the i-Vu® Pro interface.

-Vu® Pro v8.5
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Setting up i-Vu® Pro client devices and web browsers

Setting up i-Vu® Pro client devices and web browsers

The i-Vu® Pro system can be viewed on the following client devices and web browsers.

Computers

The client computer should have at least:

e  Quad core processor

e 4 GBRAM

e  Communications link of 200 Mbps or higher

The i-Vu® Pro application will work with slower computers and slower links, but the results may not be
satisfactory.

A computer with this Supports these web browsers...
operating system...

Windows® Google™ Chrome™ v84.0 or later 1
Microsoft® Edge v84 or later
Mozilla® Firefox® v79.0 or later

Mac® 0S X® Safari® vi1 or later 2

(Apple® Mac only)
Google Chrome v84.0 or later
Mozilla Firefox v79.0 or later

1 Best performance
2 Best performance unless browser is running on a Mac® Mini or a MacBook:

WARNING If machine is running Mountain Lion 10.8x with an integrated Intel HD 400 graphics card,
it will experience display issues. Use one of these workarounds for better performance:

e [f an additional NVIDIA graphics card is available, manually switch the graphic card setting in MAC® OS
X® to use that card.

e If not, use Google™ Chrome™ v84.0 or later.

Mobile devices

Device type Platform support
Smart phone Android™, i0S
Tablet Android™, i0S, Surface™

NOTE Some functionality may be limited by the capability of the mobile device and operating system.

-Vu® Pro v8.5 ©2023 Carrier.
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Setting up i-Vu® Pro client devices and web browsers

Setting up and using a computer with the i-Vu® Pro system

e  Setthe monitor's screen resolution to a minimum of 1920 x 1080 with 32-bit color quality

e  You may want to disable the computer's navigation sounds.

Mac only

NOTE The instructions below are for a Mac OS X 10.8. Other versions may vary slightly. See your computer's Help
if necessary.

Computer settings To change setting...

Enable right-clicking to see
right-click menus:

On a Mac 1 Select System Preferences > Mouse.

2  Click the drop-down list that points to the mouse's right-click button,
then select Secondary Button.

On a MacBook 1 Select System Preferences > Trackpad.

2  Enable Secondary click.

The instructions in Help are for a Windows computer. For instructions that include the Ctrl key, replace Ctrl with
Command. For example, replace Ctrl+click with Command+click.

Setting up and using a web browser to view the i-Vu® Pro interface

To set up and use Microsoft Edge

The instructions below are for Microsoft® Edge.

Web browser settings To set in Microsoft Edge...
Do not block cookies 1 Click ...to display the Actions droplist.
2 Select Settings > Site Permissions > Cookies.
Disable web browser's pop-up 1 Click ...to display the Actions droplist.
blockers * . . Lo .
2 Then select Settings > Site Permissions > Pop-ups and redirects.
-Vu® Pro v8.5 ©2023 Carrier.
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Setting up i-Vu® Pro client devices and web browsers

To... Do the following...
Maximize the web browser window *  Use the minimize/maximize button in the top right corner of the browser
window.
Have 2 different users logged in to 1 Click ...to display the Actions droplist.
the i-Vu® Pro system on the same .
computer * 2 Select New Window.
Clear browser cache 1 Click ...to display the Actions droplist.
2  Select Settings > Privacy, Search, and Services > Clear browsing
data.
3 Click Choose what to clear.
4 Click Clear now.

* Does not apply to Microsoft Edge on a phone.

To set up and use Mozilla Firefox

NOTES

e The instructions below are for Mozilla® Firefox® v60.0 on a Windows operating system. Other versions may
vary slightly. See your web browser's Help if necessary.

e If the menu bar is not visible, right-click on the window's title bar, and then select Menu bar.

e If a message appears in the i-Vu® Pro interface that includes the checkbox Prevent this page from creating
additional dialogs, DO NOT check this box.

Web browser settings To set in Firefox...
Disable Pop-up blocker 1 Click Tools > Options > Privacy & Security.
2 Under Permissions, click Exceptions next to Block pop-up windows.
3 Type http:// (or https://)and then the server name or IP
address of your system.
4 Click Allow and then Save Changes.
Enable JavaScript 1 Inthe address bar, type about:config, and then press Enter.
2  Click | accept the risk.
3 Inthe Search bar, type javascript.enabled.
4 If the value field shows true, JavaScript is enabled. If it shows false,
right-click javascript:enabled, and then select Toggle.
Add-ons Manager Select Tools > Add-ons > Extensions. On this page, you can

enable/disable installed add-ons such as:

Adobe® Acrobat® Reader (to view PDF's)

QuickTime Plug-in (to play audible alarms)

Only installed Firefox add-ons will show up in the list.

-Vu® Pro v8.5
Installation Guide
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Setting up i-Vu® Pro client devices and web browsers

To... Do the following...
Maximize the web browser window Press F11 to turn full-screen mode on\off.
Clear browser cache 1 Click Tools > Options > Privacy & Security.

2 Under Cookies and Site Data, click Clear Data.

3 Click Clear.
Have 2 different users logged in to Start a new web browser session. Select File > New Private Window.
the i-Vu® Pro system on the same
computer

To set up and use Google Chrome

NOTES

e The instructions below are for Google™ Chrome™ v66.0. Other versions may vary slightly. See your web
browser's Help if necessary.

e If a message appears in the i-Vu® Pro interface that includes the checkbox Prevent this page from creating
additional dialogs, DO NOT check this box.

On a computer

Web browser settings To set in Chrome...
Enable pop-ups 1 Click * on the browser toolbar.

2 Select Settings.

3 Click Advanced at the bottom of the page.

4 Under Privacy and security, click Content settings.

5 Under Pop-ups > Allow, click ADD, and then type http:// (or

https://) and then the server name or IP address of your system.

To... Do the following...

Clear browser cache . :
Click * on the browser toolbar.

1
2  Select More tools > Clear browsing data.

3 Select a time range in the drop-down list.

4 Check the types of information that you want to remove.
5 Click CLEAR DATA.

Maximize the web browser window Press F11 on your keyboard to turn full-screen mode on/off.

Have 2 different users logged in to

the Vu® Pro system on the same Start a new web browser session. Click = , then select New incoghito

window.
computer
-Vu® Pro v8.5 ©2023 Carrier.
Installation Guide All rights reserved.
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Setting up i-Vu® Pro client devices and web browsers

On Chrome for Android
NOTE The following settings are based on Android v11 - options may vary with versions.
Web browser settings In the Chrome menu...
Turn off desktop mode Uncheck Request desktop site
Disable pop-up blocker Settings > Advanced > Site Settings > uncheck Block
pop-ups
Enable JavaScript Settings > Advanced > Site Settings > check Enable JavaScript
Enable Cookies Settings > Advanced > Site Settings > check Accept Cookies
To... In the Chrome menu...
Clear browser cache Settings > Basics > Privacy > CLEAR BROWSING DATA

To set up and use Safari

NOTES

e The instructions below are for Safari® v11. Other versions may vary slightly. See your web browser's Help if
necessary.

e  We recommend that you do not run Safari in full-screen mode. If you do, i-Vu® Pro pop-ups will open full-
screen, covering the main application window.

On an Apple® computer (Mac®)

Web browser settings To set in Safari...

Disable pop-up blocker Preferences > Security > uncheck Block pop-up windows

Enable JavaScript Preferences > Security > check Enable JavaScript

Enable Plug-ins Preferences > Security > check Enable plug-ins

Prevent pop-ups from opening in a Preferences > Tabs > uncheck Command-click opens a link in a new
new browser tab tab

Prevent Safari from automatically Preferences > General > uncheck Open "safe" files after downloading

opening zip files exported from the i-
Vu® Pro application

To... Do the following...
Clear browser cache History > Clear History
Have 2 different users logged in to Start a new web browser session. Select Safari > Private Browsing >
the i-Vu® Pro system on the same File > New window
computer
-Vu® Pro v8.5 ©2023 Carrier.
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-Vu® Pro v8.5

Setting up i-Vu® Pro client devices and web browsers

On an Apple® iPad

Web browser settings To set on the iPad...

Disable pop-up blocker Settings> Safari > set Block pop-ups to Off

Enable JavaScript Settings > Safari > set JavaScript to On

797 TIP Re-enable popup blocking on your device when not using our software

To... Do the following...

Clear browser cache Settings > Safari > Clear History

\\"

¥ TIP Re-enable popup blocking on your device when not using our software

On an Apple® i0S 12.2
Web browser settings To set on the iPhone...

Enable JavaScript Settings > Safari > Advanced

Installation Guide
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i-Vu® Pro v8.5 client, server, operating system, and database requirements

i-Vu® Pro v8.5 client, server, operating system, and database
requirements

iVu® Pro client requirements

The i-Vu® Pro system can be viewed on the following client devices and web browsers.

Computers

The client computer should have at least:

e  Quad core processor

e 4 GBRAM

e  Communications link of 200 Mbps or higher

The i-Vu® Pro application will work with slower computers and slower links, but the results may not be
satisfactory.

A computer with this Supports these web browsers...
operating system...

Windows® Google™ Chrome™ v84.0 or later 1
Microsoft® Edge v84 or later
Mozilla® Firefox® v79.0 or later

Mac® 0S X® Safari® vi11 or later 2

(Apple® Mac only)
Google Chrome v84.0 or later

Mozilla Firefox v79.0 or later
1 Best performance
2 Best performance unless browser is running on a Mac® Mini or a MacBook:

A WARNING If machine is running Mountain Lion 10.8x with an integrated Intel HD 400 graphics card,
it will experience display issues. Use one of these workarounds for better performance:

e If an additional NVIDIA graphics card is available, manually switch the graphic card setting in MAC® 0S
X® to use that card.
e If not, use Google™ Chrome™ v84.0 or later.

-Vu® Pro v8.5 ©2023 Carrier.
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i-Vu® Pro v8.5 client, server, operating system, and database requirements

Mobile devices

Device type Platform support
Smart phone Android™, i0S
Tablet Android™, i0S, Surface™

NOTE Some functionality may be limited by the capability of the mobile device and operating system.

IFVu® Pro server requirements

The recommended minimum for an i-Vu® Pro server:

. Dual core processor

e 4 GBRAM

e 30 Gigabyte hard drive

e  Communications link of 10 Mbps or higher

e  B4-bit server (See Upgrading from a 32-bit server to a 64-bit server (page 19).)

The i-Vu® Pro application will work with slower computers and slower links, but the results may not be
satisfactory.

A i-Vu® Pro server must be 64-bit. Memory requirements vary, based on the:

e number of pieces of equipment and device instances
e size of the control programs
e number of simultaneous users logged in to the i-Vu® Pro application

-Vu® Pro v8.5 ©2023 Carrier.
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i-Vu® Pro v8.5 client, server, operating system, and database requirements

For this With this number of... The computer should have at least a dual core processor and...
size
system...
Instances of Physical Passmark | Passmark | RAM JVM Memory | Disk Mark#
equipment Pointsand @ Total Single- Minimum/ Minimum/
and devices 1 Display Score 2 threaded | Recom- Recom-
Objects Score mended mended
Small 0-250 0-1000 2000 800 4 / 8GB 4 /4GB 3000
Medium 250 - 1000 1000 - 3000 1000 8/ 12GB 4 / 8GB 5000
5000
Large 1000 - 5000 - 5000 1400 12 / 16GB 8/ 12GB 15000
10,000 50,000
Huge more than more than 6500 1600 16 /24GB3 16/ 24GB 30000
10,000 50,000

1 Total number of control programs and controllers.
2 For more information, see www.CPUbenchmark.net.

3 For a huge system with minimal user activity, the average piece of equipment or instance device requires approximately
300KB of server RAM. Contact Technical Support for server sizing recommendations.

4 SATA SSDs are recommended as baseline performance for i-Vu® Pro on all systems. Large systems benefit from the
faster PCle interface SSDs on both the i-Vu® Pro and database servers. Passmark’s Disk Rating “Disk Mark” can be
useful in gauging disk performance when designing new servers.

Rotational Drives: 900-1500
SATA SSDs: 3000-5000
PCle SSDs: 10000-30000

Operating system and database requirements

To determine which operating system and database management system (DBMS) to use, consider:

e  Operating systems and DBMS's already in use in your customer’s organization

e  Project size and trending requirements. See "Trend archival requirements" below.
e  Project budget

e  Your skill with the operating system and DBMS

The i-Vu® Pro v8.5 system use of database resources may require a moderate increase in the number of allowed
connections if your database management system is set to the default value for the maximum allowed
connections.

Supported operating systems and database management systems

A i-Vu® Pro v8.5 or later system is supported on the following 64-bit operating systems. The table below shows
which operating systems can be used with each DBMS.

e  Windows® 10 Professional and Enterprise
e  Windows® 8.1 Professional and Enterprise
e  Windows® Server 2019

e  Windows® Server 2016

e  Windows® Server 2012 R2

-Vu® Pro v8.5 ©2023 Carrier.
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Database

SQL Server®
Express 2019,
2017, 2016

SQL Server®

2019, 2017,
2016

MySQL 8.0
PostgreSQL 12

and 13
Apache Derby

-Vu® Pro v8.5
Installation Guide

Operating
systems
supported

Windows®

Windows®

Windows®

Windows®

Windows®

Speed

Fast

Fast

Fast

Fast

Slow

i-Vu® Pro v8.5 client, server, operating system, and database requirements

Supports
multiple
servers

No

Yes

Yes

Yes

No

17

Dynamic
defrag-
mentation

Yes

Yes

No

Yes

No

Database
replication

Yes

Yes

Yes

Yes

Yes

Notes

Database cannot exceed 10 GB.

SQL Server® 2016 Enterprise,
Business Intelligence, and
Standard editions can be used -
only SP2 supported.

This open source database is free
under the GNU Public License.

This open source database is free
under the BSD Public License.

The i-Vu® Pro Installs for
Windows include all the files
needed to use an Apache
Derby database.

Only one application can
access the database at one
time. Example: ViewBuilder
cannot access the database if
SiteBuilder is already running.

Do not use Derby if total
historical trend capacity will
exceed 2 GB.

Audit database cannot
contain an entry of more than
32,700 characters; compact
the database before migrating
to Derby.

©2023 Carrier.
All rights reserved.
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Trend archival requirements

Trend archival (historical trending) requirements are the most significant factors in database selection. Alarms are
not usually an issue unless large quantities (10,000+) will be kept for online access.

For each archived trend sample, the i-Vu® Pro application stores approximately 30 bytes of data. Disk space
requirements per trended point are:

Sample interval for 1 week for 1 month for 3 months for 1 year
1 minute 300 kB 1.5 MB 5 MB 18 MB

5 minutes 60 kB 250 kB 1MB 4 MB

15 minutes 21 kB 85 kB 250 kB 1 MB

1 hour 5kB 20 kB 60 kB 240 kB

For example, a system with 2000 points archiving at 15 minute intervals for one year will require as much as 5.6
GB (2000 x 2.8 MB) disk space.

NOTES

e To limit disk space required for trend storage, archive trend data only for important system points.

e If your archival requirements are 5 GB or greater, you should consider using a separate server for the trend
database.

-Vu® Pro v8.5 ©2023 Carrier.
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Upgrading from a 32-bit server to a 64-bit server

i-Vu® Pro v8.5 will not run on a 32-bit server. To upgrade, first install i-Vu® Pro v8.5 on a 64-bit server. The
method for upgrading your system depends on the database type or size.

Derby database

1  Copy your existing system's i-Vu Prox.x\webroot\<system name> folder.

2  Paste the copied folder under a folder of your choice on the 64-bit server. For example, i-Vu
Prox.x\programdata\systems.
Open the system in SiteBuilder.

4  Select File > Upgrade > i-Vu Pro system and follow the prompts to upgrade the system.

All Non-Derby databases

1
2

Open your existing system in SiteBuilder.

Select File > Manage Database > Migrate/Replicate, and then select Replicate database to create a copy of
the system in a Derby database.

Copy the replicate system's i-Vu Prox.x\webroot\<system name> folder.

Paste the copied folder under a folder of your choice on the 64-bit server. For example, iVu
Prox.x\programdata\systems.

Open the system in SiteBuilder.
Select File > Upgrade > i-Vu Pro system and follow the prompts to upgrade the system.

Select File > Manage Database > Migrate/Replicate, and then select Migrate to a different database type to
change the system back to the original database type.

Very large databases

If you are moving a very large system to a 64-bit server, contact Carrier Control Systems Support for assistance.

-Vu® Pro v8.5
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Installing and setting up databases

The system folder can be saved in any location. The default location is \i-Vu_Pro_x.x\programdata\systems\. The
actual databases may be located in another location if you are using MySQL, MS SQL Server, or PostgreSQL. See
any of the following topics for more information:

PostgreSQL on Windows (page 20)
MySQL on Windows (page 22)
SQL Server and SQL Server Express on Windows (page 25)

PostgreSQL 13.x on Windows for the I-Vu® Pro v8.5 system

To set up the databases for a new i-Vu® Pro system, complete all 4 steps below.

Step 1: Install PostgreSQL on Windows

a Download the appropriate PostgreSQL installer from the PostgreSQL downloads page.

Save postgresql-<latest version>-windows.exe to your hard drive.

c If you saved the postgresql-<latest version>-windows.exe file to a machine other than the PostgreSQL
server, move the file to the PostgreSQL server.
d On the PostgreSQL server, run the postgresql-<latest version>-windows.exe file to start the PostgreSQL
install.
e Accept the defaults until you are asked for a password.
f Enter a password for the service account, then retype the password.
g Enter the port number you wish to use or leave it at the default port of 5432.
h Continue the installation process, accepting all defaults until you reach the Finish screen; then clear the
checkbox regarding Stack Builder.
i Click Finish.
-Vu® Pro v8.5 ©2023 Carrier.
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Step 2:

a
b

(9]

Installing and setting up databases

Create database user in PostgreSQL

Go to Start > All Programs > PostgreSQL 12.x > pgAdmin 4.

In the Browser pane, expand Servers and then double-click PostgreSQL 12.

Type the service account password that you created in step 1f above.

In the Browser pane, right-click Login Roles/Group Roles, then select Create > Login/Group Role.

On the General tab, in the Name field, type a name (all lowercase) for the user, such as xxx_user; this
will be your Database User Login in SiteBuilder.

On the Definition tab, in the Password field, type a password for the user; this will be your Database User
Password in SiteBuilder.

On the Privileges tab, enable Can Login and Create Databases.

NOTE Verify that Inherit rights from the parent is enabled (default).

Step 3:

a

Step 4:

o o

(9]

9
h

Click Save.

Create database instances in PostgreSQL
In the Browser pane, right-click on Databases, then select Create Database.

In the Database field, type a name for the database such as xxx_main; this will be your Database
Connect String Instance in SiteBuilder. Record the name below.

In the Owner field, select the name that was created in Step 2e.

On the Security tab, click the Privileges plus sign. In the Grantee column, select the name that was
created in Step 2e.

Click the blank space under the Privileges column and click the All checkbox.
Click Save.

Repeat steps a-f to create the Alarms, Trends, and Audit Log databases.
NOTE Database names are case-sensitive and must be 18 characters or less in length.

Close pgAdmin 4.

Set up the PostgreSQL databases in SiteBuilder

In SiteBuilder, select File > New.

Type a name for the system.

Select PostgreSQL from the Database Type drop-down list.

Select Make this the default system for i-Vu Pro if you want the i-Vu® Pro application to automatically
run this system each time it starts.

Complete the remaining fields, then click Next.

Enter the Database Connect String information for each i-Vu® Pro database and the Database User
information. See table below.

Select your system language.

Click Finish.

NOTE To change Database Connect Strings for an existing system, select Modify database connection
parameters in the File > Open dialog box and then click Next.

-Vu® Pro v8.5
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Main Database Connect String:

Server Type one of the following:

. localhost if the i-Vu® Pro application and the database are on the same
machine

e The name or IP address of the machine that the database is on if different than the
i-Vu® Pro application

Port Do one of the following:
e  Type the default port of 5432.

e  Type the port number that the database uses for communication that you set up in
step 1g if different than the database default.

Instance The names that you gave the i-Vu® Pro databases in step 3b.

Database User:
Login The user name that you entered in step 2e.

Password The password that you entered in step 2f.

MySQL 8.0 on Windows for an i-Vu® Pro v8.5 system

To set up the databases for a new i-Vu® Pro system, complete the following steps:

Step 1: Install MySQL

a Download the appropriate MySQL Community Server 8.0 > MySQL Installer MSI from the MySQL
Downloads page.

b Save mysql-<installer-community-latest version->msi to your hard drive.

JRENS

¥ TIP I you saved the file to a machine other than the MySQL server, move the file to the MySQL server.

c On the MySQL server, run mysql-<installer-community-latest version->-.msi to start the MySQL install.
d In the Choosing a Setup Type window, select Custom and click Next.
e Select the following in the Available Products column and then click on the arrow to move them to the

Product/Features column:

MySQL Server 8.0 x86 or -x64 (use x86 for 32 bit operating systems)

e}

o MySQL Workbench
o  Connector/J (latest version)
f Click Next.
g If there are entries in the Check Requirements window, click Execute and follow the Install Wizard for

each application, until all of them are completed.
NOTE When all applications are installed, the Execute button disappears.
h Click Next.

i In the Installation window, verify that the 3 products from step f are listed and then click Execute.
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j When the Status column shows all items as Complete, click Next, then click Next again.
k Select Server Computer from the Config Type drop-down list.

I If the site requires a specific TCP port, enter this port number in the Port Number field.

m Accept defaults for the remaining configurations, then click Next.

n On the Authentication Method page choose either Strong Password authentication (recommended) or
Legacy Password authentication.

o} Click Next. Then type in a root password, confirm it, and click Next.

p Accept the Windows Service default settings.

NOTE If the site requires that the MySQL service run under a particular user account, select Custom User
and enter in the user name and password supplied by the IT department.
The account that the MySQL service runs with can be changed later in the Windows Service Control Manager.

q Click Next and then click Execute.
r Click Finish.
S In the product Configuration window, click Next, and then click Finish to complete the MySQL installation

and to launch MySQL Workbench.

Step 2: Create i-Vu® Pro database instances

a Click + next to MySQL Connections and enter a connection name, such as the name of your server.
b Click Test Connection and OK.
c In the list of connections on the Workbench, double-click your new connection to open.
d Click + on the cylindrical database icon to add a new Schema (database).
e In the Name field, type a name for the database such as xxxmain, which will be your Database Connect
String Instance in SiteBuilder. Record the name below.
f Click Apply, click Apply again, then click Finish.
o] Repeat steps f-h to create the Alarms, Trends, and Audit Log databases.
NOTE Database names are case-sensitive and must be 18 characters or less in length.
h Close all Schema Creation tabs.

Step 3: Create a database user

a Click Users and Privileges.
b At the bottom of the window, click Add Account.
c On the Login tab, type a Login Name and Password.
NOTE These will be your Database User Login and Database Password in SiteBuilder.
d Click Apply.
e On the Schema Privileges tab, select the user you created.
f Select the Add Entry button.
NOTE You may have to resize the window to see the button at the top-right.
-Vu® Pro v8.5 ©2023 Carrier.
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Step 4:

a

Under Schema, select Selected Schema and then select the Main database schema you added in step
2e.

Click OK.

Select the row you added in the Users and Privileges table, then click Select "ALL" under the privilege
check boxes.

Click Apply.

Repeat steps g through j to give the database user privileges to the Alarms, Trends, and Audit Log
databases.

Close MySQL Workbench.

Install a MySQL database driver
Locate the mysqgl-connector-java-8.x.xx.jar file in the Program (x86)\MySQL\Connector J 8.x folder.

NOTE This is the default location for the JAVA connector file. Search your designated location if you changed
the default.

Step 5:

o 9

(9]

Copy the mysql-connector-java-8.x.xx.jar to thei-Vu Prox.x\database-drivers folder under the i-Vu® Pro
install folder.

Set up the MySQL databases in SiteBuilder

In SiteBuilder, select File > New.

Type a name for the system.

Select MySQL from the Database Type drop-down list.

Select Make this the default system for i-Vu Pro if you want the i-Vu® Pro application to automatically
run this system each time it starts.

Complete the remaining fields, then click Next.

Enter the Database Connect String information and the Database User information for each i-Vu® Pro
database. See table below.

Click Next.
Select your system language.

Click Finish.

NOTE To change Database Connect Strings for an existing system, select Modify database connection
parameters in the File > Open dialog box and then click Next.

-Vu® Pro v8.5
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Database Connect Strings:

Server Type one of the following:
. localhost if the i-Vu® Pro application and the database are on the same machine

e The name or IP address of the machine that the database is on if different than the i-
Vu® Pro application

Port Type 3306.

Instance The name that you gave the i-Vu® Pro database in step 2e.

Database User:
Login The user name that you entered in step 3c.

Password The password that you entered in step 3c.

Step 6: Disable MySQL automatic updates

1 Open the MySQL Installer - Community under Start > All Programs > MySQL.
2  Click the wrench icon at the top right.

3 Uncheck Check for updates to the MySQL Installer product catalog.

Click Accept then exit the Installer - Community window.

SQL Server 2016, 2017, and 2019 on a Windows for the i-Vu® Pro
system

SQL Server versions currently supported are 2016, 2017, and 2019.

1 If you do not already have MS SQL installed, install one of the supported versions and any applicable SQL
service packs. For instructions on how to install any version of SQL Server, go to
http://msdn.microsoft.com/en-us/library/default.aspx and, in the Search window, type Install <your SQL
Version >. Select Authentication Mode - Mixed Mode during setup and enable TCP/IP on port 1433.

NOTE As you install MS SQL Server, you must select certain options to use with i-Vu® Pro. For all other
options, you may keep the defaults or select your own values. Select the following:

o  SQL Server Database Services

o  Workstation components, Books Online, and development tools

o  Authentication Mode - Mixed Mode (Windows Authentication and SQL Server Authentication)
NOTE The password you specify grants extensive privileges.

o  Service Account for database engine - NT Authority\System

Enable TCP/IP on port 1433

e}

-Vu® Pro v8.5 ©2023 Carrier.
Installation Guide All rights reserved.
25



Installing and setting up databases

2 If already installed, you must have selected Authentication Mode - Mixed Mode during setup and have TCP/IP
enabled on port 1433.

If you are the database administrator and TCP/IP is not enabled on port 1433, or you are unsure of the port,
follow the procedure below, 'To enable TCP/IP on port 1433' and then proceed to Step 1.

Install the program and follow the instructions below.

To enable TCP/IP on port 1433

a Click Start > All Programs > Microsoft SQL Server <your SQL version> > Configuration Tools > SQL
Server Configuration Manager.

b Expand the SQL Server Network Configuration.

c Select Protocols for <server instance> where <server instance> is the SQL Server running the i-Vu® Pro
application.

d In the next window, under Protocol Name, double-click TCP/IP.

e On the Protocol tab, under General, next to Enabled, select Yes.

f On the IP Address tab, scroll down to the IPAIl section.

Clear any values from the TCP Dynamics Port field.

In the TCP Port field, enter 1433, then click OK.

o «Q

Close the SQL Server Configuration Manager.

j Restart the SQL Server Service.

Step 1: Connect to the database engine for i-Vu® Pro SQL Server
a Determine if Microsoft SQL is running on the i-Vu® Pro server:

o  If Microsoft SQL is running on the i-Vu® Pro server, select Start > Programs > Microsoft SQL Server >
SQL Server <your SQL version> > Management Studio.

o  If Microsoft SQL is running on a different computer, download the SQL Management Studio and install it
on the i-Vu® Pro server.

b In the Connect to Server dialog box, select or enter the information using the table below.

c Click Connect.

To set up the databases for a new i-Vu® Pro system, complete steps 2, 3, and 4 below.

Field Notes

Server type Database engine.

Server Name The address or name of the computer running the SQL Server service. Get from your

database administrator.

Authentication Get from your database administrator.

Username Get from your database administrator.

Password Get from your database administrator.
-Vu® Pro v8.5 ©2023 Carrier.
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Step 2: Create a database instance

a In the Object Explorer pane, right-click Databases, then select New Database.

o

In the Database name field, type a name such as xxx_main; this will be your Main Database Connect
String Instance in SiteBuilder. Record the name below.

Under Select a Page, select the Options page.
From the Recovery model drop-down list, select Simple.
Click OK.

- O Qa O

Repeat steps a-e to create the Alarms, Trends, and Audit Log databases.

NOTE Database names are case-sensitive and must be 18 characters or less in length.

Step 3: Create a database user
a In the Object Explorer pane, click the plus sign to the left of Security.

Right-click Logins, then select New Login.

c In the Login name field, type in a login name for i-Vu® Pro, such as xxx_User; this will be your Database
User Login in SiteBuilder.

d Select SQL Server authentication.

e In the Password and Confirm password fields, type a password; this will be your Database User

Password in SiteBuilder.
f Clear the following checkboxes:
o  Enforce password policy
o Enforce password expiration
o  User must change password at next login
In the Default database drop-down list, select master.
In the Select a page pane, select the User Mapping.

i Under Users mapped to this login, select the Map checkbox next to a database name you created in Step
2.

i Under Database role membership for: section, select the following checkboxes:
o db_owner
o  public

k Click OK.

| Repeat steps i-k for each remaining database.

m Close SQL Server Management Studio.
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Step 4: Set up the SQL Server databases in SiteBuilder

a In SiteBuilder, select File > New.
b Type a name for the system.
c Select SQL Server from the Database Type drop-down list.
d Select Make this the default system for i-Vu® Pro if you want the i-Vu® Pro application to automatically
run this system each time it starts.
e Complete the remaining fields, then click Next.
f Enter the Connect String information for each i-Vu® Pro database. See below.
F - — —— ]
@ Open Database g e —— ﬁ
.
Main Database Connect String:
Server Port Instance
bs367307] mai
Alarms Database Connect String:
Server Port Instance
ag3e73Ing alarms
Trends Database Connect String:
Server Port Instance
ag367307 trends
Audit Log Database Connect String:
Server Port Instance
ag3a73Ing audit
Database User:
Login: Password:
MName (II117]
Help Previous I l Mext I I Cancel
o] Click Finish.

NOTE To change Database Connect Strings for an existing system, select Modify database connection

parameters in the File > Open dialog box and then click Next.
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Database Connect Strings:

Server Type one of the following:

. localhost if the i-Vu® Pro application and the database are on the same machine

e The name or IP address of the machine that the database is on if different than the i-
Vu® Pro application

Port Do one of the following:
e  Type the default port of 1433.

e Type the port number that the database uses for communication if different than the
database default.

Instance The name that you gave the i-Vu® Pro database in step 2b.

NOTE If the 4 i-Vu® Pro databases do not reside under the default instance of SQL, then the
instance name must be specified under the Instance column. The syntax for specifying the
instance name of the SQL server is <Database>; instance=<instance name>. For
example, if the SQL instance name is hvac, the syntax for the Instance field for the main
database called i-Vu Pro_Main would be i-Vu Pro_ Main;instance=hvac.

Database User:

Login The username that you entered in step 3c.

Password The password that you entered in step 3e.

-Vu® Pro v8.5
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Registering and downloading your i-Vu® Pro license

To register your software, you must obtain a license from Carrier and then apply it in the i-Vu® Pro interface.

1

Log in to the Carrier Community Portal website.
NOTES

o  Only Carrier authorized personnel may access the Community Portal website. To set up your account,
please contact Control Systems Support with the following information: name, phone number, e-mail
address, office address, and your password of choice.

o If you are an end-user or contractor, please contact your local Carrier office to obtain your license.

Click Order Management > Licenses & Subscriptions > Software Licenses.

Expand the applicable section under Available Licenses and select the site/project to register it.
NOTE All your Sites Names/Project Names are listed.

In License Details, fill in the Owner and Site information and click Register License.

Check | agree to the terms of use.

Click Download License and then save the .properties file to a convenient location to use when installing the
i-Vu® Pro application.

To apply the license to the i-Vu® Pro application

During the i-Vu® Pro installation, in the Setup Wizard, on the Product License screen, check Browse to a different
license, and select the site license you obtained.

NOTES

o  Selecting the default license results in a prompt appearing every few minutes in the i-Vu® Pro interface
to remind you to apply your site license.

o Do not edit any part of this registered license file. Editing a license file invalidates the license.

o  Store the license in a safe location.

To apply the site license after the installation:

1 Inthe i-Vu® Pro interface, select System Options > License Administration.

2 Browse to the license file.

3 Click Apply.

4 Restart i-Vu® Pro Server using the rebootserver manual command.
i-Vu® Pro v8.5 ©2023 Carrier.
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Installing the i-Vu® Pro application

PREREQUISITES

SiteBuilder v8.5 no longer supports Access, MSDE, or SQL Server Express database types.
Installer must have Windows Administrator-level user rights.
Have the site's i-Vu® Pro license saved on the computer.

USB Link driver - If your computer does not already have the CP210x driver for the USB Link, a prompt to
install it will appear. You must install it before you connect the USB Link to your computer. Please refer to the
Silicon Labs website and search "CP210x USB to UART Bridge VCP Drivers" for the most current device
drivers.

For more technical details, see i-Vu® Pro v8.5 client, server, operating system, and database requirements
(page 14).

Step 1: Install the i-Vu® Pro application

1
2
3

4

Insert the Installation USB drive into your computer and click Install i-Vu Pro and the Setup Wizard starts.
In the Setup Wizard, click Next, check | accept the agreement and click Next again.
On the Product License screen, check Browse to a different license, and select the site license.

NOTE You can select the default license, but it causes a prompt to appear every few minutes in the i-Vu®
interface to remind you to apply your site license.

Continue to follow the Setup Wizard.

NOTE If running on Windows Server 2008 R2, verify that there are no Failed to Update errors in <logs >
launcher.txt>.

Step 2: Install the service

NOTE We highly recommend you configure the i-Vu® Pro server to Run as a Service to ensure the i-Vu® Pro server
starts after a computer reboot.

1 Click the Windows Start button, then select All Programs > Accessories.
2 Right-click Command Prompt and select Run as Administrator.
3 Type: cd <path to the i-Vu install directory>
For example, cd c:\i-Vu Pro v8.5.
4 Press Enter.
Type:"i-Vu Pro Service.exe" toinstall.
6  Press Enter.
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Step 3: Launch i-Vu® Pro service as Administrator

By default, the i-Vu® Pro Server Service runs under the built-in Local System account that has extensive system
privileges. If the i-Vu® Pro application runs on its own computer or virtual machine, then running the i-Vu® Pro
Service under the Local System is acceptable, unless local site policies restrict the Local System account from
being used for running services. In this case, you can run the i-Vu® Pro application under a user account with
Administrator privileges, as described below.

NOTES

e If you need the Print Alarm Action, the i-Vu® Pro Service must run under an Installer account, not the Local
System account.

. If using an Administrator account, ensure that the password for this account does not expire.

1 Click the Windows Start button, then select Control Panel.

797 TIP If you do not see this option on your Control Panel, click View by: and select Small icons.
Select Administrative Tools and double-click Services.
Double-click i-Vu Pro Service v8.5.

On the Log On tab, select This Account.

a b~ W N

Enter the password for a user who is a member of the Administrator Group on that computer.

To uninstall the service
1 Click the Windows Start button, then select All Programs > Accessories.
2 Rightclick Command Prompt and select Run as Administrator.

3 Type: cd <path to the i-Vu install directory>
For example, cd c:\i-Vu Pro v8.5.

4 Press Enter.
Type: "i-Vu Pro Service.exe"-remove.

6  Press Enter.
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Using the i-Vu® Pro v8.5 application

Use SiteBuilder to begin setting up your system

Before starting the i-Vu® Pro application for the first time, you must use SiteBuilder to create a database that the
i-Vu Pro Server uses to communicate with the system. Follow the steps to Create a new SiteBuilder database. The
i-Vu® Pro application uses this information to scan your system and find the components.

PREREQUISITE For any database type except Apache Derby, you must install and set up the database application
before creating your system database. An Apache Derby database is installed with your i-Vu® Pro system. As of
v6.5, SiteBuilder no longer supports Access and MSDE database types. As of v7.0, SiteBuilder no longer supports
SQL Server Express.

Follow the procedures below to create your system database in SiteBuilder.

To create a new SiteBuilder database

After you create a database in SiteBuilder, you should use the i-Vu® Pro application to automatically discover
Open, XT, or TruVu™ controllers and/or a system with a single CCN Gateway. However, you must use SiteBuilder
to build a system with multiple CCN Gateways.

Click File > New.
Enter appropriate values in each of the New Database fields. See table below.

Click Next.

A W N P

Do one of the following:

o Ifyou selected a MySQL, PostgreSQL, or SQL Server® Database Type, enter the Database Connect
Strings, Login and Database User info. See table below. Then click Next.

o If you selected an Apache Derby, go to step 5.
Make language selections. See table below.
Click Next.

Click File > Close.

o N o O

If you have multiple CCN Gateways, use SiteBuilder to build a Network tree for them. See To build a Network
tree for a CCN system (page 35).

9  For BACnet, or single CCN Gateway systems, use the i-Vu® Pro interface to populate your database. You do

not need to set up the information in SiteBuilder.
a) Launch the i-Vu Pro Server. Wait for it to finish opening the database.

)

b) Browse to http://localhost to open the i-Vu® Pro interface.
)
)

c) Use the login and password you set up in SiteBuilder.

d) Find your devices and networks and upload the files. See i-Vu® Pro Help for details.
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Field

System Name

System Parent Directory

System Directory Name

Administrator

Login Name, Password,
and

Confirm Password

Database Type

Make this the default
system for iVu

Starting Base Network
Number

Starting Base Device
Instance Number

Server BACnet
Device Instance

Notes

Enter the name for this system that will be displayed at the top of the i-Vu® Pro
navigation tree.

You can specify a parent directory folder. The default is C:\i-
Vu_Pro_x.x\programdata\systems.

The name of the folder within the system parent directory that contains all the system
files.

Ex: FVu_Pro_x.x\programdata\systems\<system_directory_name>

This name is automatically generated from the System Name, but it can be edited.
The System Directory Name must have:

* less than 80 characters

* only alphanumeric characters, dashes, and underscores

* no spaces

Type a Login Name and Password (8-character minimum) for the Administrator
operator.

& CAUTION To increase the security of your system, do not use "Administrator" as
the Login Name.

NOTE You can change the password requirements in the i-Vu® Pro interface. See
"Advanced password policy" in i-Vu® Pro Help.

Select the type of database your system will use.

NOTE If you select Derby, SiteBuilder automatically creates the necessary files and
folder structures under the iVu_Pro_x.x folder. Do not move or rename system files
or folders.

Select this box to open this system when you start the i-Vu® Pro application.

SiteBuilder automatically assigns sequential numbers to BACnet networks and
devices as you add them to the database. Choose starting numbers that will generate
unique network and device instance numbers across all systems that this system will
communicate with.

Must be unique to the BACnet network. Unique Server Device IDs are important if you
are running multiple copies of the i-Vu® Pro application on the same network.

Languages Select all languages that you want your system to support.
System Select the language that you want to use for:
e  The default language for new operators
e Alarms sent to the database
e  State text and object names downloaded to the field
e The default language for the i-Vu® Pro login page.
NOTE You can select a different language on the login page.
All other information is displayed in the operator's language.
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For MySQL, PostgreSQL, or SQL Server® Database Types

Database Connect Strings:

Server Type one of the following:
. localhost if the i-Vu® Pro application and the database are on the same
machine
e The name or IP address of the machine that the database is on if different than
the i-Vu® Pro application
Port Do one of the following:
e  Type the appropriate default port number from the list below.

e  Type the port number that the database uses for communication if different than
the database default.

Default ports are:

MySQL 3306
PostgreSQL 5432
SQL Server 1433
Instance The name that you gave the i-Vu® Pro database in the database application.
Database User:
Login The user login that you set up in the database application.
Password The password that you set up in the database application.

NOTE To change Database Connect Strings for an existing system, select the Modify database connection
parameters in the File > Open dialog box, then click Next.

To build a Network tree for a CCN system

See details on the following in SiteBuilder Help and i-Vu® Pro Help.

If your CCN system has... You must...
A single CCN Gateway Use the i-Vu® Pro application to find and download the Gateway and system
An iVu® Integrator Add it in SiteBuilder, even if it is the only CCN Gateway. See "To add an i-Vu®

Integrator" in SiteBuilder Help.

Multiple CCN Gateways without 1 In the SiteBuilder Network tree, add one site with one BACnet/IP network

a NAT router for each Gateway.
2 Inthe i-Vu® Pro interface, discover all the Gateways, Bridges, and
controllers.
NOTES

e You must have the Multi-CCN license for this feature to work.
Supports up to 50 CCN Gateways in one system

e  Every Gateway must be Bus O.

e  Every BACnet/IP Network Number must be the same.
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If your CCN system has... You must...

Multiple CCN Gateways with a 1 In SiteBuilder, configure the NAT information.

NAT router ) .
2 Inthe Network tree, add one site with one BACnet/IP network per

Gateway.
3 Add one CCN Gateway and all its Bridges to each site you set up.

4 Inthe i-Vu® Pro application, discover the rest of your controllers under the
Bridges.

NOTES

You must have the Multi-CCN license for this feature to work.
Supports up to 50 CCN Gateways in one system

Every Gateway must be Bus O.

Every BACnet/IP Network Number must be the same.

CCN Gateways and Bridges can be any of the following:
e  i-Vu® Link

e i-Vu® CCN Router

e i-Vu® Integrator

e  Carrier® ChillerVu™

NOTE For your i-Vu® Control System, use the i-Vu® Pro application to find your i-Vu® Open, XT, and TruVu™
routers and controllers. You do not need to set up the information in SiteBuilder.

Options for running the i-Vu® Pro system

Running i-Vu Pro Server without connecting to controllers

To verify links between graphics and to set up properties, schedules, alarms, and trends before you connect to the
network, run iVu Pro Design Server instead of i-Vu Pro Server. Then view the i-Vu® Pro interface in a web browser.

NOTE Question marks indicate correct microblock paths. Missing data indicates errors.

Switching i-Vu Pro Server to a different system

Design engineers working on multiple projects can switch systems in the i-Vu Pro Server application.
1 Inthei-Vu Pro Server application, select Server > Change Active System.

2  Select a different system and mode.

3 Click Select.
-Vu® Pro v8.5 ©2023 Carrier.
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Running i-Vu Pro Server as a Windows® service

For Windows 8.1, 10, 2012R2, 2016, 2019, and 2020
Run i-Vu Pro Server as a Windows service if you want i-Vu Pro Server to automatically start up when the server

computer is restarted.

NOTE If your i-Vu® Pro system uses a database other than Derby and the database is located on the same
computer as i-Vu Pro Server, you must set up Windows to delay starting i-Vu Pro Server until the database service
has started. See "How to delay loading of specific services" (http;//support.microsoft.com/kb/193888) on the
Microsoft® website.

To install i-Vu® Pro Server service

NOTE If you are not sure if the service was previously installed, see To determine if i-Vu Pro Server service is

installed (page 39).

1 Inthe Windows Start menu, select All Programs > Accessories.

2 Right-click Command Prompt, then select Run as administrator.

3 Select Yes in the User Account Control message.

4 Inthe Command Prompt window, type: cd <path to the i-Vu Pro install directory>

For example, type: cd c:\i-Vu Pro x.x
replacing x.x with your current version number.

5  Press Enter.
6 Type: "i-Vu Pro Service.exe"

7  Press Enter.

To start i-Vu® Pro Server as a Windows service

1 Inthe Windows Start menu, select Control Panel.
2 Select Administrative Tools, then double-click Services.
3 Inthe Services (Local) list, double-click iVu Pro Service X.X.
4 In the Startup type drop-down list, select Automatic.
5 Onthe Log On tab, do one of the following:
o  Use the defaulted Local System account.

o  Select This account, then browse to select a user who is a member of the Administrator Group on that
computer.
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7
8

Optional: If you selected Local System account in step 5 and you want to be able to access i-Vu Pro Server
on the server computer's desktop, check Allow service to interact with desktop.

NOTES

o If you do not check this field, the computer screen will give no indication that i-Vu Pro Server is running;
you must view the computer's Services page to see if it is running.

o  This checkbox applies only to a user logged in on the server. A Windows Remote Desktop user cannot
access i-Vu Pro Server running as a service.

o If you check this field, you cannot use the instructions below to set up printing to a network printer. Ask
your Network Administrator to set up Local System account to use a network printer.

o If you check this field and the i-Vu® Pro application is to run email alarm actions, ask your Network
Administrator to set up Local System account to send emails.

On the General tab, click Start.
Click OK.

NOTE If i-Vu Pro Server does not start after you click Start, you may have a Windows permissions problem.
Follow the procedure below in To set up the i-Vu Pro service for network printing (page 38) to set up the Windows
user name and password.

To set up the service for network printing

If i-Vu Pro Server runs as a service on a computer that is using a network printer, you must set up the Windows
user name and password for the service. The Print alarm action requires this setup to be able to print.

1

2
3
4
5

In the Windows Start menu, select Control Panel.

Select Administrative Tools > Services.

Double-click iVu Pro Service x.x.

On the Log On tab, select This account.

Browse to the computer's domain, then select the user that the service will log in as.
NOTE Contact your network administrator if you need help determining the domain.

Type the user's password in the Password and Confirm password fields.

To stop or uninstall i-Vu® Pro Server service

To stop i-Vu Pro Server service

1 Inthe Windows Start menu, select Control Panel.

2  Select Administrative Tools, then double-click Services.

3 Inthe Services (Local) list, double-click iVu Pro Service X.X (where x.x is the i-Vu Pro version number.

4 In the i-Vu Pro Service x.x Properties dialog box, click Stop on the General tab.

5 Click OK.
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To uninstall i-Vu Pro Server service
1 Inthe Windows Start menu, right-click Command Prompt, then select Run as administrator.
2 Select Yes in the User Account Control message.

3 Inthe Command Prompt window, type: cd <path to the i-Vu Pro install directory>
For example, type: cd c:\i-Vu Pro x.x

4 Press Enter.
5 Type: "i-Vu Pro Service.exe" -remove

6  Press Enter.

To determine if i-Vu® Pro Server service is installed

If you do not know if the service was previously installed, follow the appropriate steps below.

1 Inthe Windows Start menu, right-click Command Prompt, then select Run as administrator.
2  Select Yes in the User Account Control message.

3 Inthe Command Prompt window, type: cd <path to the i-Vu Pro install directory>
For example, type: cd c:\i-Vu Prox.x

4 Press Enter.
5 Type: "i-Vu Pro Service.exe" -check

6  Press Enter.
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Update the SAL library

The i-Vu® Pro SAL files update your i-Vu® Pro controllers. The SAL libraries contain control programs, graphics,
drivers, screen files, and other important controller data.

Carrier periodically provides updates, which include enhancements and bug fixes.
NOTES

e The library update only changes default graphics. If you have edited your graphic in ViewBuilder, it is not
updated.

e The last digits in the SAL library name are the release date of the library.
e All of the SAL files will not necessarily have the same <date> revision.

e To ensure that your installation is running the latest software, we recommend that you check Control Systems
Support http;//www.hvacpartners.com/ for updates. Download the latest SAL files and apply them to all new
installations.

e Ifyou are changing to an older SAL file than the current one being used, a warning asks you if you are sure
you want to apply an older version.

NOTE Keep copies of the latest libraries in a safe place. In the event of a system restore, the updated .sal file
must be reapplied.

To check current SAL library version

1 Login to the i-Vu® Pro application.

2  Click E then select System Options > Update tab.

3  Click Current Libraries (.sal) to view the current SAL libraries and their revision date.

Step 1: Update library

1 Save the updated library (.sal file) to your computer.

2 Click E then select System Options > Update tab.
NOTE Expand Current Libraries (.sal) to see the current SAL libraries and their revision. Compare them to
what you downloaded from the Control Systems Support to determine if any of them have been updated.

3 Click Opaats thwary and browse to the updated .sal file that you have saved on your computer, select the
file, and click Open.

4 Click Continue.

5 When process is complete, the message appears File added successfully.

6 Click Close.

NOTE These changes are not applied to the controllers until you have updated routers and controllers.
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Follow these steps to implement the new equipment library:

Step 2: Update the files for the routers

1

2
3
4

Select the router that you wish to update in the navigation tree.
Right-click and select Driver Properties.
Select Properties page > Update tab.

If the database contains two or more routers, you must check Change for all controllers of this type? in the
Controller section.

Click Update. A message appears Changes the driver and screen file to use the current library version.
Continue?

NOTE If more than one router exists, the additional routers are listed below the Update button.
Click OK.
Click Accept.

Step 3: Update the files for the controllers

1
2
3

Double-click the controller in the navigation tree or right-click and select Configure.
If you have multiple controllers of the same type, enable Change for all control programs of this type?.

Click Update under Control Program. A message appears Changes the control program, view, driver, and
screen file to use the current library version. Continue?

Click OK. When the message Updated to the library version xx. appears, click Close.
Repeat steps 1 - 4 for any additional types of controllers.

Click Close again.

Step 4: Update the files for CCN controllers

1
2

In the navigation tree, select the CCN device manager associated with the controllers that are to be updated.

Select Devices > CCN Discovery and re-scan any controllers that need to be updated by checking Rescan
Controllers Selected Below for Configuration Changes and clicking Start Scan.

Step 5: Apply the update to the routers and controllers

Select the System in the navigation tree and then select the Downloads page.

1
2 If you wish to apply the new SAL file to your entire system, you can use this page to compare to your
navigation tree and verify that you have selected all of your routers and controllers for download.
NOTE Only the CCN Gateway and device managers require download, so the CCN controllers/equipment will
not be listed.
3 Anetwork's controllers download in the order shown. To change the order, select a controller(s), then drag
and drop or click Move to Top or Move to Bottom.
EXCEPTION If a controller's router requires a download, it will download first regardless of its position on the
Downloads page. Click the Start button.
NOTES
o  Use Ctri+click, Shift+click, or the Select All checkbox to select multiple controllers.
o  See To download from the Downloads page in Help for more details.
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To back up a system

The type of database your system uses determines the method you use to back up the system.

& CAUTION Do not use SiteBuilder's Replicate feature to back up your database.

For Apache Derby
1 Shut down the SiteBuilder and i-Vu Pro Server applications.
2  Copy your system folder.

3  Paste the copy to a new location.

¥ TP Zip the copy before transporting it over a network or to a USB drive.

For MySQL, MS SQL Server, PostGreSQL, or SQL Server Express
1 Copy your system folder.

2 Use the database management system's backup method. See To safely shut down the i-Vu® Pro application
for database server maintenance before doing any maintenance on your database server.

Communicating using PuTTY

You can connect a computer to a controller's Local Access port and then use PuTTY, a free open source terminal
emulation program, to:

e  Set the baud rate for ports S1 on the i-Vu® Open Router, i-Vu® Open Link, or Carrier® ChillerVu™
e  Set controller properties, such as IP address and network information
e Retrieve a Modstat

NOTE Use Network Service Tool V to set the CCN baud rate and configure IP settings for an i-Vu® CCN Router, i-
Vu® Link, or Carrier® ChillerVu™.

PREREQUISITES
e A computer with a USB port

e AUSB Link cable
The USB Link driver is installed with an i-Vu® Pro v6 or later system. Please refer to the Silicon Labs website
and search for "CP210x USB to UART Bridge VCP Drivers" for the most current device drivers. Install the
driver before you connect the USB Link to your computer.

& CAUTION If multiple controllers share power but polarity was not maintained when they were wired, the
difference between the controller's ground and the computer's AC power ground could damage the USB Link and
the controller. If you are not sure of the wiring polarity, use a USB isolator between the computer and the USB
Link. Purchase a USB isolator online from a third-party manufacturer.
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1 Download and install PUTTY from the PuTTY website
(http://www.chiark.greenend.org.uk/~sgtatham/putty/download.html).

2 Connect the laptop to the local access port of the controller, ZS sensor, or an SPT sensor using the USB Link
cable(s).

Connect to Connect to
USB port Local Access por

(][]} ai———— i
| |

T
USB Link

NOTE If using a USB isolator, plug the isolator into your computer's USB port, and then plug the USB Link
cable into the isolator.

3 Tochange a router's IP address, subnet mask, or default gateway, set its IP Address DIP switch to Assigned.
4 Start PuTTY.
5 Under Category > Connection, select Serial.
6  Under Options controlling local serial lines, enter the following settings:
Field Value
Serial line to connect to Replace X with the computer's port number that the USB Link cable is

connected to.

NOTE To find the port number, select Start > Control Panel > System >
Device Manager > Ports (Com & LPT). The COM port number is beside
Silicon Labs CP210x USB to UART Bridge.

477 Ports (COM & LPT)

P --‘? Comrmunications Port (COML)

¥ ? ECP Printer Port (LPT1)

--"?' Intel(R) Active Management Technelogy - 50L (COM3)
. % Silicon Labs CP210x USB to UART Bridge [[COMA4)

Speed (baud) 115200
Data Bits 8

Stop Bits 1

Parity None
Flow Control None

7  Click Open. A window similar to the one below appears.

1) Restart

2) Display Modstat

3) IP Address [192.168.1.6]
4) Subnet Mask [255.255.255.01
5) Default Gateway [0.0.6.0]
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8 Do one of the following:

o To change a property value:
a. Type the number of the property, then press Enter.
b. Type the new value, then press Enter.

o To take an action, type number of the action, then press Enter.
9 If you changed a value, type 1, then press Enter to restart the controller.

10 Close PuTTY.

Communicating using HyperTerminal

You can connect a computer to a controller's Local Access port and then use HyperTerminal, an application
installed with Windows XP and older operating systems, to:

e  Set the baud rate for ports S1 or S2 on the i-Vu® Open Router or i-Vu® Open Link
e  Set controller properties, such as IP address and network information
e  Retrieve a Modstat

NOTE Use Network Service Tool V to set the CCN baud rate and configure IP settings for an i-Vu® CCN Router or i-
Vu® Link.

PREREQUISITES
e Acomputer with a USB port

e AUSB Link cable
NOTE The USB Link driver is installed with an i-Vu® Pro v6 or later system. Please refer to the Silicon Labs
website and search "CP210x USB to UART Bridge VCP Drivers" for the most current device drivers. Install the
driver before you connect the USB Link to your computer.

& CAUTION If multiple controllers share power but polarity was not maintained when they were wired, the
difference between the controller's ground and the computer's AC power ground could damage the USB Link and
the controller. If you are not sure of the wiring polarity, use a USB isolator between the computer and the USB
Link. Purchase a USB isolator online from a third-party manufacturer.
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1 Connect the computer to the local access port of the controller, ZS sensor, or an SPT sensor using the USB
Link cable(s).
Connect to Connect to
USB port Local Access port
.:D]m:@ﬁ_ y A .
7 3/4in. 12 ft
| | |
USB Link
NOTE If using a USB isolator, plug the isolator into your computer's USB port, and then plug the USB Link
cable into the isolator.
2 Verify that the baud rate is set to 115,200.
3 Tochange a router's IP address, subnet mask, or default gateway, set its IP Address DIP switch to Assigned.
4 Start Windows HyperTerminal located under Start > Programs > Accessories > Communications.
5 NOTE This option is not available in Windows v7 or later. You can download it from the Internet.
6 Select an icon for this connection file, then click OK.
7 In the Connect to dialog box, set the Connect using field to ComX, where X is the number of the computer's
Com port that the USB Link cable is connected to, then click OK.
8 In the Com Properties dialog box, set the Port Settings for your local access port, then click OK.
Port Setting Value
Bits per second i-Vu® Open Link or i-Vu® Open 115200
Router
i-Vu® Link or i-Vu® CCN Router
Data Bits 8
Parity None
Stop Bits 1
Flow Control None
-Vu® Pro v8.5 ©2023 Carrier.
Installation Guide All rights reserved.

45



System Management

9  From the main HyperTerminal screen, press Enter to view a router configuration screen like the one below.

BAChet Router, Ethernet MAC address = BO-EQ-CO-D0-4E-BE

1) Restart

Mi=play Modstat

IP Address [192.168.168.11
Subnet Mask [255.255.255.0]
Default Gateway [0.0.0.0]
BAChet /TP UDP Port [OxBACA]
BAChet /TP Network [&8245+]
BACnet/Ethernet Hetwork [&829]
BAChe 1 ARCHET Hetworl [&825]

} BAChet/MSTP Hetwork [4834]

I Dizplay BSIP PAD Table

} Rdd B/IP PAD Table Entry

} Delete BSIP PAD Table Entry
1) Clear BSIP PAD Table

15) Set baud rate for HMSTP [T6S00]
16} Set baud rate for PTP (3846001

B ek ek i L D0 ] T L L

L P et D et e e et e o

+ The HOME network iz updated each time a network number

iz changed (H7-10).

Enter selection: _

10 Do one of the following:

o  To change a property value:
a. Type the number of the property, then press Enter.
b. Type the new value, then press Enter.

o Totake an action, type number of the action, then press Enter.
11 If you changed a value, type 1, then press Enter to restart the controller.

12 Close HyperTerminal.
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Document revision history

Important changes to this document are listed below. Minor changes such as typographical or formatting errors are not
listed.

Date Topic Change description Code*
11/22/23  To back up a system Updated SQL Server Express procedure X-PM-BK-R
Before starting the i-Vu® Pro Removed operating system note C-PM-RD-0O
application and your system
3/31/23 Upgrading from a 32-bit server to a 64- = New topic C-TS-0C-O
bit server
Communicating using PuTTY Updated USB Link Driver i-Vu version compatibility
Communicating using HyperTerminal
Registering and downloading your i- Updated website menu options

Vu® Pro license

* For internal use only
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