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If upgrading from an i-Vu® Standard or Plus system

Prerequisite
Verify that you have the latest version of all the add-ons that are currently used. Some have been updated for the i-Vu®
application. Be sure to have those updated add-ons ready to install during the upgrade process.
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Before you upgrade an i-Vu® Pro database

• Server requirements—Verify that the i-Vu® server computer meets the v10.0 i-Vu® server requirements (page 8).• 
• Alternative authentication providers—If you are using non-local authentication via the LDAP or SSO add-ons, insure that you• 

have a locally authenticated admin user and that you can successfully login as that user. This ensures access to the system
if you are disabling add-ons during the installation or in the event that the authentication add-on fails to start.
 

• Trends— i-Vu® Pro v6.5 and later systems have a different Trends database structure than earlier systems. If you are• 
upgrading a v6.0 or earlier system, use one of the following methods to convert your current trends:
◦ Before upgrading, use the Trend Conversion Utility (highly recommended for large trend databases)◦ 
◦ As part of the upgrade process in SiteBuilder's upgrade wizard◦ 
See Converting your trend database (page 9).
 

• BACnet Bindings—i-Vu® v6.0 and later uses only dynamic binding for communication between devices. Before you upgrade• 
from v4.2 or earlier, uncheck Use Static BACnet Bindings on the System Settings > Communications tab, restart the BACnet
connection, and then immediately run the Reports > Network > Controller Status report to verify that you have no
communication problems. If you do, contact Carrier Control Systems Support.
 

• Access® and MSDE databases—As of v6.5, SiteBuilder no longer supports Access and MSDE database types. If your system• 
uses one of these, you need to migrate to a Derby database in your current i-Vu® version before upgrading to v10.0.
NOTE  Derby became a supported database type in v6.0. If your current system is v5.1 or earlier, you will need to upgrade to
v6.0 or v6.5 (32-bit only), migrate to Derby, and then upgrade to v10.0 (64-bit).

• SQL Server® Express database—If your system is currently using an SQL Server Express database running on a 32-bit i-Vu®• 
server, you must do the following before upgrading to v10.0:
1. Shut down i-Vu Server application.1. 
2. On the server's Start menu, select All Programs > Microsoft SQL Server > Configuration Tools > SQL Server2. 

Configuration Manager.
3. In the left pane, select Protocols for SQLEXPRESS.3. 
4. In the right pane, right-click Named Pipes, and then select Enable.4. 
5. In the left pane, select SQL Server Services.5. 
6. In the right pane, right-click SQL Server (SQLEXPRESS), and then select Restart.6. 

• Backup—Always back up your database before upgrading. A failed upgrade could corrupt your data.• 
Back up a Derby or SQL Server Express database by copying the system folder typically located in i-Vu_Pro_x.x\webroot or i-
Vux.x\programdata\systems.

• Back up a MySQL, MS SQL Server, Oracle, or PostgreSQL using the database management system's backup method. Also,• 
copy the system folder. It is typically under i-Vux.x\webroot or i-Vux.x\programdata\systems.

 CAUTION  Do not use SiteBuilder's Replicate feature to back up your database.

i-Vu® server requirements
The recommended minimum for an i-Vu® server:
• Dual core processor• 
• 4 GB RAM• 
• 30 Gigabyte hard drive• 
• Communications link of 10 Mbps or higher• 
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• 64-bit server (See Upgrading from a 32-bit server to a 64-bit server (page 15).)• 

The i-Vu® application will work with slower computers and slower links, but the results may not be satisfactory.
The i-Vu® server must be 64-bit. Memory requirements vary, based on the:
• number of pieces of equipment and device instances• 
• size of the control programs• 
• number of simultaneous users logged in to the i-Vu® application• 

 

For this
size
system...

With this number of... The computer should have at least a dual core processor and...

Instances of
equipment
and devices
1

Physical
Points and
Display
Objects

Passmark
Total
Score 2

Passmark
Single-
threaded
Score

RAM
Minimum/
Recom-
mended

JVM Memory
Minimum/
Recom-
mended

Disk Mark4

Small 0 - 250 0 - 1000 2000 800 4 / 4GB 1 / 1GB 3000

Medium 250 - 1000 1000 -
5000

3000 1000 4 / 8GB 2 / 4GB 5000

Large 1000 -
10,000

5000 -
50,000

5000 1400 6 / 12GB 4 / 8GB 15000

Huge more than
10,000

more than
50,000

6500 1600 16 / 16GB
3

12 / 12GB 30000

1   Total number of control programs and controllers.
2   For more information, see www.CPUbenchmark.net.
3   For a huge system with minimal user activity, the average piece of equipment or instance device requires approximately

300KB of server RAM. Contact Technical Support for server sizing recommendations.
4 SATA SSDs are recommended as baseline performance for i-Vu® on all systems. Large systems benefit from the faster

PCIe interface SSDs on both the i-Vu® and database servers. Passmark’s Disk Rating “Disk Mark” can be useful in
gauging disk performance when designing new servers.
Rotational Drives: 900-1500
SATA SSDs: 3000-5000
PCIe SSDs: 10000-30000

Converting your trend database
If you are upgrading from v6.0 or earlier, you must convert your current trend database to the trend database structure for v6.5
and later systems.
• For a Derby database, the trends are converted as part of the upgrade process in SiteBuilder's upgrade wizard.• 
• For an SQL Server, MySQL, or PostgreSQL database, use one of the following methods to convert your current trends:• 

◦ As part of the upgrade process in SiteBuilder's upgrade wizard. The i-Vu® system is not running during the upgrade.◦ 
◦ Before upgrading using the Trend Conversion Utility (highly recommended for large trend databases. See "To determine◦ 

the size of your trend database" below.) This method is faster and the utility can run while the i-Vu® system is running.
Before using either of these methods, verify that the trend database management system user has 'drop' authority.

 
NOTES

9i-Vu® Application v10.0
Rev 2/12/2026

© 2026 Carrier.
All rights reserved.

Before you upgrade an i-Vu® Pro database



• If your trend database is on a different server than the i-Vu® system, you have the option of installing and running the Trend• 
Conversion Utility on either server. However, the conversion will run faster if you run it on the trend database server.

• If you created any custom software to access the i-Vu® trend data, it may not work with the new trend database structure.• 
Contact Carrier Control Systems Support for assistance.

• Upgrading to and/or running a i-Vu v6.5 or later system uses more database resources than previous versions.• 
 

 CAUTIONS   
• If you use the Trend Conversion Utility, back up your system before you run the utility and again before you upgrade the• 

system in SiteBuilder. Make the backup using the database management system's backup method, and also copy the
system webroot folder.

• Disable trend expiration in your source trend database. In i-Vu®, go to System Settings > Scheduled Tasks, and uncheck• 
Remove expired historical trends daily at ___.

 

To determine the size of your trend database
In the i-Vu® interface, select System Options > System Settings > General tab > System Statistics button.
 

Size Small Medium Large X-Large

Trend Samples < 100M 100M - 500M 500M - 650 > 650M

Conversion time using
Trend Conversion Utility

1 hour 1 - 4 hours 4 - 6 hours > 6 hours

 

Options for migrating and upgrading the database
NOTE The "system folder" refers to the folder with the name of your site as in the following example, i-Vu_Pro_x.x > programdata
> acme_corp.

From To Steps to migrate to the 64-bit i-Vu® Pro v10.0 application on a new
computer

Access Access
or
MSDE

SiteBuilder v6.5 and later no longer supports Access and MSDE
database types. If a system uses one of these, we recommend that
you migrate to a Derby database in the 32-bit v6.0 i-Vu® application
before upgrading to v10.0.
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From To Steps to migrate to the 64-bit i-Vu® Pro v10.0 application on a new
computer

Access Derby 1. Install the i-Vu® Pro v6.0 32-bit application from the DVD on1. 
your existing computer.

2. Upgrade database in SiteBuilder. Select File > Upgrade i-Vu2. 
System.

3. In SiteBuilder, select File > Manage Database > Migrate/Replica3. 
> Migrate. Select Derby.

4. Copy upgraded i-Vu® system folder to your own USB drive.4. 
5. On your new computer, install the 64-bit i-Vu® Pro v10.05. 

application from the Installation USB drive.
6. Upgrade database in SiteBuilder. Select File > Upgrade i-Vu6. 

System.
7. Copy the system folder from your USB drive into the7. 

programdata\systems folder or other folder of your choice.
8. Upgrade database in SiteBuilder. Select File > Upgrade i-Vu8. 

System.

Access MS
SQL SiteBuilder v6.5 and later no longer supports Access and MSDE

database types. If a system uses one of these, we recommend that
you migrate to a Derby database in the 32-bit v6.0 i-Vu® application
before upgrading to v10.0.
1. On your existing computer, install the 32-bit i-Vu® Pro v6.01. 

application from the DVD.
2. Upgrade database in SiteBuilder. Select File > Upgrade i-Vu2. 

System.
3. In SiteBuilder, select File > Manage Database > Migrate/Replica3. 

> Migrate. Select Derby.
4. Copy upgraded i-Vu® system folder to your own USB drive.4. 
5. On your new computer, install the 64-bit i-Vu® Pro v10.05. 

application from the Installation USB drive.
6. Install 2014, 2016, 2017, or 2019 MS SQL. See Install the i-Vu6. 

Pro® application and SQL Server on a new computer (page
17).

7. Copy the system folder from your USB drive into the7. 
programdata\systems folder or other folder of your choice.

8. In SiteBuilder, select File > Manage Database > Migrate/Replica8. 
> Migrate. Select MS SQL.
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From To Steps to migrate to the 64-bit i-Vu® Pro v10.0 application on a new
computer

MSDE MS
SQL

SiteBuilder v6.5 and later no longer supports Access and MSDE
database types. If a system uses one of these, we recommend that
you migrate to a Derby database in the 32-bit v6.0 i-Vu® application
before upgrading to v10.0.
1. On your existing computer, install the 32-bit i-Vu® Pro 6.01. 

application from the DVD.
2. Upgrade database in SiteBuilder. Select File > Upgrade i-Vu2. 

System.
3. In SiteBuilder, select File > Manage Database > Migrate/Replica3. 

> Migrate. Select Derby.
4. Copy upgraded i-Vu® system folder to your own USB drive.4. 
5. On your new computer, install the 64-bit i-Vu® Pro v10.05. 

application from the Installation USB drive.
6. Install 2014, 2016, 2017, or 2019 MS SQL. See Install the i-Vu6. 

Pro® application and SQL Server on a new computer (page
17).

7. Copy the system folder from your USB drive into the7. 
programdata\systems folder or other folder of your choice.

8. In SiteBuilder, select File > Manage Database > Migrate/Replica8. 
> Migrate. Select MS SQL.

MS SQL MS
SQL

1. Copy existing i-Vu system folder on your own USB drive.1. 
2. Backup 4 databases in MS SQL on your USB drive.2. 
3. On your new computer, install the 64-bit i-Vu® Pro v10.03. 

application from the Installation USB drive.
4. Install 2014, 2016, 2017, or 2019 MS SQL. See Install the i-Vu4. 

Pro® application and SQL Server on a new computer (page
17).

5. Restore above databases to upgraded MS SQL (page 20).5. 
6. On your new computer, install the 64-bit i-Vu® Pro v10.06. 

application from the Installation USB drive.
7. Upgrade database in SiteBuilder v10.0. Select File > Upgrade i-7. 

Vu System.
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Registering and downloading your i-Vu® license

To register your software, you must obtain a license from Carrier and then apply it in the i-Vu® Pro interface.
1. Log in to the Carrier Community Portal website.1. 

NOTES
◦ Only Carrier authorized personnel may access the Community Portal website. To set up your account, please contact◦ 

Control Systems Support with the following information: name, phone number, e-mail address, office address, and your
password of choice.

◦ If you are an end-user or contractor, please contact your local Carrier office to obtain your license.◦ 
2. Click Order Management > Licenses & Subscriptions > Software Licenses, then click the link.2. 

3. Expand the section containing the unregistered license(s) indicated by the  symbol on the right side of the blue bar.3. 
4. Click on the row that shows unregistered in the Registration Status column.4. 
5. In License Details, complete the fields under Owner Information and Site Information.5. 
6. Click Register License.6. 
7. Check I agree to the terms of use.7. 
8. Click Download License and then save the .properties file to a convenient location to use when installing the i-Vu® Pro8. 

application.
To apply the license to the i-Vu® application
During the i-Vu® installation, in the Setup Wizard, on the Product License screen, check Browse to a different license, and
select the site license you obtained.
NOTES
◦ Selecting the default license results in a prompt appearing every few minutes in the i-Vu® interface to remind you to apply◦ 

your site license.
◦ Do not edit any part of this registered license file. Editing a license file invalidates the license.◦ 
◦ Store the license in a safe location.◦ 
To apply the site license after the installation:
1. In the i-Vu® interface, select System Options > License Administration.1. 
2. Browse to the license file.2. 
3. Click Apply.3. 
4. Restart i-Vu® Server using the rebootserver manual command.4. 
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Upgrading to the i-Vu® Pro v10.0 application

To begin, see To register and download your i-Vu® Pro license (page 13).
If your database is Access®, MSDE, or SQL Server Express, be sure you have followed the instructions in Before you upgrade
(page 8).
The table below is a quick outline of steps. Each step is explained in detail in the sections that follow.

Existing system Notes Procedure

i-Vu® CCN Pro v3.1 You must install the latest
driver in all i-Vu® Integrators.
They download automatically
with the installation.
See Upgrade v3.1 or v4.2
database in SiteBuilder (page
15).

SiteBuilder v6.5 and later no longer
supports Access and MSDE database
types. If a system uses one of these, we
recommend that you migrate to a Derby
database in the 32-bit v6.0 i-Vu®
application before upgrading to v10.0.
1. On your new computer, install the 64-1. 

bit i-Vu® Pro v10.0 application from
the Installation USB drive.

2. Upgrade database in SiteBuilder.2. 
Select File > Upgrade i-Vu System.

3. Upgrade graphics in ViewBuilder,3. 
using the plug-in (page 22).

i-Vu® CCN Pro v4.2 See Upgrade v3.1 or v4.2
database in SiteBuilder (page
15).

SiteBuilder v6.5 and later do not support
Access and MSDE database types. If a
system uses one of these, we
recommend that you migrate to a Derby
database in the 32-bit v6.0 i-Vu®
application before upgrading to v10.0.
1. On your new computer, install the 64-1. 

bit i-Vu® Pro v10.0 application from
the Installation USB drive.

2. Upgrade database in SiteBuilder.2. 
Select File > Upgrade i-Vu System.

i-Vu® Pro v6.5 1. If you have a 32-bit system, you can1. 
only run v10.0 on a 64-bit server. See
Upgrading from a 32-bit server to a
64-bit server (page 15).

2. Follow the steps in Install the i-Vu2. 
(page 15)® Pro application and use
SiteBuilder to upgrade database.
(page 15)
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Existing system Notes Procedure

i-Vu® Standard or
Plus v6.0 and later
or
i-Vu® Express v8.5
and later

Requires i-Vu® Pro installed on
a PC that matches the same
version as i-Vu® Standard,
Plus, or Express.

1. Export clipping file. Go to  >1. 
System Options > General tab >
Clippings > and click Export.

2. On your new computer, install the2. 
same version of the i-Vu® Pro
application.

3. Open SiteBuilder. Go to File > Clipping3. 
> Import.

4. Follow the steps in Install the i-Vu®4. 
Pro application and use SiteBuilder to
upgrade the database (page 15).

For more details on upgrading to the i-Vu® Pro v10.0 application and migrating to different databases, see Options for migrating
and upgrading the database (page 10).

Upgrading from a 32-bit server to a 64-bit server
i-Vu® v10.0 will not run on a 32-bit server. To upgrade, first install i-Vu® v10.0 on a 64-bit server. The method for upgrading
your system depends on the database type or size.

Derby database
1. Copy your existing system's <system name> folder. It is typically under i-Vux.x\webroot or i-Vux.x\programdata\systems.1. 
2. Paste the copied folder under a folder of your choice on the 64-bit server. For example, i-Vux.x\programdata\systems.2. 
3. Open the system in SiteBuilder.3. 
4. Select File > Upgrade > i-Vu system and follow the prompts to upgrade the system.4. 

All Non-Derby databases
1. Open your existing system in SiteBuilder.1. 
2. Select File > Manage Database > Migrate/Replicate, and then select Replicate database to create a copy of the system in a2. 

Derby database.
3. Copy the replicate system's <system name> folder. It is typically under i-Vux.x\webroot or i-Vux.x\programdata\systems.3. 
4. Paste the copied folder under a folder of your choice on the 64-bit server. For example, i-Vux.x\programdata\systems.4. 
5. Open the system in SiteBuilder.5. 
6. Select File > Upgrade > i-Vu system and follow the prompts to upgrade the system.6. 
7. Select File > Manage Database > Migrate/Replicate, and then select Migrate to a different database type to change the7. 

system back to the original database type.

Very large databases
If you are moving a very large system to a 64-bit server, contact Carrier Control Systems Support for assistance.

Install the i-Vu® Pro v10.0 application and use SiteBuilder to upgrade database
SiteBuilder v6.5 and later do not support Access and MSDE database types. If a system uses one of these, we recommend that
you migrate to a Derby database in the 32-bit v6.0 i-Vu® application before upgrading to v10.0. See Options for migrating and
upgrading the database (page 10).
Typically, the file path for an i-Vu® Pro system is the default path: C:\i-Vu_Pro_x.x.
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1. Back up your system before upgrading. Once a system is upgraded, you cannot retrieve or access the database with your1. 
previous i-Vu® installation.

2. Install the i-Vu® Pro v10.0 application from the Installation USB drive.2. 
3. Open SiteBuilder v10.0 and select File > Upgrade i-Vu System.3. 
4. Click Browse and select the system folder for your previous i-Vu® Pro system. It is typically under i-Vux.x\webroot or i-4. 

Vux.x\programdata\systems.
5. Check Make this the default system for i-Vu and click Next.5. 
6. Confirm that you have backed up and click Next when the Upgrade complete message appears.6. 
7. The upgrade process copies the necessary system files to your i-Vu® Pro v10.0 installation folder and performs the required7. 

database upgrade steps.
Upgrading drivers
◦ When upgrading a v3.1 database, the drivers for the i-Vu® Integrators are automatically updated to the latest drivers.◦ 

v3.1 drivers do not function in v10.0.
◦ When upgrading a v4.2 or later database, a dialog lists all the current drivers and you can uncheck them if you do not◦ 

want them to be upgraded. v4.2, v6.0, and v6.5 drivers will function in v10.0.
8. Log in to your new i-Vu® Pro v10.0 application using an Administrator account.8. 

Upgrade from Access and i-Vu® Pro v3.1 or v4.2 application to Derby, new
computer, and 64-bit v10.0
i-Vu® Pro v3.1 and v4.2 only ran on a 32-bit platform and v10.0 is only 64-bit. In the 32-bit v6.0 of i-Vu®, Access or MSDE is
supported and they are not supported in the 64-bit version.
Access®, MSDE, and SQL Server Express databases—As of v6.5, SiteBuilder no longer supports Access and MSDE database
types. As of v7.0, SiteBuilder no longer supports SQL Server Express. If your system uses one of these, you need to migrate to a
Derby database in your current i-Vu® version before upgrading to v10.0.
NOTE  Derby became a supported database type in v6.0. If your current version is earlier, you will need to upgrade to v6.0 32-
bit, migrate to Derby, and then upgrade to v10.0 64-bit.
1. Install the 32-bit version of the i-Vu® Pro v6.0 application on your current computer.1. 

NOTE You will still have your i-Vu® Pro v3.1 or v4.2 system there, also.
2. Make a backup of your current i-Vu® system by copying the system folder under the webroot folder.2. 
3. Upgrade database in SiteBuilder. Select File > Upgrade i-Vu System.3. 
4. In SiteBuilder, select File > Manage Database > Migrate/Replica > Migrate. Select Derby.4. 
5. Copy the migrated system folder from the i-Vu® v6.0 webroot folder to your own USB drive.5. 
6. Install the i-Vu® v10.0 application from the Installation USB drive.6. 
7. Copy the saved Derby database from your USB drive to the programdata\systems folder or any other folder of your choice of7. 

the new i-Vu® Pro v10.0 application.

Upgrade from the i-Vu® v3.1, v4.2, or v6.0 application that uses SQL Server 2000,
2005, 2008, 2012 to SQL Server 2016, 2017, or 2019 on a new computer
Follow these procedures to successfully upgrade and migrate your system and computer:
1. Copy system folder from your previous the i-Vu® Pro application and back up the i-Vu® databases in MS SQL (page 17).1. 
2. Install the i-Vu® Pro v10.0 application and SQL Server on your new computer. (page 17)2. 
3. Restore previous i-Vu® databases to upgraded SQL. (page 20)3. 
4. Upgrade system in SiteBuilder (page 20).4. 
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i-Vu® Pro v3.1 or later system folder and backup in SQL to USB drive

 CAUTION You must have installed the i-Vu® Pro v10.0 application on your existing computer and set up a database in
SiteBuilder before following these steps.
Use this procedure if you have been using SQL Server 2000, 2005, 2008, or 2012 and are upgrading to SQL Server 2014,
2016, 2017, or 2019 on a new computer.
Copy data from computer used for i-Vu® Pro v3.1 or v4.2
1. Stop the i-Vu® Pro Server and close any i-Vu® applications. If the i-Vu® Pro Server is installed as a service, stop it.1. 
2. Browse to your i-Vu® Pro v3.1 or later webroot folder and copy the system folder to a USB drive.2. 
In SQL, back up the i-Vu® databases to a USB drive
NOTE The i-Vu® databases are named main, alarms, audit, and trends.
1. Log in to SQL Studio Manager using your Windows Authentication login.1. 
2. Expand Databases on the left.2. 
3. Right-click any of the 4 databases and select New task > Backup.3. 
4. In the Backup > General tab, verify that the Backup Type is Full.4. 
5. Under Destination, click ADD.5. 
6. In the popup window, browse to the USB drive and enter a filename (i.e. main, alarms etc..)6. 
7. Click OK and then OK again to return to the original backup window.7. 
8. Under Options, check Overwrite all existing backup sets.8. 
9. Click OK to start the backup.9. 
10. Repeat the above steps for the 3 remaining i-Vu® databases.10. 

Install the i-Vu® Pro v10.0 application and SQL Server on new computer
After installing the i-Vu® Pro v10.0 application from the Installation USB drive on your new computer, use the following steps:
1. If you do not already have MS SQL installed, install one of the supported versions and any applicable SQL service packs. For1. 

instructions on how to install any version of SQL Server, go to http://msdn.microsoft.com/en-us/library/default.aspx and, in
the Search window, type Install <your SQL Version >. Select Authentication Mode - Mixed Mode during setup and enable
TCP/IP on port 1433.
NOTE As you install MS SQL Server, you must select certain options to use with i-Vu®. For all other options, you may keep
the defaults or select your own values. Select the following:
◦ SQL Server Database Services◦ 
◦ Workstation components, Books Online, and development tools◦ 
◦ Authentication Mode - Mixed Mode (Windows Authentication and SQL Server Authentication)◦ 

NOTE The password you specify grants extensive privileges.
◦ Service Account for database engine – NT Authority\System◦ 
◦ Enable TCP/IP on port 1433◦ 

2. If already installed, you must have selected Authentication Mode - Mixed Mode during setup and have TCP/IP enabled on2. 
port 1433.

If you are the database administrator and TCP/IP is not enabled on port 1433, or you are unsure of the port, follow the
procedure below, 'To enable TCP/IP on port 1433' and then proceed to Step 1.
Install the program and follow the instructions below.

To enable TCP/IP on port 1433
a. Click Start > All Programs > Microsoft SQL Server <your SQL version> > Configuration Tools > SQL Server Configurationa. 

Manager.
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b. Expand the SQL Server Network Configuration.b. 
c. Select Protocols for <server instance> where <server instance> is the SQL Server running the i-Vu® application.c. 
d. In the next window, under Protocol Name, double-click TCP/IP.d. 
e. On the Protocol tab, under General, next to Enabled, select Yes.e. 
f. On the IP Address tab, scroll down to the IPAll section.f. 
g. Clear any values from the TCP Dynamics Port field.g. 
h. In the TCP Port field, enter 1433, then click OK.h. 
i. Close the SQL Server Configuration Manager.i. 
j. Restart the SQL Server Service.j. 

Step 1:  Connect to the database engine for i-Vu® SQL Server
a. Determine if Microsoft SQL is running on the i-Vu® server:a. 

◦ If Microsoft SQL is running on the i-Vu® server, select Start > Programs > Microsoft SQL Server > SQL Server <your SQL◦ 
version> > Management Studio.

◦ If Microsoft SQL is running on a different computer, download the SQL Management Studio and install it on the i-Vu®◦ 
server.

b. In the Connect to Server dialog box, select or enter the information using the table below.b. 
c. Click Connect.c. 
To set up the databases for a new i-Vu® system, complete steps 2, 3, and 4 below.

Field Notes

Server type Database engine.

Server Name The address or name of the computer running the SQL Server service. Get from
your database administrator.

Authentication Get from your database administrator.

Username Get from your database administrator.

Password Get from your database administrator.

Step 2:  Create a database instance
a. In the Object Explorer pane, right-click Databases, then select New Database.a. 
b. In the Database name field, type a name such as xxx_main; this will be your Main Database Connect String Instanceb. 

in SiteBuilder. Record the name below.
c. Under Select a Page, select the Options page.c. 
d. From the Recovery model drop-down list, select Simple.d. 
e. Click OK.e. 
f. Repeat steps a-e to create the Alarms, Trends, and Audit Log databases.f. 

NOTE  Database names are case-sensitive and must be 18 characters or less in length.

Step 3:  Create a database user
a. In the Object Explorer pane, click the plus sign to the left of Security.a. 
b. Right-click Logins, then select New Login.b. 
c. In the Login name field, type in a login name for i-Vu®, such as xxx_User; this will be your Database User Login inc. 

SiteBuilder.
d. Select SQL Server authentication.d. 
e. In the Password and Confirm password fields, type a password; this will be your Database User Password in SiteBuilder.e. 
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f. Clear the following checkboxes:f. 
◦ Enforce password policy◦ 
◦ Enforce password expiration◦ 
◦ User must change password at next login◦ 

g.  In the Default database drop-down list, select master.g. 
h. In the Select a page pane, select the User Mapping.h. 
i. Under Users mapped to this login, select the Map checkbox next to a database name you created in Step 2.i. 
j. Under Database role membership for: section, select the following checkboxes:j. 

◦ db_owner◦ 
◦ public◦ 

k. Click OK.k. 
l. Repeat steps i-k for each remaining database.l. 
m. Close SQL Server Management Studio.m. 

Step 4:  Set up the SQL Server databases in SiteBuilder
a. In SiteBuilder, select File > New.a. 
b. Type a name for the system.b. 
c. Select SQL Server from the Database Type drop-down list.c. 
d. Select Make this the default system for i-Vu® if you want the i-Vu® application to automatically run this system eachd. 

time it starts.
e. Complete the remaining fields, then click Next.e. 
f. Enter the Connect String information for each i-Vu® database. See below.f. 

g. Click Finish.g. 
NOTE  To change Database Connect Strings for an existing system, select Modify database connection parameters in the File >
Open dialog box and then click Next.

Database Connect Strings:
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     Server Type one of the following:
• localhost if the i-Vu® application and the database are on the same• 

machine
• The name or IP address of the machine that the database is on if different than• 

the i-Vu® application

     Port Do one of the following:
• Type the default port of 1433.• 
• Type the port number that the database uses for communication if different• 

than the database default.

     Instance The name that you gave the i-Vu® database in step 2b.
NOTE If the 4 i-Vu® databases do not reside under the default instance of SQL,
then the instance name must be specified under the Instance column. The syntax
for specifying the instance name of the SQL server is
<Database>;instance=<instance name>. For example, if the SQL instance
name is hvac, the syntax for the Instance field for the main database called i-
Vu_Main would be i-Vu_Main;instance=hvac.

 
Database User:

     Login The username that you entered in step 3c.

     Password The password that you entered in step 3e.

Restore i-Vu® Pro v3.1 or later databases to upgraded SQL
1. Insert the USB drive that contains the database backups from your i-Vu® Pro v3.1 or later system into your computer.1. 
2. Open SQL Studio Manager and expand Databases.2. 
3. Right-click the Main database and select Tasks > Restore > Database.3. 
4. Under Source for restore, select From device.4. 
5. Click on the browse icon on the right.5. 
6. Click the Add button in the Specify Backup window.6. 
7. Browse to the USB drive that contains the backed-up databases and select main.back (or whatever name you assigned to7. 

the main database).
8. Click OK twice to return to the Restore database window.8. 
9. Check the box under the Restore column.9. 
10. Select Options at the top left of the Restore database window.10. 
11. Check Overwrite existing database and click OK.11. 
12. A popup message will appear showing the restore was successful.12. 
13. Repeat the above for the remain three databases.13. 
14.  Close SLQ Studio Manager.14. 

Upgrade in SiteBuilder v10.0
1. Open SiteBuilder v10.0 and select File > Upgrade i-Vu Pro System.1. 
2. Browse to your i-Vu® Pro v3.1 or later system folder on the USB drive.2. 
3. Enter a new system name, if desired.3. 
4. Enter the name of the computer where the SQL server is installed.4. 

20i-Vu® Application v10.0
Rev 2/12/2026

© 2026 Carrier.
All rights reserved.

Upgrading to the i-Vu® Pro v10.0 application



NOTE This is usually the PC name itself. (See below)
5. Leave the port field blank unless the IT department insists that a port number be entered.5. 

NOTE Default port number for SQL Server is 1433.
6. Enter the name of the four databases that were created in SQL Studio Manager on the new computer.6. 
7. Enter the username and password that was created in SQL Studio manager for the new i-Vu® Pro v10.0 installation.7. 
8. Click Next.8. 

9. Confirm that you have backed up and click Next when the Upgrade complete message appears.9. 
10. The upgrade process copies the necessary system files to your i-Vu® Pro v10.0 installation folder and performs the required10. 

database upgrade steps.
Upgrading drivers
◦ When upgrading a v3.1 database, the drivers for the i-Vu® Integrators are automatically updated to the latest drivers.◦ 

v3.1 drivers do not function in v10.0.
◦ When upgrading a v4.2 database, a dialog lists all the current drivers and you can uncheck them if you do not want◦ 

them to be upgraded. v4.2 drivers will function in v10.0.
11. Enter a password and click Next to complete the database upgrade.11. 
NOTE If the 4 i-Vu databases do not reside under the default instance of SQL, then the instance name must be specified under
the Instance column. The syntax for specifying the instance name of the SQL server is <Database>;instance=<instance
name>. For example, if the SQL instance name is hvac , the syntax for the Instance field for the main database called iVu_Main
would be iVu_Main;instance=hvac.

Update your routers and controllers for the i-Vu® Pro v10.0 application
IMPORTANT! Update your routers and controllers only once. Use either the i-Vu® or Field Assistant application.
Router and controller configurations are maintained when they are updated using the procedure below.
Step 1: Update the files for routers and controllers
1. On the i-Vu® navigation tree, right-click the router or controller to update and select Driver Properties.1. 
2. Select Properties tab > Update tab > Add New Driver tab.2. 
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3. If the database contains two or more controllers, select which routers to change:3. 
◦ This controller only◦ 
◦ All controllers on this network that use the current driver version◦ 
◦ All controllers in the system that use the current driver version◦ 

4. Click Update.4. 
5. Click Save.5. 
NOTES
• Check Stage driver in controller to stage the driver to the controller before installing it. Use this option to avoid interrupting• 

controller function when installing the driver.
• Click Delete Unused to delete all unused drivers in <system_name>\drivers.• 
Step 2: Update the files for CCN controllers
1. In the navigation tree, select the CCN device manager associated with the controllers that are to be updated.1. 
2. Select Devices > CCN Discovery and re-scan any controllers that need to be updated by checking Rescan Controllers2. 

Selected Below for Configuration Changes and clicking Start Scan.
Step 3: Apply the update to routers and controllers

1. Select the System  in the navigation tree and then select the Downloads page.1. 
2. If you wish to apply the new SAL file to your entire system, you can use this page to compare to your navigation tree and2. 

verify that you have selected all of your routers and controllers for download.
NOTE Only the CCN Gateway and bridges require download, so the CCN controllers/equipment are not listed.

3. A network's controllers download in the order shown. To change the order, select a controller(s), then drag and drop or click3. 
Move to Top or Move to Bottom.
EXCEPTION  If a controller's router requires a download, it will download first regardless of its position on the Downloads
page. Click the Start button.
NOTES
◦ Use Ctrl+click, Shift+click, or the Select All checkbox to select multiple controllers.◦ 

4. See To download from the Downloads page in Help for more details.4. 

Upgrade i-Vu® Pro v3.1 graphics and custom control programs

Upgrade v3.1 graphics
i-Vu® 3.1 graphics files (.view files) must be upgraded to be used in the i-Vu® Pro v10.0 application.
The graphics were copied to your v10.0 system when you upgraded the database in SiteBuilder v10.0. However, you must
upgrade your graphics in ViewBuilder v10.0.
Area graphics in the i-Vu® CCN Pro v3.1 application may have been designed to use variable color expressions, which change
zone color based on fixed temperature ranges. Colors in a zone on a floorplan graphic do not change dynamically in i-Vu® Pro

v10.0. The Equipment Color control oval  takes over this function and changes color based on the specific setpoints for the
zone.
The equipment’s color in the oval is based on the current zone temperature and the position of the colored bands in the
setpoint control.
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Floorplan images used in the i-Vu® v3.1 application often had random background colors assigned to each dynamically
changing zone. These background colors will not be shown once the graphics have been upgraded.
When you open an i-Vu® v3.1 .view file in ViewBuilder, you are prompted to upgrade the graphic and select a fill color for the
zone. We recommend selecting a neutral color that is distinguishable from the wall color.

You can convert one graphic at a time, or you can convert an entire folder at once by installing the plug-in before upgrading your
graphics.
1.  Select Tools > Configure Tools > Upgrade 3.1 graphics and click Add.1. 

2. Select upgrade-3_1-graphics.viewbuilder-plugin and click Open.2. 
3. Once the plug-in is installed, all the graphics in a folder (views and symbols) may be upgraded at once by selecting Tools >3. 

Upgrade 3.1 Graphics.

Upgrade v3.1 custom control programs

Library
The number of types of devices supported in the built-in equipment library has been greatly expanded since the i-Vu® Pro v3.1
application.
• If the control program in the Integrator is only being used to access values in the CCN device, it is strongly• 

recommended to use the control programs that are automatically generated when the devices are discovered.
• If equipment is using control programs that were automatically generated during discovery in v3.1, you can select• 

those equipment on the Devices page and re-scan them to update their control programs and graphics to the current
versions.

• If you wish to replace a control program that was made in the Snap application with a program that is automatically• 
generated, you will have to delete the equipment from the Devices page and rediscover it. Deleting an equipment results in
losing schedules, alarm actions, setpoints, or other parameters that are defined in that equipment. Schedules or alarm
actions defined further up the hierarchy will not be affected.

Custom Control Programs
• If you have custom logic created in the Snap application that is being used as a part of the control sequence, you cannot• 

replace the custom control program with the automatically-generated one.
• Your Snap-created control program will still run in an i-Vu® Integrator that has been upgraded to run with the i-Vu® Pro• 

v10.0 application.
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• In order for a custom control program to support any of the new features available in the i-Vu® Pro v10.0 application, it is• 
necessary to apply an update to the Snap application under the i-Vu® Pro v3.1 application.

To apply the Snap update:
1. Download the update file called iv42_eikon.update from the Service Intranet.1. 
2. Open SiteBuilder v3.1.2. 
3. Select Actions > Apply Update.3. 
4. Browse to the location of the .update file and select it.4. 
5. The screen should appear as seen below. Click Apply to apply the Snap patch.5. 

• You will need to use the Snap application that was a part of your i-Vu® Pro v3.1 system to edit any custom control• 
programs.
NOTE Custom programs created with Snap will only run in an i-Vu® Integrator. They are not supported in i-Vu® CCN Routers.

Local override
• Local overrides were not allowed in the i-Vu® Pro v3.1 application.• 
• Control programs that are automatically generated during the discovery process in the i-Vu® CCN Pro v4.2 application will• 

support local overrides.
• To support new features in a Snap-generated control program, you need to make some small changes.• 

◦ v3.1 control programs typically had a section like the one shown in Figure 1. This took the current schedule state and◦ 
used a Carrier Schedule Write microblock to write it to a CCN device. This should be replaced with logic similar to that
shown in Figure 2.

Figure 1
◦ The logic shown in Figure 2 uses a new Carrier Schedule microblock and DOES NOT use either of the microblocks shown in◦ 

Figure 1. The bottom output from the new Carrier Schedule microblock indicates if the device is in override. If you wish to
use the Tenant Override Billing add-on, you must add a binary trend with a reference name of override (case sensitive) to
this output, as shown in Figure 2.

Figure 2
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After the upgrade

• Add-ons• 
◦ Some add-ons have been updated for compatibility with the i-Vu® v10.0 application . Be sure that you have the latest◦ 

version of the add-ons that were used in the previous i-Vu® version.

▪ Click System Menu  > System Options > System Settings > Add-ons tab, select the add-on, then click Remove▪ 
Add-on and Keep Data. Install the latest version of the add-on.

◦ To increase security of a i-Vu® system, by default, v10.0 allows only add-ons that are supported and signed by◦ 
Carrier®. However, you can run an unsigned add-on. You must open SiteBuilder and go to Configure > Preferences >
Web Server, and check Allow unsigned add-ons.

• Schedules—Descriptions are limited to 50 characters in a v6.0 or later system using v6-00a or later drivers. You must• 
shorten any schedule descriptions over 50 characters or the schedules will not download.
 

• Alarm sounds—If an operator's My Settings page had an alarm sound file defined, copy the file from the old system to the• 
new system.

• Interface images and Graphics pages—On each client computer, clear the web browser's cache to avoid error messages,• 
strange graphics, or images.
◦ In Edge®, search on "Clear browsing data".◦ 
◦ In Safari®, search on "empty cache".◦ 
◦ In Mozilla® Firefox®, search on "clear cache".◦ 
◦ In GoogleTM ChromeTM, search on "delete cache". ◦ 

i-Vu® Pro application only:
• SSL—If your old system used SSL, you will need to set up TLS again after upgrading. See "To set up i-Vu® server• 

communication" in SiteBuilder Help.  
• Windows® service—If you run i-Vu Pro Server as a Windows service, you must uninstall the service for your previous i-Vu®• 

Pro version, and then install the service for your new i-Vu® Pro version. See "Running i-Vu Pro Server as a Windows®
service" in i-Vu® Pro Help for instructions on uninstalling and installing i-Vu Pro Server service.

• MySQL• 
If you use MySQL and your system is v4.2 or earlier, copy the MySQL driver from i-Vux.x\lib to the i-Vux.x\database-drivers
folder.
If you use MySQL and your system is v3.1, copy the MySQL driver from i-Vux.x\bin\lib to the i-Vux.x\database-drivers folder.
If the driver is not named mysql-driver.jar, change its name to this.
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